Fehler "MAPI nicht verfügbar" in Skype for Business 2016-Client

Symptome

In bestimmten Situationen ist die MAPI-Verbindung mit Exchange Server für Skype for Business 2016-Clients möglicherweise nicht verfügbar. Dieses Problem tritt in den folgenden Szenarien auf:

  • Sie verfügen über eine neue Installation von Office 2016 oder erstellen ein neues Outlook 2016 Profil.
  • Sie aktualisieren eine vorhandene Office 2013-Installation auf Office 2016 und erstellen dann ein neues Outlook 2016 Exchange Server Profil.

Dieses Problem kann bei Microsoft 365 Exchange Online oder lokalen Exchange-Benutzern auftreten. Wenn dieses Problem auftritt, ist die MAPI-Verbindung für Skype for Business 2016-Clients nicht verfügbar. Darüber hinaus können die folgenden Symptome auftreten:

  • Das Feature Skype for Business Konfigurationsinformationen (halten Sie die STRG-TASTE gedrückt, und klicken Sie mit der rechten Maustaste auf das Skype for Business 2016-Taskleistensymbol) zeigt die status "MAPI nicht verfügbar" an, wie gezeigt.

    Screenshot: M AP I status

    Wenn Sie auf die Registerkarte Unterhaltungen und dann auf Mehr in Outlook anzeigen klicken, wird die folgende Fehlermeldung angezeigt:

    Ihr Outlook-Profil ist nicht ordnungsgemäß konfiguriert. Wenden Sie sich mit diesen Informationen an Ihr Supportteam.

  • Stellvertretungsfunktionen können beschädigt werden. Beispielsweise können Sie keine Besprechung im Namen einer anderen Person planen. Wenn Sie versuchen, die Onlinebesprechung zu erstellen, wird die folgende Fehlermeldung angezeigt:

    Sie sind nicht berechtigt, Onlinebesprechungen im Namen des Besitzers dieses Kontos zu planen. Wenden Sie sich an den Besitzer des Kontos, um Stellvertretungsberechtigungen in Lync zu erhalten.

Ursache

Dieses Problem tritt auf, weil Skype for Business 2016 die eigenschaft PR_PROFILE_USER verwendet, um die Frei/Gebucht-Informationen abzurufen. Microsoft Outlook 2016 schreibt die Eigenschaft jedoch nicht als Teil des Features "Zuverlässige Profile".

Lösung

Um dieses Problem zu beheben, verwenden Sie je nach Office-Installationstyp eine der folgenden Methoden. Im Abschnitt "Weitere Informationen" erfahren Sie, ob Ihre Office-Installation MSI-basiert oder klick-und-run ist.

Für MSI-basierte Versionen von Skype for Business 2016

Um dieses Problem zu beheben, installieren Sie das Update vom 5. Juli 2016 (KB3115268) für Skype for Business 2016.

Klick-und-Run-Versionen von Skype for Business 2016

Aktueller Kanal (CC): Behoben in Builds 16.0.7167.2040 und höher

First Release Deferred Channel (FRDC): Behoben in Builds 16.0.6965.2078 und höher

Verzögerter Kanal (DC): Behoben in Builds 16.0.6965.2092 und höher

Weitere Informationen zu C2R-Kanalbuilds finden Sie unter Microsoft 365-Clientupdatekanalreleases.

Problemumgehung

Wichtig

Führen Sie die in diesem Abschnitt beschriebenen Schritte sorgfältig aus. Durch eine fehlerhafte Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Sichern Sie die Registrierung, bevor Sie sie ändern, damit Sie sie bei Bedarf wiederherstellen können.

Um dieses Problem in einer Klick-und-Run-Version von Skype for Business 2016 zu umgehen, verwenden Sie die Problemumgehung in diesem Abschnitt.

Hinweis

Nur die Problemumgehung selbst wird vom Outlook-Team unterstützt. Die vorläufigen Schritte im ersten Verfahren werden nicht unterstützt. Dieses Verfahren enthält jedoch Informationen, die zum Ausführen der Problemumgehung erforderlich sind. Diese Schritte bieten auch eine Methode, um zu überprüfen, ob die Problemumgehung ordnungsgemäß bereitgestellt wurde, und um die Änderungen bei Bedarf zu sichern.

Vorläufige Schritte (nicht unterstützt)

Wichtig

Das folgende Verfahren wird vom Outlook-Team nicht unterstützt und kann andere Probleme in Outlook verursachen. Verwenden Sie dieses Verfahren auf eigenes Risiko. Es wird davon abgeraten, dieses Verfahren zu verwenden. Wir fügen sie jedoch hier ein, da sie zuvor veröffentlicht wurde und Sie möglicherweise diese Schritte ausführen müssen, um die MAPI-PR_PROFILE_USER-Eigenschaft (oder den Registrierungsschlüssel) zu entfernen, nachdem Korrekturen für alle Klick-und-Los-Produktkanäle veröffentlicht wurden.

  1. Starten Sie den Registrierungs-Editor.

    Windows 10

    Geben Sie auf dem Startbildschirm regedit.exe ein, und tippen oder klicken Sie dann in den Suchergebnissen auf regedit .

    Windows 8.1 und Windows 8

    Wischen Sie von rechts nach rechts, um die Charms zu öffnen, wählen Sie Suchen aus, und geben Sie dann regedit.exe in das Suchfeld ein.

    Windows 7 und Windows Vista

    Klicken Sie auf Start, geben Sie regedit in das Feld Suche starten ein, und drücken Sie dann die EINGABETASTE. Wenn Sie zur Eingabe eines Administratorkennworts oder zur Bestätigung aufgefordert werden, geben Sie das Kennwort ein, oder klicken Sie auf Zulassen.

  2. Suchen Sie den folgenden Registrierungsunterschlüssel:

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Profiles

  3. Suchen und erweitern Sie unter diesem Unterschlüssel den Namen Ihres Outlook-Profils.

    Hinweis

    Standardmäßig lautet der Profilname "Outlook". Ihr Profil hat jedoch möglicherweise einen anderen Namen, wenn Sie es manuell erstellt haben.

  4. Suchen Sie unter dem Profil den Schlüssel 9375CFF0413111d3B88A00104B2A6676 , und erweitern Sie ihn.

  5. Unter dem Schlüssel 9375CFF0413111d3B88A00104B2A6676 sollte für jedes Konto in Ihrem Profil ein Unterordner angezeigt werden. Wählen Sie den ersten Unterordner (00000001) aus und überprüfen Sie dann die Daten des Binärwerts Kontoname, indem Sie auf den Wert doppelklicken. Wiederholen Sie diesen Vorgang, bis Sie den Wert Kontoname gefunden haben, der Ihre SMTP-Adresse enthält.

  6. Suchen Sie unter dem Unterschlüssel \0000000x, der Ihre SMTP-Adresse enthält, den Binärwert Dienst-UID.

    Hinweis

    Dieser Wert stellt eine GUID dar (z. B. c3 d1 9a 7b 80 1b c4 4a 96 0a e5 b6 3b f9 7c 7e).

  7. Suchen Sie den Unterordner in Ihrem Profil, der dem GUID-Wert entspricht, den Sie in Schritt 6 gefunden haben (z. B. \c3d19a7b801bc44a960ae5b63bf97c7e).

  8. Untersuchen Sie unter dem Unterschlüssel aus Schritt 7 den Binärwert 01023d0d .

    Hinweis

    Dieser Wert stellt eine GUID dar (z. B. 5f cf d5 f1 ba 5c 6f 45 b3 57 cc 5e 0d 16 94 58).

  9. Suchen Sie den Unterordner in Ihrem Profil, der dem GUID-Wert aus Schritt 8 entspricht (z. B. \5fcfd5f1ba5c6f45b357cc5e0d169458).

  10. Erstellen Sie an diesem Speicherort wie gezeigt einen Zeichenfolgenwert mit dem Namen 001e6603.

    Screenshot: Zeichenfolgenwert

  11. Suchen Sie den Legacy-Exchange-Domänennamen (DN) des Benutzers.

  12. Halten Sie STRG gedrückt, während Sie mit der rechten Maustaste auf das Outlook-Taskleistensymbol klicken. Wählen Sie dann Test E-Mail AutoConfiguration aus.

  13. Deaktivieren Sie im daraufhin geöffneten Dialogfeld die Kontrollkästchen GuessSmart undSichere Guessmart-Authentifizierung verwenden, und klicken Sie dann auf Testen.

  14. Wählen Sie nach Abschluss des Tests die Registerkarte XML aus, und suchen Sie dann wie gezeigt nach dem Wert Legacy DN.

    Screenshot: Fenster

    Kopieren Sie die Legacy-DN-Informationen. Obwohl der gesamte markierte Eintrag in diesem Screenshot hervorgehoben ist, ist der Wert, den Sie kopieren möchten, alles zwischen den <LegacyDN-Tags> . In diesem Beispiel lautet dies /o=Contoso /ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=4ef0d05da334258afda34a7ce08a430-TestDir1.

  15. Füllen Sie in der Registrierung das Feld Wertdaten aus, indem Sie die soeben kopierten Legacy-DN-Informationen verwenden, wie gezeigt. Klicken Sie anschließend auf OK.

    Screenshot: Fenster zum Bearbeiten des MAPI-Zeichenfolgenwerts

Problemumgehung (unterstützt)

  1. Rufen Sie das MFCMapi-Tool von der folgenden Website ab:

    MFCMapi

  2. Starten Sie das Tool auf dem Computer des betroffenen Benutzers.

    Screenshot: Startseite des MFCMapi-Tools

  3. Klicken Sie auf Profil und dann auf Profile anzeigen.

  4. Doppelklicken Sie auf das Profil des betroffenen Benutzers. In dieser Situation gibt es nur das Standardprofil mit dem Namen "Outlook". Wenn der Benutzer über mehrere Profile verfügt, wählen Sie das Profil aus, das sein primäres Benutzerkonto darstellt, bei dem dieses Problem auftritt.

    Screenshot: Profile in Outlook

  5. Suchen Sie in der geöffneten Tabelle Dienste den Dienst mit dem Anzeigenamen "Microsoft Exchange", und doppelklicken Sie dann auf diesen Dienst, um ihn zu öffnen.

    Screenshot: Microsoft Exchange-Dienst in der Tabelle

  6. In der Tabelle Providers, die geöffnet wird. Suchen Sie den Anbieter, der über die SMTP-Adresse des betroffenen Benutzers ohne Einträge für "PR_PROVIDER_DISPLAY" verfügt, und wählen Sie ihn aus.

    Screenshot: Tabelle

  7. Überprüfen Sie im MFCMapi-Tool das Fenster Anbieter, um sicherzustellen, dass der SMTP-Adressanbieter des Benutzers ausgewählt ist. Suchen Sie dann nach der Eigenschaft, die PR_PROFILE_USER benannt ist. Wenn diese Eigenschaft vorhanden ist, fahren Sie mit Schritt 10 fort. Wenn diese Eigenschaft nicht vorhanden ist, klicken Sie im Menü Eigenschaft auf Zusätzliche Eigenschaften, und klicken Sie dann auf die Schaltfläche Hinzufügen.

    Screenshot, der die Providers-Eigenschaft zeigt.

  8. Geben Sie im Dialogfeld Eigenschaftentag PR_PROFILE_USER ein.

    Hinweis

    MFCMapi übersetzt das benannte Eigenschaftstag wie gezeigt in die richtigen Werte.

    Screenshot: Fenster des Eigenschaftentag-Editors

  9. Klicken Sie auf OK. Klicken Sie dann im zusätzlichen Eigenschaftenfenster auf OK.

    Screenshot: Zusätzliche Eigenschaften

  10. Führen Sie Test AutoErmittlung über die Vorläufigen Schritte aus, um den Legacy Exchange DN (LegDN) des betroffenen Benutzers abzurufen. Kopieren Sie diese Informationen in die Zwischenablage.

  11. Klicken Sie im Fenster Anbieter mit der rechten Maustaste auf die Eigenschaft PR_PROFILE_USER, und klicken Sie dann auf Bearbeiten.

    Screenshot: Eigenschaften-Editor für die ausgewählte Eigenschaft

  12. Fügen Sie die LegDN-Informationen des Benutzers in das Textfeld Ansi ein, und klicken Sie dann auf OK.

    Screenshot: Seite

    Hinweis

    MFCMapi zeigt jetzt möglicherweise zwei Einträge für PR_PROFILE_USER an. Dies ist ein bekanntes Anzeigeproblem, das problemlos ignoriert werden kann.

  13. Optional: Verwenden Sie die unter Problemumgehung 1 beschriebene Methode, um den neuen Registrierungswert zu untersuchen, der von MFCMapi erstellt wurde, und überprüfen Sie, ob er sich im richtigen Outlook-Profil für den betroffenen Benutzer befindet.

    Screenshot: Outlook-Profile

  14. Schließen Sie alle MFCMapi-Fenster und registrierungs Editor, und testen Sie dann die MAPI-Konnektivität. Melden Sie sich außerdem vollständig von Skype ab, und vergewissern Sie sich, dass das Programm nicht ausgeführt wird.

  15. Melden Sie sich wieder bei Skype an, warten Sie ein oder zwei Minuten, und überprüfen Sie dann die Skype-Konfiguration. Der MAPI-Status sollte nun als OK angezeigt werden.

    Screenshot: M AP I status in Skype

    Hinweis

    Es kann einige Zeit dauern, bis die Änderung wirksam wird. Möglicherweise müssen Sie sich von Outlook und Skype for Business abmelden und sich dann wieder anmelden, um die Änderung zu sehen.

Weitere Informationen

Führen Sie die folgenden Schritte aus, um zu bestimmen, ob Ihre Office-Installation Klick-und-Run- oder MSI-basiert ist:

  1. Starten Sie eine Office 2016-Anwendung.
  2. Wählen Sie im Menü Datei die Option Konto aus.
  3. Für Office 2016 Klick-und-Run-Installationen wird ein Updateoptionen-Element angezeigt. Bei MSI-basierten Installationen wird das Element Updateoptionen nicht angezeigt.
Office 2016 Klick-und-Run-Installation MSI-basiertes Office 2016
Screenshot: Word Installationsoption klicken, um die Installation auszuführen. Screenshot, der die msi-Datei des Word zeigt.

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