Verwendung des Visual Basic-Aktualisierungs-Assistenten

Zusammenfassung

Dieser Artikel beschreibt, wie eine einfache Visual Basic 6.0-Anwendung erstellen und dann mithilfe des Visual Basic-Aktualisierungs-Assistenten in Visual Studio .NET oder Visual Studio 2005 die Anwendung Visual Basic .NET oder Visual Basic 2005 aktualisieren.

Hinweis Visual Basic .NET Upgrade Wizard wird in Visual Studio .NET Professional enthalten.

Hinweis Visual Basic 2005-Aktualisierungs-Assistenten wurde aus früheren Versionen von Visual Basic erweitert.

Voraussetzungen

Der folgenden Liste sind die empfohlene Hardware, Software, Netzwerkinfrastruktur, Qualifikationen, Kenntnisse und Servicepacks müssen Sie:
  • Microsoft Windows 2000 Professional (oder Server) oder Microsoft Windows XP Professional (oder Server) mit.NET Framework installiert
  • Microsoft Visual Basic 6.0
  • Microsoft SQL Server 7.0 oder höher mit der Datenbank Northwind, die entsprechenden Berechtigungen und Benutzer-ID und das Kennwort Werte
Erforderliche Vorkenntnisse:
  • Allgemeine Kenntnisse mithilfe von Visual Basic 6.0 erstellen

Verwenden der Visual Basic-Aktualisierungsassistent

Die folgenden Schritte zeigen, wie eine einfache Visual Basic 6.0-Anwendung erstellen und aktualisieren Sie die Anwendung auf Visual Basic .NET oder Visual Basic 2005 mithilfe des Visual Basic-Aktualisierungs-Assistenten in Visual Studio .NET oder Visual Studio 2005:
  1. Im Startmenü auf Programme, zeigen Sie auf Microsoft Visual Studio 6.0und klicken Sie dann auf Microsoft Visual Basic 6.0.
  2. Klicken Sie im Dialogfeld Neues Projekt klicken Sie auf Standard-EXEund klicken Sie dann auf Öffnen.
  3. Die erste Form in dieser Anwendung verwendet ADO Recordset abgerufen und zeigt das Recordset in einem Microsoft Hierarchische FlexTabelle-Steuerelement. Geben Sie im Feld Name im Dialogfeld Eigenschaften für Form1
    FrmADO.
  4. Wenn die Toolbox nicht geöffnet ist, im Menü Ansicht klicken Sie auf Toolbox.
  5. Aus der Toolbox Platzieren einer MSHFlexGrid auf dem Formular, damit es die meisten des Formulars ausfüllt. Lassen Sie Platz am unteren Rand des Formulars eine Schaltfläche platzieren.

    Hinweis: Wenn das MSHFlexGrid -Symbol in der Toolbox nicht angezeigt wird, es der Toolbox hinzufügen. Mit der rechten Maustaste in der Toolbox, und klicken Sie auf Komponenten. Aktivieren Sie im Dialogfeld Komponenten Microsoft Hierarchical FlexGrid Control 6.0 (OLEDB) aus der Liste der verfügbaren Komponenten, und klicken Sie auf OK.
  6. Aus der Toolbox Platzieren einer Befehlsschaltfläche auf dem Formular unterhalb der MSHFlexGrid. Geben Sie im Feld Beschriftung im Dialogfeld Eigenschaften OK.
  7. Maustaste auf mADO, und klicken Sie dann auf Code anzeigen. Fügen Sie den folgenden Code, dem eine Verbindung erstellt und gibt ein Recordset, das alle Daten aus der Tabelle der Northwind-Datenbank enthält.

    Hinweis: Sie müssen im folgenden Beispielcode ändern Benutzer-Id =< Benutzername > und
    Kennwort =< sicheres Kennwort > auf die richtigen Werte. Stellen Sie sicher, dass die Benutzer-ID die entsprechenden Berechtigungen für diesen Vorgang in der Datenbank.
    Private Sub Command1_Click()    Unload Me
    End Sub

    Private Sub Form_Load()
    Dim cn As Connection
    Set cn = New Connection
    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"
    cn.Open

    Dim rs As Recordset
    Set rs = New Recordset
    rs.CursorLocation = adUseClient
    rs.Open "select * from products", cn

    Set MSHFlexGrid1.DataSource = rs
    End Sub

  8. Drücken Sie STRG + S zum Speichern des Formulars. Klicken Sie im Menü Datei auf Speichern unter. Klicken Sie im Dialogfeld Speichern unter auf Speichern.
  9. Im Projekt-Explorer mit der rechten Maustaste Project1, klicken Sie auf Hinzufügenund dann auf Formular. Klicken Sie auf Öffnen.
  10. Geben Sie im Feld Name des Dialogfelds Eigenschaften FrmClipboard.
  11. Platzieren Sie aus der Toolbox ein Textfeld auf dem Formular. Geben Sie in das Textfeld der schnelle braune Fuchs sprang über den trägen Hund.
  12. Platzieren einer Befehlsschaltfläche unter das Textfeld. Geben Sie im Feld Beschriftung im Dialogfeld Eigenschaften Kopieren.
  13. Platzieren Sie eine zweite Befehlsschaltfläche auf dem Formular. Geben Sie im Feld Beschriftung im Dialogfeld Eigenschaften Einfügen.
  14. Maustaste auf FrmClipboard, und klicken Sie dann auf Code anzeigen. Fügen Sie folgenden Code für die Befehlsschaltfläche klicken Sie auf Ereignisse. Dieser Code verwendet die Zwischenablage -Objekt abrufen und den Text einfügen:
    Private Sub Command1_Click()    Clipboard.SetText Text1.SelText
    End Sub

    Private Sub Command2_Click()
    Text1.SelText = Clipboard.GetText
    End Sub

  15. Drücken Sie STRG + S zum Speichern des Formulars.
  16. Das letzte Formular wird das Hauptformular der Anwendung. Im Projekt-Explorer mit der rechten Maustaste Project1, klicken Sie auf Hinzufügenklicken Sie auf Formularund klicken Sie auf Öffnen.
  17. Geben Sie im Feld Name des Dialogfelds Eigenschaften FrmMain.
  18. Platzieren Sie aus der Toolbox eine Befehlsschaltfläche im Formular FrmMain. Geben Sie im Feld Beschriftung im Dialogfeld Eigenschaften von ADO.
  19. Platzieren Sie eine zweite Befehlsschaltfläche auf dem Formular. Geben Sie im Feld Beschriftung im Dialogfeld Eigenschaften der Zwischenablage.
  20. FrmMainMaustaste, und klicken Sie dann auf Code anzeigen. Fügen Sie folgenden Code für die Befehlsschaltfläche auf Ereignisse klicken, zeigen die beiden Formulare:
    Private Sub Command1_Click()    frmADO.Show
    End Sub

    Private Sub Command2_Click()
    frmClipboard.Show
    End Sub

  21. Drücken Sie STRG + S zum Speichern des Formulars.
  22. Im Projektmappen-Explorer mit der rechten Maustaste Projekt1und dann auf Eigenschaften von Project1. Klicken Sie im Feld Startobjekt FrmMain, und klicken Sie auf OK.
  23. Um einen Verweis auf die ADO-Komponente im Projekt hinzuzufügen, klicken Sie auf Referenzen. Klicken Sie in der Liste Verfügbare Verweise Microsoft ActiveX Data Object Library (jede Version 2.0 oder höher tun wird). Klicken Sie auf OK.
  24. Klicken Sie zum Kompilieren des Projekts im Menü Datei auf Project1.exe machen. Klicken Sie im Dialogfeld Projekt erstellen auf OK (akzeptieren Sie den Standardnamen).
  25. Drücken Sie F5, um die Anwendung im Debugmodus ausgeführt.

    Hinweis: Sie müssen nicht überprüfen, ob ältere Visual Basic-Anwendung ohne Probleme ausgeführt wird, bevor Sie aktualisieren.
  26. Schließen Sie die Visual Basic Development Environment. Aufgefordert werden, das Projekt zu speichern klicken Sie auf Ja. Verwenden Sie den Standardnamen, und speichern Sie das Projekt.
  27. Im Startmenü auf Programme, zeigen Sie auf Microsoft Visual Studio .NETund klicken Sie dann auf Microsoft Visual Studio .NET.
  28. Klicken Sie auf der Startseite auf Projekt öffnen. Suchen Sie den Ordner mit der Visual Basic 6.0-Projektdatei nur (normalerweise C:\Program Files\Microsoft Visual Studio\VB98) erstellt. Klicken Sie auf Project1.vdp, und klicken Sie auf Öffnen.
  29. Visual Studio .NET erkennt, dass dies eine ältere Visual Basic-Projekt und den Visual Basic-Aktualisierungs-Assistenten startet. Der Assistent zeigt eine Beschreibung der einzelnen Schritte gehen Sie durch die Schritte in der folgenden Reihenfolge:
    • Erstellen Sie ein neues Projekt in das vorhandene Projekt aktualisiert wird.
    • Kopieren Sie Dateien und Klassendateien in das neue Projekt.
    • Geben Sie einen Aktualisierungsbericht, die Komponenten des Projekts erfolgreich aktualisiert und die Komponenten, die nicht erfolgreich aktualisiert.

  30. Klicken Sie auf nächste Schritte bis der Upgrade-Prozess beginnt. Das Update wird ca. 30-60 Sekunden.
  31. Doppelklicken Sie im Projektmappen-Explorer _UpgradeReport.htmaus. Dieser Bericht zeigt die Ergebnisse der Aktualisierung. Beachten Sie, dass alle außer FrmClipboard ohne Probleme aktualisiert.
  32. Erweitern Sie frmClipboard.vb , um die Probleme anzuzeigen. Clipboard.SetText und GetText nicht korrekt aktualisiert. Klicken Sie auf die Beschreibung ein, wie zum Beheben der Probleme.
  33. Beachten Sie im Projektmappen-Explorer, dass alle ihre ursprünglichen Namen, aber die Erweiterung von frm zu geändert. vb.
  34. Erweitern Sie Verweise. Hinweis Verweise auf Komponenten, die älteren Visual Basic verwenden und ADO-Komponenten wurden automatisch hinzugefügt.
  35. Maustaste auf die Formulare und klicken Sie dann auf Code anzeigen. Erweitern Sie den Bereich Support aktualisieren . Dieser Bereich zeigt wie Visual Studio .NET oder Visual Studio 2005 verschiedene Eigenschaften und Variablen der aktualisierte Code konfiguriert.
  36. Im Projektmappen-Explorer mit der rechten Maustaste frmClipboard.vbund klicken Sie dann auf Code anzeigen. Beachten Sie, dass Kommentare vor den Zeilen, die nicht aktualisiert.
  37. Ändern Sie die Ereignisse Command1_Click und Command2_Click wie folgt:
    Private Sub Command1_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command1.Click
    Clipboard.SetDataObject(Text1.Text)
    End Sub

    Private Sub Command2_Click(ByVal eventSender As System.Object, _
    ByVal eventArgs As System.EventArgs) Handles Command2.Click
    Text1.SelectedText = _
    Clipboard.GetDataObject().GetData(GetType(System.String))
    End Sub

Vollständige Codelisten

Der vollständige Code aufgelistet (frmADO.frm)

Private Sub Command1_Click()    Unload Me
End Sub

Private Sub Form_Load()
Dim cn As Connection
Set cn = New Connection
cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"
cn.Open

Dim rs As Recordset
Set rs = New Recordset
rs.CursorLocation = adUseClient
rs.Open "select * from products", cn

Set MSHFlexGrid1.DataSource = rs
End Sub

Der vollständige Code aufgelistet (frmClipboard.frm)

Private Sub Command1_Click()    Clipboard.SetText Text1.SelText
End Sub

Private Sub Command2_Click()
Text1.SelText = Clipboard.GetText
End Sub

Complete Code Listing (frmMain.frm)
Private Sub Command1_Click()
frmADO.Show
End Sub

Private Sub Command2_Click()
frmClipboard.Show
End Sub

Überprüfen der Funktionsfähigkeit die Anwendung

  1. Drücken Sie F5, um die Anwendung zu starten.
  2. Aufforderung zum Speichern des Projekts klicken Sie auf OK.
  3. Klicken Sie in Form1 auf ADO. Ein Formular wird mit Daten in einem Raster angezeigt. Schließen Sie dieses Formular.
  4. Klicken Sie in Form1 auf Zwischenablage.
  5. Klicken Sie auf Kopieren.
  6. Setzen Sie die Einfügemarke in das Textfeld am Anfang des Textes und klicken Sie dann auf Einfügen. Den Text sollte angezeigt werden.

Problembehandlung:

Visual Basic .NET ist eine bedeutende Veränderung von früheren Versionen von Visual Basic. Für viele Projekte empfiehlt einige umfangreiche Vorbereitungsarbeiten vor der Aktualisierung. Finden Sie im folgenden Dokument Informationen leichter aktualisieren können:

REFERENZEN

Weitere Informationen finden Sie in folgenden Artikeln der Microsoft Developer Network (MSDN):
Eigenschaften

Artikelnummer: 317885 – Letzte Überarbeitung: 16.01.2017 – Revision: 1

Feedback