Ausgehende E-Mail-Nachrichten werden nicht auf dem Exchange Hub-Transport oder Edgeserver gesendet

Ursprüngliche KB-Nummer: 4051498

Symptome

Wenn Sie die status der Warteschlange untersuchen, wird die folgende Fehlermeldung angezeigt:

451 4.4.0 Die ip-Adresse des primären Ziels hat geantwortet: "421 4.4.1 Timeout bei der Verbindung." Es wurde versucht, ein Failover auf einen alternativen Host durchzuführen, aber dies war nicht erfolgreich. Entweder gibt es keine alternativen Hosts, oder die Übermittlung an alle alternativen Hosts ist fehlgeschlagen.

Darüber hinaus wird der folgende Eintrag in den Sendeconnectorprotokollen protokolliert, wenn die Protokollierung aktiviert ist:

Fehler bei der TLS-Aushandlung mit Dem Fehler UnknownCredentials.

Ursache

Dieses Problem tritt auf, wenn ein Drittanbieterzertifikat, das auf dem Server installiert ist, auf dem Exchange Server ausgeführt wird, nicht an den SMTP-Dienst gebunden ist.

Lösung

Um dieses Problem zu beheben, binden Sie das Drittanbieterzertifikat an den SMTP-Dienst. Gehen Sie dazu wie folgt vor:

  1. Aktivieren Sie die Protokollierung für den Sendeconnector. Führen Sie dazu den folgenden Befehl aus:

    Set-SendConnector "<SendConnectorName>" -ProtocolLoggingLevel Verbose
    
  2. Suchen Sie in den Sendeconnectorprotokollen nach dem Fingerabdruck des TLS-Zertifikats. Beispielprotokoll:

    2017-10-07T04:42:56.804Z,Ausgehend zu Office 365,08D50D3D9730A8D2,16,10 .10.248.7:16547,216.32.181.234:25,*,"CN=*.domain.com, OU=Enterprise SSL-Wildcard, OU=Contoso IT, O=Contoso Corporation",Zertifikatantragsteller
    2017-10-07T04:42:56.804Z,Ausgehend zu Office 365,08D50D3D9730A8D2,17,10 .10.248.7:16547,216.32.181.234:25,*,"CN=Trusted Secure Certificate Authority 5, O=Corporation Service Company, L=Wilmington, S=DE, C=US",Zertifikatausstellername
    2017-10-07T04:42:56.804Z,Ausgehend zu Office 365,08D50D3D9730A8D2,18,10.10.248.7:16547,216.32.181.234:25,*,xxxxxxxxxx,Seriennummer des Zertifikats
    2017-10-07T04:42:56.804Z,Ausgehend zu Office 365,08D50D3D9730A8D2,19,10.10.248.7:16547,216.32.181.234:25,*,xxxxxxxxxx,Zertifikatfingerabdruck
    2017-10-07T04:42:56.804Z,Ausgehend zu Office 365,08D50D3D9730A8D2,20,20, 10.10.248.7:16547,216.32.181.234:25,*,*.domai.com;conotso.com,Alternative Zertifikatnamen
    2017-10-07T04:42:56.804Z,Ausgehend zu Office 365,08D50D3D9730A8D2,21 10.10.248.7:16547,216.32.181.234:25,*,,TLS-Aushandlung fehlgeschlagen mit Dem Fehler UnknownCredentials

  3. Überprüfen Sie die Dienste, die dem TLS-Zertifikat zugeordnet sind. Führen Sie dazu den folgenden Befehl aus. Die Namen der Dienste werden im nächsten Schritt verwendet.

    Get-ExchangeCertificate -ThumbPrint "<TLSCertThumbprint>" | select-object services
    
  4. Binden Sie das Zertifikat an den SMTP-Dienst. Führen Sie dazu den folgenden Befehl aus:

    Enable-ExchangeCertificate -ThumbPrint "<TLSCertThumbprint>" -services <ServicesNames>
    

    Beispiel:

    Enable-ExchangeCertificate -ThumbPrint "xxxxxxxxxxxxxxxxxxxx" -services SMTP,IIS,POP
    
  5. Geben Sie an der Eingabeaufforderung zum Ersetzen des vorhandenen Zertifikats mithilfe des neuen Zertifikats N ein, und drücken Sie dann die EINGABETASTE.