Schlechte Leistung bei Verwendung eines benutzerdefinierten Standardbenutzerprofils in Windows

Dieser Artikel bietet eine Lösung für Probleme, die auftreten, wenn Sie Standardbenutzerprofile anpassen.

Gilt für: Windows 10 (alle Editionen), Windows Server 2019, Windows Server 2016
Ursprüngliche KB-Nummer: 4056823

Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  • Sie erstellen ein neues Standardbenutzerprofil und aktivieren es.
  • Ein neuer Benutzer meldet sich mit einem Profil an, das aus dem Standardprofil auf einem Windows 10-, Windows Server 2016- oder Windows Server 2019-basierten Computer erstellt wird.

In diesem Szenario tritt mindestens eines der folgenden Probleme auf:

  • Es dauert lange, bis Desktopsymbole angezeigt werden.

  • Die Leistung ist schlecht, wenn Sie in Internet-Explorer oder Microsoft Edge starten oder navigieren.

  • ESENT-Fehler wie die folgenden werden im Ereignisprotokoll aufgezeichnet:

    EventLogID: 454
    TaskHostW: (pid)
    WebCacheLocal: "Fehler bei der Datenbankwiederherstellung/Wiederherstellung mit unerwartetem Fehler -1907"

    Hinweis

    Die vollständige Ereignisprotokollmeldung kann auch auf eine Zuordnung mit einem anderen Benutzerordnerspeicherort hinweisen, z. B. C:\Users\Administrator.

Ursache

Diese Probleme treten auf, weil das Standardbenutzerprofil eine gesperrte Kopie der Cachedatenbank eines anderen Benutzers enthält.

Wenn sich ein neuer Benutzer am Computer anmeldet, wird der Standardinhalt des Benutzerprofils in das neue Profil integriert. Wenn die Windows-Shell und der Desktop zu laden beginnen, kann die Datenbank nicht vollständig für die Verwendung initialisiert werden. Anwendungen, die die Datenbank verwenden, treten bei der Leistung negativ auf oder melden Fehler.

Lösung

Führen Sie die folgenden Schritte aus, um das Problem zu beheben:

  1. Melden Sie sich bei jedem betroffenen Computer mit einem Konto mit Administratoranmeldeinformationen an, und löschen Sie dann die folgende ausgeblendete Datei und den folgenden Ordner, sofern vorhanden:

    Datei: C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
    Ordner: C:\Users\Default\AppData\Local\Microsoft\Windows\WebCache

  2. Stellen Sie für jedes Benutzerkonto auf dem Computer sicher, dass der Benutzer vollständig abgemeldet ist und das Profil vollständig entladen wurde, und löschen Sie dann die folgende ausgeblendete Datei und den folgenden Ordner, sofern vorhanden:

    Datei: C:\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCacheLock.dat
    Ordner: C:\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCache

Hinweis

<affectedUserFolder> ist ein Platzhalter für den Namen des Benutzerprofilordners. Für das Administratorbenutzerkonto befindet sich der Ordner beispielsweise unter C:\Users\Administrator. Sie müssen die oben genannten Dateien und Ordner für jedes betroffene Benutzerkonto auf dem Computer entfernen.

Anzeigen ausgeblendeter Dateien

Führen Sie die folgenden Schritte aus, um ausgeblendete Dateien anzuzeigen:

  1. Wählen Sie in Windows Explorer Datei und dann Optionen aus.
  2. Wählen Sie auf der Registerkarte Ansicht die Option Ausgeblendete Dateien, Ordner und Laufwerke anzeigen aus.
  3. Deaktivieren Sie die Option Geschützte Betriebssystemdateien ausblenden (empfohlen), und klicken Sie dann auf OK.

Hinweis

Es wird empfohlen, die beiden Optionen erneut auszuwählen, nachdem das Problem behoben wurde.

Weitere Informationen

Da die Cachedatenbank so konzipiert ist, dass sie bei der ersten Anmeldung auf einem einzelnen Computer pro Benutzer generiert wird, empfiehlt oder unterstützt Microsoft die Aufnahme der Cachedatenbank nicht in das Standardprofil oder in ein anderes Benutzerprofil, das als Vorlage verwendet werden soll.