Verschiedene Szenarien zum Speichern von Anlagen funktionieren in Outlook 2016 nicht wie erwartet

Ursprüngliche KB-Nummer: 4090818

Symptome

Microsoft Outlook bietet eine Reihe von Features zum Speichern von Anlagen in einer E-Mail-Nachricht. In diesem Prozess haben Sie die Möglichkeit, jede Anlage einzeln zu speichern oder alle Anlagen gleichzeitig zu speichern.

Outlook ermöglicht das Speichern von Dateien auf lokalen oder Netzwerklaufwerken, und auf die Funktionalität kann von verschiedenen Stellen in der Outlook-Benutzeroberfläche aus zugegriffen werden. Sie können beispielsweise mit der rechten Maustaste auf eine Anlage im Anlage well klicken und dann Alle speichern auswählen. Sie können auch anlagen speichern im Menü Datei auswählen. Es gibt jedoch mehrere Szenarien, in denen Sie die Anlage nicht wie erwartet speichern können.

Szenario 1: Alle können nicht an einem Netzwerkdateispeicherort gespeichert werden

Sie wählen Alle Anlagen speichern für eine E-Mail-Nachricht aus, die mehrere Anlagen enthält, und geben einen Netzwerkspeicherort als Ziel an. Die Dateien werden jedoch nicht erfolgreich am Netzwerkspeicherort gespeichert. Stattdessen werden Sie zur Dateiliste zurückgegeben, und Sie erhalten keine Fehlermeldung.

Szenario 2: Alle können nicht an einem Speicherort der SharePoint Online-Websitebibliothek gespeichert werden

Sie wählen Alle Anlagen speichern für eine E-Mail-Nachricht aus, die mehrere Anlagen enthält, und geben einen SharePoint Online-Speicherort als Ziel an. Die Dateien wurden jedoch nicht erfolgreich gespeichert, und Sie erhalten den Wert Kann die Anlage nicht speichern. Die Fehlermeldung Datei- oder Verzeichnisnamen ist ungültig .

Jemand sendet Ihnen eine moderne Anlage, bei der es sich um einen Link zu einer Datei handelt, die an einem Cloudspeicherort gespeichert ist. Sie versuchen, die Anlage an einem Netzwerkspeicherort zu speichern, aber das Speichern ist nicht erfolgreich. Wenn Sie die Option Alle Anlagen speichern verwenden, erhalten Sie den Wert Diese Datei kann nicht gefunden werden. Überprüfen Sie, ob pfad und Dateiname korrekt sind . Wenn Sie die Option Speichern unter verwenden, um die einzelne Anlage zu speichern, ist das Speichern nicht erfolgreich. Sie erhalten jedoch keine Fehlermeldung.

Szenario 4: Eine Anlage kann nicht auf einem zugeordneten Netzlaufwerk gespeichert werden

Sie haben eine Netzwerkfreigabe einem Laufwerkbuchstaben zugeordnet. Der Ordner \\server\share\ wurde beispielsweise dem Ordner H:\ zugeordnet. Wenn Sie versuchen, alle Anlagen aus einer E-Mail-Nachricht im Ordner H:\ zu speichern, ist das Speichern nicht erfolgreich. Sie erhalten jedoch keine Fehlermeldung.

Szenario 5: Pfadfehler beim Speichern einer einzelnen Datei aus dem Dialogfeld "Alle speichern"

Sie wählen Alle Anlagen speichern für eine E-Mail-Nachricht aus, die mehrere Anlagen enthält. Wählen Sie im Dialogfeld Alle speichern eine einzelne Datei aus, die gespeichert werden soll. Obwohl die Datei erfolgreich gespeichert wurde, erhalten Sie die Meldung "Pfad ist nicht vorhanden. Überprüfen Sie, ob der Pfad richtig ist" Fehlermeldung. Sie können diesen Fehler ignorieren.

Ursache

Aufgrund der vielen Variablen, die am Speichern von Dateien in einem Dateisystem beteiligt sind (Netzwerk oder lokal, Auswirkungen auf die Sicherheit, Berechtigungsanforderungen usw.), garantiert die Technologie, die von Microsoft Outlook in diesem Featuresatzbereich verwendet wird, keine erfolgreiche Speicherung in allen Szenarien in älteren Builds. Da Korrekturen für die Problemszenarien vorgenommen werden, werden die festen Buildinformationen in diesem Artikel aufgeführt.

Hinweis

  • Ab Outlook 365, Version 1806 (Build 10228.20080), sollten die Szenarien 1, 2 und 3 erfolgreich funktionieren.
  • Ab Outlook 365, Version 1807 (Build 10730.20088), sollte Szenario 4 erfolgreich funktionieren.
  • Ab Outlook 365, Version 1809 (Build 10872.20138), sollte Szenario 5 erfolgreich funktionieren.

Informationen zum Überprüfen des Outlook-Builds finden Sie unter Welche Version von Outlook habe ich?.

Problemumgehung

Um die im Abschnitt Symptome beschriebenen Szenarien zu beheben, wird eine neue Implementierung des Featuresatzes zum Speichern von Anlagen in Microsoft Outlook implementiert.

Wenn Sie einen älteren Outlook-Build verwenden, können Sie viele der Problemszenarien umgehen, indem Sie die Dateien an einem temporären lokalen Speicherort speichern und dann die üblichen Windows-Methoden verwenden, um die Dateien an den Netzwerkspeicherort zu kopieren. In vielen Szenarien können Sie die Anlage auch erfolgreich an das Ziel ziehen.

References

Einen Updateverlauf für Microsoft 365 Apps for Enterprise finden Sie unter Updateverlauf fürMicrosoft 365 Apps for Enterprise (nach Datum aufgelistet).