Langsame Leistung und hohe CPU-Auslastung in Microsoft Entra Connect Health for Sync Monitoring Agent auf einem System, auf dem .NET Framework
In diesem Artikel wird ein Problem beschrieben, das eine langsame Leistung und hohe CPU-Auslastung in Microsoft Entra Connect Health for Sync-Überwachungs-Agent auf einem System verursacht, auf dem .NET Framework 4.7.2 oder die Updates vom Juli 2018 für .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 oder 4.7.2 installiert sind.
Ursprüngliche Produktversion: Microsoft Entra ID
Ursprüngliche KB-Nummer: 4457331
Problembeschreibung
Angenommen, Sie führen den Microsoft Entra Connect Health for Sync-Überwachungs-Agent auf einem System aus, das .NET Framework 4.7.2 oder die Updates vom Juli 2018 für .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 oder 4.7.2 installiert hat. In diesem Szenario kann es zu einer langsamen Leistung und einer hohen CPU-Auslastung des Systems führen.
Um die hohe CPU-Auslastung anzuzeigen, starten Sie den Task-Manager, und zeigen Sie die CPU-Auslastung des MIcrosoft.Online.Reporting.MonitoringAgent.Startup-Prozesses auf der Registerkarte Prozesse an.
Ursache
Dieses Problem tritt auf, weil der Microsoft Entra Connect Health for Sync-Überwachungs-Agent .NET Framework 4.7.2 oder die Updates vom Juli 2018 für .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 oder 4.7.2 nicht vollständig unterstützt. Die folgenden Updates können zu einer hohen CPU-Auslastung des Überwachungs-Agents führen.
.NET FrameworkUpdate | Serverversion | Updatetyp |
---|---|---|
KB-4340007 | Windows Server 2008 | Sicherheit |
KB-4340556 | Windows Server 2008 R2 | Sicherheit |
KB-4340004 | Windows Server 2008 R2 | Sicherheit |
KB-4340557 | Windows Server 2012 | Sicherheit |
KB-4340005 | Windows Server 2012 | Sicherheit |
KB-4340558 | Windows Server 2012 R2 | Sicherheit |
KB-4340006 | Windows Server 2012 R2 | Sicherheit |
KB-4054542 | Windows Server 2012 | Nicht sicherheitsrelevante |
KB-4054566 | Windows Server 2012 R2 | Nicht sicherheitsrelevante |
KB-4054590 | Windows Server 2016 | Nicht sicherheitsrelevante |
KB-4338814 | Windows Server 2016 (Build 14393.2363) | Nicht sicherheitsrelevante |
KB-4345418 | Windows Server 2016 (Build 14393.2368) | Nicht sicherheitsrelevante |
Fehlerbehebung
Um dieses Problem zu beheben, installieren Sie das Update, das für Ihre Umgebung geeignet ist.
Für Connect Health für AD DS und AD FS
Installieren Sie den Microsoft Entra Connect Health-Agent, Version 3.1.7.0, die im Juli 2018 veröffentlicht wurde. Dieses Update ist verfügbar für [download here]/azure/active-directory/hybrid/how-to-connect-health-agent-install#download-and-install-the-azure-ad-connect-health-agent).
Für Microsoft Entra Connect
Installieren Sie die neueste Version von Microsoft Entra Connect, die die Behebung dieses Problems mit hoher CPU-Auslastung enthält. Diese Version steht hier zum Download zur Verfügung.
Hinweis
Wenn Sie das Feature für das automatische Upgrade auf Ihrem Microsoft Entra Connect-Server aktiviert haben, wird die neueste Version automatisch installiert.
Virenscan-Anspruch
Microsoft hat diese Datei mit der aktuellsten Virenerkennungssoftware gescannt, die zum Zeitpunkt der Veröffentlichung der Datei verfügbar war. Die Datei wird auf Servern mit verbesserter Sicherheit gespeichert, die dazu beitragen, nicht autorisierte Änderungen daran zu verhindern.
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