Fehler, wenn ein Benutzer ein Zertifikat von den Webregistrierungsseiten der Zertifizierungsstelle anfordert: Es wurden keine Zertifikatvorlagen gefunden.

Dieser Artikel enthält Hilfe bei der Behebung des Fehlers "Es wurden keine Zertifikatvorlagen gefunden", der auftritt, wenn Sie Zertifikate von Webregistrierungsseiten der Zertifizierungsstelle anfordern.

Gilt für: Windows Server 2003
Ursprüngliche KB-Nummer: 811418

Symptome

Wenn ein Benutzer versucht, ein Zertifikat von den Webregistrierungsseiten der Zertifizierungsstelle (Ca) anzufordern, erhält der Benutzer möglicherweise die folgende Fehlermeldung:

Es konnten keine Zertifikatvorlagen gefunden werden. Sie sind nicht berechtigt, ein Zertifikat von dieser Zertifizierungsstelle anzufordern, oder beim Zugriff auf Active Directory ist ein Fehler aufgetreten.

Dieses Verhalten tritt auf, wenn sich die Webregistrierungsseiten in einer Active Directory-Domäne auf einem Unternehmenszertifizierungsstellenserver befinden. Es tritt auf, ob sich die Webregistrierungsseiten auf demselben Server oder auf einem anderen Mitgliedsserver befinden.

Ursache

Die Webregistrierungsseiten der Zertifizierungsstelle führen einen Zeichenfolgenvergleich zwischen zwei Werten durch, bei dem die Groß-/Kleinschreibung beachtet wird. Ein Wert ist der sServerConfig-Wert in der Datei Certdat.inc im %systemroot%\System32\Certsrv Ordner auf dem Zertifikatserver, und der andere Wert ist das dnsHostName-Attribut für das pkiEnrollmentService-Objekt in Active Directory. Wenn die beiden Zeichenfolgen, einschließlich der Groß-/Kleinschreibung, nicht übereinstimmen, schlägt die Registrierung fehl.

Lösung

Führen Sie die folgenden Schritte aus, um dieses Verhalten zu korrigieren:

  1. Zeigen Sie das Active Directory-Attribut dNSHostName für das pkiEnrollmentService-Objekt an. Dieses Objekt befindet sich an der folgenden Stelle:

    CN= CertificateServer,CN=Enrollment Services,CN=Public Key Services,CN=Services,CN=Configuration,DC= MyDomain,DC=com

    Um das dNSHostName-Attribut anzuzeigen, verwenden Sie ADSIEdit.msc oder LDP.exe.

  2. Bearbeiten Sie die Datei Certdat.inc so, dass der Wert für sServerConfig mit dem Wert für das Attribut dNSHostName gefolgt vom Namen der Zertifizierungsstelle identisch ist.

    Hinweis

    Der sServerConfig-Wert muss in der genauen Groß-/Kleinschreibung wie das dNSHostName-Attribut vorliegen. Wenn dies nicht der Fall ist, erhalten Sie weiterhin denselben Fehler.

  3. Wenn der DNS-Hostname für die Zertifizierungsstelle beispielsweise server1.domain.local und der Name der Zertifizierungsstelle MYCA ist, stellen Sie dann sicher, dass das dNSHostName-Attribut für CN=MYCA,CN=Enrollment Services,CN=Public Key Services,CN=Services,CN=Configuration,DC= Domain,DC=local object auf server1.domain.local und sServerConfig in der Datei certdat.inc im %systemroot%\system32\certsrv Ordner der Zertifizierungsstelle auf server1.domain.local\MYCA festgelegt ist..

  4. Lassen Sie den Benutzer, der das Zertifikat anfordern möchte, internet Explorer neu starten. Dadurch können die neuen Anmeldeinformationen an die Zertifizierungsstelle übergeben werden.

    Hinweis

    Stellen Sie außerdem sicher, dass dem Benutzer lese- und registrierungsberechtigungen für die Zertifikatvorlage gewährt werden, die dieser Benutzer anfordert. Sie können diese Berechtigungen entweder mithilfe des ADSIEdit-Snap-Ins oder des Zertifikatvorlagen-Snap-Ins erteilen.