Intermittent "Stop error code 0x0000001E" error message

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

Symptoms

Intermittently, when you make a terminal connection to a multiple-processor computer, the computer may unexpectedly shut down (crash), and you may receive a "Stop 0x1E" error message. The crash occurs in Win32k.sys when Win32k.sys handles fonts on multiple-processor computers that use Asian languages.

Cause

This problem occurs because of a synchronization problem between a CSCSS thread and a USERINIT thread in this new terminal connection on a multiple-processor computer.

Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Windows Server 2003

Prerequisites
No prerequisites are required.
Restart Requirement
You must restart your computer after you apply this hotfix.
Hotfix Replacement Information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date Time Version Size File name
------------------------------------------------------
14-Oct-2003 00:23 5.2.3790.92 1,811,456 Win32k.sys

Windows XP

Prerequisites
You must have Windows XP Service Pack 1 (SP1) to install this hotfix.
Restart Requirement
You must restart your computer after you apply this hotfix.
Hotfix Replacement Information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date Time Version Size File name
--------------------------------------------------------
15-Oct-2003 00:16 5.1.2600.1310 1,796,864 Win32k.sys

Windows 2000

Prerequisites
You must have Windows 2000 Service Pack 4 (SP4) to install this hotfix.
Restart Requirement
You must restart your computer after you apply this hotfix.
Hotfix Replacement Information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date Time Version Size File name
----------------------------------------------------------
16-Sep-2003 04:03 5.0.2195.6820 42,256 Basesrv.dll
13-Sep-2003 04:53 5.0.2195.6820 236,304 Cmd.exe
16-Sep-2003 04:03 5.0.2195.6820 222,992 Gdi32.dll
16-Sep-2003 04:03 5.0.2195.6820 711,440 Kernel32.dll
16-Sep-2003 04:03 5.0.2195.6820 333,584 Msgina.dll
16-Sep-2003 04:03 5.0.2195.6820 90,232 Rdpwd.sys
13-Sep-2003 04:36 5.0.2195.6813 5,280,768 Sp3res.dll
16-Sep-2003 04:03 5.0.2195.6820 380,176 User32.dll
16-Sep-2003 04:03 5.0.2195.6820 385,808 Userenv.dll
16-Sep-2003 03:24 5.0.2195.6821 1,628,560 Win32k.sys
13-Sep-2003 03:23 5.0.2195.6820 182,032 Winlogon.exe
16-Sep-2003 04:03 5.0.2195.6820 243,984 Winsrv.dll
16-Sep-2003 04:03 5.0.2195.6820 711,440 Kernel32.dll
16-Sep-2003 03:24 5.0.2195.6821 1,628,560 Win32k.sys
16-Sep-2003 04:03 5.0.2195.6820 243,984 Winsrv.dll

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

More Information

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming Schema for Microsoft Windows Hotfix Packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates
Eigenschaften

Artikelnummer: 828514 – Letzte Überarbeitung: 10.10.2014 – Revision: 1

Feedback