Beschreibung von bislang unbekannten Tipps zu Excel

Zusammenfassung

Dieser Artikel beschreibt einige der leistungsstärksten Features und Funktionen in Microsoft Excel, die bislang von Benutzern noch. Beispielsweise können Sie ein neues Makro eine Berechnung bei einer vorhandenen Formel oder Funktion der Aufgabe. Oder Sie können ein neues Makro um eine Aufgabe auszuführen, wenn Sie ein vorhandenes Feature verwenden können, das die Aufgabe ausführt.

IN DIESER AUFGABE

Einführung

Dieser Artikel enthält Tipps zur Verwendung von Microsoft Excel.

zurück zum Anfang

Weitere Informationen

Verknüpfen von Text in mehreren Spalten

Sie können verketten oder Text in mehreren Spalten mithilfe der & -Operator oder die Verketten -Funktion – z. B. anfügen, wenn Sie die folgenden Daten in Zellen A1:C2 eingeben:

A1: ersteB1:
Mitte
C1: letzte
A2: TomB2:
Edward
C2: Smith

Um den vollständigen Namen in Zelle D2 setzen, geben Sie die folgenden Formeln:
$D$2: =CONCATENATE(A2," ",B2," ",C2)
$D$2: =A1&" "&B2&" "&C2
Hinweis Ein Leerzeichen ("") zwischen den Zellen wird verwendet, um ein Leerzeichen zwischen den angezeigten Text einzufügen.

zurück zum Anfang

Festlegen des Druckbereichs

Seit Microsoft Excel 97 für Windows wurde eine Symbolleistenschaltfläche Druckbereich festlegen im Menü Datei verfügbar. Beim Klicken auf die Symbolleistenschaltfläche Druckbereich festlegen können Sie den Druckbereich auf die aktuelle Auswahl festlegen. Nach dem Hinzufügen der Druckbereich Symbolleisten-Schaltfläche zu einer vorhandenen Symbolleiste können Sie Druckbereich festlegen , um einfach einen Druckbereich auf den ausgewählten Bereich festlegen klicken.

Gehen Sie folgendermaßen vor, um die Symbolleistenschaltfläche Druckbereich festlegen in Excel hinzuzufügen:
  1. Auf der
    Klicken Sie im Menü Ansicht auf Symbolleistenzeigen und dann auf
    Anpassen.
  2. Klicken Sie auf die Registerkarte Befehle .
  3. Klicken Sie unter Kategorienauf
    Dateiund dann Bildlauf unten in der Liste Befehle bis Symbolleistenschaltfläche Druckbereich festlegen angezeigt.
  4. Klicken Sie auf Druckbereich festlegen, und ziehen Sie den Befehl auf eine vorhandene Symbolleiste.
zurück zum Anfang

Ausschließen von doppelt vorhandenen Elementen in einer Liste

Erstellen einer Liste von Elementen, die Duplikate enthält, und eine eindeutige Liste abgeleitet, verwenden Sie den Befehl Spezialfilter in Excel.

Gehen Sie hierzu folgendermaßen vor:
  1. Geben Sie die folgenden Daten in die Zellen a1: a10 in einer neuen Arbeitsmappe:

    A1: Früchte
    A2: Apple
    A3: Cherry
    A4: Birne
    A5: Cherry
    A6: Plum
    A7: Apple
    A8: Apple
    A9: Birne
    A10: Apple
  2. Auf der
    Im Menü Daten auf Filterund klicken Sie dann auf Spezialfilter.
  3. Klicken Sie unter Aktionauf zu kopieren.
  4. Geben Sie im Feld Listenbereich
    $A$1:$A$10.
  5. Klicken Sie auf keine DuplikateTyp $B$ 1 in Kopieren zuFeld, und klicken Sie dann auf OK.

    Die folgende eindeutige Liste wird in Spalte b

    B1: Früchte
    B2: Apple
    B3: Cherry
    B4: Birne
    B5: Plum
Beachten Sie, dass diese Methode auch für mehrere Spalten. Wenn Sie den Befehl Spezialfilter verwenden, können Sie Zeilen ausblenden.

zurück zum Anfang

Multiplizieren von Textwerten mit 1, um Text in Zahlen zu ändern

Wenn Sie Dateien aus anderen Quellen importieren, können numerische Werte Zahlen jedoch wie Textwerte angezeigt. Um dieses Problem zu beheben, konvertieren Sie diese Werte in Zahlen. Eine Methode hierfür ist diese Textwerte mit 1 zu multiplizieren.

Um die Textwerte zu konvertieren, gehen Sie folgendermaßen vor:
  1. Klicken Sie auf eine leere Zelle im Arbeitsblatt sicher, dass die Zelle nicht als Text formatiert ist, und geben Sie 1 in die Zelle.
  2. Die leere Zelle, klicken Sie auf Kopieren der
    Menü Bearbeiten .
  3. Wählen Sie den Bereich mit den Werten, die Sie in Zahlen umwandeln möchten.
  4. Auf der
    Klicken Sie im Menü Bearbeiten klicken Sie auf Einfügen.
  5. Klicken Sie unter Vorgangauf
    Multiplizieren, und klicken Sie dann auf OK.
Diese Methode konvertiert den Text in Zahlen. Sie können feststellen, ob Sie erfolgreich die Textwerte konvertiert die Ausrichtung der Nummer. Wenn Sie das Format und die Werte rechts ausgerichtet werden, die Werte Zahlen und die Textwerte sind links ausgerichtet.

zurück zum Anfang

Verwenden Sie der Textimport-Assistent, um Text in Zahlen zu ändern

Gehen Sie hierzu folgendermaßen vor:
Diese Methode konvertiert Text in Zahlen. Sie können feststellen, ob Sie erfolgreich die Textwerte konvertiert die Ausrichtung der Nummer. Wenn Sie das Format und die Werte rechts ausgerichtet werden, die Werte Zahlen und die Textwerte sind links ausgerichtet.

zurück zum Anfang

Sortieren von Dezimalzahlen in einer Gliederung

Angenommen Sie, Sie erstellen die folgenden Gliederungspunkte in den Zellen a1: a6:

A1: 1.1.0
A2: 1.10.0
A3: 1.2.0
A4: 1.20.0
A5: 1.21.1
A6: 1.3.0

Nachdem Sie die Gliederungspunkte sortiert haben, werden sie in derselben Reihenfolge angezeigt. Die Gliederungsnummern werden in der Reihenfolge, die Sie eingegeben haben. Jedoch die Zahlen zwischen den Dezimalstellen sortieren, verwenden Sie den Textimport-Assistenten. Gehen Sie hierzu folgendermaßen vor:
Die sortierte Liste wird in Spalte A.

zurück zum Anfang

Verwenden Sie ein Formular, um Datensätze zu einer Liste hinzufügen

Wenn beim Hinzufügen von Datensätzen zu einer Liste verwenden Sie ein vordefiniertes Formular. Dazu klicken Sie auf eine Zelle in der Liste und klicken Sie dann auf
Formular im Menü Daten .
Public/EN-US/Office/Excel/843504A.gif
zurück zum Anfang

Geben Sie das aktuelle Datum oder die Uhrzeit

Wenn Sie schnell das aktuelle Datum in eine Zelle eingeben möchten, drücken Sie STRG +; und drücken Sie die EINGABETASTE. Um schnell die aktuelle Uhrzeit in eine Zelle einzugeben, drücken Sie STRG +: und drücken Sie dann die EINGABETASTE.

zurück zum Anfang

Anzeigen der Argumente in einer Formel

Während Sie eine Formel in eine Zelle eingeben, drücken Sie STRG + UMSCHALT + A , um die Argumente in einer Formel anzuzeigen. Wenn Sie = Zinsund drücken Sie dann STRG + UMSCHALT + A, die Argumente für diese Funktion beispielsweise = RATE (Zzr, Rmz, BW, Zw, Typ, Schätzwert)angezeigt. Wenn Sie mehr Details wünschen, = Zinsund drücken Sie STRG + A, um den Funktions-Assistenten anzuzeigen.

zurück zum Anfang

Geben Sie den Text oder die Formel in einen Zellbereich

Wenn Sie schnell den gleichen Text oder die gleiche Formel in einen Zellbereich eingeben möchten, gehen Sie folgendermaßen vor:
Die Daten in den ausgewählten Bereich.

zurück zum Anfang

Verknüpfen eines Textfelds mit Daten in einer Zelle

Gehen Sie hierzu folgendermaßen vor:
In der verknüpften Zelle eingegebenen Text erscheint z. B. in dem Textfeld,
A1. Sie können das Textfeld jedem Arbeitsblatt in der Arbeitsmappe verschoben.

zurück zum Anfang

Verknüpfen eines Bildes mit einem Zellbereich

Sie können einen Zellbereich kopieren und das Ergebnisbild in ein Arbeitsblatt einfügen. Wenn Sie dies tun, sehen einfach Zelleninhalt überall im Arbeitsblatt Sie. Diese Methode können Sie nicht benachbarte Zellen auf einer Seite drucken. Das Bild ist verknüpft und mit Inhalt und Format aktualisiert. Gehen Sie folgendermaßen vor, um ein verknüpftes Bild zu erstellen:
Das Ergebnis ist eine Momentaufnahme, die aktualisiert wird, wenn die Quellzellen geändert oder formatiert werden.

zurück zum Anfang

Problembehandlung bei einer langen Formel

Wenn Sie eine lange Arbeitsblattformel, die nicht das erwartete Ergebnis zurückgibt erstellen, ziehen Sie den Teil der Formel in der Bearbeitungsleiste, und drücken Sie F9. Wenn Sie dies tun, wird nur der ausgewählte Teil der Formel ausgewertet.

Wichtig Wenn Sie ENTERdrücken, wird dieser Teil der Formel verloren. Stellen Sie daher sicher, dass Sie ESC drücken. Versehentlich durch Drücken der EINGABETASTEdrücken Sie STRG + Z , um die Änderung rückgängig machen Sie.

zurück zum Anfang

Grafisch einen definierten Namen anzeigen

Hinweis Dieser Abschnitt gilt für Excel 97 für Windows nur.

Beim Festlegen von Feld Zoom für ein Arbeitsblatt auf eine Einstellung, 39 Prozent oder weniger, ein definierter Namen, der aus einem Zellbereich mit zwei oder mehr benachbarten Zellen in einem Rechteck auf dem Bildschirm angezeigt. Klicken Sie auf der Standardsymbolleiste auf Vergrößern und geben einen Wert von 40 Prozent verschwinden Rechtecke, die identifizieren, benannte Bereiche automatisch. Beachten Sie, dass diese Funktion nicht in früheren Versionen von Microsoft Excel.

zurück zum Anfang

Füllen Sie leerer Zellen in einer Spalte mit Inhalten aus einer vorherigen Zelle aus

Angenommen Sie, Sie die folgenden Namen in Spalte a Geben
Public/EN-US/Office/Excel/843504B.gif
Um die Namen korrekt zu sortieren, geben Sie Namen in die leeren Zellen. Gehen Sie hierzu folgendermaßen vor:
Die Namen werden die Zellen für Sie ausgefüllt.

zurück zum Anfang

Wechseln von einem relativen Bezug zu einem absoluten Bezug

Drücken Sie F4 , um die relativen und absoluten Zelladressen für eine Formel zu wechseln. Wenn Sie eine Formel in der Bearbeitungsleiste eingeben, verwenden Sie beispielsweise einen Zellbezug in Form einer relativen Adresse, verwenden Sie A1. Nach der Eingabe des Verweis F4 drücken und der Zellbezug automatisch in ein absoluter Zellbezug – z. B. geändert $A$ 1. Sie können auch drücken F4 , um gemischte absolute und relative Bezüge anzuzeigen.

Weitere Informationen zu Zellbezügen klicken Sie auf die Registerkarte Suchen in der Hilfe zu Microsoft Excel absolutund relativ und doppelklicken Sie auf das Thema der Unterschied zwischen relativen und absoluten Bezügen .

zurück zum Anfang

Verwenden Sie zum Ändern von Daten in Zellen, die eingefügt werden

Angenommen, dass Sie mit den folgenden Daten in Zellen a1: a7 und die letzte Zeile in der ersten Zeile des Bereichs subtrahieren möchten:

A1: 1
A2: 2
A3: 3
A4: 4
A5: 5
A6:
A7: =A5-A1

Angenommen Sie, Sie möchten eine Formel, die immer zwei Zeilen unter der letzten Zelle mit einer leeren Zelle zwischen der Formel und der letzten Zelle mit Daten. Angenommen Sie, wenn Sie eine neue Zeile bei der leeren Zelle (Zeile 6 im folgenden Beispiel), soll die Formel subtrahiert die Daten einfügen, die in Zelle A1 aus den Daten in Zelle A6 anstelle von Daten ist in Zelle A5.

Beachten Sie, dass in diesem Beispiel wird die Formel
= A1 A5 wird nicht subtrahiert die Daten in Zeile A6 beim Einfügen einer Zeile mit Daten in A6.

Verwenden Sie dazu die Funktion . Die Funktion gibt einen Verweis auf einen Bereich, die angegebene Anzahl von Zeilen und Spalten eine Zelle oder einen Zellbereich. Verwenden Sie in diesem Beispiel die folgende Formel:
=OFFSET(A6,-1,0)-A1
Die
OFFSET Formel ist auf die Zeile oberhalb A6 und ändert nicht behoben, neue Zeilen einfügen.

zurück zum Anfang

Verwenden Sie den Befehl Spezialfilter

Wenn eine Liste mit Daten in Excel erstellen und Sie bestimmte Elemente auswählen und auf ein anderes Arbeitsblatt kopieren möchten, verwenden Sie den Befehl Spezialfilter in Excel. Um diesen Befehl zu verwenden, zeigen Sie im Menü Daten auf Filter , klicken Sie auf Spezialfilterund folgen Sie der Anleitung auf dem Bildschirm angezeigt. Wenn Sie nicht sicher Informationen Excel vorausgesetzt werden sind, finden Sie in Microsoft Excel-Hilfe.

zurück zum Anfang

Verwenden Sie bedingter Summen zum Summieren von Daten

Angenommen Sie, erstellen eine Liste von Daten in die Zellen a1: a10, und alle Werte addiert, die größer als 50 und kleiner als 200 sind. Verwenden Sie hierzu die folgende Arrayformel:
= Summe (IF (a1: a10 > = 50, wenn (a1: a10 < = 200 a1: a10, 0), 0))
Hinweis Stellen Sie sicher, dass die Formel als Matrix einzugeben, drücken Sie STRG + UMSCHALT + Eingabe. Nachdem Sie dies tun, sehen Sie geschweifte Klammern {} um die Formel. Versuchen Sie nicht, die Klammern manuell einzugeben.

Die Formel verwendet geschachtelte Wenn -Funktionen für jede Zelle im Bereich und fügt die Daten nur, wenn beide Kriterien erfüllt sind.

zurück zum Anfang

Verwenden Sie bedingter Summen zum Zählen von Daten

Angenommen Sie, eine Liste von Daten in die Zellen a1: a10 erstellen und Sie möchten alle Werte zählen, die größer als 50 und kleiner als 200 sind. Verwenden Sie hierzu die folgende Arrayformel:
= Summe (IF (a1: a10 > = 50, wenn (a1: a10 < = 200, 1, 0), 0))
Hinweis Stellen Sie sicher, dass die Formel als Matrix einzugeben, drücken Sie STRG + UMSCHALT + Eingabe. Nachdem Sie dies tun, sehen Sie geschweifte Klammern {} um die Formel. Versuchen Sie nicht, die Klammern manuell einzugeben.

Die Formel verwendet geschachtelte Wenn -Funktionen für jede Zelle im Bereich und fügt eine Summe nur, wenn beide Kriterien erfüllt sind.

zurück zum Anfang

Verwenden der Index- und der Suchen-Funktion zum Nachschlagen von Daten

Angenommen Sie, die folgende Tabelle mit Informationen in den Zellen a1: C5 erstellen und diese Tabelle Informationen in den Zellen C1: C5 enthält:
Public/EN-US/Office/Excel/843504C.gif
Angenommen Sie, Sie das Alter einer Person mithilfe der Person suchen möchten. Verwenden Sie dazu eine Kombination der Index- und der Suchen -Funktion, wie in der folgenden Beispielformel:
= INDEX($A$1:$C$5, MATCH("Mary",$A$1:$A$5,),3)
Diese Beispielformel verwendet Zellen a1: C5 als Tabelle und sucht nach Alter von Maria in der dritten Spalte. Die Formel gibt 22 zurück.

zurück zum Anfang

Ziehen des Ausfüllkästchens zur Erstellung einer Nummernreihe

Indem Sie das Ausfüllkästchen einer Zelle ziehen, können Sie den Inhalt der Zelle in andere Zellen in derselben Zeile oder Spalte kopieren. Wenn die Zelle eine Zahl, Datum enthält oder Zeitraum Excel in einer Reihe projizieren kann die Werte nicht erhöht kopiert. Beispielsweise enthält die Zelle "Januar", können Sie schnell füllen Sie andere Zellen in einer Zeile oder Spalte mit "Februar", "März" usw. Sie können auch eine benutzerdefinierte Datenreihe für häufig verwendete Texteinträge wie Verkaufsregionen Ihres Unternehmens erstellen.

zurück zum Anfang

Füllen Sie Automatisches mit Daten aus

Doppelklicken Sie auf das Ausfüllkästchen einer ausgewählten Zelle der Inhalt der Zelle in einer Spalte dieselbe Anzahl von Zeilen wie der angrenzenden Spalte ausfüllen. Wenn Daten im Zellbereich a1: A20 eingeben, eine Formel oder Text in die Zelle B1 geben, drücken Sie die EINGABETASTE und doppelklicken Sie auf das Ausfüllkästchen, füllt Excel die Daten der Spalte von der Zelle B1 bis zur Zelle B20.

zurück zum Anfang

Verwenden Sie die Funktion SVERWEIS mit nicht sortierten Daten

In Excel 97 für Windows und höher funktioniert die Funktion SVERWEIS bei Verwendung mit nicht sortierten Daten. Allerdings müssen Sie ein zusätzliches Argument zu der Formel hinzufügen. Das Argument Bereich_Verweis wird TRUE , wenn Sie keinen Wert angeben. Beachten Sie, dass das Argument Bereich_Verweis das vierte Argument ist. Aufgrund dieses Verhaltens ist die Funktion kompatibel mit früheren Versionen von Excel.

Soll die Funktion SVERWEIS ordnungsgemäß mit nicht sortierten Daten, ändern das Bereich_Verweis -Argument auf FALSE. Folgendes ist eine Beispiel-Funktion das Alter der Stan in der Datentabelle, die weiter oben im Abschnitt sucht "Verwenden der Index- und der Suchen-Funktion zum Nachschlagen von Daten" erstellt:
=VLOOKUP("Stan",$A$2:$C$5,3,false)
zurück zum Anfang

Zurückgeben von jeder dritten Zahl

Angenommen Sie, in der folgenden Datentabelle in die Zellen a1: a12 erstellen und jeder dritten Zahl in einer Spalte zu erhalten und die Zahlen in eine angrenzende Spalte werden soll:
Public/EN-US/Office/Excel/843504D.gif
Dazu verwenden Sie die Zeile -Funktion mit der Funktion – beispielsweise, mithilfe der folgenden Beispielformel:
=OFFSET($A$1,ROW()*3-1,0)
Dabei hängt die Zeile der Zelle, eingegeben werden. Die Formel gibt die Funktion Zeile die Zeilennummer der Zelle, die Formel eingegeben werden. Diese Zahl wird mit 3 multipliziert. Die Funktion verschiebt der aktiven Zelle unten aus Zelle A1 die angegebene Anzahl von Zeilen und jeder dritten Zahl zurückgibt.

zurück zum Anfang

Rundung auf den nächsten Cent

Angenommen Sie, die folgenden Formeln in den Zellen a1: a3 in ein Arbeitsblatt eingeben:

A1: =1.23/2
A2: =1.21/2
A3: =SUM(A1:A2)

Angenommen Sie, Sie mit Money arbeiten und die Ergebnisse der Berechnung für Währung formatiert werden. Die zurückgegebenen Werte sind:

A1: $0.62
A2: $0.61
A3: $1.22

Wie Sie sehen, ist die Gesamtsumme in Zelle A3 falsch. Das Problem ist, obwohl das Zahlenformat (Währung) gerundet angezeigten Werte die zugrunde liegenden Werte nicht auf den nächsten Cent gerundet wurden. Dieses Verhalten kann mit der runden -Funktion behoben. Ändern Sie die Formeln z. B. folgende:

A1: =ROUND(1.23/2,2)
A2: =ROUND(1.21/2,2)
A3: =ROUND(SUM(A1:A2),2)

Das zweite Argument der Funktion runden weist Excel welche Stelle gerundet. In diesem Fall weist 2 Excel auf das nächste Hundertstel gerundet.

zurück zum Anfang

Installieren und Verwenden der Microsoft Excel-Hilfe

Microsoft Excel-Hilfe können Sie Informationen zu bestimmten Verwendungen suchen, eine Liste von Themen oder nach bestimmten Wörtern oder Ausdrücken anstelle von Themen suchen. Außerdem können Sie kontextbezogene Hilfe (F1 drücken) Informationen anzuzeigen, die zu der Aufgabe.

Die Hilfedateien installiert auf sie zugreifen. Wenn Hilfe nicht installiert ist, führen Sie das Setup-Programm erneut aus und klicken Sie dann auf
Software zur Installation der Dateien.

zurück zum Anfang

Kein direktes Öffnen Sie und speichern Sie direkt von einer Diskette

Wenn Sie eine Arbeitsmappe öffnen, erstellt Excel temporäre Dateien in dem Ordner, in dem Sie die Datei speichern, und in den Ordner, in dem die Arbeitsmappe geöffnet. Diese temporären Dateien werden gelöscht, wenn Sie die Datei schließen. Excel erstellt außerdem eine Kopie der Datei auf dem Datenträger beim Speichern der Datei. Dies kann problematisch sein, beim Öffnen einer Arbeitsmappe von einer Diskette oder die Diskette nicht genügend freien Speicherplatz für die Datei.

Aus diesen Gründen ist es eine gute Idee, kopieren Sie die Datei auf der Festplatte, bevor Sie damit arbeiten. Nachdem Sie Änderungen speichern Sie die Datei auf die Festplatte und anschließend wieder auf die Diskette kopieren.

zurück zum Anfang

Verwenden Sie zum Erstellen eines neuen Diagramms oder Arbeitsblatts Tastendruck

Um ein Diagramm zu erstellen, wählen Sie die Daten und drücken Sie dann F11. Drücken Sie UMSCHALT + F11, um ein neues Arbeitsblatt zu erstellen.

zurück zum Anfang

Richten Sie mehrerer Druckbereiche im gleichen Arbeitsblatt ein

Sie können mehrere Druckbereiche im gleichen Arbeitsblatt einrichten, ohne Verwendung eines Makros. Verwenden Sie hierzu den Befehl benutzerdefinierte Ansichten und dem Befehl Bericht drucken. Im Wesentlichen definieren Sie Ansichten des Arbeitsblatts und definieren Sie dann einen Bericht mit den Ansichten Ihrer Wahl. Weitere Informationen finden Sie in der Microsoft Excel-Hilfe.

Klicken Sie für Weitere Informationen auf die folgende Artikelnummer, um den Artikel der Microsoft Knowledge Base anzuzeigen:

142529 XL: zum Erstellen mehrerer Ansichten und erstellen und Drucken eines Berichts

zurück zum Anfang
Eigenschaften

Artikelnummer: 843504 – Letzte Überarbeitung: 16.01.2017 – Revision: 2

Feedback