Internet Explorer or another program that uses DDE stops responding on a Microsoft Windows 2000-based or Microsoft Windows XP-based computer

Symptoms

If you start Microsoft Internet Explorer or another program that uses Dynamic Data Exchange (DDE), Internet Explorer and any other program that uses DDE stops responding. This symptom occurs if you start Internet Explorer or another program that uses DDE on a Microsoft Windows 2000-based or Microsoft Windows XP-based computer

Cause

This problem occurs when Internet Explorer or another program that uses DDE unregisters a DDE server. Internet Explorer or another program that uses DDE then sends a DDE registration broadcast message by using the SendMessage function. If another program that is running on the Windows 2000-based or on the Windows XP-based computer does not correctly process an Windows message loop, the program that uses DDE stops responding.

Resolution

Windows 2000 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows 2000 Service Pack 3 (SP3) is required to install this hotfix

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
--------------------------------------------------------------
17-Jun-2004 23:05 5.0.2195.6951 46,352 Basesrv.dll
21-Sep-2003 00:45 5.0.2195.6824 236,304 Cmd.exe
17-Jun-2004 23:05 5.0.2195.6945 231,184 Gdi32.dll
17-Jun-2004 23:05 5.0.2195.6946 712,464 Kernel32.dll
24-Mar-2004 02:17 5.0.2195.6898 37,136 Mf3216.dll
24-Mar-2004 02:17 5.0.2195.6824 54,544 Mpr.dll
17-Jun-2004 23:05 5.0.2195.6928 335,120 Msgina.dll
24-Mar-2004 02:17 5.0.2195.6892 90,264 Rdpwd.sys
07-Feb-2005 05:35 5.0.2195.7026 6,301,696 Sp3res.dll
28-Feb-2005 11:46 5.0.2195.7032 380,688 User32.dll
05-Aug-2003 22:14 5.0.2195.6794 385,808 Userenv.dll
24-Dec-2004 17:23 5.0.2195.7013 1,633,616 Win32k.sys
24-Aug-2004 22:59 5.0.2195.6970 182,544 Winlogon.exe
17-Jun-2004 23:05 5.0.2195.6946 244,496 Winsrv.dll
17-Jun-2004 23:05 5.0.2195.6946 712,464 Kernel32.dll
24-Dec-2004 17:23 5.0.2195.7013 1,633,616 Win32k.sys
17-Jun-2004 23:05 5.0.2195.6946 244,496 Winsrv.dll

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows XP Service Pack 1 (SP1) or later is required to install this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP Service Pack 1 x86

   Date         Time   Version            Size    File name
--------------------------------------------------------------
02-Feb-2005 20:27 5.1.2600.1619 574,464 User32.dll
05-Aug-2004 18:15 5.1.2600.1581 1,845,888 Win32k.sys

Windows XP Service Pack 2 x86

   Date         Time   Version            Size    File name
--------------------------------------------------------------
02-Feb-2005 20:20 5.1.2600.2597 577,024 User32.dll

Windows XP Service Pack 1 IA-64

   Date         Time   Version         Size       File name
-----------------------------------------------------------------
02-Feb-2005 19:22 5.1.2600.1619 1,485,312 User32.dll IA-64
05-Aug-2004 16:27 5.1.2600.1581 5,629,952 Win32k.sys
02-Feb-2005 19:27 5.1.2600.1619 557,056 Wuser32.dll x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Eigenschaften

Artikelnummer: 892850 – Letzte Überarbeitung: 20.06.2014 – Revision: 1

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