Erstellen einer benutzerdefinierten Symbolleiste/Multifunktionsleiste für alle Benutzer im Project-Client

Einführung

Dieser Artikel beschreibt eine benutzerdefinierte Makros und Symbolleiste/Multifunktionsleiste, die Schaltflächen zum Ausführen von Makros). Dieser Artikel beschreibt außerdem, wie benutzerdefinierte Objekte an der lokalen globalen Projektvorlage (Global.mpt) oder der Enterprise-global-Projektvorlage bereitgestellt, wenn Project Server. Dadurch wird das benutzerdefinierte Symbolleiste/Menüband für alle Benutzer von Microsoft Office Project-Clients zur Verfügung, ob Benutzer in Microsoft Office Project Server herstellen oder eigenständige Kunden.

Weitere Informationen

Beim Öffnen eines Projekts verwendet Informationen in der lokalen Datei sowie die globale Vorlagendatei zum Festlegen von Standardeinstellungen für den Plan. Die globale Projektvorlage
enthält Ansichten, Berichte, Module (Makros), Tabellen, Filter, Kalender, Karten, Felder und Gruppen (Symbolleisten werden in Project 2007 oder früher globale Vorlagendateien aber nicht 2010, die Multifunktionsleiste 2010 eingeführt wurde). Projektplan verwendet die Standardwerte aus der globalen Vorlage, wenn Sie neue oder vorhandene Objekte zu ändern. Angepasste werden lokale Projekt gespeichert, wenn Sie Schritte die Informationen in die Globaldatei kopieren. Diese globalen Vorlage kann andere Projekt Client Benutzer durch Senden der Datei global.mpt lokal speichern oder über Netzwerk freigeben freigegeben werden.

Wenn ein Enterprise-Projekt in Project Server geöffnet wird, werden die Enterprise-global-Projektvorlage Einstellungen zum Projekt angewendet.  Nachdem die Enterprise-global-Projektvorlage auf das Projekt angewendet wird, gelten alle Elemente in der lokalen Globaldatei, die nicht denselben Namen wie die Elemente in der Enterprise-global-Projektvorlage auch der Projektdatei. Sie erstellt eine benutzerdefinierte Ansicht, Tabelle oder Filter, der den gleichen Namen wie ein Element in der Enterprise-global-Projektvorlage hat, werden Sie umbenennen oder das benutzerdefinierte Element überschrieben wird. Empfangene Fehlermeldung ähnelt den folgenden Fehler:

"Enterprise-Global enthält bereits ein (ein Objekt wie eine Ansicht, Tabelle, Kalender usw.) mit dem Namen"< Objektname >". Umbenennen oder ersetzen."

Benennen Sie das Objekt wird das Problem behoben und Sie weiterhin den Plan. Eine zweite Version des Objekts bleibt auch bei Bedarf.

In der Regel Vorrang die Enterprise-global-Vorlage andere Vorlagen. Jedoch ist die Rangfolge der Bänder, Symbolleisten und Menüs von anderen Elementen in der Enterprise-global-Projektvorlage behandelt. Bänder, Symbolleisten und Menüs in der lokalen globalen Datei Vorrang gegenüber Bändern, Symbolleisten und Menüs mit dem gleichen Namen in der Enterprise-global-Projektvorlage. Darüber hinaus Vorrang Sprachversionen von Bändern, Symbolleisten und Menüs in der Globaldatei lokale Bänder, Symbolleisten und Elemente in der Enterprise-global-Projektvorlage. Eine benutzerdefinierte Multifunktionsleiste oder Symbolleiste, das einen eindeutigen Namen in der Enterprise-global-Projektvorlagendatei in Project Server werden jedoch für alle Benutzer des Projekts verfügbar.

Die allgemeinen Schritte verwendet, um benutzerdefinierte Objekte in der lokalen globalen Datei aus einem lokalen verschieben sind recht einfach:
  1. Erstellen Sie das benutzerdefinierte Objekt in Ihrem lokalen Plan.
  2. Zeigt die Objekte in die lokale globale Vorlage und den Plan nebeneinander Organizer öffnen.
  3. Das benutzerdefinierte Objekt aus dem Plan in die globale Vorlage, und Sie sind fertig.

Diese Schritte funktionieren für alle Versionen von Project 2010.

Allerdings möchten Sie die Enterprise-Global-Projektvorlage benutzerdefinierte Objekte hinzugefügt werden (da Sie Project Server verwenden) die Enterprise-Global nur von einem Benutzer mit Zugriff auf die Enterprise-Global-Projektvorlage aus Project Server öffnen möglich. Diese Aktion dann startet Project Professional mit der Enterprise-Global-Projektvorlage öffnen im Arbeitsspeicher. Sie können Objekte aus lokalen globalen oder offenen Projektplan geöffneten Enterprise-Global-Projektvorlage verschieben.

Gehen Sie folgendermaßen vor, um eine benutzerdefinierte Multifunktionsleisten-Registerkarte einzuschließen, die einer zum Ausführen eines Makros in der Enterprise-global-Projektvorlagendatei in Project 2010 Befehlsschaltfläche:

Schritte zum Erstellen eines benutzerdefinierten Makros

  1. Starten Sie Project-Client.
  2. Starten Sie ein neues Projekt. Der Name ist Project1.
  3. Auf der Registerkarte Ansicht auf Makros Dropdown-Liste und klicken Sie dann auf Makros .
  4. Geben Sie im Feld Makroname einen Namen ein. Makro1 ist beispielsweise die Standardeinstellung.
  5. Klicken Sie in der Liste Speichern in auf Globaldatei. Bei Auswahl Dieses Projekts ist das Makro nur in Project 1verfügbar.
  6. Klicken Sie auf die gewünschten Optionen, und klicken Sie dann auf OK.

Schritte, um das Modul kopieren, das Makros, die lokale globale Vorlage enthält ggf.

  1. Klicken Sie auf der Registerkarte Info auf Orgahinaus Schaltfläche ot Links Organisieren-Global-Projektvorlage.

    Hinweis: der Name der derzeit geöffneten Dateien erscheinen am oberen Rand jedes Fensters. Sie können die Datei in einer anderen geöffneten Datei mithilfe der Dropdown-Liste am unteren Rand jedes Fensters ändern.
  2. Klicken Sie auf der Registerkarte Module
  3. Finden Sie das Modul, das in den Schritten erstellte Makro wählen sie.
  4. Zwischen den Bereichen klicken Sie auf Kopierenund dann auf Schließen.

Globale wird automatisch gespeichert. Moduel und Makro jetzt werden alle Pläne zur, die diese lokalen globalen Vorlage verwenden.

Schritte des Moduls 2007 oder 2010 in der Enterprise-global-Projektvorlage kopieren.

  1. Starten Sie Project Web Access als Benutzer mit Berechtigungen zum Ändern der Enterprise-Global-Artikelvorlage...
  2. Klicken Sie auf Server > Enterprise-Global und auf die Schaltfläche Konfigurieren Sie Project Professional. Project Professional wird mit der Enterprise-Global-Projektvorlage im Arbeitsspeicher gestartet.
  3. Klicken Sie auf die Registerkarte Datei , wählen Sie Info und Globalvorlage verwalten.
  4. Öffnen Sie den Plan, in dem das Makro gespeichert, wenn nicht bereits in der Global (+ nicht zwischengespeicherte Enterprise).
  5. Klicken Sie auf der Registerkarte Modul, und wählen Sie das Modul in Enterprise-Global-Vorlage kopieren möchten.
  6. Zwischen den Bereichen klicken Sie auf Kopierenund dann auf Schließen.
  7. Klicken Sie auf TFragen , und klicken Sie auf Speichern , um die Enterprise-global-Projektvorlage zu speichern.
  8. Beenden Sie Project Professional.

Das nächste Mal, das ein Benutzer alle Unternehmensplan öffnet, finden das Makro.

Schritte zum Erstellen einer benutzerdefinierten Symbolleiste und das Makro einer Schaltfläche in 2007 und früheren Versionen hinzufügen.

  1. Starten Sie th Project-Client.
  2. Im Menü Extras auf Anpassen, und klicken Sie dann auf Symbolleisten.
  3. Auf der Registerkarte Symbolleisten auf neu, und geben Sie einen Namen im Feld Name der Symbolleiste . Beispielsweise CustToolbar1, und klicken Sie dann auf OK.
  4. Klicken Sie auf die Registerkarte Befehle .
  5. Klicken Sie in der Liste Kategorien auf Alle Makros.
  6. Ziehen Sie den Befehl Makro1 aus der Liste Befehle auf die Symbolleiste.
  7. Klicken Sie auf der Symbolleiste auf die Makroschaltfläche neue.
  8. Klicken Sie im Dialogfeld Anpassen auf Auswahl ändern.
  9. Klicken Sie auf Schaltfläche Bearbeiten oder Schaltflächensymbol ändern, und stellen Sie die Änderungen.
  10. Klicken Sie auf Schließen.
  11. Öffnen Sie die Enterprise-global-Projektvorlage oder die Symbolleiste lokale globale Vorlagendatei gespeichert.
  12. Die neu hinzugefügte Schaltfläche ausgewählt Klicken Sie auf Auswahl ändernund dann auf Makro zuweisen.
  13. Stellen Sie sicher, dass die erstellte Makro im Befehl . Dieses Makro muss ein Makro Datei nicht.
  14. Klicken Sie auf Schließen.
  15. Projekt-Client beenden.
Eigenschaften

Artikelnummer: 913678 – Letzte Überarbeitung: 17.02.2017 – Revision: 2

Microsoft Project Server 2013, Microsoft Project 2013 Professional, Microsoft Project Server 2010, Microsoft Project Professional 2010, Microsoft Office Project Server 2007, Microsoft Office Project Professional 2007, Microsoft Office Project Server 2003, Microsoft Office Project Professional 2003, Microsoft Project Server 2002, Microsoft Project 2002 Professional Edition

Feedback