Fehler "RPC-Ausnahme 1726 in Sitzung 10" beim Überprüfen des Anwendungsprotokolls auf dem Computer, auf dem Microsoft Dynamics AX AOS-Dienste ausgeführt werden

Dieser Artikel bietet eine Lösung für die Fehler, die auftreten, wenn Sie das Anwendungsprotokoll auf einem Computer überprüfen, auf dem AOS-Dienste (Microsoft Dynamics AX 4.0 Application Object Server) ausgeführt werden.

Gilt für: Microsoft Dynamics AX
Ursprüngliche KB-Nummer: 937873

Problembeschreibung

Wenn Sie das Anwendungsprotokoll auf einem Computer überprüfen, auf dem AOS-Dienste (Microsoft Dynamics AX 4.0 Application Object Server) ausgeführt werden, werden möglicherweise Fehlermeldungen angezeigt, die in etwa wie folgt aussehen:

Fehlermeldung 1

Ereignistyp: Information
Ereignisquelle:Dynamics Server 17
Datum:04.07.2007
Uhrzeit:12:30:14 PM
Ereigniskategorie:Keine
Beschreibung:
Objektserver 01: RPC-Fehler: RPC-Ausnahme 1726 in Sitzung 10 aufgetreten

Fehlermeldung 2

Ereignistyp: Information
Ereignisquelle:Dynamics Server 01
Ereigniskategorie:Keine
Ereignis-ID:110
Datum:04.07.2007
Zeit:12:30:33 AM
Benutzer: n/v
Computer: ComputerName
Beschreibung:
Objektserver 01: Kein Ping von 10. Beenden der Sitzung.

Die erste Fehlermeldung kann der zweiten Fehlermeldung zugeordnet sein. Bis der AOS-Server Sitzung 10 beendet, reagiert jede Sitzung, die RPC-Fehlermeldungen zurückgibt, nicht mehr. Wenn zu viele Sitzungen nicht mehr reagieren und RPC-Fehlermeldungen zurückgeben, wird der AOS-Server möglicherweise heruntergefahren.

Ursache

Dieses Problem kann auftreten, weil Benutzer Microsoft Dynamics AX nicht ordnungsgemäß beenden. Beispielsweise beenden Benutzer den Microsoft Dynamics AX-Prozess mithilfe des Task-Managers.

RPC 1726 ist eine allgemeine Verbindungsfehlermeldung. Die RPC 1726-Fehlermeldung kann jedoch mit dem No ping from 10 (Kein Ping von 10) verknüpft sein. Sitzungsfehlermeldung wird beendet. In diesem Fall wird das Problem in der Regel dadurch verursacht, dass Benutzer Microsoft Dynamics AX nicht ordnungsgemäß verlassen.

Lösung

Wenn dieses Problem auf dem Microsoft Dynamics AX-Client auftritt, beenden Sie den Client nicht, indem Sie STRG+ALT+ENTF drücken. Es wird empfohlen, STRG+PAUSE zu verwenden und dann zu warten, bis das System wieder reagiert, oder wenden Sie sich an den Microsoft Dynamics AX-Administrator oder einen anderen Benutzer, der über Rechte für das Onlinebenutzerformular verfügt. Der Administrator oder der andere Benutzer kann Sitzung beenden auswählen, um die Clientsitzung zu beenden.

Weitere Informationen

Wenn dieses Problem auf dem AOS-Server auftritt, ist es wichtig zu ermitteln, welche Sitzung die Ursache ist und was die Benutzer tun, um das Problem zu verursachen.

Führen Sie dazu das folgende Skript aus:

select * from sysuserlog where logouttime = 0 and sessionid = <X>

Hinweis

Ersetzen Sie <X> durch die Sitzung, die in der RPC-Fehlermeldung angegeben ist. Beachten Sie in den Ergebnissen der Abfrage die Spalten USERID und COMPUTERNAME . Die Spaltenwerte geben an, wer sich von wo aus anmeldet.

RPC-Ausnahmen werden in der Regel dadurch verursacht, dass die Anwendung nicht ordnungsgemäß beendet wird. Die Ausnahmen können jedoch auch darauf hindeuten, dass ein Geschäftsprozess hängt oder lange dauert.

References

Weitere Informationen finden Sie unter Suchen einer Benutzer-ID, die einer Sitzungs-ID in einer Fehlermeldung im Anwendungsprotokoll auf dem AOS-Server in Microsoft Dynamics AX zugeordnet ist: "RPC-Fehler: RPC-Ausnahme 1726 in Sitzungs-Sitzungs-ID <>aufgetreten".