Verschiedene Probleme können auf einem Windows Server 2003-Computer auftreten, die den Volumeschattenkopie-Dienst ausgeführt wird

Problembeschreibung

Auf einem Microsoft Windows Server 2003-basierten Computer mit Volume Shadow Copy Service (VSS), treten die folgenden Symptome auftreten:
  • Beim Ausführen eines Sicherungsvorgangs verwenden das Sicherungsprogramm wird das folgende Ereignis im Anwendungsprotokoll protokolliert:


    Hinweis Die Sicherungsprotokolldatei anzuzeigen, wird Folgendes angezeigt:
    Fehler beim Erstellen des Volume Shadow Copy: 0xffffffff
  • Wenn Sie Zugriff auf die Eigenschaften eines Volumes und klicken Sie dann auf
    Schattenkopien, erhalten Sie eine der folgenden Fehlermeldungen angezeigt:
    Fehler 0x8004230F: Schattenkopie-Anbieter ist ein unerwarteter Fehler beim Versuch, den angegebenen Vorgang zu verarbeiten.
    Fehler 0 x 80004002: Schnittstelle nicht unterstützt
  • Die folgenden Ereignisse werden im Anwendungsprotokoll protokolliert:

Ursache

Dieses Problem tritt auf, weil die VSS-Systemdateien nicht registriert sind.

Problemlösung

Hinweis Dieser Artikel ist nicht mit Windows Vista, Windows Server 2008 oder höher. Mit Windows Vista und Windows Server 2008 ist Windows Komponenteninstallation Manifest basiert. Unerwartete Ergebnisse können auftreten, wenn Sie versuchen, bestimmte Komponenten wie manuell registrieren, die in diesem Abschnitt "Lösung" in die Betriebssysteme beschrieben werden, die in diesem Hinweis genannten erfordern, die Neuinstallation von Windows zu beheben.


Um das Problem automatisch beheben, lesen Sie den Abschnitt "Fix it für mich". Wenn Sie dieses Problem manuell beheben möchten, lesen Sie den Abschnitt "Problem manuell beheben lassen".

Automatisch mit Fix it beheben lassen



Klicken Sie auf die Fix it-Schaltfläche oder den Link, um dieses Problem automatisch zu beheben. Klicken Sie im Dialogfeld Dateidownload auf Ausführen und folgen Sie dann den Schritten des Fix it Assistenten.




Notes
  • Dieser Assistent ist nur auf Englisch verfügbar. Die automatische Korrektur funktioniert jedoch auch für andere Sprachversionen von Windows.
  • Wenn Sie gerade nicht auf dem Computer arbeiten, auf dem das Problem auftritt, speichern Sie die Fix it Fehlerbehebung auf ein Flashlaufwerk oder CD und führen diese dann auf dem Computer, auf dem das Problem auftritt, aus.

Wechseln Sie dann zum Abschnitt "Wurde das Problem behoben?".



Lassen Sie mich das Problem manuell beheben



Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
  1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie cmd ein, und klicken Sie auf OK.
  2. Geben Sie die folgenden Befehle in der Befehlszeile. Nach der Eingabe jedes Befehls die EINGABETASTE.
    • cd /d %windir%\system32
    • Net Stop vss
    • Net Stop swprv
    • regsvr32 ole32.dll
    • regsvr32 oleaut32.dll
    • regsvr32 vss_ps.dll
    • vssvc /register
    • regsvr32 /i swprv.dll
    • regsvr32 /i eventcls.dll
    • regsvr32 es.dll
    • regsvr32 stdprov.dll
    • regsvr32 vssui.dll
    • regsvr32 msxml.dll
    • regsvr32 msxml3.dll
    • regsvr32 msxml4.dll
    Hinweis Der letzte Befehl kann nicht ausgeführt werden.
  3. Führen Sie einen Sicherungsvorgang überprüfen, ob das Problem behoben ist.

Wurde das Problem behoben?

  • Überprüfen Sie, ob das Problem behoben ist. Wenn das Problem behoben ist, Sie sind mit diesem Abschnitt fertig. Wenn das Problem nicht behoben ist, können Sie sich an den Support wenden.
  • Wir schätzen Ihr Feedback. Um Feedback zu geben oder über Probleme mit dieser Lösung zu informieren, schreiben Sie einen Kommentar im "Für mich beheben"-Blog, oder senden Sie uns eine E-Mail-Nachricht.

Weitere Informationen

Schritte zum Reproduzieren des Problems

  1. Geben Sie folgenden Befehl in der Befehlszeile. Drücken Sie die EINGABETASTE, nachdem Sie den Befehl eingeben.
    regsvr32 /u swprv.dll
  2. Versuchen Sie, eine Sicherung durchzuführen.
Eigenschaften

Artikelnummer: 940032 – Letzte Überarbeitung: 13.01.2017 – Revision: 2

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