Wenn Sie Remotedesktopverbindung die Verbindung zu einem Windows Server 2003-basierten terminal Server oder Windows XP verwenden, wird der erste Laufwerkbuchstabe des Computers, von dem Sie eine Verbindung herstellen, mit der Terminaldienste-Sitzung nicht umgeleitet

Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Mithilfe von Remotedesktopverbindung eine Terminaldienste-Sitzung an einem Terminalserver mit Windows Server 2003-basierten erstellen.
  • Smartcard-Umleitungsfunktion aktiviert und Umleitungsfunktion Festplatte deaktiviert.
  • Die Terminaldienste-Sitzung trennen.
  • Sie verwenden Sie Remotedesktopverbindung dieser Sitzung. Dieses Mal Umleitungsfunktion Smartcard deaktiviert und die Umleitungsfunktion Festplatte aktiviert.
In diesem Szenario wird der erste Laufwerkbuchstabe des Clients für die Terminaldienste-Sitzung nicht umgeleitet. Z. B. vorhanden Laufwerke C, D, E und F auf Terminaldiensteclients. Allerdings werden nur die Laufwerke D, E und F umgeleitet. Dieses Problem betrifft auch Windows CE-Benutzer, da das lokale Laufwerk auf Terminaldienste-Sitzung in diesem Szenario nicht umgeleitet wird.

Ein virtuellen Windows XP-Computer treten folgende Probleme Smartcard-Umleitung ist deaktiviert und laufwerkumleitung aktiviert:

  1. Zwischenablage zwischen dem virtuellen Computer und dem Computer funktioniert nicht.
  2. Dateien und Ordner zwischen dem virtuellen Computer und dem Computer funktioniert nicht.
  3. Sie können keine Windows XP Virtual Machine Systemlaufwerk des Computers zugreifen.

Ursache

Terminaldienste Ursache. Das Smartcard-Gerät wird nicht korrekt zurückgesetzt eine Terminaldienste-Sitzung getrennt wird. Problem betrifft, das erste Laufwerk ID auftritt, wenn die Terminaldienste-Sitzung wiederhergestellt wird, sobald die Smartcard Umleitungsfunktion deaktiviert ist. Daher ist der erste Laufwerkbuchstabe nicht umgeleitet. Windows CE-Geräte sind auf der anderen Seite nur ein Laufwerk. Daher können Sie Dateien auf einem Windows CE-Gerät beim diesbezügliche zugreifen.

PROBLEMUMGEHUNG

Um das Problem zu umgehen, Aktivieren der Smartcard-Umleitungsfunktion in Remotedesktopverbindung.

Problemlösung

Hotfix-Informationen

Windows Server 2003

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix soll nur der Behebung des Problems dienen, das in diesem Artikel beschrieben wird. Verwenden Sie diesen Hotfix nur auf Systemen, bei denen dieses spezielle Problem auftritt. Dieser Hotfix sollte weiteren Tests unterzogen werden. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir sie, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, gibt es einen Abschnitt "Hotfixdownload available" ("Hotfixdownload verfügbar"), am oberen Rand dieses Knowledge Base-Artikel. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an den Microsoft Customer Service and Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die nicht diesem speziellen Hotfix zugeordnet werden können. Für eine vollständige Liste der Telefonnummern des Microsoft Customer Service and Support, oder um eine separate Serviceanfrage zu erstellen, gehen Sie auf folgende Microsoft-Website:Hinweis Das Formular "Hotfix download available" ("Hotfixdownload verfügbar") zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist dieser Hotfix für Ihre Sprache nicht verfügbar.
Voraussetzungen
Um diesen Hotfix anwenden zu können, müssen Sie Windows Server 2003 Service Pack 1 oder Windows Server 2003 Service Pack 2 installiert haben.
889100 so erhalten Sie das neueste Servicepack für Windows Server 2003

Neustartanforderung
Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.
Informationen zu ersetzten Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist Dateiattribute (oder spätere Attribute), die in der folgenden Tabelle aufgelistet sind. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) aufgelistet. Wenn Sie die Dateiinformationen anzeigen, werden sie in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu finden, verwenden Sie die Registerkarte Zeitzone unter Datum und Uhrzeit in der Systemsteuerung.

Windows Server 2003 mit Service Pack 1 X86 Version
DateinameDateiversionDateigrößeDatumZeitPlattformSP-AnforderungServicebereich
Rdpdr.sys5.2.3790.3076200,19222-Jan-200810:28x86SP1SP1QFE
Windows Server 2003 mit Service Pack 2 X86 Version
DateinameDateiversionDateigrößeDatumZeitPlattformSP-AnforderungServicebereich
Rdpdr.sys5.2.3790.4222200,19222-Jan-200810:19x86SP2SP2QFE
Windows Server 2003 X64 Version
DateinameDateiversionDateigrößeDatumZeitPlattformSP-AnforderungServicebereich
Rdpdr.sys5.2.3790.3076333.31222-Jan-200815:36x64SP1SP1QFE
Windows Server 2003 mit SP2, X64 Version
DateinameDateiversionDateigrößeDatumZeitPlattformSP-AnforderungServicebereich
Rdpdr.sys5.2.3790.4222333.82422-Jan-200816:18x64SP2SP2QFE
Windows Server 2003 mit Service Pack 1, IA-64-version
DateinameDateiversionDateigrößeDatumZeitPlattformSP-AnforderungServicebereich
Rdpdr.sys5.2.3790.3076641,02422-Jan-200815:36IA-64SP1SP1QFE
Windows Server 2003 mit Service Pack 2 IA-64-version
DateinameDateiversionDateigrößeDatumZeitPlattformSP-AnforderungServicebereich
Rdpdr.sys5.2.3790.4222640,51222-Jan-200816:16IA-64SP2SP2QFE

Windows XP

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix soll nur der Behebung des Problems dienen, das in diesem Artikel beschrieben wird. Verwenden Sie diesen Hotfix nur auf Systemen, bei denen dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download zur Verfügung steht, gibt es einen Abschnitt "Hotfixdownload available" ("Hotfixdownload verfügbar"), am oberen Rand dieses Knowledge Base-Artikel. Wenn dieser Abschnitt nicht angezeigt wird, senden Sie eine Anforderung an Microsoft Customer Service and Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die nicht diesem speziellen Hotfix zugeordnet werden können. Eine vollständige Liste der Telefonnummern von Microsoft Customer Service and Support oder eine separate Serviceanfrage erstellen finden Sie auf der folgenden Microsoft-Website:Hinweis Das Formular "Hotfix download available" ("Hotfixdownload verfügbar") zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist dieser Hotfix für Ihre Sprache nicht verfügbar.
Voraussetzungen
Dieser Hotfix erfordert Windows XP Service Pack 2 oder Windows XP Service Pack 3 auf dem Computer installiert sein.

322389 wie Sie das neueste Servicepack für Windows XP erhalten

Neustartanforderung
Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.
Informationen zu ersetzten Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist Dateiattribute (oder spätere Attribute), die in der folgenden Tabelle aufgelistet sind. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) aufgelistet. Wenn Sie die Dateiinformationen anzeigen, werden sie in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu finden, verwenden Sie die Registerkarte Zeitzone unter Datum und Uhrzeit in der Systemsteuerung.

Windows XP mit SP2, X86-basierte Versionen
DateinameDateiversionDateigrößeDatumZeitPlattformSP-AnforderungServicebereich
Rdpdr.sys5.1.2600.3385195,32806-Jun-200809:22x86SP2SP2QFE
Windows XP mit SP3, X86-basierte Versionen
DateinameDateiversionDateigrößeDatumZeitPlattformSP-AnforderungServicebereich
Rdpdr.sys5.1.2600.5616195,45606-Jun-200811:10x86SP3SP3QFE
Windows XP Professional X64 Edition mit SP1
DateinameDateiversionDateigrößeDatumZeitPlattformSP-AnforderungServicebereich
Rdpdr.sys5.2.3790.3076333.31222-Jan-200815:36x64SP1SP1QFE
Windows XP Professional X64 Edition mit SP2
DateinameDateiversionDateigrößeDatumZeitPlattformSP-AnforderungServicebereich
Rdpdr.sys5.2.3790.4222333.82422-Jan-200816:18x64SP2SP2QFE

Status

Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt „Eigenschaften“ aufgeführt sind.
Eigenschaften

Artikelnummer: 940458 – Letzte Überarbeitung: 10.01.2017 – Revision: 1

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