Informationen über den Netzwerkmonitor 3.2 in Windows Vista

Einführung

Dieser Artikel enthält Informationen zum Microsoft Network Monitor 3.2. Network Monitor 3.2 ist ein Netzwerkprotokoll-Analyseprogramm, mit dem Sie aufzeichnen, anzeigen und Analysieren der Netzwerkdaten. Sie können Probleme mit dem Netzwerk beheben.

Dieser Artikel enthält Download und Supportinformationen, Installationshinweise und allgemeine Informationen zu Network Monitor 3.2.

Weitere Informationen

Network Monitor 3.2 ist die neueste Version von Netzwerkmonitor. Die folgende Liste enthält Informationen zu neuen Features in Network Monitor 3.2:
  • Prozessen Sie Verfolgung von. Anzeigen der Prozessname und PID aller Prozesse, die den Netzwerkverkehr auf einem Computer generieren. Unterhaltungsstruktur können Sie außerdem die Rahmen anzeigen, die jeder Prozess zugeordnet sind.
  • Gespräche zu finden. Sie können Frames in der Unterhaltung Netzwerk schnell isolieren. Dazu gehören TCP-Datenströme, HTTP-Abläufe und andere Arten von Netzwerkverkehr.
  • Aufnahme-Unterstützung für PCAP.

    Hinweis

    Network Monitor 3.2 enthält Software, die von den folgenden Personen entwickelt:
    • Der University of California, Berkeley und ihren Mitarbeitern
    • Kungliga Tekniska Danshögskolan und seine Mitarbeiter
    • Yen Yen Lim und North Dakota State University
  • Aufnahme-Modul wurde neu gestaltet, um die Abtastrate für Hochgeschwindigkeits-Netzwerke zu verbessern. Network Monitor 3.2 Tropfen deutlich weniger Frames als Network Monitor 3.1 ist.
    • Umfassende Parser festlegen. Network Monitor 3.2 unterstützt jetzt Parser für 300 Protokolle. Dies umfasst die Protokolle, die den Windows Open-Spezifikationen gelten. Weitere Informationen finden Sie auf der folgenden Microsoft-Website:
    • Netzwerkmonitor API. Sie können Ihre eigene Anwendung erstellen, die erfassen, analysieren und Analysieren des Netzwerkverkehrs.
    • Besseres Management Parser. Standardmäßig wird nur eine Teilmenge der Parser geladen. Sie können vollständigen Parser festlegen Ändern der Suchreihenfolge Parser laden. Dies ist unter dem Parser Element im Menü Optionen möglich.
    • Unterstützung für Frames abgeschnitten. Begrenzen Sie die Anzahl der Bytes, die pro Frame Leistung erfasst. Dazu klicken Sie unter Optionen auf die
      Das Menü Extras .
    • Ausführliche Dokumentation der NPL. Diese Dokumentation umfasst die Dokumentation neue NDIE. Zugriff auf diese Dokumentation von der
      Element im Hilfemenü NPL und API-Dokumentation .
    • Erweiterte Filter auf Elemente im NPL Schleifen oder Arrays. Sie können einen Index im Array oder in der While-Schleife, die Sie filtern möchten.
    • Verfügbarkeit der IA-64 Version.
    • ContainsBin-Plug-in. Sie können Frames willkürlicher Bytefolgen oder Zeichenfolgen suchen. Sie können z. B. nach "Msn" Suchen mithilfe der folgenden Abfrage:
      ContainsBin (FrameData, ASCII, "Msn")
    • Weitere UI-Indikatoren. Neue Indikatoren enthalten Unterhaltung Status ausgelassenen Frames und die Anzahl der Rahmen im Sammlungspuffer.

Supportinformationen zu Download und

Network Monitor 3.2 herunterladen finden Sie auf der folgenden Microsoft-Website:Hinweis Diese Website enthält Network Monitor 3.2 Downloads für X86-basierten Versionen von Windows Vista, X64-basierten Versionen von Windows Vista und Windows Vista IA-64-basierten Versionen.

Informationen zum Network Monitor 3.2 Support finden Sie auf der folgenden Microsoft-Website:Sie müssen auf dieser Website anmelden mit einer Windows Live ID Nach der Anmeldung können Sie anwenden, um am Programm teilnehmen. Klicken Sie hierzu auf Übernehmen neben Network Monitor 3 in der
Optionen -Spalte der Tabelle. Nach der Anmeldung in der Anwendung haben Sie Zugriff auf Newsgroups und Fehlerberichte übermitteln.

Installationshinweise

Network Monitor 3.2 kann mit Network Monitor 2 verwendet werden. X und frühere Versionen. Network Monitor 3.2 wird standardmäßig im Ordner Programm Files%\Microsoft Network Monitor 3 installiert. Konflikte treten daher nicht in einem anderen Ordner auf dem Computer eine frühere Version installiert ist. Wenn Sie Network Monitor 3.2 installieren, werden frühere Versionen Network Monitor 3 deinstalliert.

Network Monitor 3.2 enthält einen Treiber für Windows Vista-Computer. Dieser Treiber unterstützt neue Funktionen des Treibers NDIS Network Driver Interface Specification () 6.0. Wenn Sie Tools, die auf Network Monitor 2 verwenden. X NPPTools, diese Tools funktionieren nicht mehr. Zum Sammeln von Netzwerkdaten in Windows Vista verwenden Sie Network Monitor 3.2. Network Monitor 2. X erfasst Daten ordnungsgemäß in Windows Vista nicht.

Die folgenden sind empfohlene Hardware an Network Monitor 3.2:
  • 1 Gigahertz (GHz) Prozessor oder schneller
  • mindestens 1 Gigabyte (GB) Arbeitsspeicher
  • 25 Megabytes (MB) freien Speicherplatz auf der Festplatte und zusätzlichen Festplattenspeicher zum Speichern von Sammlungsdateien
Network Monitor 3.2 wird von folgenden Betriebssystemen unterstützt:
  • Windows Vista
  • Windows Server 2008
  • Windows XP
  • Windows Server 2003
Warnhinweise

Derzeit empfohlen nicht, Network Monitor 3 auf Produktionssysteme auszuführen. Verwenden Sie in Szenarien, in denen wichtig sind die folgende Befehlszeilenversion von Network Monitor 3 Daten erfassen:
nmcap.exe
Weitere Informationen zu Nmcap.exe finden Sie im Abschnitt "Nmcap.exe-Befehlszeilenprogramm".


Network Monitor 3.2 kann viele Systemressourcen verbraucht. Es folgen einige wichtige Punkte.
  • Speicherplatz

    Beim Starten einer Aufnahme Sitzung speichert Network Monitor 3 Frames in einer Sequenz von Erfassung Dateien im Temp-Ordner. Standardmäßig ist die Größe jeder Datei 20 MB. Wenn Sie nicht die Aufnahme-Sitzung beenden, weiterhin Network Monitor 3 bis 2 Prozent Festplattenspeicher des Computers unterschreitet Sammlungsdateien im Ordner Temp gespeichert. Network Monitor 3 beendet dann die erfassungssitzung.

    Sie können die Aufnahme Dateigröße den Speicherort in denen Sammlung gespeichert, Begrenzung für den Speicherplatz und andere Optionen aufgezeichnet. Dazu zeigen Sie im Menü Extras auf Optionen , und klicken Sie auf die Registerkarte erfassen .
  • Speicherverwendung

    Neben Datenerfassung, Network Monitor 3 Frames Eigenschaften zugewiesen und dann anhand dieser Eigenschaften Frames in Themen gruppieren. Netzwerkmonitor 3 zeigt Gespräche und den zugeordneten Frames in einer Baumstruktur im Fenster Netzwerk-Kommunikation.

    Die Gespräche in Network Monitor 3 erhöht deutlich Speicher. Dadurch kann den Computer reagiert. Gespräche-Feature ist standardmäßig deaktiviert. Einige übergeordnete Protokollfilter benötigen Unterhaltung Eigenschaften. Um die Kommunikation zu aktivieren, klicken Sie auf der
    Startseite und dann auf Diskussionen aktivieren Kontrollkästchen das.
  • Prozessor-Auslastung

    Gespräche Feature von Network Monitor 3 kann eine Auslastung deutlich, wenn viele Bilder verarbeitet werden. Gespräche-Feature ist standardmäßig deaktiviert.

Allgemeine Verwendung

Allgemeine Verwendung folgende für Network Monitor 3 Informationen.
  • Sammeln von Netzwerkdaten

    Auswirkung auf Systemressourcen minimiert, wenn Network Monitor 3 verwenden, um Daten zu erfassen, verwenden Sie das Befehlszeilentool Nmcap.exe Datenerfassung.

    Netzwerkmonitor 3 können Sie Daten sammeln und diese Daten in Echtzeit anzeigen, wie bei seiner Aufnahme. Um eine Aufnahme starten in Network Monitor 3, klicken Sie auf Startseiteauf
    Erstellen einer neuen Sammlungund klicken dann entweder auf
    Aufnahme startenoder drücken Sie F5.
  • Filter

    Netzwerkmonitor 3 verwendet eine einfache Syntax ausdrucksbasierte Filter Frames. Alle Frames, die mit dem gewählten Ausdruck übereinstimmenden werden dem Benutzer angezeigt. Weitere Informationen zu filtern sind folgende:
    • Die Themen im Abschnitt "Verwenden von Filtern" Network Monitor 3-Benutzerhandbuch anzeigen Dazu klicken Sie im Menü Hilfe auf Inhalt , und doppelklicken Sie dann auf Filter verwenden.
    • Im Menü Hilfe auf How Do I und klicken Sie dann auf Filter.
    • Klicken Sie Standardfilter Registerkarte Sammlungsfilter oder Filter anzeigen .
  • Gespräche

    Unterhaltung-Feature ist standardmäßig aktiviert. Diese Einstellung beansprucht viel Speicher, insbesondere in Szenarien, wenn Sie große Datenmengen erfassen oder Daten über längere Zeiträume erfassen. Siehe Abschnitt "NMCap" Informationen über längere Zeiträume Datenerfassung.

    Gespräche ermöglichen das Gruppieren und die Darstellung der Bilder im Fenster Netzwerk Gespräche in einer Baumstruktur nach Themen, die sie angehören. TCP-Daten, denselben Quellport und Zielport dieselbe ist z. B. in einer Gruppe organisiert. Beim Klicken auf einen Knoten im Fenster Netzwerk Gespräche ist der entsprechenden Unterhaltung Filter automatisch auf Frames im Fenster Zusammenfassung Frame angewendet. Nur Bilder, die zu dieser bestimmten Unterhaltung gehören werden angezeigt.
  • Nmcap.exe-Befehlszeilenprogramm

    Nmcap.exe-Befehlszeilentool können Sie konfigurieren die und Endzeiten für eine erfassungssitzung. Sie können auch dieses Befehlszeilentool erstellten verkettete erfasst. Verkettete erfasst können Sie mehrere Sammlungsdateien erstellen, während die Größe jeder Datei gering halten.
  • Netzwerk Analyse Sprache (NPL)

    Network Monitor 3 Parser werden in einer Sprache geschrieben, die speziell Parser Entwicklung einfacher machen soll. Dies bietet auch einen Schutz gegen mögliche Ausnutzung von bösartigen Code, der auftreten können, wenn der Parser als DLL-Dateien erstellt wurden. Sie können anzeigen oder Ändern der Parser in Network Monitor 3 enthalten sind. Dokumentation für NPL-Sprache kann im Menü Hilfezugegriffen werden.
  • NDIE

    NDIE können Sie programmgesteuert das Modul analysieren und Erfassen von Network Monitor 3.2. Siehe Menü Hilfe einen Link zu der API-Dokumentation.

Allgemeine Probleme

Die folgenden: Probleme Network Monitor 3.2
  • Protokolle werden nicht ordnungsgemäß analysiert. Dieses Problem kann auftreten, wenn eine der folgenden Situationen zutrifft:
    • Gespräche-Feature ist deaktiviert.

      Bestimmte Protokolle hängen Unterhaltung Eigenschaften die Werte in späteren Bilder speichern. Beispielsweise erfordert TCP Themen Informationen zu gesendeten Frames. Der Filter für TCP überträgt funktioniert nicht, wenn die Gespräche-Funktion aktiviert ist.

      Ebenso kann nicht Protokoll (SMB = Server Message Block) auf einen Befehl Transact übersetzt werden, weil die Antwort nicht den ursprünglichen Befehl enthält. Ursprünglichen wird im Gespräch Eigenschaften gespeichert.
    • Sie müssen nicht vollständigen Parser geladen festgelegt. Standardkonfiguration Parser für Network Monitor 3.2 ist eine Teilmenge des Satzes. Network Monitor 3.2 schneller ausführen können. Alle finden Sie unter den "How Do I... Vollständige Parsers? laden "auf das Hilfemenü .
  • Sie erhalten eine der folgenden Fehlermeldungen beim Ausführen von Network Monitor 3 auf einem Windows Vista-Computer:
    Keine Netzwerkadapter sind an der Netmon-Treiber gebunden.
    Diese Netzwerkkarte ist nicht konfiguriert mit dem Netzwerkmonitor
    Dieses Problem tritt auf, wenn eine der folgenden Situationen zutrifft:
    • Network Monitor 3 sind nicht als Administrator ausgeführt werden.
    • Sie sind nicht Mitglied der Gruppe Benutzer Netmon.
    Weitere Informationen finden Sie unter Network Monitor 3 Notizen frei oder finden Sie im Thema "Betriebssystem auf Windows Vista" im Network Monitor 3 unterstützen.

Referenzen

Support-Informationen zu Network Monitor 3 finden Sie auf der folgenden Microsoft-Websites:
Eigenschaften

Artikelnummer: 955998 – Letzte Überarbeitung: 14.01.2017 – Revision: 2

Feedback