Eine physische Datenträgerressource in "Online" Ausstehend bleibt oder das Dienstprogramm "Chkdsk" automatisch auf einem Server ausführen, auf dem Windows Server 2008 ausgeführt wird

Problembeschreibung

Beim Onlineschalten einer Ressource Physikalischer Datenträger auf einem Server, auf dem Windows Server 2008 ausgeführt wird, können Sie eines der folgenden Symptome auftreten:

Symptom 1

Wenn Sie die physische Datenträgerressource in das Failovercluster-Snap-in anzeigen, kann die Ressource Status Online ausstehendanzeigen Darüber hinaus wird die folgende Fehlermeldung im Systemprotokoll protokolliert:
Namen: System

Quelle: Microsoft-Windows-FailoverClustering

Ereignis-ID: 1066

Vorgangskategorie: Physische Datenträgerressource

Ebene: Warnung

Beschreibung

Cluster-Datenträgerressource "Cluster Diskette 3" gibt beschädigte Volume ' \\?\Volume{ec2fa15d-b438-11de-88bc-00155dd99d36} ". CHKDSK wird ausgeführt, um Probleme zu beheben. Der Datenträger sind verfügbar, bis Chkdsk abgeschlossen ist. Ausgabe von CHKDSK wird in Datei 'C:\Windows\Cluster\Reports\ChkDsk_ResCluster Datenträger 3_Disk2Part1.log' protokolliert.

CHKDSK kann auch Informationen in das Anwendungsereignisprotokoll schreiben.
Darüber hinaus wird die folgende Fehlermeldung im Clusterprotokoll protokolliert:
Fehler [RES] Physikalischer Datenträger < Cluster Datenträger 3 >: VerifyFS: Fehler beim Öffnen der Datei \\?\GLOBALROOT\Device\Harddisk2\Partition1\TextDocument.txt Fehler: 5.

Symptom 2

Bei der Anzeige der physischen Datenträgerressource in die Microsoft-Clusterverwaltung auftreten eine oder mehrere der folgenden Symptome:
  • Die Ressource kann nicht online geschaltet kann, oder es online nach einer kurzen Verzögerung.
  • Mit der Option/f des Dienstprogramms Chkdsk automatisch auf der freigegebenen Festplatte.
  • Im Systemprotokoll der Ereignisanzeige wird Ereignis-ID 1066 mit eine ähnlich der folgenden angezeigt:
    Clusterressource Datenträger Y:: ist beschädigt. Ausführen von ChkDsk/f zum Beheben von Problemen.

Ursache

Diese Probleme treten aus einem der folgenden Gründe.

Ursache für Symptom 1

Dieses Problem tritt auf, weil eine schreibgeschützte Datei im Stammverzeichnis der Ressource befindet. Bei eine gemeinsam verwendeten physikalischen Datenträgerressource online geschaltet wird, wird der Clusterdienst Listet die Dateien des Stammverzeichnisses und versucht, jede Datei mit Vollzugriff zu öffnen. Dieses Verhalten soll sicherstellen, dass das Dateisystem konsistent ist und der Datenträger nicht beschädigt ist. Wenn Dateien in das Stammverzeichnis der Ressource schreibgeschützt sind, gilt das Volume beschädigt und Chkdsk wird gestartet. Um dieses Problem zu umgehen, verwenden Sie umgehen erwähnt wird im Abschnitt "Lösung 1".

Ursache für Symptom 2

Dieses Problem tritt auf, weil das Flag "geändert" für das Volume gesetzt ist. Bei eine gemeinsam verwendeten physikalischen Datenträgerressource online geschaltet wird, wird der Clusterdienst Listet die Dateien des Stammverzeichnisses und versucht, jede Datei mit Vollzugriff zu öffnen. Dieses Verhalten soll sicherstellen, dass das Dateisystem konsistent ist und der Datenträger nicht beschädigt ist. Wenn Dateien die in das Stammverzeichnis der Ressource "geändert" gekennzeichnet sind, gilt das Volume beschädigt und Chkdsk wird gestartet. Um dieses Problem zu umgehen, verwenden Sie umgehen erwähnt wird im Abschnitt "Lösung 2".

PROBLEMUMGEHUNG

Abhilfemaßnahme 1

Um dieses Problem zu umgehen, führen Sie eine der folgenden:
  • Deaktivieren Sie das Schreibschutzattribut der Dateien Dateieigenschaften anzeigen oder mit dem Befehl Attrib-r in der Befehlszeile.
  • Verschieben Sie die Dateien mit dem nur-Lese-Attribut aus dem Stammverzeichnis der Ressource in einem entsprechenden Unterordner.

Hinweis: Wenn Sie nicht den Datenträger online schalten und eine weitere Überprüfung der Dateien, legen Sie Festplatte private Eigenschaft DiskRunChkDsk -Eigenschaft 4 (ChkDskDontRun). Dies deaktiviert Volume Mount überprüft. Weitere Informationen finden Sie in:

Der freigegebene Datenträger in Windows Server 2008-Cluster nicht online
http://support.microsoft.com/kb/2517696


Abhilfemaßnahme 2

Um dieses Problem zu umgehen, zuerst ermitteln Sie, ob das Flag "geändert" für das angegebene Volume festgelegt ist.

Um festzustellen, ob für das Volume in Windows Server 2008 "geändert" gesetzt ist, verwenden Sie das Tool Chkntfs.

Weitere Informationen zum Tool Chkntfs finden Sie auf der folgenden Microsoft TechNet Web Site:Um festzustellen, ob für das Volume in Windows Server 2008 R2 "geändert" gesetzt ist, verwenden Sie überprüfen einen Konfigurations-Assistenten.

Weitere Informationen überprüfen einen Konfigurations-Assistenten finden Sie auf der folgenden Microsoft TechNet Web Site:Wenn das Flag "geändert" für das Volume festgelegt ist, führen Sie das Dienstprogramm Chkdsk mit der Option/f.

Weitere Informationen zum Dienstprogramm "Chkdsk" finden Sie auf der folgenden Microsoft TechNet Web Site:

Status

Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt „Eigenschaften“ aufgeführt sind.
Eigenschaften

Artikelnummer: 977516 – Letzte Überarbeitung: 13.01.2017 – Revision: 1

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