Fehler "die Tabelle Microsoft Office Access-Datenbankmodul kann nicht gefunden werden" beim Öffnen einer Tabelle in einer Access 2010-Vorlage

Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Sie erstellen eine Datenbank Microsoft Access 2010.
  • Verknüpfen einer Tabelle in dieser Datenbank mit externen Datendienste Tabellen aus Business Data Catalog (BDC) Service-Systemtabellen auf einem Microsoft SharePoint Server.
  • Speichern der Datenbank als Access 2010-Vorlage (.accdt) und dann die Vorlage unterbrechen.
  • Sie versuchen, die Tabelle öffnen, die Data Services-Tabellen verknüpft ist.
In diesem Szenario wird die folgende Fehlermeldung angezeigt:
Microsoft Office Access-Datenbankmodul nicht gefunden die Eingabetabelle oder Abfrage 'MSysBDCMetadata'. Stellen Sie sicher, dass es vorhanden ist und der Name richtig geschrieben ist.

Ursache

Dieses Problem tritt auf, weil die BDC-Systemtabellen, die Sie mit nicht in der Vorlage enthalten sind, die von der Datenbank gespeichert.

PROBLEMUMGEHUNG

Microsoft bietet Programmierbeispiele lediglich zur Veranschaulichung, ohne ausdrückliche oder konkludente Gewährleistung. Dies beinhaltet, ist jedoch nicht beschränkt auf, konkludente Gewährleistungen der Tauglichkeit oder Eignung für einen bestimmten Zweck. Dieser Artikel setzt voraus, dass Sie mit der von Beispielen verwendeten Programmiersprache und den Tools, die zum Erstellen und Debuggen von Prozeduren verwendet werden, vertraut sind. Microsoft-Supporttechniker helfen der Erläuterung der Funktionalität bestimmter Prozeduren. Allerdings werden sie diese Beispiele nicht ändern, um zusätzliche Funktionalität bereitzustellen oder Prozeduren erstellen, die Ihren spezifischen Bedürfnisse erfüllen.

Gehen Sie folgendermaßen vor, um dieses Problem zu umgehen:
  1. Erstellen Sie eine leere Datenbank in Access 2010.
  2. Klicken Sie auf die Registerkarte Externe Daten in mehrere Dropdown-Liste, die in der Gruppe Importieren und Datendienste.
  3. Klicken Sie im Dialogfeld Link zu Datendiensten erstellen auf neu installieren.
  4. Wählen Sie die XML-Quelldatei, die die Verbindung definiert, und klicken Sie auf Öffnen.
  5. Klicken Sie auf Schließen.
  6. Klicken Sie auf der Registerkarte Database Tools in der Makrogruppe auf Visual Basic.
  7. Klicken Sie im Menü Einfügen auf Modul.
  8. Fügen Sie im neuen Modul den folgenden Code ein.
    '// Set all the MSysBDC* system tables  so that they become visible to Save As Template
    '// This should only be needed as soon as in the database that will be used to create the template (accdt)

    Sub PrepareBDCTables()

    Dim db As Database, tbl As TableDef

    Set db = CurrentDb



    For Each tbl In db.TableDefs

    If tbl.Name Like "MSysBDC*" Then

    '//Set all the bdc tables so that they are visible to the save as template wizard

    tbl.Attributes = 0

    End If

    Next

    End Sub
  9. Klicken Sie im Menü Ansicht auf Direktfenster.
  10. Geben Sie den folgenden Befehl ein, und drücken Sie die EINGABETASTE:
    PrepareBDCTables
    Hinweis Dieser Befehl stellt BDC-Tabellen für die Vorlage.
  11. Im Projekt mit der rechten Maustaste in des neuen Moduls und klicken Modulname.
  12. Klicken Sie auf Nein , wenn Sie aufgefordert werden, das Modul zu exportieren.
  13. Schließen Sie Microsoft Visual Basic-Editor.
  14. Klicken Sie auf die Registerkarte Datei Speichern und veröffentlichen.
  15. Klicken Sie unter Datenbank speichern unterauf Vorlage (*.ACCDT).
  16. Klicken Sie im Dialogfeld Neue Vorlage aus dieser Datenbank erstellen Geben Sie Informationen für die Vorlage, und aktivieren Sie das Kontrollkästchen Daten in Vorlage einbeziehen .
  17. Klicken Sie auf OK.
Eigenschaften

Artikelnummer: 983275 – Letzte Überarbeitung: 12.01.2017 – Revision: 1

Feedback