ImageX.exe erfassen kann keines Abbilds in Windows PE 3.0 auf einem Computer, auf dem Windows 7 oder Windows Server 2008 R2 ausgeführt wird

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Den englischen Originalartikel können Sie über folgenden Link abrufen: 2525084
Problembeschreibung
Betrachten Sie das folgende Szenario:
  • Sie haben einen Computer, auf dem Windows 7 oder Windows Server 2008 R2 ausgeführt wird und, die über mehrere Prozessoren verfügt.
  • Sie führen das Tool Imagex.exe, um ein Bild in der Windows-Vorinstallationsumgebung (Windows PE) 3.0 auf dem Computer zu erfassen.
In diesem Szenario schlägt gelegentlich Imagex.exe. Darüber hinaus erhalten Sie eine der folgenden Fehlermeldungen angezeigt:
Der Prozess kann nicht auf die Datei zugreifen, da es von einem anderen Prozess verwendet wird.


Die Anweisung an Speicheradresse referenzierte Speicher an Speicheradresse. Der Speicher konnte nicht schreiben. Klicken Sie auf OK, um das Programm zu beenden.

Ursache
Dieses Problem tritt aufgrund eines Zeitproblems in das Tool Imagex.exe.

Wenn das Timing-Problem auftritt, versuchen Sie zwei Threads gleichzeitig eine Datei öffnen. Aus diesem Grund erhalten Sie die Fehlermeldung, die im Abschnitt "Problembeschreibung" erwähnt wird.
Lösung
Um dieses Problem zu beheben, installieren Sie die neueste Version von Windows Assessment and Deployment Kit (Windows ADK) oder installieren Sie das im Abschnitt "Hotfix-Informationen" beschriebene Hotfix-Paket.

Methode 1: Installieren von Windows ADK

  1. Downloaden Sie die neueste Version von Windows ADK.
  2. Bereitstellen Sie die problematische Winpe.wim-Datei mithilfe des Tools "Imagex.exe" zusammen mit der Syntax/mountrw . Führen Sie hierzu den folgenden Befehl an einer Eingabeaufforderung:
    IMAGEX. EXE/mountrw Pfad des Stagingbereichs Winpe.wim 1
  3. Kopieren Sie die Datei aktualisiert Imagex (es wird standardmäßig unter C:\Program Files (X 86) \Windows Kits\8.1\Assessment und Bereitstellung Kit\Deployment Tools\amd64\DISM\Imagex.exe) in das Verzeichnis Tools der bereitgestellten Winpe.wim-Datei.
  4. Heben Sie die Bereitstellung der Winpe.wim-Datei mithilfe des Tools "Imagex.exe" zusammen mit der/Commit -Syntax. Führen Sie hierzu den folgenden Befehl an einer Eingabeaufforderung:
    IMAGEX. EXE/Commit

Methode 2: Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix soll nur der Behebung des Problems dienen, das in diesem Artikel beschrieben wird. Verwenden Sie diesen Hotfix nur auf Systemen, bei denen dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download zur Verfügung steht, gibt es einen Abschnitt "Hotfixdownload available" ("Hotfixdownload verfügbar"), am oberen Rand dieses Knowledge Base-Artikel. Wenn dieser Abschnitt nicht angezeigt wird, senden Sie eine Anforderung an Microsoft Customer Service and Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die nicht diesem speziellen Hotfix zugeordnet werden können. Für eine vollständige Liste der Telefonnummern des Microsoft Customer Service and Support, oder um eine separate Serviceanfrage zu erstellen, gehen Sie auf folgende Microsoft-Website: Hinweis Das Formular "Hotfixdownload available" ("Hotfixdownload verfügbar") zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist dieser Hotfix für Ihre Sprache nicht verfügbar.

Voraussetzungen

Um diesen Hotfix anwenden zu können, müssen Sie eines der folgenden Betriebssysteme verwenden:
  • Windows 7
  • Windows 7 Servicepack 1 (SP1)
  • Windows Server 2008 R2;
  • Windows Server 2008 R2 Servicepack 1 (SP1)
Weitere Informationen dazu, wie Sie eine Windows 7 oder Windows Server 2008 R2 Servicepack erhalten, klicken Sie auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:
976932 Informationen zum Servicepack 1 für Windows 7 und Windows Server 2008 R2

Anweisungen zur Installation

Für Benutzer, die bereits Win7 RTM OPK oder WAIK Tool Kit installiert haben:

Dieser Download enthält die aktualisierte Version der Datei imagex.exe, die die Datei imagex.exe System ersetzen. ImageX wird standardmäßig im folgenden Ordner installiert:

WAIK-Benutzer:
C:\Program Files\Windows AIK\Tools\<architecture>

OPK-Benutzer:
C:\Program Files\Windows OPK\Tools\<architecture>
Hinweis: <architecture>X 86 oder amd64 oder IA64 ist.

Um imagex.exe zu aktualisieren, gehen Sie folgendermaßen vor:
1. Downloaden Sie 1. ImageX Release-CAB-Datei für alle Architekturen in einen Ordner auf Ihrem Computer.
2. im Windows-Explorer suchen Sie X 86 CAB-Datei auf Ihrem Computer.
(3) im Windows-Explorer doppelklicken Sie auf die CAB-Datei, um den Inhalt der Datei anzuzeigen.
4. drücken Sie STRG + A, um imagex.exe auszuwählen.
(5) mit der rechten Maustaste in der Auswahl, und klicken Sie dann auf extrahieren.
6 Klicken Sie im Zielfenster auswählen wählen Sie den Ordner mit der CAB-Datei.
7. Klicken Sie auf neuen Ordner erstellen, und geben Sie dann X 86 für den Namen des Ordners.
8. Klicken Sie auf Extrahieren, um die Dateien zu extrahieren.
(9) in Windows-Explorer suchen Sie den Ordner, in dem Sie die Dateien in den vorherigen Schritten extrahiert.
10. drücken Sie STRG + A zum ImageX im Ordner auszuwählen.
(11) mit der rechten Maustaste in der Auswahl, und klicken Sie dann auf Kopieren.
12. Suchen Sie den Ordner, in dem die Datei X 86 imagex.exe auf Ihrem Computer installiert ist. Die Datei X 86 imagex.exe kann z. B. im Ordner C:\Program Files\Windows AIK\Tools\x86 oder C:\Program Files\Windows OPK\Tools\x86 nach WAIK oder OPK Benutzer installiert werden.
13. mit der rechten Maustaste an einer beliebigen Stelle im Ordner, und klicken Sie dann auf Einfügen.
14. Wenn Sie dazu aufgefordert werden, klicken Sie auf Kopieren und ersetzen die imagex.exe-Datei durch die neuere Version ersetzen, die diese Version enthält.
15. wenn ein Fenster für Administratorberechtigungen aufgefordert werden, klicken Sie auf Weiter. Wenn andere Fenster Dateioperation aufgefordert, klicken Sie auf Ja, in einem dieser Fenster.
16 wiederholen Sie die Schritte 2-15 mit der CAB-Datei für amd64 ImageX, amd64 für den Ordnernamen eingeben und durch Auswählen dieses Ordners als Ziel für die extrahierten amd64 ImageX-Datei. Beispielsweise kann die amd64 imagex.exe-Datei im Ordner C:\Program Files\Windows AIK\Tools\amd64 OR C:\Program Files\Windows OPK\Tools\amd64 nach WAIK oder OPK Benutzer installiert werden.
17. Wiederholen Sie die Schritte 2-15 mit der CAB-Datei mit ImageX IA64 IA64 für den Ordnernamen eingeben, und wählen Sie diesen Ordner als Ziel für die extrahierte Datei IA64 ImageX. Beispielsweise kann die amd64 imagex.exe-Datei im Ordner C:\Program Files\Windows AIK\Tools\IA64 OR C:\Program Files\Windows OPK\Tools\IA64 nach WAIK oder OPK Benutzer installiert werden.

Benutzer, die als eigenständige ausführbare Datei imagex.exe verwenden, gehen Sie folgendermaßen vor:
</architecture></architecture></architecture>
  1. Extrahieren Sie dieses Hotfix-Paket an einen temporären Speicherort manuell.
  2. Bereitstellen Sie die problematische Winpe.wim-Datei mithilfe des Tools "Imagex.exe" zusammen mit der Syntax/mountrw . Führen Sie hierzu den folgenden Befehl an einer Eingabeaufforderung:
    IMAGEX. EXE/mountrw Pfad des Stagingbereichs Winpe.wim 1
  3. Kopieren Sie die aktualisierten Imagex-Datei in das Verzeichnis Tools der bereitgestellten Datei Winpe.wim.
  4. Heben Sie die Bereitstellung der Winpe.wim-Datei mithilfe des Tools "Imagex.exe" zusammen mit der/Commit -Syntax. Führen Sie hierzu den folgenden Befehl an einer Eingabeaufforderung:
    IMAGEX. EXE/Commit

Informationen zur Registrierung

Um den Hotfix aus diesem Paket verwenden zu können, müssen Sie keine Änderungen an der Registrierungsdatenbank vornehmen.

Neustart Anforderung

Sie müssen keinen Neustart des Computers nach der Installation dieses Hotfixes durchführen.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.

Datei-Informationen

Die internationale Version dieses Updates installiert Dateien mit den Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) aufgelistet. Die Datums- und Uhrzeitangaben für diese Dateien auf Ihrem lokalen Computer sind in Ihrer Ortszeit zusammen mit Ihrem aktuellen Zeitunterschied Sommerzeit (DST) angezeigt. Darüber hinaus können sich die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen auf die Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows 7 und Windows Server 2008 R2
Wichtig Windows 7- und Windows Server 2008 R2-Hotfixes sind in denselben Paketen enthalten. Allerdings werden Updates auf der Seite Hotfix Anforderung unter beiden Betriebssystemen aufgelistet. Um das Hotfix-Paket anzufordern, das auf eine oder beide Betriebssysteme angewendet kann, wählen Sie den Hotfix aus, der auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgeführt ist. Beachten Sie im Abschnitt "Gilt für" im Artikel, um das aktuelle Betriebssystem zu bestimmen, dem die einzelnen Hotfixes gelten.
  • Die Dateien für ein bestimmtes Produkt SR_Level (RTM, SPn), und Servicebereiche (LDR, GDR) gelten, durch die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt.
    VersionProduktSR_LevelServicebereich
    6.1.760 1. 21xxxWindows 7 und Windows Server 2008 R2SP1LDR
Für alle unterstützten x86-basierten Versionen von Windows 7
DateinameDateiversionGröße der DateiDatumZeitPlattform
ImageX.exe6.1.7601.21716475,64828-Apr-201102:34x86
Für alle unterstützten x64-basierten Versionen von Windows 7 und Windows Server 2008 R2
DateinameDateiversionGröße der DateiDatumZeitPlattform
ImageX.exe6.1.7601.21716574,97628-Apr-201102:51x64
Für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
DateinameDateiversionGröße der DateiDatumZeitPlattform
ImageX.exe6.1.7601.217161,188,35228-Apr-201102:12IA-64
Status
Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Eigenschaften" aufgeführt sind.
Weitere Informationen
Für weitere Informationen zur Softwareupdate-Terminologie, klicken Sie auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:
824684 Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird.
Weitere Informationen zum ImageX-Tool finden Sie auf der folgenden TechNet-Website:
ImageX Racing Problem Windows PE

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 2525084 – Letzte Überarbeitung: 07/09/2015 07:30:00 – Revision: 5.0

Windows 7 Starter, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Home Basic, Windows 7 Enterprise, Windows 7 Ultimate, Windows Server 2008 R2 Standard, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Foundation, Windows Server 2008 R2 for Itanium-Based Systems

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