OL2000: Wie Sie programmatisch den Journalmodus für alle Kontakte festlegen können

Dieser Artikel wurde zuvor veröffentlicht unter D252947
Dieser Artikel wurde archiviert. Er wird im vorliegenden Zustand bereitgestellt und nicht mehr aktualisiert.
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
252947 OL2000: How to Programmatically Set Journaling for All Contacts
Zusammenfassung
In diesem Artikel wird ein Outlook Visual Basic für Applikationen-Makro beschrieben, mit dem Sie programmatisch alle Ihre Kontakte so ändern können, dass für diese der Journalmodus gilt.
Weitere Informationen
Standardmäßig ist die Einstellung für das Erstellen von Journaleinträgen zu Kontaktelementen deaktiviert. Wenn Sie Kontakte erstellen und sich dann dafür entscheiden, den Journalmodus für diese Kontakte zu aktivieren, müssen Sie die Journaloption für jeden Kontakt festlegen:
  1. Klicken Sie im Menü Extras auf Optionen.
  2. Klicken Sie auf der Registerkarte Einstellungen auf Journaloptionen.
  3. Im Feld Für diese Kontakte klicken Sie alle Kontakte an, für die Sie den Journalmodus aktivieren möchten.
Sollten Sie sehr viele Kontakte haben und für alle den Journalmodus aktivieren wollen, ist es eventuell effizienter, alle Kontakte programmatisch zu ändern.

Die Verwendung der hier aufgeführten Informationen, Makro- oder Programmcodes geschieht auf eigene Verantwortung. Microsoft stellt Ihnen diese Informationen sowie Makro- und Programmlistings ohne Gewähr auf Richtigkeit, Vollständigkeit und/oder Funktionalität sowie ohne Anspruch auf Support zur Verfügung. Die zur Verfügung gestellten Makro- und Programmierungsbeispiele sollen lediglich exemplarisch die Funktionsweise des Beispiels aufzeigen.
Weitere Informationen zu den von Microsoft angebotenen Supportoptionen finden Sie unter folgender Internetadresse: Gehen Sie folgendermaßen vor, um das Makro zu erstellen:
  1. Zeigen Sie im Menü Extras auf Makro und klicken Sie dann auf Makros.
  2. In das Feld Makroname geben Sie bitte SetAllContactsToJournal ein. Klicken Sie dann auf Erstellen. Der Visual Basic-Editor wird gestartet und erstellt automatisch eine Subroutine für Sie.
  3. Geben Sie die folgenden Codezeilen ein:
    Sub SetAllContactsToJournal()   Dim objContactsFolder As Outlook.MAPIFolder   Dim objContacts As Outlook.Items   Dim objContact As Object   Dim iCount As Integer   ' Zu verwendenden Kontaktordner angeben   Set objContactsFolder = Session.GetDefaultFolder(olFolderContacts)   Set objContacts = objContactsFolder.Items   iCount = 0   ' Änderungen verarbeiten   For Each objContact In objContacts      If TypeName(objContact) = "ContactItem" Then         If objContact.Journal = False Then            objContact.Journal = True            objContact.Save            iCount = iCount + 1         End If      End If   Next      MsgBox "Anzahl aktualisierter Kontakte:" & Str$(iCount)   ' Aufräumen   Set objContact = Nothing   Set objContacts = Nothing   Set objContactsFolder = NothingEnd Sub
  4. Klicken Sie im Menü Datei auf Schließen und zurück zu Microsoft Outlook.
Gehen Sie folgendermaßen vor, um das Makro einzusetzen:
  1. Zeigen Sie im Menü Extras auf Makro und klicken Sie dann auf Makros.
  2. Klicken Sie auf SetAllContactsToJournal und danach auf Ausführen.
Es wird ein Fenster mit der Anzahl der aktualisierten Kontakte eingeblendet.

Anmerkungen

  • Es kann eine Weile dauern, die Elemente in Ihrem Ordner "Kontakte" zu verarbeiten.
  • Wenn Ihre Kontakte aktualisiert werden, nimmt Ihr Mauszeiger nicht die Gestalt einer Sanduhr an.
  • Sie können das Makro einer Schaltfläche zuordnen, wenn Sie es häufiger benutzen möchten. Weitere Informationen dazu, wie Sie dieses Makro einer Symbolleistenschaltfläche zuordnen können, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    252426 OL2000: Zuordnen eines Makros zu einer Schaltfläche in der Symbolleiste
  • Der Beispielcode aus diesem Artikel funktioniert nur in Verbindung mit dem standardmäßigen Ordner "Kontakte". Wenn Sie ihn auch für andere Kontaktordner anwenden möchten, gehen Sie zu der folgenden Codezeile
    Set objContactsFolder = Session.GetDefaultFolder(olFolderContacts)
    und ändern Sie diese zu:
    Set objContactsFolder = Outlook.ActiveExplorer.CurrentFolder
  • Wenn Sie über Programmierungserfahrungen verfügen und einen bestimmten Kontaktordner an einem anderen Speicherort verwenden möchten, lesen Sie bitte den folgenden Artikel in der Microsoft Knowledge Base:
208520 OL2000: Programming Examples for Referencing Items and Folders
Verweise
Weitere Informationen zu verfügbaren Ressourcen und Antworten auf häufig gestellte Fragen zu Microsoft Outlook-Lösungen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
146636 OL2000: Fragen zu benutzerdefinierten Formularen und Outlook-Lösungen
OutSol OutSol2000 OL2K
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Eigenschaften

Artikelnummer: 252947 – Letzte Überarbeitung: 02/14/2014 09:55:03 – Revision: 1.0

  • Microsoft Outlook 2000 Standard Edition
  • kbnosurvey kbarchive kbhowto KB252947
Feedback