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Ein oder mehrere Objekte synchronisieren nicht, wird Active Directory Synchronisierungsprogramm Azure

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PROBLEM
Active Directory-Domänendienste (AD DS) Objekte oder Attribute synchronisiert nicht wie erwartet Microsoft Azure Active Directory (AD Azure). Wenn Active Directory-Synchronisierung ausgeführt wird, ein Objekt nicht synchronisieren und eines der folgenden Symptome auftreten:
  • Sie erhalten eine Fehlermeldung, die besagt, dass ein Attribut einen doppelten Wert besitzt.
  • Sie erhalten eine Fehlermeldung, die besagt, dass ein oder mehrere Attribute Formatierung Anforderungen wie Zeichen oder Zeichen verletzt.
  • Sie keine Fehlermeldung und Verzeichnissynchronisation scheint abgeschlossen werden. Jedoch werden nicht einige Objekte oder Attribute wie erwartet aktualisiert.
Die folgenden: Beispiele für die Fehlermeldung, die angezeigt wird
  • Ein synchronisiertes Objekt mit derselben Proxyadresse existiert bereits im Verzeichnis Microsoft Online Services.
  • Kann nicht auf dieses Objekt aktualisieren, da die Benutzer-ID nicht gefunden wird.
  • Dieses Objekts im Microsoft Online Services aktualisieren, da die folgenden Attribute, die diesem Objekt zugeordnete Werte, die möglicherweise bereits mit einem anderen Objekt in Ihrem lokalen Verzeichnis nicht möglich.
URSACHE
Dieses Problem kann folgende Gründe haben:
  • Domänenwert, der von AD DS verwendet noch nicht bestätigt.
  • Ein oder mehrere Attribute, die einen eindeutigen Wert haben einen doppelt vorhandener Attributswert (z. B. die proxyAddresses Attribut oder UserPrincipalName Das Attribut) in einem vorhandenen Benutzerkonto.
  • Ein oder mehrere Attribute verletzen Formatierung Vorschriften, die die Zeichen und die Zeichenlänge von Attributwerten einschränken.
  • Ein oder mehrere Attribute übereinstimmen Ausschlussregeln für die Verzeichnissynchronisation.

    Die folgende Tabelle zeigt die Standard-Sync Bereichsregeln:
    ObjekttypName des AttributsZustand des Attributs bei Synchronisierungsfehlern
    KontaktDisplayNameEnthält "MSOL"
    msExchHideFromAddressLists"True" festgelegt ist
    Gruppe mit aktivierter SicherheitisCriticalSystemObject"True" festgelegt ist
    E-Mail-aktivierte Gruppen
    (Sicherheit oder Verteilerliste Liste)
    proxyAddresses

    und

    e-Mail-Nachrichten
    Keine "SMTP:"-Eintrag

    und

    ist nicht vorhanden
    E-Mail-aktivierte KontakteproxyAddresses

    und

    e-Mail-Nachrichten
    Keine "SMTP:"-Eintrag

    und

    ist nicht vorhanden
    iNetOrgPersonsAMAccountNameIst nicht vorhanden
    isCriticalSystemObjectIst vorhanden
    BenutzermailNickNameBeginnt mit "SystemMailbox"
    mailNickNameBeginnt mit "CAS_"

    und

    enthält "{"
    sAMAccountNameBeginnt mit "CAS_"

    und

    enthält "}"
    sAMAccountNameEntspricht "SUPPORT_388945a0"
    sAMAccountNameEntspricht "MSOL_AD_Sync"
    sAMAccountNameIst nicht vorhanden
    isCriticalSystemObject"True" festgelegt ist
  • Der Benutzerprinzipalname (UPN) wurde nach der ersten Synchronisierung geändert und muss manuell aktualisiert werden.
  • Exchange Online Simple Mail Transfer Protocol (SMTP) Adressen synchronisierte Benutzer sind nicht in der lokalen Active Directory-Schema entsprechend aufgefüllt.
LÖSUNG
Um dieses Problem zu beheben, wenden Sie je nach Ihrer Situation, eine der folgenden Methoden an:

Lösung 1: Ausführen IdFix Überprüfung auf Duplikate und fehlende Attribute Regelverstöße

Verwenden der Dirsync-IdFix Fehler Remediation-Tool Objekte suchen und Fehler, die Synchronisierung Azure AD verhindern.
  • Wenn "Leer" in der Spalte Fehler nach dem Ausführen der IdFix angezeigt wird, finden Sie im folgenden Microsoft Knowledge Base-Artikel:
    2857349 "Leer" erscheint in der Spalte Fehler für ein oder mehrere Objekte nach Ausführung des Tools IdFix
  • Wenn Sie "Format" in der Spalte Fehler sehen nach IdFix ausführen, finden Sie im folgenden Microsoft Knowledge Base-Artikel:
    2857351 "Format" in der Spalte Fehler für ein oder mehrere Objekte angezeigt, nachdem Sie das IdFix Tool ausführen
  • Wenn Sie "Zeichen" in der Spalte Fehler finden Sie nach dem Ausführen von IdFix, finden Sie im folgenden Microsoft Knowledge Base-Artikel:
    2857352 'Character' in der Spalte Fehler für ein oder mehrere Objekte angezeigt, nachdem Sie das IdFix Tool ausführen
  • Wenn "Duplicate" in der Spalte Fehler nach IdFix ausführen angezeigt, finden Sie im folgenden Microsoft Knowledge Base-Artikel:
    2857385 "Duplizieren" erscheint in der Spalte Fehler für ein oder mehrere Objekte nach Ausführung des Tools IdFix

Lösung 2: Ermitteln Sie Attributkonflikte Objekte verursacht werden, die in Azure AD mittels Verzeichnissynchronisation erstellt wurden nicht

Attributkonflikte ermitteln, die Benutzerobjekte zurückzuführen sind, mithilfe erstellt wurden (und waren nicht im Azure AD mittels Verzeichnissynchronisation erstellt), gehen Sie folgendermaßen vor:
  1. Bestimmen der einzigartigen Attribute von lokalen Benutzerkonto AD DS. Dazu auf einem Computer, der Windows-Supporttools installiert sind, gehen Sie folgendermaßen vor:
    1. Klicken Sie auf Startund auf Ausführen, geben LDP.exe, und klicken Sie dann auf OK.
    2. Klicken Sie auf Verbindung, klicken Sie auf Verbinden, geben Sie den Namen des AD DS-Domänencontroller, und klicken Sie auf OK.
    3. Klicken Sie auf Verbindungund klicken Sie auf binden.
    4. Klicken Sie auf Ansicht, klicken Sie auf Ansichtwählen Sie die AD DS-Domäne in der Liste BaseDN und klicken Sie dann auf OK.
    5. Klicken Sie im Navigationsbereich zu suchen Sie und doppelklicken Sie auf das Objekt ist nicht ordnungsgemäß synchronisiert. Im Detailfenster auf der rechten Seite des Fensters sind alle Attribute aufgeführt. Das folgende Beispiel zeigt die Attribute des Objekts:

      Screenshot der Objektattribute
    6. Notieren Sie die Werte des Attributs UserPrincipalName und jede SMTP-Adresse im mehrwertigen ProxyAddresses -Attribut. Diese Werte werden später benötigen werden.
      Name des Attributs Beispiel Hinweise
      proxyAddresses ProxyAddresses (3): X 500: / o = Exchange/Ou = Exchange Administrative Gruppe (FYDIBOHF23SPDLT) / Cn = Recipients/Cn = 1ae75fca0d3a4303802cea9ca50fcd4f-7628376; SMTP:7628376@Service.contoso.com; SMTP:7628376@contoso.com;
      • Die Zahl in Klammern neben dem Attribut angezeigt gibt die Anzahl der Proxy-Adresswerte in dem mehrwertigen Attribut.
      • Jedes distinct Proxy-Adresswert sind durch ein Semikolon (;).
      • SMTP-Proxy-Adresse Primärschlüsselwert sind durch Großbuchstaben "SMTP:"
      userPrincipalName 7628376@contoso.com
      Hinweis LDP.exe ist in Windows Server 2008 und Windows Server 2003-Supporttools enthalten. Windows Server 2003-Supporttools sind in Windows Server 2003-Installationsmedium enthalten. Oder rufen Sie die Supporttools auf der folgenden Microsoft-Website:
  2. Verbinden Sie mit Azure AD mithilfe der Azure Active Directory-Modul für Windows PowerShell. Weitere Informationen finden Sie unter Verwalten von Azure AD mit Windows PowerShell.

    Lassen Sie das Konsolenfenster geöffnet. Sie müssen im nächsten Schritt verwenden.
  3. Überprüfen Sie die doppelte UserPrincipalName Attribute.

    Geben Sie in der Konsolenverbindung, die Sie in Schritt 2 geöffnet haben folgende Befehle in der Reihenfolge, in der sie angezeigt werden, und drücken Sie nach jedem Befehl:
    • $userUPN = "<search UPN>"
      Hinweis In diesem Befehl den Platzhalter "<search upn="">" stellt das UserPrincipalName -Attribut, das in Schritt 1f aufgezeichnet.<b00> </b00> </search>
    • get-MSOLUser –UserPrincipalName $userUPN | where {$_.LastDirSyncTime -eq $null} 
    Lassen Sie das Konsolenfenster geöffnet. Sie verwenden es erneut im nächsten Schritt.
  4. Doppelte ProxyAddresses Attribute überprüfen. Geben Sie in der Konsolenverbindung, die Sie in Schritt 2 geöffnet haben folgende Befehle in der Reihenfolge, in der sie angezeigt werden, und drücken Sie nach jedem Befehl:
    • $SessionExO = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid/ -Credential $Cred -Authentication Basic - AllowRedirection
    • Import-PSSession $sessionExO -prefix:Cloud 
  5. Geben Sie für jeden Schritt 1f aufgezeichneten Proxy-Adresseintrag folgende Befehle in der Reihenfolge, in der sie angezeigt werden, und drücken Sie nach jedem Befehl:
    • $proxyAddress = "<search proxyAddress>" 
      Hinweis In diesem Befehl den Platzhalter "<search proxyaddress="">" stellt den Wert ProxyAddresses -Attribut, das in Schritt 1f aufgezeichnet.<b00> </b00> </search>
    • get-cloudmailbox | where {[string] $str = ($_.EmailAddresses); $str.tolower().Contains($proxyAddress.tolower()) -eq $true} | foreach {get-MSOLUser -UserPrincipalName $_.MicrosoftOnlineServicesID | where {($_.LastDirSyncTime -eq $null)<AngularNoBind>}}</AngularNoBind> 
Nach dem Ausführen der Befehle in Schritt 3 und 4 zurückgegebenen Elemente darstellen Benutzerobjekte, waren nicht mittels Verzeichnissynchronisation erstellt und deren Attribute, die in Konflikt mit dem Objekt, die ist nicht richtig synchronisiert.

Lösung 3: Update AD DS Attribute Duplikate Verstöße gegen Regeln und scoping Ausschlüsse entfernen

Identifizieren Sie die spezifischen Attribute, die Synchronisierung wird basierend auf den folgenden Informationen verhindern:
  • Mail-Nachrichten
  • Der Bericht von der Ausgabe des Office 365 Readiness-Bereitstellungstools
  • Standard-Verzeichnis Synchronisierung Bereichsregeln und benutzerdefinierte Regeln
Nach ein bestimmten Attributwert identifiziert wird, verwenden Sie die Active Directory-Benutzer und-Computer den Attributwert bearbeiten. Gehen Sie hierzu folgendermaßen vor:
  1. Öffnen Sie Active Directory-Benutzer und-Computer, und wählen Sie den Stammknoten der AD DS-Domäne.
  2. Klicken Sie auf anzeigen, , und stellen Sie dann sicher, dass die Erweiterte Funktionen aktiviert ist.
  3. Klicken Sie im linken Navigationsbereich suchen das Benutzerobjekt Maustaste und klicken Sie dann auf Eigenschaften.
  4. Suchen Sie auf der Registerkarte Objekt-Editor das Attribut, das gewünschten klicken Sie auf Bearbeiten, und bearbeiten Sie den Attributwert auf den gewünschten Wert.
  5. Klicken Sie auf OK zweimal.
Oder Sie können Active Directory Service Interfaces (ADSI) Edit Objektattribute in AD DS aktualisieren. Sie können herunterladen und Installieren von ADSI Edit als Teil des Windows Server-Toolkit. Mit ADSI Edit Attribute bearbeiten, gehen Sie folgendermaßen vor.

Warnung Dieser Vorgang erfordert ADSI Edit. Mit ADSI Edit falsch kann schwerwiegende Probleme verursachen, die möglicherweise eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung von ADSI aufgelöst werden können. Verwenden Sie ADSI-Bearbeitung auf eigene Gefahr.
  1. Klicken Sie auf Startund auf Ausführen, geben ADSIEdit.msc, und klicken Sie dann auf OK.
  2. Mit der rechten Maustaste ADSI Edit im Navigationsbereich klicken Sie auf Verbinden,und klicken Sie dann auf OK die Domänenpartition zu laden.
  3. Suchen Sie das Benutzerobjekt Maustaste und klicken Sie dann auf Eigenschaften.
  4. In der Attribute Liste, suchen Sie das Attribut die gewünschten klicken Sie auf Bearbeiten, und bearbeiten Sie den Attributwert auf den gewünschten Wert.
  5. Klicken Sie auf OK zweimal und dann beenden ADSI Edit.

Lösung 4: Erstellen einer neuen Gruppe und Hinzufügen zur integrierten Gruppe nicht synchronisiert

Lösen das Problem in dem Szenario, in dem einige vordefinierte (z. B. der Gruppe der Domänenbenutzer) Gruppen, nicht synchronisiert, Erstellen einer neuen Gruppe, die alle entsprechenden Elemente und Berechtigungen der vordefinierten Gruppe enthält. Fügen Sie dieser Gruppe als Mitglied der integrierten Gruppe nicht synchronisiert. Anstelle der neuen Gruppe der vordefinierten Gruppe Mitglieder verwalten. Dadurch können Sie weiterhin nur eine Gruppe verwalten.

Sie möchten die Attribute der vordefinierten Gruppe oder ändern die Bereichsregeln Identität Sync Appliance wichtige Systemobjekte synchronisiert werden, da diese anderen unerwartetes Verhalten auslösen können.

Lösung 5: Verwenden SMTP Vergleichs, um einen lokalen Benutzer-Objekt auf ein vorhandenes Benutzerobjekt synchronisieren

Hierzu finden Sie im folgenden Artikel der Microsoft Knowledge:
2641663 Wie SMTP entsprechend mit lokalen Benutzerkonten auf Office 365 Benutzerkonten für die Verzeichnissynchronisation

Auflösung 6: Aktualisieren Sie ein Benutzerkonto UPN manuell

Um ein Benutzerkonto UPN aktualisieren, die nach der ersten Synchronisierung lizenziert wurde, gehen Sie folgendermaßen vor:
  1. Klicken Sie auf Start, klicken Sie auf Alle Programme, klicken Sie auf Windows Azure Active Directoryund klicken Sie dann auf Windows Azure Active Directory Modul für Windows PowerShell.
  2. Führen Sie die folgenden Cmdlets in Windows PowerShell eingeben:
    1. $cred = get-credential
      Hinweis Wenn Sie aufgefordert werden, geben Sie die Administrator-Anmeldeinformationen.
    2. Connect-MSOLService
    3. Set-MsolUserPrincipalName -UserPrincipalName [CurrentUPN] -NewUserPrincipalName [NewUPN]

Auflösung 7: Update SMTP-Adressen von Benutzern mit lokalen Active Directory-Attribute

Wenn SMTP-Attribute zu erwarteten Weise synchronisiert werden nicht, möglicherweise der lokalen Active Directory-Attribute aktualisieren. Verwenden Sie, um lokale Active Directory-Attribute aktualisieren, damit die richtige e-Mail-Adresse in Exchange Online zeigt Lösung 2 die Attribute bearbeiten, die in der folgenden Tabelle aufgeführt sind.
Name der lokalen Active Directory-AttributBeispiel für lokale Active Directory-AttributwertWird Exchange Online e-Mail-Adressen
proxyAddressesSMTP:User1@contoso.comPrimäre SMTP: user1@contoso.com
Sekundäre SMTP: user1@contoso.onmicrosoft.com
proxyAddressesSMTP:User1@contoso.comPrimäre SMTP: sekundäre SMTP user1@contoso.onmicrosoft.com: user1@contoso.com
proxyAddressesSMTP:User1@contoso.com
SMTP:User1@Sub.contoso.com
Primäre SMTP: user1@contoso.com
Sekundäre SMTP: user1@sub.contoso.com
Sekundäre SMTP: user1@contoso.onmicrosoft.com
e-Mail-NachrichtenUser1@contoso.comPrimäre SMTP: user1@contoso.com
Sekundäre SMTP: user1@contoso.onmicrosoft.com
UserPrincipalNameUser1@contoso.comPrimäre SMTP: user1@contoso.com
Sekundäre SMTP: user1@contoso.onmicrosoft.com
Der Eintrag Microsoft Online e-Mail-Routing Adresse (MOERA), die mit der Standarddomäne (z. B. das user1@contoso.onmicrosoft.com) ist eine interpretierte Wert des Benutzerkontos Alias basiert. Diese spezielle e-Mail-Adresse ist untrennbar Exchange Online Empfänger und kann nicht verwalten, löschen oder weitere MOERA-Adressen für Empfänger erstellen. Allerdings kann die Adresse MOERA als SMTP-Hauptadresse überschrieben werden mit den Attributen im lokalen Active Directory-Benutzerobjekt.

Hinweis Das Vorhandensein von Daten im Attribut ProxyAddresses maskiert vollständig Daten in das Attribut Mail Exchange Online e-Mail Adresse Bevölkerung.

Hinweis Das Vorhandensein von Daten in das ProxyAddresses -Attribut oder das Attribut Mail Attribute vollständig Maske UserPrincipalName Daten für Exchange Online e-Mail Adresse auffüllen. Der UPN kann zum Verwalten von e-Mail-Adressen verwendet werden. Administrator können jedoch die e-Mail-Adresse und UPN getrennt durch Auffüllen ProxyAddresses oder e-Mail- Attribute verwalten.

Wir empfehlen, dass eines dieser Attribute konsistent verwendet Exchange Online e-Mail-Adressen für synchronisierte Benutzer verwalten.
Weitere Informationen
Windows PowerShell-Befehle, die in diesem Artikel erwähnten erfordern die Azure Active Directory-Modul für Windows PowerShell. Informationen Sie weitere über die Azure Active Directory-Modul für Windows PowerShell Verwalten von Azure AD mit Windows PowerShell.

Weitere Informationen zum Filtern von Synchronisierung von Attributen finden Sie unter Microsoft TechNet Wiki-Artikel:
Brauchen Sie Hilfe? Klicken Sie auf der Office 365-Community Website oder Active Directory Azure-Foren Website.

Warnung: Dieser Artikel wurde automatisch übersetzt

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Artikelnummer: 2643629 – Letzte Überarbeitung: 11/19/2015 17:44:00 – Revision: 33.0

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