Das Dashboard für die Vertriebsleistung kann in Microsoft Dynamics CRM 2011 nicht bearbeitet werden

Dieser Artikel hilft Ihnen, das Problem zu beheben, das auftritt, wenn Sie versuchen, das Sales Performance Dashboard in Microsoft Dynamics CRM 2011 zu öffnen oder zu bearbeiten.

Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 2741768

Problembeschreibung

Beim Versuch, das Sales Performance Dashboard in Microsoft Dynamics CRM 2011 zu öffnen oder zu bearbeiten, kann der folgende Fehler auftreten:

Das Dashboard kann nicht bearbeitet werden. Das Dashboard konnte nicht geöffnet werden. Maximal nein. der im Layout zulässigen Spalten ist 4.

Ursache

Der Dashboard-Editor lässt Keine Dashboards mit mehr als drei Spalten zu. Der Dashboard-Editor wurde entwickelt, um die Bearbeitung nicht zuzulassen, da das Erhöhen dieser Werte Skriptfehler innerhalb der Dashboards verursacht.

Lösung

Dies kann mithilfe der Funktion zum Exportieren und Reimport von Projektmappen (nicht verwaltet) geändert werden.

  1. Speichern Sie diese Dashboard als neue Dashboard. (Verwenden Sie die Schaltfläche Speichern unter auf der Symbolleiste)

  2. Erstellen Sie eine Projektmappe, die die neue Dashboard enthält.

  3. Erstellen Sie eine neue Projektmappe, fügen Sie ihr die neue Dashboard hinzu, und exportieren Sie diese Lösung.

  4. Navigieren Sie unter dem Knoten Dashboards im customizations.xml zum Dashboard xml (FormXml-Knoten), und ändern Sie das Spaltensattribut des Abschnitts wie unten gezeigt in 111:

    <sectionshowlabel="false"showbar="false"columns="111"

  5. Für jede Zelle weist der aktuelle Colspan folgende Reihenfolge auf: 2,1,2,3,2,3,2,3. Ändern Sie dies in 1,1,1,2,1,2. Zum Beispiel:

    <cellcolspan="2"rowspan="24"

  6. Speichern Sie die Datei, und zippen Sie die Projektmappe erneut, um sie erneut zu importieren.