Sysprep schlägt nach dem Entfernen oder Aktualisieren von Windows Store-Apps fehl, die integrierte Windows-Abbilder enthalten

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Den englischen Originalartikel können Sie über folgenden Link abrufen: 2769827
Zusammenfassung
Dieser Artikel beschreibt ein Problem, dass beim Entfernen oder aktualisieren eine bereitgestellte Windows Store-app mit Windows Store und Sysprep auf dem Computer ausgeführt.

Sysprep ist ein Tool für IT-Administratoren, die eine Installation von Windows für die Duplizierung, Überwachung und Auslieferung an den Kunden vorbereiten möchten. Die Anleitung richtet Kundendienstmitarbeiter und IT-Experten. Wenn Sie Privatkunde, die Probleme beim Verwenden von Windows Store-apps vorliegt sind, finden Sie in folgenden Microsoft-Websites:
Einführung
Einige Windows Store-apps enthalten integrierte Windows 10 und Windows 8 Bilder. Dazu zählen E-Mail, Karten, Messaging, Bing, Reisen und News-apps unter anderem. Diese werden als bereitgestellt apps bezeichnet. Bereitgestellte apps im Bild bereitgestellt und für jeden Benutzer bei der ersten Anmeldung das Windows-Abbild installiert werden sollen. Neben den integrierten apps Sie können Seite eigene Zeile Business Windows Store-apps in das Windows-Abbild Laden ohne Windows Store veröffentlichen. Sie können Seite laden Pakete Appx online oder Wartung offline verfügbaren Befehle DISM.exe oder über DISM PowerShell-Modul.
Problembeschreibung
Betrachten Sie die folgenden Szenarien.

Szenario 1
  • Sie erstellen einen benutzerdefinierten Windows 10 oder Windows 8 Referenzcomputer, den Sysprep und erfassen möchten.
  • Einige bereitgestellte Windows Store-apps (Appx Pakete) dieser Referenzcomputer entfernen möchten.
  • Ausführen DISM-Online-/Remove-ProvisionedAppxPackage/PackageName:<packagename></packagename> um Pakete Appx entziehen.
Beim Ausführen von Sysprep Vorgang in diesem Szenario schlägt der Vorgang mit dem folgenden Fehler fehl:

Systemvorbereitungsprogramm 3.14
Schwerwiegender Fehler beim Versuch, Sysprep der Maschine


Szenario 2
  • Haben Sie ein Windows-Abbild und mehrere Windows Store-apps werden im Bild Seite geladen.
  • Möchten Ihr Bild entfernen einiger Pakete Appx Seite geladen und weiter anpassen.
  • Sie starten den Referenzcomputer und führen Sie einen der folgenden PowerShell Befehle entfernen die Bereitstellung des Pakets Appx:
    • Entfernen AppxProvisionedPackage – Paketname<PackageName></PackageName>
    • Entfernen ProvisionedAppxPackage – Paketname<PackageName></PackageName>
Beim Ausführen von Sysprep Vorgang in diesem Szenario schlägt der Vorgang mit dem folgenden Fehler fehl:

Systemvorbereitungsprogramm 3.14
Schwerwiegender Fehler beim Versuch, Sysprep der Maschine


Szenario 3
  • Erstellen Sie ein Referenzabbild Windows 10 oder Windows 8.
  • Verbinden mit Windows 10 oder Windows 8 Speicher und dann integrierte Windows Store-apps mit Windows Store aktualisieren.
Beim Ausführen von Sysprep Vorgang in diesem Szenario schlägt der Vorgang mit dem folgenden Fehler fehl:

Systemvorbereitungsprogramm 3.14
Schwerwiegender Fehler beim Versuch, Sysprep der Maschine


Darüber hinaus können Sie in der SetupErr.log Fehler Folgendes feststellen:

<Date><Time>, Fehler SYSPRP Paket <PackageFullName>für einen Benutzer installiert wurde, aber nicht für alle Benutzer bereitgestellt. Dieses Paket funktioniert nicht ordnungsgemäß in das Sysprep-Abbild.
<Date><Time>, SYSPRP Fehler apps für den aktuellen Benutzer entfernen: 0x80073cf2.
<Date><Time>, Fehler SYSPRP Exitcode der RemoveAllApps Thread wurde 0x3cf2.
<Date><Time>, Fehler [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Fehler beim Ausführen von 'SysprepGeneralize' vom C:\Windows\System32\AppxSysprep.dll; DwRet = 0x3cf2
<Date><Time>, SYSPRP ActionPlatform::ExecuteAction Fehler: Fehler beim Ausführen der Aktion, DwRet = 0x3cf2
<Date><Time>, SYSPRP ActionPlatform::ExecuteActionList Fehler: Fehler beim führen Aktionen; DwRet = 0x3cf2
<Date><Time>, SYSPRP SysprepSession::Execute Fehler: Fehler beim Ausführen von Aktionen aus C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml, DwRet = 0x3cf2
<Date><Time>, SYSPRP RunPlatformActions Fehler: Fehler beim Ausführen von Aktionen SysprepSession; DwRet = 0x3cf2
<Date><Time>, Fehler [0x0f0070] SYSPRP RunExternalDlls: Fehler beim Ausführen Registrierung von Sysprep DLLs anhalten Sysprep ausführen. DwRet = 0x3cf2
<Date><Time>, Fehler [0x0f00a8] SYSPRP WinMain:Hit Fehler während der Verarbeitung Sysprep generalize interne Anbieter; hr = 0x80073cf2</Time></Date></Time></Date></Time></Date></Time></Date></Time></Date></Time></Date></Time></Date></Time></Date></Time></Date></PackageFullName></Time></Date>
Ursache
Sysprep ist einen zusätzlichen Windows 10 und Windows 8 Pakete Appx reinigen und das Abbild verallgemeinern hinzugefügten Anbieter. Der Anbieter kann nur bei CA-Paket eine pro Benutzer oder ein Paket alle Benutzer bereitgestellt wird.
  • Pro-Benutzer-Paket bedeutet, dass die Anlage für ein bestimmtes Benutzerkonto installiert und nicht für andere Benutzer des Computers verfügbar ist.
  • Alle Benutzer-Paket bedeutet, dass die Anlage in das Abbild bereitgestellt wurde, damit alle Benutzer dieses Abbild die Anwendung zugreifen können.

Wenn eine Paket alle Benutzer, die in das Abbild bereitgestellt wurde manuell aus dem Bild hat, aber nicht für einen bestimmten Benutzer entfernt, wird der Anbieter einen Fehler beim Entfernen dieses Pakets Sysprep. Der Anbieter schlägt auch fehl, wenn eine Paket alle Benutzer, die in das Abbild bereitgestellt von einem Benutzer auf dem Referenzcomputer aktualisiert wurde.
Lösung
Um dieses Problem zu beheben, entfernen Sie das Paket für Benutzer Sysprep ausgeführt wird und auch entfernen Sie die Bereitstellung. Gehen Sie hierzu folgendermaßen vor:

Hinweis Um zu verhindern, dass Windows Store apps aktualisieren, trennen Sie die Verbindung mit dem Internet oder deaktivieren Sie automatische Updates im Überwachungsmodus, bevor Sie das Abbild erstellen.
  1. Führen Sie das PowerShell-Cmdlet Import-Module Appx aus.
  2. Führen Sie Import-Module Dism aus.
  3. Führen Sie Get-AppxPackage - AllUser | Wo PublisherId - Eq 8wekyb3d8bbwe | Format-List-Eigenschaft PackageFullName, PackageUserInformation.

    Hinweise
    • Überprüfen Sie in der Ausgabe dieses letzten Cmdlet die Benutzer, für die das Paket als installiertangezeigt wird. Mit Benutzerkonten löschen Sie diese Benutzerkonten vom Referenzcomputer oder am Computer anmelden. Führen Sie das Cmdlet in Schritt 4 das CA-Paket zu entfernen.
    • Dieser Befehl listet alle Pakete, die von Microsoft veröffentlicht und von jedem Benutzer des Referenzcomputers installiert wurden. Ist der Computer Sysprep werden, wird angenommen, dass dieser Benutzerprofile das Paket nicht mehr benötigen.
    • Apps manuell bereitgestellt haben, die zu anderen Herausgeber gehören führen Sie den folgenden Befehl werden aufgelistet:

      Get-AppxPackage -AllUser | Format-List -Property PackageFullName,PackageUserInformation
  4. Führen Sie Entfernen AppxPackage-Paket <packagefullname> </packagefullname> .
  5. Entfernen Sie die Bereitstellung durch das folgende Cmdlet ausführen:

    Entfernen AppxProvisionedPackage-Online - Paketname<packagefullname></packagefullname>
Wenn Sie versuchen, ein Updateproblem zu beheben, kann die app Basis, nachdem Sie diese Schritte.

Hinweis Das Problem tritt nicht auf, wenn Sie einem Offlineabbild warten. In diesem Szenario wird die Bereitstellung automatisch für alle Benutzer deaktiviert. Dabei wird der Benutzer, der den Befehl ausführt.
Weitere Informationen
Weitere Informationen zum Hinzufügen und Entfernen von apps finden Sie auf der folgenden TechNet-Ressourcen:

Weitere Informationen zu Cmdlets Appx:

Weitere Informationen zu Dism Appx warten Cmdlets:


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Eigenschaften

Artikelnummer: 2769827 – Letzte Überarbeitung: 07/03/2016 09:10:00 – Revision: 6.0

Windows 8, Windows 8 Enterprise, Windows 8 Pro, Windows 10

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