Sie sind zurzeit offline. Es wird auf die erneute Herstellung einer Internetverbindung gewartet.

Excel-Funktion "Text zu Sprache" für ein anderes Office-Programm automatisieren

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
287120 How to automate Excel Text to Speech in another Office program
Zusammenfassung
Dieser Artikel erläutert Schritt für Schritt, wie Sie die Microsoft Excel-Funktion "Text zu Sprache" in anderen Programmen verwenden können, einschließlich Microsoft Word, Microsoft PowerPoint und Microsoft Outlook.

Microsoft Excel ist das einzige Microsoft Office XP-Programm mit integrierter "Text-zu-Sprache"-Funktion (Text to Speech, TTS). In diesem Artikel wird erklärt, wie Sie die OLE-Automatisierung nutzen können, um programmatisch auf das Excel-Objektmodell zuzugreifen und so die Funktion "Text zu Sprache" auch in anderen Programmen einzusetzen.

Die Verwendung der hier aufgeführten Informationen, Makro- oder Programmcodes geschieht auf Ihre eigene Verantwortung. Microsoft stellt Ihnen diese Informationen sowie Makro- und Programmlistings ohne Gewähr auf Richtigkeit, Vollständigkeit und/oder Funktionalität sowie ohne Anspruch auf Support zur Verfügung. In diesem Artikel wird vorausgesetzt, dass Sie mit der in den Beispielen verwendeten Programmiersprache und mit den zum Erstellen und Debuggen von Prozeduren verwendeten Tools vertraut sind. Die Spezialisten von Microsoft Support Services können bei der Erläuterung der Funktionalität bestimmter Prozeduren helfen, jedoch werden sie diese Beispiele nicht in Bezug auf eine erweiterte Funktionalität verändern, noch werden sie Prozeduren entwickeln, die auf Ihre besonderen Bedürfnisse zugeschnitten sind.

Zurück zum Anfang

Verwendung von "Text zu Sprache" in PowerPoint

In dem folgenden Beispiel wird das Excel-Objektmodell verwendet, um aus einer PowerPoint-Präsentation auf die Funktion "Text zu Sprache" zuzugreifen. Das folgende Verfahren veranschaulicht, wie Sie ein Excel-Objekt referenzieren und erstellen können, um das Objekt Speech zu nutzen.

Zurück zum Anfang

Einfügen eines Moduls in eine PowerPoint-Präsentation

  1. Öffnen Sie eine PowerPoint-Präsentation.
  2. Drücken Sie die Tastenkombination [ALT]+[F11], um den Visual Basic-Editor zu starten.
  3. Klicken Sie im Menü Einfügen auf Modul.
  4. Geben Sie den nachstehenden Beispielcode in das Modul ein oder kopieren Sie ihn in das Modul.
Zurück zum Anfang

Hinzufügen eines Verweises zur Excel 10.0-Objektbibliothek

  1. Zeigen Sie im Visual Basic-Editor im Menü Extras auf Verweise.
  2. Aktivieren Sie unter Verfügbare Verweise das Kontrollkästchen Microsoft Excel 10.0-Objektbibliothek, und klicken Sie danach auf OK.
Zurück zum Anfang

Subprozedur zum Automatisieren der Excel-Funktion "Text zu Sprache" für die Nutzung aus PowerPoint

Bei dem folgenden Beispiel wird vorausgesetzt, dass Ihre PowerPoint-Präsentation zwei Folien beinhaltet.
Sub demoTTS()        'Declare and create an Excel object.    Dim XL As Excel.Application    Set XL = CreateObject("Excel.Application")        ActivePresentation.SlideShowSettings.Run     With SlideShowWindows(1).View        'The following is said on the first slide:        XL.Speech.Speak "Welcome to my presentation."        'Change to slide 2, and then say the following two sentences:        .Next        XL.Speech.Speak "This is an example of how to create an Excel Application object."        XL.Speech.Speak "We can use Excel's object model to invoke Text to Speech."                'Close the Excel object and set the object to nothing.        XL.Quit        Set XL = Nothing                'Exit the slideshow.        .Exit    End With    End Sub				
Hinweis: In PowerPoint ist die Sicherheit standardmäßig auf hoch gesetzt. Nicht signierte Visual Basic-Makros können bei dieser Einstellung nicht ausgeführt werden. Gehen Sie folgendermaßen vor, um die Makrosicherheitsstufe auf mittel zu setzen:
  1. Zeigen Sie im Menü Extras auf Makro, und klicken Sie anschließend auf Sicherheit.
  2. Aktivieren Sie auf der Registerkarte Sicherheitsstufe die Option Mittel, und klicken Sie danach auf OK.
  3. Klicken Sie im Menü Datei auf Beenden, um PowerPoint zu beenden.

    Hinweis: Damit die Änderung der Sicherheitsstufe wirksam wird, müssen Sie PowerPoint beenden und anschließend neu starten.
Zurück zum Anfang

Verwendung von "Text zu Sprache" in Word

In dem folgenden Beispiel wird das Excel-Objektmodell verwendet, um aus einem Word-Dokument auf die Funktion "Text zu Sprache" zuzugreifen. Das folgende Verfahren veranschaulicht, wie Sie ein Excel-Objekt referenzieren und erstellen können, um das Objekt Speech zu nutzen.

Zurück zum Anfang

Einfügen eines Moduls in Word

  1. Öffnen Sie ein Word-Dokument.
  2. Drücken Sie die Tastenkombination [ALT]+[F11], um den Visual Basic-Editor zu starten.
  3. Klicken Sie im Menü Einfügen auf Modul.
  4. Geben Sie den nachstehenden Beispielcode in das Modul ein oder kopieren Sie ihn in das Modul.
Zurück zum Anfang

Hinzufügen eines Verweises zur Excel 10.0-Objektbibliothek

  1. Zeigen Sie im Visual Basic-Editor im Menü Extras auf Verweise.
  2. Aktivieren Sie unter Verfügbare Verweise das Kontrollkästchen Microsoft Excel 10.0-Objektbibliothek, und klicken Sie danach auf OK.
Zurück zum Anfang

Subprozedur zum Automatisieren der Excel-Funktion "Text zu Sprache" für die Nutzung aus Word

In dem folgenden Beispiel wird vorausgesetzt, dass Sie Text in Ihr Word-Dokument eingeben und anschließend den Text markieren, bevor Sie die Subprozedur ausführen.
Sub TTS()   'Declare and create an Excel object.      Dim XL_tts As Excel.Application      Set XL_tts = CreateObject("Excel.Application")      XL_tts.Speech.Speak Selection      XL_tts.Quit      Set XL_tts = NothingEnd Sub				
Hinweis: In Word ist die Sicherheit standardmäßig auf hoch gesetzt. Nicht signierte Visual Basic-Makros können bei dieser Einstellung nicht ausgeführt werden. Gehen Sie folgendermaßen vor, um die Makrosicherheitsstufe auf mittel zu setzen:
  1. Zeigen Sie im Menü Extras auf Makro, und klicken Sie anschließend auf Sicherheit.
  2. Aktivieren Sie auf der Registerkarte Sicherheitsstufe die Option Mittel, und klicken Sie danach auf OK.
  3. Klicken Sie im Menü Datei auf Beenden, um Word zu beenden.
Hinweis: Damit die Änderung der Sicherheitsstufe wirksam wird, müssen Sie Word beenden und anschließend neu starten.

Zurück zum Anfang

Informationsquellen

Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
277808 "XL2002: Laufzeitfehler 1004 Sie versuchen, wann Text zu Sprache in Makro zu verwenden"
Weitere Informationen dazu, wie Sie Hilfe zu Visual Basic für Applikationen erhalten können, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
163435 Ressourcen mit Visual Basic für Applikationen für Programmierung
Zurück zum Anfang
OfficeKBHowTo inf
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Eigenschaften

Artikelnummer: 287120 – Letzte Überarbeitung: 02/08/2008 18:30:00 – Revision: 3.1

  • Microsoft Excel 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • kbhowtomaster kbautomation kbenablesight KB287120
Feedback