Sie sind zurzeit offline. Es wird auf die erneute Herstellung einer Internetverbindung gewartet.

Erstellen einer persönlichen Makro-Arbeitsmappe in Excel für Mac

Dieser Artikel wurde zuvor veröffentlicht unter D288117
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
288117 How to create a Personal Macro Workbook in Excel for Mac
Zusammenfassung
Dieser Artikel beschreibt, wie Sie eine persönliche Makro-Arbeitsmappe erstellen können, in der Sie VBA-Makros (Microsoft Visual Basic für Appliationen), die Sie nicht aufzeichnen können, programmieren und bearbeiten können.
Weitere Informationen

Erstellen einer persönlichen Makro-Arbeitsmappe

Am einfachsten können Sie eine persönliche Makro-Arbeitsmappe erstellen, indem Sie ein "Dummy"-Makro erstellen. Gehen Sie hierzu folgendermaßen vor:
  1. Starten Sie Excel, sodass nur eine neue Arbeitsmappe geöffnet ist. Klicken Sie im Menü Extras auf Makro und dann auf Aufzeichnen.
  2. Klicken Sie im Dialogfenster Makro aufzeichnen in der Liste Makro speichern in auf Persönliche Makro-Arbeitsmappe.
  3. Klicken Sie auf OK. Klicken Sie auf nichts und geben Sie nichts ein, denn Sie erstellen nur ein "Dummy"-Makro.
  4. Klicken Sie in der Menüleiste, die erscheint, auf die Schaltfläche Aufzeichnung beenden.
  5. Klicken Sie im Menü Excel auf Beenden. In Excel-Versionen vor Excel X klicken Sie im Menü Datei auf Beenden
  6. Klicken Sie auf Speichern, wenn Sie dazu aufgefordert werden, Ihre Änderungen zu speichern.
Beim Starten von Excel wird diese persönliche Makro-Arbeitsmappe als versteckte Arbeitsmappe geöffnet. Standardmäßig befindet sie sich an folgendem Speicherort, abhängig von Ihrer Version von Excel:

In Excel 98 und in Excel 2001
Microsoft Office-Ordner:Office:Startup:Excel:Personal Macro Workbook
In Excel X oder höheren Versionen
Festplattenlaufwerk:Applications:Microsoft Office version:Office:Startup:Excel:Personal Macro Workbook

Verwenden der persönlichen Makro-Arbeitsmappe

Gehen Sie folgendermaßen vor, um in der persönlichen Makro-Arbeitsmappe VBA-Code zu erstellen oder zu bearbeiten:
  1. Zeigen Sie im Menü Extras auf Makro, und klicken Sie auf Visual Basic-Editor.
  2. Klicken Sie im Fenster "Projekt - VBA-Projekt" VBAProjekt (Persönliche Makro-Arbeitsmappe) doppelt, um den inneren Ordner Module anzuzeigen.
  3. Klicken sie den Ordner Module doppelt, um die Module in diesem Projekt anzuzeigen, und klicken Sie ein Modul doppelt, um seinen Code oder sein leeres Codefenster anzuzeigen.

    Sie können dieses Codefenster verwenden, um VBA-Code zu erstellen oder zu bearbeiten.
MacXLX MAC XL98 XL2001 XL2004 program VBA code start record personal macro automation automate edit
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Eigenschaften

Artikelnummer: 288117 – Letzte Überarbeitung: 10/11/2006 23:42:43 – Revision: 3.2

  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X für Macintosh
  • Microsoft Excel 2001 für Mac
  • Microsoft Excel 98 für Macintosh
  • kbdtacode kbhowto KB288117
Feedback