Was tun, wenn Word für Mac einen Makrovirus öffnet

Wichtig: Dieser Artikel wurde maschinell übersetzt und wird dann möglicherweise mithilfe des Community Translation Framework (CTF) von Mitgliedern unserer Microsoft Community nachbearbeitet. Weitere Informationen zu CTF finden Sie unter http://support.microsoft.com/gp/machine-translation-corrections/de.

Den englischen Originalartikel können Sie über folgenden Link abrufen: 291824
Zusammenfassung
Dieser Artikel beschreibt, was Viren sind, was tun, wenn Sie glauben, dass Ihr Computer einen Word-Makrovirus möglicherweise und wie Sie sicherstellen können, dass Ihre Dokumente nicht mit einem Makrovirus infiziert werden.
Weitere Informationen
Der erste Makrovirus entdeckt wurde im Sommer 1995. Seit dieser Zeit wurden andere Makroviren.

Ein Makrovirus ist ein bösartiges Programm, das mithilfe der Makrosprache von einem Programm wie Word geschrieben wird. Der Virus verbreitet sich unter Datendateien und Ihre Dateien oder das Betriebssystem Ihres Computers beschädigen kann.

Word-Makroviren sind nicht frei über das Internet oder ein anderes Medium übertragen; Sie können nur übertragen werden, beim Öffnen eines Dokuments oder einer Vorlage, die den Makrovirus enthält.

Makroviren können per E-mail übertragen werden, es sei denn, ein betroffenes Dokument in der e-Mail-Nachricht eingebettet ist, und der Empfänger das Dokument öffnet.

Symptome eines Makrovirus

Im folgenden werden einige Symptome von Word-Makroviren, die Auswirkungen auf Word und Word Dokumente:
  • Wenn Sie versuchen, ein Dokument zu speichern, kann Word nur Sie das Dokument als Vorlage zu speichern.

    – oder –
  • Das Symbol der Datei sieht aus wie eine Vorlage statt eines Dokuments.

    – oder –
  • Wenn Sie ein Dokument öffnen, wird ein Dialogfeld mit der Zahl 1 angezeigt.

    – oder –
  • Makro- und Anpassen -Befehle werden nicht mehr im Menü Extras angezeigt.

    – oder –
  • Neue Makros werden in der Liste der Makros angezeigt. Außerdem können Makros AutoOpen und FileSaveAs angezeigt werden; Wenn Sie Makros mit diesen Namen bereits haben, kann deren Inhalt von den Makrovirus geändert werden.

    – oder –
  • Ungewöhnliche oder unerwartete Meldungen werden angezeigt, wenn Sie ein Word-Dokument oder eine Vorlage öffnen.
Hinweise
  • Word nicht nach Makroviren suchen oder Entfernen etwaiger Makroviren aus vorhandenen Dokumenten und Vorlagen. Es warnt Sie nur, wenn das Dokument, das Sie öffnen möchten, Makros enthält. Anschließend öffnen Sie das Dokument mit den aktiven Makros oder mit dem deaktivierten Makros zu öffnen. Mit den Makros aktiv ist, sollten Sie kein Dokument öffnen, es sei denn, Sie absolut sicher sind, dass das Dokument keine schädigenden Makroviren enthält.
  • Antivirenprogramme von Drittanbietern müssen häufig aktualisiert werden, um wirksam zu bleiben. Wenden Sie sich an den Kreditor Update-Informationen.

Installieren Sie ein Antiviren-Programm

Installieren Sie für eine langfristige Lösung für Makroviren antivirus-Software, die speziell auf Makroviren zu erkennen. Weitere Informationen zu Antivirussoftware-Herstellern, einschließlich der Software erkennen und verhindern von Makroviren klicken Sie auf die folgende Artikelnummer, um den Artikel der Microsoft Knowledge Base anzuzeigen:
49500 Liste von Antivirussoftware-Herstellern
Microsoft stellt Kontaktinformationen von Drittanbietern zur Verfügung, damit Sie technischen Support erhalten können. Diese Kontaktinformationen können ohne vorherige Ankündigung ändern. Microsoft garantiert nicht die Richtigkeit dieser Kontaktinformationen von Drittanbietern.

Was tun, wenn Sie glauben, dass Ihr Computer möglicherweise einen Makrovirus

Verwenden Sie die folgenden Methoden wie provisorische Lösungen nur, wenn Sie glauben, dass Ihr Computer einen Makrovirus haben könnte.

Methode 1: Deaktivieren Sie Sie, und kopieren Sie den Text in ein neues Dokument

Wenn Sie treten nicht auf, die weiter oben in diesem Artikel beschriebenen Symptome, aber nicht von einem Makrovirus betroffen sein möchten, halten Sie die UMSCHALTTASTE gedrückt, wenn Sie eine Datei öffnen, die möglicherweise von einem Makrovirus infiziert ist. Durch Drücken der UMSCHALTTASTE wird verhindert, dass Word automatische Makros nicht ausgeführt; Wenn ein Makrovirus vorhanden ist, wird es nicht geladen.

Methode 2: Löschen Sie das Makro und Wiederherstellen das Dokument

Wenn die weiter oben in diesem Artikel beschriebenen Symptome auftreten, oder wenn Sie vermuten, dass Sie über einen Makrovirus verfügen, der nicht in diesem Artikel beschrieben wird, gehen Sie folgendermaßen löschen verdächtige Makro und betroffenes Dokument korrigieren.

Hinweis Dies ist nur eine temporäre Lösung. Da neue Makros erstellt werden, können diese Schritte nicht auf neue Makros funktionieren.
  1. Im Menü klicken Sie auf Word, und klicken Sie auf Beenden. Verschieben Sie die normale Datei auf Desktop. Zu diesem Zweck
    1. Beenden Sie alle Microsoft-Programme.
    2. Klicken Sie im Finder aufgehenWählen SieHome.
    3. Öffnen Sie den OrdnerBibliothek.
    4. Ordner "Application Support" zu öffnen.
    5. Öffnen Sie denOrdner Microsoft.
    6. Öffnen Sie denOffice-Ordner.
    7. Öffnen Sie den Ordner fürBenutzervorlagen.
    8. Normale Datei mit der rechten Maustaste. Klicken Sie auf Bearbeiten und wählen Sie dann "Normal.dotm" kopieren.

  2. Öffnen Sie Word. Klicken Sie im Menü Datei auf Öffnen.
  3. Navigieren Sie zu dem Ordner, der die betreffende Datei enthält.
  4. Klicken Sie auf die betroffene Datei. Drücken Sie sofort und halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie dann aufÖffnen. Weiterhin die UMSCHALTTASTE gedrückt, bis die betroffene Datei in Word geöffnet ist.

    Hinweis Halten Sie die UMSCHALTTASTE beim Öffnen einer Datei verhindert, dass alle Word-Auto-Makros ausgeführt.
  5. Gehen Sie folgendermaßen vor, um eine verdächtige Makro zu löschen:
    1. Klicken Sie im Menü Extras auf Makro, und klicken Sie auf Makros.
    2. Wählen Sie im klicken Sie im Popupmenü Makros Inallen aktiven Vorlagen und Dokumenten.
    3. Wählen Sie verdächtige Makro, und klicken Sie dann auf Löschen. Klicken Sie auf Ja, Wenn Sie gefragt werden, ob Sie das Makro löschen möchten.
    4. Wiederholen Sie Schritt c für alle verdächtigen Makros.
    5. Klicken Sie auf Abbrechen , um das Makro -Dialogfeld schließen.
  6. Um den Text der ein infiziertes Dokument wiederherzustellen, gehen Sie folgendermaßen vor:
    1. Wählen Sie das gesamte Dokument durch Drücken von Befehl + A oder im Menü Bearbeiten auf Alles markieren .
    2. Löschen der letzten Absatzmarke des Dokuments aus der Auswahl durch Drücken von UMSCHALT + nach-links-Pfeil.
    3. Klicken Sie im Menü Bearbeiten auf Kopieren.
    4. Klicken Sie im Menü Datei auf neu. Wählen Sie die Vorlage, die Sie verwenden möchten, und klicken Sie dann auf OK.
    5. Klicken Sie im Menü Bearbeiten auf Einfügen.
    6. Wiederholen Sie Schritt 7, um sicherzustellen, dass das Makro-Virus, enthält nicht repliziert wurde.
    7. Speichern Sie das Dokument.
  7. Wiederholen Sie diese Schritte für jedes Dokument, das Sie vermuten einen Makrovirus enthalten kann.
Hinweis Wenn Sie Methode 2 nicht funktioniert, versuchen Sie Methode 3.

Methode 3: Verwenden der Organisator vorübergehend einen Makrovirus bereinigen

Mit dem Dialogfeld Organisieren um der Makrovirus zu bereinigen. Denken Sie daran, wenn Sie andere Dateien öffnen, nachdem Sie die infizierte Datei zu öffnen, diese Dateien höchstwahrscheinlich auch infiziert sind.

Gehen Sie folgendermaßen vor, um den Virus aus der Dokumentvorlage Normal.dot zu entfernen:
  1. Schließen Sie alle Dokumente. Wenn ein infiziertes Dokument geöffnet ist, kann die Dokumentvorlage einfach erneut infizieren.
  2. Klicken Sie auf Vorlagen und Add-Insim Menü Extras , und klicken Sie dann auf die Schaltfläche " Organisieren ".
  3. Klicken Sie auf die Registerkarte Makroprojektelemente umbenennen Sie und löschen Sie alle der folgenden Makros:
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • DateiBeenden
    • FileNew
    • FileOpen
    • (Save As)
    • FileSaveAs
    • Makros
    • ToolsMacro
  4. Klicken Sie auf Schließen.
  5. Drücken Sie und halten Sie UMSCHALT, während Sie die Vorlage speichern im Menü DateiAlles speichern klicken.
So entfernen einen Makrovirus aus ein infiziertes Dokument:

Wenn eine Datei infiziert ist, verwenden Sie dieselbe Methode wie in den Schritten 1 bis 5, aber entfernen Sie die Makros von sowohl der Dokumentvorlage und das infizierte Dokument (Vorlage), klicken Sie im Organizer zu. Wenn Sie fertig sind, drücken Sie und bei gedrückter Umschalttaste Klicken Sie im Menü Datei auf Alle speichern , und klicken Sie dann mit der nächsten Datei verschieben. Denken Sie daran, dass jedes Mal, wenn Sie eine infizierte Datei öffnen, die Dokumentvorlage Normal, es infiziert wiederholt die Makros in der Dokumentvorlage Normal.dot müssen entfernt.

Methode 4: Fügen Sie die infizierte Datei in ein neues Dokument

Diese Methode ist besonders mit dem Makrovirus "CAP", der im Menü ExtrasMakro und Anpassen entfernt.

Hinweis In diesem Fall funktionieren Vorlagen und Add-Ins im Menü Extras nicht.
  1. Im Menü klicken Sie auf Word, und klicken Sie auf Beenden. Verschieben Sie die Dokumentvorlage Normal auf den Desktop. Zu diesem Zweck
    1. Beenden Sie alle Microsoft-Programme.
    2. Klicken Sie im Finder aufgehenWählen SieHome.
    3. Öffnen Sie den OrdnerBibliothek.
    4. Ordner "Application Support" zu öffnen.
    5. Öffnen Sie denOrdner Microsoft.
    6. Öffnen Sie denOffice-Ordner.
    7. Öffnen Sie den Ordner fürBenutzervorlagen.
    8. Recht-ClickNormal-Datei. Klicken Sie auf Bearbeiten und wählen Sie dann "Normal.dotm" kopieren.

  2. Öffnen Sie Word, und vergewissern Sie sich, dass Makros und anpassen im Menü Extras angezeigt.
  3. Öffnen Sie ein neues Dokument. Klicken Sie im Menü Einfügen auf Datei.
  4. Navigieren Sie zu dem Ordner, der die betroffene Datei.
  5. Klicken Sie auf die betroffene Datei.
  6. Drücken Sie und halten Sie die UMSCHALTTASTE gedrückt, und klicken Sie auf Öffnen. Weiterhin die UMSCHALTTASTE gedrückt halten, bis die betroffene Datei in Word geöffnet ist.
    Hinweis Halten Sie die UMSCHALTTASTE beim Öffnen einer Datei verhindert, dass Word Auto-Makros ausgeführt.
  7. Überprüfen, ob die Makros vorhanden sind, in das neue Dokument (keine aufgelistet werden soll), zeigen Sie im Menü Extras auf Makro , und klicken Sie dann auf Makros. Die Makros In Popup-Liste klicken Sie auf alle aktiven Dokumentvorlagen und Dokumenten. Klicken Sie unter Makronamesollte keine Makros aufgeführt werden. Klicken Sie auf Abbrechen.
  8. Speichern Sie die Datei unter einem anderen Namen.
  9. Löschen Sie die infizierte Datei.

Methode 5: Verwenden Sie die RTF-Problemumgehung

A. löschen Sie A. die Datei Normal (globale Vorlage).

Dies ist ein Problem mit einem Makro in der Dokumentvorlage Normal gespeichert werden.

Die folgenden Schritte entfernen die Dokumentvorlage Normal. Beachten Sie, dass besondere Formatierung Gruppe in der Dokumentvorlage Normal.dot entfernt werden, und die Vorlage wird auf die Standardeinstellungen zurückgesetzt.
  1. Beenden Sie alle Microsoft-Programme.
  2. Klicken Sie im Finder aufgehenWählen SieHome.
  3. Öffnen Sie den OrdnerBibliothek.
  4. Ordner "Application Support " zu öffnen.
  5. Öffnen Sie denOrdner Microsoft.
  6. Öffnen Sie denOffice-Ordner.
  7. Öffnen Sie den Ordner fürBenutzervorlagen.
  8. Suchen Sie die Datei mit dem NamenNormal.Klicken Sie auf Datei , und klicken Sie auf in den Papierkorb verschieben.

B. deaktivieren Sie B. Sie.

Öffnen Sie die Virusdateien, und dann deaktivieren Sie für jede Datei die Makros, wie Sie die Makrowarnung angezeigt werden. Wenn Sie eine Warnung erhalten, müssen Sie Makrowarnungen zu aktivieren. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf das MenüWord Einstellungen.
  2. Klicken Sie im Navigationsbereich klicken Sie auf Sicherheit, und wählen Sie dann das KontrollkästchenWarnung anzeigen, bevor das Öffnen einer Datei, die Makros enthält .

C. speichern Sie C. die vorhandenen Dateien.

  1. Klicken Sie aufSpeichern unterim MenüDatei.
  2. Klicken Sie in der Liste Format auf Rich Text Format (RTF).
  3. Klicken Sie auf Speichern.

Nachdem Sie die Datei als RTF-Datei gespeichert haben, speichern Sie das Dokument erneut in Word (DOC)-Format Überschreiben der Datei mit den Makrovirus oder speichern Sie das Dokument unter einem neuen Dateinamen und löschen Sie die alte Datei mit dem Virus. Nachdem Sie die neue Datei im DOC-Format speichern, können Sie die RTF-Datei löschen. Denken Sie daran, dass möglicherweise einige Formatierungselemente beim Übergang von Word (DOC) Format in RTF nicht beibehalten werden.


Mac Macword Vorlage wie Fehlermeldung unbekannte Makros Visual Basic Recover Organizer Bereinigen infizierter Werkzeugsymbol falsch anpassen nicht korrekt speichern CAP öffnen neue Autoexec ausführen Boot Start alert VBA-Editor starten, haben Sie einen Makro-Virus OFF2004 WD2004

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 291824 – Letzte Überarbeitung: 01/03/2015 01:05:00 – Revision: 4.0

Microsoft Word 2011 for Mac, Microsoft Word 2004 for Mac

  • dftsdahomeportal kbinfo kbmt KB291824 KbMtde
Feedback