Sie können nicht große Anlagen mithilfe EWS-Client senden

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Den englischen Originalartikel können Sie über folgenden Link abrufen: 3107326
Problembeschreibung
Betrachten Sie das folgende Szenario:
  • Ein Benutzer verbindet ihr Postfach mit einem Exchange-Webdienste (EWS)-Client.
  • Das Postfach des Benutzers befindet sich auf Standort b
  • Die Verbindung erfolgt mit einem Microsoft Exchange Server von Standort a
  • Exchange-Server an Standort A Proxys die Anforderung an einen Exchange-Server an Standort B.

In diesem Szenario kann nicht der Benutzer eine e-Mail senden, die große Anlagen enthält. Bei Verwendung von Outlook für Macintosh-Client die Nachricht in den Ordner Entwürfe verschoben und gibt folgenden Fehler zurück:

An unknown error has occurred. Connection to the server failed or was dropped. Outlook cannot send the message, because the message size exceed the maximum limit set on the server


EWS protokolliert Site eine einen HTTP 500-Status mit einem allgemeinen Fehler, der der folgenden ähnelt:

ReportException_Message=Exchange Web Services are not currently available for this request because none of the Client Access Servers in the destination site could process the request.;ReportException_StackTrace= at Microsoft.Exchange.Services.Wcf.EWSService.GetServiceAsyncResult[TSoapResponseBody](IAsyncResult result) at Microsoft.Exchange.Services.Wcf.EWSService.CreateSoapResponse[TSoapResponse;TSoapResponseBody](IAsyncResult result; Func`2 createSoapResponseCallback) at AsyncInvokeEndEndCreateItem(Object ; Object[] ; IAsyncResult ) at System.ServiceModel.Dispatcher.AsyncMethodInvoker.InvokeEnd(Object instance; Object[]& outputs; IAsyncResult result) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeEnd(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage7(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet);

EWS-Protokolle für Standort B zeigen einen HTTP 500-Status mit eine allgemeine Fehlermeldung, die der folgenden ähnelt:

ReportException_Message=The remote host closed the connection. The error code is 0x80070057.;ReportException_StackTrace= at System.ServiceModel.Channels.HttpOutput.HostedRequestHttpOutput.HostedResponseOutputStream.CheckWrapThrow(Exception e) at System.ServiceModel.Channels.HttpOutput.HostedRequestHttpOutput.HostedResponseOutputStream.Write(Byte[] buffer; Int32 offset; Int32 count) at System.IO.BufferedStream.FlushWrite() at System.IO.BufferedStream.Flush() at System.Xml.XmlStreamNodeWriter.Flush() at Microsoft.Exchange.Services.Wcf.SoapWcfResponseRenderer.Render(Message message; Stream stream) at Microsoft.Exchange.Services.Wcf.MessageEncoderWithXmlDeclaration.WriteMessage(Message message; Stream stream) at System.ServiceModel.Channels.HttpOutput.WriteStreamedMessage(TimeSpan timeout) at System.ServiceModel.Channels.HttpOutput.Send(TimeSpan timeout) at System.ServiceModel.Channels.HttpRequestContext.OnReply(Message message; TimeSpan timeout) at System.ServiceModel.Channels.RequestContextBase.Reply(Message message; TimeSpan timeout) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.Reply(MessageRpc& rpc);

Ursache
Die Verbindung zwischen Exchange-Servern auf beiden Seiten für diese Anforderung ist Droppedbecause eine ProxyTimeout Einstellung.


Lösung
Um dieses Problem zu beheben, erhöhen Sie den ProxyTimeout -Wert auf dem Clientzugriffsserver durch Bearbeiten der Datei web.config für EWS. Gehen Sie hierzu folgendermaßen vor:

  1. Suchen Sie die Datei web.config, und öffnen Sie die Datei in Editor oder einem anderen Textbearbeitungsprogramm. Der Standardpfad lautet%ExchangeInstallPath%\ClientAccess\exchweb\ews.
  2. In der Datei einen Bildlauf zu der folgenden Anweisung:<AppSettings></AppSettings>
  3. Fügen Sie die folgende Zeile im Abschnitt <AppSettings>den Timeoutwert erhöhen:
    </AppSettings>
    <add key="ProxyTimeout" value="120000" />
  4. Starten Sie den Anwendungspool MSExchangeServicesAppPool.

Hinweis Der Standardwert für ProxyTimeoutist 59000.This Wert schrittweise erhöht werden soll, bis das Problem behoben ist. Beispielsweise durch Erhöhung des Timeouts 120000 beginnen. Wenn das Problem weiterhin auftritt, erhöhen Sie den Wert auf 210000.
Weitere Informationen
Weitere Informationen finden Sie unter Starten oder Beenden eines Anwendungspools.
EWS Outlook für MAC großen Anlage, ProxyTimeout, Cross-Site-Proxy

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Vlastnosti

ID článku: 3107326 - Poslední kontrola: 12/11/2015 01:50:00 - Revize: 1.0

Microsoft Exchange Server 2010 Enterprise, Microsoft Exchange Server 2010 Standard, Microsoft Outlook 2016 for Mac, Microsoft Outlook 2011 for Mac

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