Sie sind zurzeit offline. Es wird auf die erneute Herstellung einer Internetverbindung gewartet.

Verweis in einer Access-Datenbank Behebung

Der Support für Office 2003 wurde eingestellt

Microsoft stellte am 8. April 2014 den Support für Office 2003 ein. Diese Änderung wirkt sich auf Ihre Softwareupdates und Sicherheitsoptionen aus. Erfahren Sie, was das für Sie bedeutet und wie Sie Ihren Schutz aufrechterhalten können.

Wichtig: Dieser Artikel wurde maschinell übersetzt und wird dann möglicherweise mithilfe des Community Translation Framework (CTF) von Mitgliedern unserer Microsoft Community nachbearbeitet. Weitere Informationen zu CTF finden Sie unter http://support.microsoft.com/gp/machine-translation-corrections/de.

Den englischen Originalartikel können Sie über folgenden Link abrufen: 310803
Zusammenfassung
Dieser Artikel beschreibt Probleme, die die Nutzung von Verweisen in einer Access-Datenbank.

Ungültige Zellbezüge ein allgemeines Verständnis wie Bibliotheken in einer Access-Datenbank verwiesen werden und was für eine Datenbank auf einem Zielcomputer installieren, ohne diese Verweise erforderlich ist. Dieser Artikel ist eine Zusammenfassung der folgenden Themen:
  • Verweise auf die Access-Datenbank anzeigen
  • Auflösen von Microsoft Visual Basic für Applicationsreferences in Access
  • Grundlegendes zu Referenz-Fehlermeldungen
  • Probleme der Verweis auf die developmentcomputer
  • Verteilen von Dateien
  • Aktualisieren der Liste
  • Verteilen von Dateien, die ActiveX-Steuerelemente
  • Registrieren einer Datei
Weitere Informationen

Anzeigen von Access Verweise

Anzeigen die aktuelle Datenbank verweist:
  1. Öffnen Sie die Datenbank.
  2. Drücken Sie ALT + F11, um Visual Basic-Editor zu starten.
  3. Klicken Sie im Menü Extras auf Verweise.

Auflösen von Verweisen in Access Visual Basic

Access lädt die relevante Datei (z. B. eine Typbibliothek, eine Objektbibliothek oder eine Steuerelementbibliothek) für jeden Verweis Angaben, die im Verweise angezeigt. Wenn Access die Datei finden kann, führt Access die folgenden Verfahren, um die Datei zu suchen:
  1. Access überprüft, ob die referenzierte Datei Iscurrently in den Speicher geladen.
  2. Wenn die Datei nicht im Speicher geladen ist, versucht Access, Überprüfen der Registrierungsschlüssel RefLibPaths existiert. Wenn der Schlüssel vorhanden ist, sucht Access eine Namedvalue mit dem gleichen Namen als Referenz. Wenn eine Übereinstimmung, Accessloads den Verweis vom Pfad vorliegt, dem der benannte Wert verweist.
  3. Access sucht nach der referenzierten Datei folgende Speicherorte in dieser Reihenfolge:
    1. Der Anwendungsordner (Speicherort der Datei Msaccess.exe).
    2. Aktuellen Ordner angezeigt, wenn Sie im Menü Datei auf Öffnen klicken.
    3. Der Ordner Windows oder Winnt, in dem die Betriebssystemdateien ausgeführt werden.
    4. Der Systemordner im Ordner Windows oder Winnt.
    5. Die Ordner in der PATH-Umgebungsvariablen, die direkt vom Betriebssystem zugegriffen werden.
  4. Wenn Access die Datei Erroroccurs einen Verweis gefunden.

Grundlegendes zu Referenz-Fehlermeldungen

Es gibt mehrere Fehlermeldungen, die sich beziehen auf eine fehlende Datei oder eine Datei mit einer anderen Version von der Version, die in der Datenbank verwendet wird. In den meisten Fällen der Microsoft Knowledge Base nach einem Artikel zu der speziellen Fehlermeldung suchen und Sie können den Fehler mithilfe der Schritte im Artikel beheben. In einigen Fällen stimmt eine Abhängigkeitsdatei nicht ordnungsgemäß mit der primären Datei überein.

Die folgende Liste beschreibt einige der Referenz-Fehlermeldungen, die auftreten können. Beachten Sie jedoch, dass die Liste nicht alle möglichen Verweis Fehlermeldungen.
  • "-Methode MethodName des ObjektsObjektname Fehler"

    Normalerweise Mayreceive Sie diese Fehlermeldung, wenn ein Problem mit der Programmierung Typelibrary beispielsweise eine ungültige Data Access Object (DAO) library(DLL) DLL-Datei. Sie können Microsoft Knowledge Base nach Artikeln Thatdescribe die verschiedenen Formen der Fehlermeldung suchen.
  • "Funktion ist nicht verfügbar inVerwendung Ausdruck"

    Thiserror Meldung erhalten, wenn ein mit der Programmierung Typbibliothek Problem oder wenn Thecode nicht ausdrücklich die richtige Bibliothek und die Datei Listedat in der Liste eine niedrigere Priorität als eine Datei mit Namen Samefunction – z. B. wenn DAO-Code mit der Bibliothek ActiveX Data Object(ADO) mit einer höheren Priorität als die DAO-Bibliothek erscheint. Sie können Alsoreceive diese Fehlermeldung, wenn ein Formular oder einen Bericht ein ActiveX-Steuerelement enthält.
  • "Projekt oder Bibliothek nicht gefunden werden"

    Sie können Receivethis-Fehlermeldung, wenn Access eine Datei in der Liste finden kann. Oftenthe Datei wird als fehlt im Dialogfeld Verweise gekennzeichnet. In einigen Fällen befindet sich die Datei auf die Entwicklung Computerbut nicht auf dem Zielcomputer. Weitere Informationen zu diesem Fehler finden Sie im Artikel der Microsoft Knowledge Base:
    208218 ACC2000: VBA-Funktionen in Datenbank mit fehlenden Referenzen unterbrechen
  • "Variable nicht definiert" oder "benutzerdefinierter Notdefined"

    Diese Fehlermeldung möglicherweise bei Verwendung des c-Datensicherheits-Assistent zum Sichern einer Datenbank, die Bibliotheken andererals verweist, der Bibliotheken, die standardmäßig enthalten sind. Beispielsweise sind Tolibraries Verweise, die nicht gesicherte Datenbank war nicht automatisch Createdin die gesicherte Datenbank.
  • "Laufzeitfehler 5" "Ungültiger Prozeduraufruf oder ungültiges Argument", "die Bibliothek, die dieses Symbol enthält keine verweist das CurrentProject-Objekt" oder "Bibliothek, die dieses Symbol enthält nicht referenziert wird Thecurrent Projekt, damit das Symbol nicht definiert ist"

    Sie können eine koordiniert Fehlermeldungen ist ein Verweis auf eine Datenbank, eine Typbibliothek, Oran-Objektbibliothek, die als Fehlendgekennzeichnet ist. Klicken Sie für Weitere Informationen auf die nachstehende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:
    231413 ACC2000: Fehlermeldungen, die einen fehlenden Verweis angeben
  • "Objekt ActiveX-Komponente kann nicht erstellt werden"

    Thiserror Meldung bedeutet nicht unbedingt, dass ein ActiveX-Steuerelement beteiligt ist. Beispielsweise ist eine mögliche Ursache, dass DAO eine ActiveX-Komponente ist ein Objekt nicht da DAO Automation Server gestartet werden kann. Häufig ist die DLLs, die referenzierte für die Anwendung Funktionalität nicht registriert oder nicht korrekt registriert.Weitere Informationen zu diesem Fehler finden Sie im Artikel der Microsoft Knowledge Base:
    244264 INFO: Fehlerbehandlung für Fehler 429 beim Automatisieren von Office-Programmen
    Obwohl dieser Artikel aus Sicht VisualBasic geschrieben wird, werden viele Ursachen für diesen Fehler behandelt.

Referenz-Probleme auf dem Entwicklungscomputer

Eine neue, leere Datenbank erstellen und Importieren von Objekten aus einer anderen Datenbank können Code oder ActiveX-Steuerelemente verweisen abhängig, die nicht in einer Datenbank enthaltenen Verweis Probleme erstellen. Die Standardverweise für Access 2000-Datenbanken sind:
  • Visual Basic for Applications
  • Microsoft Access 9.0-Objektbibliothek
  • OLE-Automatisierung
  • Microsoft ActiveX Data Objects (ADO) 2.1-Bibliothek
Die anderen Access 2000-Datenbank ist, sicher, dass die Verweise übereinstimmen. Ist die Quelle in einer früheren Version von Access wird DAO 3.5 oder frühere wahrscheinlich. Access 2000 bietet jedoch keine DAO 3.5 standardmäßig. Entfernen Sie den Verweis auf ADO 2.1-Bibliothek (falls vorhanden) und den Verweis auf die DAO 3.6-Objektbibliothek.

Wenn Sie die Datenbank aus einer früheren Version von Access konvertiert und die Datenbank einen Verweis auf die Datei "Utility.MDA enthält" können in den meisten Fällen Sie diesen Verweis entfernen, da die Funktionen dieser Verweis wird in die Standardverweise in Access 2000 enthalten sind. Wenn Verweise auf frühere Versionen von DAO vorhanden sind, können Sie diese Verweise denn DAO 3.6 können diese Funktionen auch entfernen.

Einen Verweis auf eine Objektbibliothek hinzufügen:
  1. Öffnen Sie die Datenbank.
  2. Drücken Sie ALT + F11, um Visual Basic-Editor zu starten.
  3. Klicken Sie im Menü Extras auf Verweise.
  4. Aktivieren Sie unter Verfügbare Verweisedas Kontrollkästchen neben den Namen der Bibliothek, und klicken Sie auf OK.
So entfernen Sie einen Verweis auf eine Bibliothek:
  1. Öffnen Sie die Datenbank.
  2. Drücken Sie ALT + F11, um Visual Basic-Editor zu starten.
  3. Klicken Sie im Menü Extras auf Verweise.
  4. Deaktivieren Sie unter Verfügbare Verweisedas Kontrollkästchen neben den Namen der Bibliothek, und klicken Sie auf OK.

Verteilen von Dateien

Es gibt zwei grundlegende Datei Verteilungsmethoden. Sie können die Datei vom Entwicklungscomputer auf den Zielcomputer oder können Paket- und Weitergabe-Assistenten zum Erstellen eines Setuppakets.

Wenn Sie die Datei vom Entwicklungscomputer auf den Zielcomputer kopieren, wird nur die Datenbankdatei kopiert. Sie müssen manuell sicherstellen, dass alle Dateien, die in der Liste aufgeführt sind, auf die richtige Version und die gleiche relative Position auf dem Zielcomputer auf dem Entwicklungscomputer vorhanden.

Wenn Sie Package and Deployment Wizard ein Setup-Paket erstellen, finden Sie in der Knowledge Base als Prüfliste dient für die Anwendungsentwicklung zur Laufzeit in Access. Weitere Informationen über die Prüfliste finden Sie der Microsoft Knowledge Base:
247530 MOD2000: Wie Sie häufige Fehler zu vermeiden, wenn verteilbare Laufzeit-Anwendung
Bei der Entwicklung von Laufzeit-Applikationen in Access werden Sie einige Dateien mit der Anwendung verteilt werden müssen. Die Verpackung dieser Dateien wird automatisch von der Paket- und Weitergabe-Assistent-Komponente von Microsoft Office 2000 Developer ausgeführt. Die Versionen der enthaltenen Dateien hängt manchmal andere Programme auf dem Entwicklungscomputer installiert sind und die möglicherweise die Betriebssystemdateien geändert.

Bestimmte Richtlinien wird normalerweise sichergestellt, dass die Versionen der Dateien, mit denen Sie mit Dateien auf dem Zielcomputer Konflikt bei der Installation der Anwendungdes. Hier sind die Richtlinien:
  1. Entwickeln Sie die Access-Datenbank auf einem Computer.
  2. Erstellen einer computerumgebung hat die Festplatte Beenreformatted und dem nur die früheste Version des entsprechenden Betriebssystems betrachtet, Office und Office 2000 Developer installiert ist. Führen Sie Packageand Deployment-Assistenten auf diesem Computer die Laufzeitversion des Anwendungsbetriebs erstellen aus. Dadurch Revisionsstufen Dateien Onany der Zielcomputer funktionieren.
  3. Erstellen einer computerumgebung hat die Festplatte Beenreformatted und dem nur das Betriebssystem installiert ist. Test Run-Timeapplication in dieser Umgebung.
    • Wenn die Anwendung nicht erfolgreich ausgeführt wird, wissen Sie, dass die Anwendung selbst fehlerhaft ist. Identifizieren und beheben Sie das Problem, bevor Sie die Anwendung verteilen möchten.
    • Wenn die Anwendung erfolgreich auf dem Testcomputer funktioniert aber nicht auf dem Zielcomputer funktioniert, wissen Sie, dass etwas falsch auf dem Zielcomputer nicht in der Anwendung. Sie müssen identifizieren und korrigieren Sie wahrscheinlich auf dem Zielcomputer wahrscheinlich eine Inkompatibilität oder eine beschädigte Datei.

Aktualisieren der Liste

Wenn diesen Verweis auf ein ActiveX-Steuerelement beinhaltet, können Sie auch das Problem durch Aktualisieren der Liste. Um die Liste zu aktualisieren:
  1. Klicken Sie im Visual Basic-Editor im Menü Extras auf Verweise .
  2. Klicken Sie im Dialogfeld Verweise einen Verweis, der nicht Alreadyselected ist, notieren Sie, Sie wählen, und klicken Sie dann auf OK.
  3. Klicken Sie im Menü Extras erneut auf Verweise .
  4. Klicken Sie zum Abbrechen der Auswahl die, und klicken Sie auf OK.

Verteilen von Dateien, die ActiveX-Steuerelemente

Es gibt zwei Arten von Lizenzen für ActiveX-Steuerelemente: eine Entwurfszeitlizenz und eine Laufzeitlizenz.
  • Eine Entwurfszeitlizenz ermöglicht LicensedActiveX Steuerelemente in Formularen und Berichten in einer Accessdatabase von Office 2000 Developer einfügen.
  • Eine Laufzeit-Lizenz erlaubt Ihnen, ActiveX-Controlsin Verwenden einer Access-Datenbank auf einem Computer ohne Office 2000 Developerinstalled, aber eine Laufzeitlizenz nicht neue LicensedActiveX Steuerelemente einfügen. Um eine Laufzeitlizenz installieren, verteilen Sie die ActiveX-Steuerelemente mit dem Package and Deployment Wizard, der die Licensefor der Steuerelemente in der Registrierung des Zielcomputers schreibt.
Ein Flag fehlt , Sie finden ein Modul in der Entwurfsansicht öffnen und klicken Sie dann im Menü Extras auf Verweise , gibt an, dass der Verweis auf das Standarddialog-Steuerelement auf dem Zielcomputer nicht die Quelle in der Datenbank auf dem Entwicklungscomputer.

Verteilen einer Datenbankdatei ohne das verteilbare Standarddialog-Steuerelement installiert, das Steuerelement Verweis möglicherweise als Fehlendgekennzeichnet oder möglicherweise eine Fehlermeldung angezeigt, dass "Sie dieses ActiveX-Steuerelements erforderliche Lizenz nicht" Wenn nicht verteilbar-Steuerelements bereits auf dem Zielcomputer installiert ist.

Auch wenn die Datenbankdatei eine Anwendung gehört, möglicherweise die Fehlermeldung "Sie dieses ActiveX-Steuerelements erforderliche Lizenz haben" ist nicht verteilbaren Steuerelement, das bereits auf dem Zielcomputer installiert ist höher als des Steuerelements, die von der Anwendung zur Laufzeit bereitgestellt wird. Dieses Problem kann auftreten, da das Setup-Programm keine höhere Versionen einer Datei mit einer früheren Version derselben Datei überschreibt.

Registrieren einer Datei

Es ist möglich, dass eine Datei in der Liste ohne Registrierung ordnungsgemäß in der Registrierung. Wenn Sie vermuten, dass dies der Fall sein kann, folgendermaßen Sie vor, um die Datei zu registrieren:
  1. Klicken Sie in Microsoft Windows NT 4.0 auf Start, zeigen Sie auf Suchen, und klicken Sie auf Dateien oder Ordner, oder unter Windows2000, klicken Sie auf Start, zeigen Sie auf Suchenund klicken Sie dann auf nach Dateien AndFolders.
  2. Geben Sie im Feld oder im Feld Suchen nach Dateien und foldersnamedregsvr32.exe.
  3. Klicken Sie im Feld Suchen in auf Stamm Thehard Datenträger (normalerweise c:)).
  4. Aktivieren Sie das Kontrollkästchen Unterordner einschließen , wenn es nicht bereits aktiviert ist, und klicken Sie dann auf Starten bzw. Jetzt suchen.
  5. Nachdem Sie die Datei finden, klicken Sie auf Start, klicken Sie auf Ausführenund löschen Sie nichts in das Feld Öffnen ein.
  6. Ziehen Sie die Datei Regsvr32.exe aus dem Suchergebnisfenster auf das Öffnen .
  7. Wiederholen Sie die Schritte 2 bis 6 dieser suchenDateinameDLL,Dateiname ist der Name der Datei, die Sie Toreregister möchten.
  8. Nach der DateinameDLL-Datei Isin das Feld Öffnen die Datei Regsvr32.exe klicken Sie auf OK.
  9. In Access prüfen, ob das Problem Stillexists.
Haben Sie nicht die Datei "Regsvr32.exe" auf Ihrem Computer, prüfen Sie anderen Computern für die Datei Wenn die Datei nicht verfügbar ist, erhalten die Datei von der Microsoft-Website Sie. Klicken Sie für Weitere Informationen auf die nachstehende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:
161983 ACC: Regsvr32a.exe im Download Center verfügbar
Hinweis: Denken Sie daran, alle Module kompiliert, nachdem Verweise anpassen. Alle Module kompilieren mit dem Modul geöffnet, klicken Sie im Menü Debuggen auf Kompilieren Datenbank . Die Module nicht kompilieren, möglicherweise zusätzliche nicht aufgelöste Verweise.

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 310803 – Letzte Überarbeitung: 10/04/2015 11:40:00 – Revision: 6.0

Microsoft Access 2000 Standard Edition, Microsoft Access 2002 Standard Edition, Microsoft Office Access 2003, Microsoft Office Access 2007, Microsoft Access 2010, Microsoft Access 2013, Access 2016

  • kbhowto kbenv kbinfo kbinterop kbprogramming kbmt KB310803 KbMtde
Feedback
/html> ay: none; " src="https://c1.microsoft.com/c.gif?DI=4050&did=1&t=">1&t=">ody>>