Schlechte Leistung mit Datei- und Druckdienste für NetWare

Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.

311243
Dieser Artikel wurde archiviert. Er wird im vorliegenden Zustand bereitgestellt und nicht mehr aktualisiert.
Problembeschreibung
File und Print Services für NetWare (FPNW) die Leistung kann beeinträchtigt sein, wenn bestimmte Client-Vorgänge nicht richtig verarbeitet werden. Beispielsweise wenn Sie Dateien von einem Clientcomputer, auf denen Microsoft Windows 95, Microsoft Windows 98 oder Microsoft Windows Millennium Edition zu einem FPNW-Server ausgeführt wird kopieren, indem des Novell-Clients, jede Datei kann über eine Sekunde dauern, kopiert werden und die Uhrzeit und Datum der Datei können nicht auf die Uhrzeit und Datum der ursprünglichen Datei festgelegt werden. Verzögerungen können auch auftreten, wenn Sie Laufwerkzuordnungen erstellen.
Ursache
Dies tritt auf, da FPNW Anweisungen GetNSLoadedListFromVolNumber und "NCP Set Datei Datum Uhrzeit" wegen eine nicht passende Größe Struktur nicht verarbeitet. Der Client sendet die Anweisung nach ungefähr einer Sekunde erneut, aber FPNW die resent Anweisung soll ein Duplikat betrachtet und gibt "Erfolg" ohne Verarbeitung zurück.
Lösung
Installieren Sie das neueste Service Pack für Windows 2000, um dieses Problem zu beheben. Weitere Informationen finden Sie die folgende KB-Artikelnummer:
260910Wie Sie das neueste Service Pack für Windows 2000 erhalten
Die englische Version dieses Updates müsste die folgenden Dateiattribute oder höher:
   Date         Time   Version        Size     File name   -------------------------------------------------------   13-Nov-2001  13:03  5.0.2195.4625  213,648  Fpnwsrv.sys				

Abhilfe
Um dieses Problem zu umgehen, verwenden Sie Microsoft Client Service für NetWare-Netzwerke, wenn Sie Windows 2000 Professional ausführen. Wenn Sie Windows 2000 Server oder Windows 2000 Advanced Server ausführen, verwenden Sie Gateway (und Client) Services für NetWare.
Status
Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt. Dieses Problem wurde erstmals in Microsoft Windows 2000 Service Pack 3 (SP3) behoben.
Weitere Informationen
Weitere Informationen zum Installieren mehrerer Hotfixes mit nur einem Neustart finden Sie die Artikel der Microsoft Knowledge Base:
296861Verwenden von QChain.exe zum Installieren mehrerer Hotfixes mit nur einem Neustart
Weitere Informationen über das gleichzeitige Installieren von Windows 2000 und Windows 2000-Hofixes finden Sie in folgendem Artikel der Microsoft Knowledge Base:
249149Installation von Microsoft Windows 2000 und Windows 2000-Hotfixes
KbMgmtAdmin kbDirServices

Warnung: Dieser Artikel wurde automatisch übersetzt

Eigenschaften

Artikelnummer: 311243 – Letzte Überarbeitung: 02/13/2014 01:59:22 – Revision: 2.2

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kbbug kbdirservices kbfix kbsysadmin kbwin2000presp3fix kbwin2000sp3fix kbwinxpsp1fix KB311243 KbMtde
Feedback