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Datawarehouse Aufträge schlagen fehl, und Ereignis-ID 33502 protokolliert

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Den englischen Originalartikel können Sie über folgenden Link abrufen: 3137611
Symptom
Datawarehouse-Aufträgen fehlschlagen in Microsoft System Center 2012 Service Manager. Wenn dieses Problem auftritt, wird das folgende Ereignis in Operations Manager-Ereignisprotokoll auf dem Data Warehouse-Server protokolliert:

Protokollname: Operations Manager
Quelle: Datawarehouse
Ereignis-ID: 33502
Stufe: Fehler
Beschreibung
ETL-Modul fehlgeschlagen:
ETL-Prozesstyp: umwandeln
Stapel ID: ###
Modul: TransformEntityRelatesToEntityFact
Nachricht: Timeout abgelaufen. Das Zeitlimit wurde vor Abschluss des Vorgangs oder der Server antwortet nicht.


Auch beim Ausführen bestimmter Cmdlets für Data Warehouse Youfrequently finden Sie ein Timeout Fehlercode für dasTransformEntityRelatesToEntityFact -Modul, das der folgenden ähnelt:

Get-SCDWJobModule - JobName transform.common
. . .
1952 TransformEntityRelatesToEntityFact fehlgeschlagen
. . .
Ursache
Dieses Problem kann auftreten, übersteigt die Transformation Datenmenge, die durch die Transformation Module innerhalb des Timeoutzeitraums verarbeitet werden können. Dies tritt in der Regel nach Data Warehouse Aufträge für einige Zeit deaktiviert wurden, da die Datenmenge zu transformierenden schnell zurückgestellt werden. Standardmäßig haben Data Warehouse Transformation Jobs eine hartcodierte 60-minütigen Timeouts.
Lösung
Um dieses Problem zu beheben, verwenden Sie eine der folgenden Methoden.

Methode 1

Wenn Sie glauben, dass dies ein Problem kurzfristig und isoliert, transformiert Prozess der Rückstand Aufträge, um den Vorgang funktioniert Status zurück. Zu diesem Zweck den Status aller Data Warehouse-Projekte alsNicht gestartet oder Fehlerangezeigt warten und dann folgendermaßen:

  1. Beenden Sie auf dem Server Date Warehouse Integritätsdienst Serviceat belegen. Führen Sie hierzu den folgenden Befehl aus:

    Net Stop HealthService

    Hinweis Je nach Version des Dienst-Managers könnte dieser Dienstname alsMicrosoft Monitoring Agent oder System Center Managementangezeigt werden.
  2. Aktualisieren Sie folgende SQL Server-Abfrage entsprechend ist ModuleNameWert des Moduls Transform.Common Auftrag Dieses Beispiel verwendetTransformEntityRelatesToEntityFact.

    Hinweis Die einfachste Möglichkeit dazu ist den ModulnameWert für das Modul ist zum Öffnen der Service Manager-Konsole aufData Warehouse, klicken Sie erneut auf Data Warehouse , klicken Sie auf Data Warehouse-Projekte, und klicken Sie auf Transform.Common. Klicken Sie im unteren mittleren sehen Sie eine Liste von Modulen und den aktuellen Status. Nach dem Ändern führen Sie die Abfrage aus.

    Use DWStagingAndConfig  declare  @mybatchid INT,  @mysourceid INT,  @outXML XML,  @myProcessCategoryName NVARCHAR(100),  @myProcessName NVARCHAR(100),  @myModuleName NVARCHAR(100),  @sqlString NVARCHAR(150),  @paramDef NVARCHAR(100)  set @myProcessCategoryName = N'Transform'  set @myProcessName = N'Transform.Common'  set @myModuleName = N'TransformEntityRelatesToEntityFact'  USE DWStagingAndConfig  create table #MyTempTable (  ProcessCategoryName NVARCHAR(150),  ProcessName NVARCHAR(150),  BatchId INT,  BatchStatus NVARCHAR(150),  WorkItemStatus NVARCHAR(150),  WorkItems INT  )  insert #MyTempTable  exec Infra.GetBatchDetails @ProcessCategoryName=@myProcessCategoryName, @ProcessName=@myProcessName  select @mybatchid = BatchId from #MyTempTable  select @mysourceid = sourceid from etl.source where SourceName='SCDW'  create table #MyTempTable2 (  myWaterMark XML  )  insert #MyTempTable2  exec etl.GetWaterMark @BatchId=@mybatchid, @ModuleName=@myModuleName, @ProcessName=@myProcessCategoryName, @SourceId=@mysourceid  select @outXML = myWaterMark from #MyTempTable2  create table #MyTempTable3 (  myWaterMark XML,  BatchId INT,  UpdatedRowCount INT,  InsertedRowCount INT  )  USE DWRepository  set @paramDef = N'@ioutXML XML'  set @sqlString = 'insert #MyTempTable3 exec ' + @myModuleName + 'Proc @WaterMark=@ioutXML'  exec sp_executesql @sqlString, @paramDef, @ioutXML=@outXML  select @mybatchid = BatchId, @outXML = myWaterMark from #MyTempTable3  USE DWStagingAndConfig  exec etl.SetWaterMark @BatchId=@mybatchid, @ModuleName=@myModuleName, @ProcessName=@myProcessCategoryName, @SourceId=@mysourceid, @WaterMark=@outXML  drop table #MyTempTable  drop table #MyTempTable2  drop table #MyTempTable3
  3. Starten Sie den Dienst Integritätsdienst auf belegen. Führen Sie hierzu den folgenden Befehl aus:

    Net Start HealthService
Hinweis Sie müssen diese Schritte wiederholen, mehrere oder in mehreren Modulen.

Methode 2

Wenn Sie Forefront identifizieren Manager (FIM) verwenden, kann dieses Problem aufgrund des Datenflusses wiederholt, die Service Manager erreicht. Ändern Sie zum Verteilen der Arbeitslast für diese DatenFIM_ScheduleReportingIncrementalSynchronizationJob Zeitplan vom Standardwert alle 8 Stunden 2 Stunden. Gehen Sie hierzu folgendermaßen vor:

  1. In SQL Server Management Studio Verbinden mit FIM-Datenbank, erweitern Sie SQL Server-Agentund klicken Sie auf Aufträge.
  2. FIM_ScheduleReportingIncrementalSynchronizationJobMaustaste klicken Sie auf Eigenschaftenund klicken Sie dann auf Zeitpläne.
  3. Ändern der tritt jedes Wert für FIM_UpdateReportingIncrementalSynchronizationJobSchedule_1 auf 2 Stunden.

Methode 3

Eine langfristige Lösung auf Microsoft System Center 2012 R2 Service Manager Updaterollup 4 (UR4) oder höher aktualisieren. Updaterollup 4 ab, hat Service Manager veränderbaren Timeouteinstellung Außerdem ändert das Standardtimeout Data Warehouse Transformation Auftrag von 60 Minuten auf 180 Minuten. Wenn drei Stunden nicht lange genugTransform.Common Modul abgeschlossen ist, können Sie den Wert erhöhen, indem Sie den folgenden Registrierungswert ändern:

HKLM\SOFTWARE\Microsoft\System Center\2010\Common\DAL

SqlCommandTimeout = (32-Bit im zweiten DWord)

Hinweis Wenn Sie Forefront Identity Manager verwenden, müssen Sie Microsoft Identity Manager 2012 R2 erhalten Sie Support für Service Manager 2012 R2 aktualisieren.

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Eigenschaften

Artikelnummer: 3137611 – Letzte Überarbeitung: 03/28/2016 17:53:00 – Revision: 2.0

Microsoft System Center 2012 Service Manager Service Pack 1, Microsoft System Center 2012 R2 Service Manager

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