SSL-Verbindung funktioniert unter Windows XP nicht

Der Support für Windows XP wurde eingestellt

Microsoft stellte am 8. April 2014 den Support für Windows XP ein. Diese Änderung wirkt sich auf Ihre Softwareupdates und Sicherheitsoptionen aus. Erfahren Sie, was das für Sie bedeutet und wie Sie Ihren Schutz aufrechterhalten können.

Dieser Artikel wurde zuvor veröffentlicht unter D314864
Dieser Artikel wurde archiviert. Er wird im vorliegenden Zustand bereitgestellt und nicht mehr aktualisiert.
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
314864 SSL connection does not work on Windows XP
Problembeschreibung
Wenn Sie sich mithilfe eines selbstsignierten Serverzertifikats über eine SSL-Verbindung (SSL = Secure Sockets Layer) mit einem Webserver verbinden, zeigt Microsoft Internet Explorer möglicherweise eine Fehlermeldung an, dass der Server nicht gefunden werden konnte. Daraufhin kann Internet Explorer möglicherweise keine Verbindungen mehr herstellen.
Ursache
Dieses Problem kann auftreten, wenn die Datei "Crypt32.dll" das Serverzertifikat fälschlicherweise als ungültig identifiziert. Dieses Problem kann auch dadurch verursacht werden, dass eines der folgenden Firewallprogramme auf Ihrem Computer installiert ist:
  • Freedom Firewall
  • Zone Alarm von Zonelabs
  • McAffee VirusScan und Firewall
  • Norton Personal Firewall von Symantec
  • BlackICE PC Protection
Lösung

Informationen zum Service Pack

Installieren Sie das neueste Service Pack für Windows XP, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322389 Wie Sie das neueste Service Pack für Windows XP erhalten

Hotfix-Informationen

Ein Hotfix zur Behebung des Problems ist jetzt bei Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Update zu warten, das diesen Hotfix enthält.

Falls der Hotfix zum Download zur Verfügung steht, finden Sie am Anfang dieses Knowledge Base-Artikels den Hinweis "Hotfix-Download ist verfügbar". Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um den Hotfix zu erhalten.

Hinweis: Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Besuchen Sie die folgende Microsoft-Website, um eine vollständige Liste mit Telefonnummern der Kundenbetreuung bzw. des Support von Microsoft zu erhalten oder um eine separate Serviceanfrage zu erstellen: Hinweis: Das Formular "Hotfix-Anfrage" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Falls Ihre Sprache nicht angezeigt wird, gibt es für diese Sprache (noch) keinen Hotfix.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Den Unterschied zwischen UTC-Zeit und lokaler Zeit können Sie in der Systemsteuerung unter "Datum und Uhrzeit" mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.
   Datum        Uhrzeit   Version         Größe     Dateiname   ------------------------------------------------------------   19.12.2001   09:53     5.131.2600.24   544.256   Crypt32.dll				

Abhilfe
Wenn Sie den im Abschnitt "Lösung" genannten Hotfix installiert haben und das im Abschnitt "Problembeschreibung" beschriebene Problem immer noch auftritt, deaktivieren Sie gegebenenfalls eines der im Abschnitt "Ursache" aufgelisteten Firewallprodukte, sofern es auf Ihrem Computer installiert ist. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start und auf Ausführen, geben Sie msconfig in das Feld Öffnen ein, und drücken Sie dann die [EINGABETASTE].
  2. Klicken Sie auf die Registerkarte Dienste.
  3. Blättern Sie durch die Liste unter Dienste, um den Dienst für das auf Ihrem Computer installierte Firewallprogramm zu finden.
  4. Deaktivieren Sie das Kontrollkästchen neben dem Namen des Firewalldienstes, den Sie in Schritt 3 gefunden haben, und klicken Sie anschließend auf Übernehmen.
  5. Starten Sie den Computer neu.
Status
Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt. Dieses Problem wurde erstmals in Windows XP Service Pack 1 behoben.
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Eigenschaften

Artikelnummer: 314864 – Letzte Überarbeitung: 12/07/2015 08:25:55 – Revision: 2.7

Microsoft Windows XP Home Edition, Microsoft Windows XP Professional

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