Sie sind zurzeit offline. Es wird auf die erneute Herstellung einer Internetverbindung gewartet.

Gewusst wie: Verwenden Sie die Visual Basic-Aktualisierungs-Assistent

Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.

Den englischen Originalartikel können Sie über folgenden Link abrufen: 317885
Zusammenfassung
In diesem Artikel wird erläutert, wie ein einfaches Erstellen Visual Basic-6.0-Anwendung und der anschließenden Aktualisierung der Anwendung Visual Basic .NET oder Visual Basic 2005 mithilfe der Visual Basic-Aktualisierungs-Assistent Visual Studio .net oder Visual Studio 2005.

Hinweis Der Visual Basic .net-Aktualisierungs-Assistent ist in Visual enthalten. Studio .net Professional.

Hinweis Visual Basic-2005-Aktualisierungs-Assistenten wurde von früheren Versionen von Visual Basic erweitert. back to the top

Anforderungen

Die folgende Liste beschreibt die empfohlene Hardware, Software, Netzwerkinfrastruktur, Fähigkeiten, Kenntnisse und Servicepacks müssen Sie:
  • Microsoft Windows 2000 Professional (oder Server) oder Microsoft Windows XP Professional (oder Server) mit der.NET Framework installiert
  • Microsoft Visual Basic 6.0
  • Microsoft SQL Server 7.0 oder höher mit der Beispieldatenbank Nordwind Datenbank, die entsprechenden Berechtigungen und die Werte für Benutzer-ID und Kennwort
Erforderliche Vorkenntnisse:
  • Allgemeine Kenntnisse zum Erstellen von Anwendungen mithilfe von Visual Basic 6.0
back to the top

Verwenden Sie den Visual Basic-Aktualisierungs-Assistenten

Die folgenden Schritte veranschaulichen das Erstellen einer einfachen Visual Basic 6.0-Anwendung und der anschließenden Aktualisierung der Anwendung zu Visual Basic .net oder Visual Basic 2005 mithilfe von die Visual Basic-Aktualisierungs-Assistenten in Visual Studio, .net oder Visual Studio 2005:
  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft Visual Studio 6.0, und klicken Sie dann auf Microsoft Visual Basic 6.0.
  2. Klicken Sie im Dialogfeld Neues Projekt klicken Sie auf Standard-EXE, und klicken Sie dann auf Öffnen.
  3. Die erste Form in dieser Anwendung verwendet ADO zum Abrufen einer Recordset, und zeigt anschließend das Recordset in einem Microsoft Hierarchical FlexGrid Steuerelement. Geben Sie im Feld Name im Dialogfeld Eigenschaften für Form1frmADO.
  4. Wenn die Toolbox nicht geöffnet ist, klicken Sie im Menü Ansicht auf Toolbox.
  5. Setzen Sie ein MSHFlexGrid aus der Toolbox auf das Formular, so dass es sich um das Formular ausfüllt. Lassen Sie genügend Speicherplatz am unteren Rand des Formulars eine Schaltfläche platziert.

    Hinweis: Wenn Sie das MSHFlexGrid -Symbol in der Toolbox nicht angezeigt werden, es der Toolbox hinzufügen. Mit der rechten Maustaste die Toolbox, und klicken Sie anschließend auf Komponenten. Klicken Sie im Dialogfeld Komponenten aktivieren Sie Microsoft Hierarchical FlexGrid Control 6.0 ((OLEDB)) aus der Liste der verfügbaren Komponenten zu, und klicken Sie dann auf OK.
  6. Platzieren Sie eine Befehlsschaltfläche (CommandButton) auf dem Formular unterhalb der MSHFlexGrid, aus der Toolbox. Geben Sie im Feld Beschriftung im Dialogfeld " Eigenschaften " OK.
  7. Mit der rechten Maustaste mADO, und klicken Sie dann auf Code anzeigen. Fügen Sie folgenden Code, der eine Datenbankverbindung erstellt und Gibt ein Recordset, das alle Daten aus der Products -Tabelle der Northwind-Datenbank enthält.

    Hinweis: Sie müssen im folgenden Beispielcode ändern Benutzer-Id =<username></username> und Kennwort =<strong password=""></strong> auf die richtigen Werte. Stellen Sie sicher, dass die Benutzer-ID verfügt über die entsprechenden Berechtigungen zum Ausführen dieses Vorgangs in der Datenbank.
    Private Sub Command1_Click()    Unload MeEnd SubPrivate Sub Form_Load()    Dim cn As Connection    Set cn = New Connection    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"    cn.Open        Dim rs As Recordset    Set rs = New Recordset    rs.CursorLocation = adUseClient    rs.Open "select * from products", cn        Set MSHFlexGrid1.DataSource = rsEnd Sub					
  8. Drücken Sie STRG + S, um das Formular zu speichern. Klicken Sie auf Speichern unter, klicken Sie im Menü Datei . Klicken Sie im Dialogfeld Speichern unter auf Speichern.
  9. Im Projekt-Explorer mit der rechten Maustaste Projekt1, klicken Sie auf Hinzufügen, und klicken Sie dann auf Formular. Klicken Sie auf Öffnen.
  10. Geben Sie im Feld Name im Dialogfeld " Eigenschaften " frmClipboard.
  11. Setzen Sie ein Textfeld aus der Toolbox auf das Formular. Geben Sie im Feld TextDer flinke braune Fuchs sprang über die verzögerte Hund.
  12. Fügen Sie eine Befehlsschaltfläche (CommandButton) unterhalb der Textbox. Geben Sie im Feld Beschriftung im Dialogfeld " Eigenschaften " Kopie.
  13. Platzieren Sie eine zweite Befehlsschaltfläche (CommandButton) auf dem Formular. Geben Sie im Feld Beschriftung im Dialogfeld " Eigenschaften " Einfügen.
  14. Mit der rechten Maustaste FrmClipboard, und klicken Sie dann auf Code anzeigen. Fügen Sie den folgenden Code für das CommandButton click-Ereignisse. Dieser Code kann mithilfe der Zwischenablage Objekt zu erhalten, und fügen Sie den Text:
    Private Sub Command1_Click()    Clipboard.SetText Text1.SelTextEnd SubPrivate Sub Command2_Click()    Text1.SelText = Clipboard.GetTextEnd Sub					
  15. Drücken Sie STRG + S, um das Formular zu speichern.
  16. Das letzte Formular, die, das Sie brauchen, ist das Hauptformular der Anwendung. Im Projekt-Explorer mit der rechten Maustaste Projekt1, klicken Sie auf Hinzufügen, klicken Sie auf Formular, und klicken Sie dann auf Öffnen.
  17. Geben Sie im Feld Name im Dialogfeld " Eigenschaften " frmMain.
  18. Platzieren Sie eine Befehlsschaltfläche (CommandButton) aus der Toolbox auf das Formular FrmMain. Geben Sie im Feld Beschriftung im Dialogfeld " Eigenschaften " ADO.
  19. Platzieren Sie eine zweite Befehlsschaltfläche (CommandButton) auf dem Formular. Geben Sie im Feld Beschriftung im Dialogfeld " Eigenschaften " Zwischenablage.
  20. Mit der rechten Maustaste FrmMain, und klicken Sie dann auf Code anzeigen. Fügen Sie den folgenden Code für die Befehlsschaltfläche (CommandButton) klicken Sie auf Ereignisse, um Zeigen Sie die beiden anderen Formen:
    Private Sub Command1_Click()    frmADO.ShowEnd SubPrivate Sub Command2_Click()    frmClipboard.ShowEnd Sub					
  21. Drücken Sie STRG + S, um das Formular zu speichern.
  22. Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste Projekt1, und klicken Sie dann auf Eigenschaften von Projekt1. Klicken Sie im Feld StartobjektFrmMainklicken Sie auf, und klicken Sie dann auf OK.
  23. Um einen Verweis auf die ADO-Komponente im Menü Projekt hinzuzufügen, klicken Sie auf " Verweise". Aktivieren Sie in der Liste der verfügbaren Verweise Microsoft ActiveX Daten Objektbibliothek (werden führen Sie eine beliebige Version 2.0 oder höher). Klicken Sie auf OK.
  24. Klicken Sie zum Kompilieren des Projekts, klicken Sie im Menü Datei auf Project1.exe machen. Das Dialogfeld Projekt erstellen , klicken Sie auf OK (akzeptieren Sie den Standardnamen).
  25. Drücken Sie F5, um die Anwendung im Debugmodus auszuführen.

    Hinweis: Sie müssen nicht zu überprüfen, ob die legacy Visual Basic Anwendung wird ohne Probleme ausgeführt, bevor Sie aktualisieren.
  26. Schließen Sie die Visual Basic-Entwicklungsumgebung. Bei der Aufforderung zum Speichern von Änderungen auf das Projekt, klicken Sie auf Ja. Verwenden Sie den Standardnamen, und speichern Sie das Projekt.
  27. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft Visual Studio., und klicken Sie dann auf Microsoft Visual Studio .net.
  28. Klicken Sie auf der Startseite auf Projekt öffnen. Suchen Sie den Ordner, der das Visual Basic 6.0-Projekt enthält die Datei gerade (normalerweise C:\Program Files\Microsoft Visual erstellt Studio\VB98). Klicken Sie auf Project1.vdp, und klicken Sie dann auf Öffnen.
  29. Visual Studio-.net erkennt, dass dies eine ältere Visual Basic-Projekt und startet den Visual Basic-Aktualisierungs-Assistenten. Der Assistent zeigt eine Beschreibung der einzelnen Schritte, wie Sie die Schritte im folgenden fortfahren Sequenz:
    • Erstellen eines neuen Projekts, in dem die vorhandenen Projekt wird aktualisiert.
    • Kopieren von Dateien und Klassendateien in das neue Projekt.
    • Geben Sie einen Aktualisierungsbericht, in der die Komponenten der aufgeführt das Projekt, das erfolgreich aktualisiert und die Komponenten, die nicht aktualisiert haben erfolgreich.

  30. Klicken Sie auf Weiter durch die einzelnen Schritte, bis der Upgrade-Vorgang beginnt. Die Upgrade dauert ca. 30-60 Sekunden abgeschlossen.
  31. Doppelklicken Sie im Projektmappen-Explorer _UpgradeReport.htmaus. Dieser Bericht zeigt die Ergebnisse der Aktualisierung. Beachten Sie, dass alle Formulare mit Ausnahme von FrmClipboard ohne Probleme aktualisiert.
  32. Erweitern Sie frmClipboard.vb , um die Probleme anzuzeigen. Clipboard.SetText und GetText nicht korrekt aktualisiert. Klicken Sie auf die Links in der Beschreibung an wie Sie die Probleme zu beheben.
  33. Beachten Sie, dass alle Formulare im Projektmappen-Explorer Ihre ursprünglichen Namen, aber die Dateierweiterung wird von frm zu geändert. . vb.
  34. Erweitern Sie Verweise. Beachten Sie, die Verweise auf alle Komponenten, die erforderlich sind um ältere Visual Basic und ADO-Komponenten verwenden hinzugefügt wurden automatisch.
  35. Mit der rechten Maustaste die Formulare, und klicken Sie dann auf Code anzeigen. Erweitern Sie den Upgrade Support -Bereich. Dieser Bereich zeigt an, wie Visual Studio .net oder Visual Studio 2005 konfiguriert verschiedene Eigenschaften und Variablen, um den aktualisierten Code zu unterstützen.
  36. Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste frmClipboard.vb, und klicken Sie dann auf Code anzeigen. Beachten Sie, dass Kommentare platziert werden, bevor Sie die Zeilen, die haben nicht aktualisiert werden.
  37. Ändern Sie die Ereignisse Command1_Click und Command2_Click wie folgt:
    Private Sub Command1_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command1.Click        Clipboard.SetDataObject(Text1.Text)    End Sub    Private Sub Command2_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command2.Click        Text1.SelectedText = _            Clipboard.GetDataObject().GetData(GetType(System.String))    End Sub					
back to the top

Vollständige Codelisten

Vollständige Codeauflistung (frmADO.frm)

Private Sub Command1_Click()    Unload MeEnd SubPrivate Sub Form_Load()    Dim cn As Connection    Set cn = New Connection    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"    cn.Open        Dim rs As Recordset    Set rs = New Recordset    rs.CursorLocation = adUseClient    rs.Open "select * from products", cn        Set MSHFlexGrid1.DataSource = rsEnd Sub				
back to the top

Vollständige Codeauflistung (frmClipboard.frm)

Private Sub Command1_Click()    Clipboard.SetText Text1.SelTextEnd SubPrivate Sub Command2_Click()    Text1.SelText = Clipboard.GetTextEnd SubComplete Code Listing (frmMain.frm)Private Sub Command1_Click()    frmADO.ShowEnd SubPrivate Sub Command2_Click()    frmClipboard.ShowEnd Sub				
back to the top

Stellen Sie sicher, dass die Anwendung funktioniert

  1. Drücken Sie F5, um die Anwendung zu starten.
  2. Klicken Sie auf " OK", an der Eingabeaufforderung zum Speichern des Projekts.
  3. Klicken Sie in Form1 auf ADO. Ein Formular wird mit Daten in einem Raster angezeigt. Schließen Sie diese Formular.
  4. Klicken Sie in Form1 auf Zwischenablage.
  5. Klicken Sie auf Kopieren.
  6. Setzen Sie die Einfügemarke in das Textfeld am Anfang der Text und klicken Sie dann auf Einfügen. Den eingefügten Text sollte angezeigt werden.
back to the top

Problembehandlung

Visual Basic .net ist eine bedeutende Veränderung aus früheren Versionen von Visual Basic. Für viele Projekte empfiehlt einige umfangreiche Vorbereitungsarbeiten Bevor Sie aktualisieren. Finden Sie im folgenden Dokument, die u. u. Informationen helfen Sie leichter aktualisieren:
back to the top

REFERENZEN

Weitere Informationen finden Sie in der folgenden Microsoft-Entwickler Network (MSDN)-Artikeln: back to the top

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 317885 – Letzte Überarbeitung: 07/02/2012 05:25:00 – Revision: 1.0

Microsoft Visual Basic 2005, Microsoft Visual Basic .NET 2003 Standard Edition, Microsoft Visual Basic .NET 2002 Standard Edition, Microsoft Visual Basic 6.0 Professional Edition, Microsoft .NET Framework 1.1

  • kbvs2005swept kbvs2005applies kbmigration kbhowtomaster kbmt KB317885 KbMtde
Feedback