Sie sind zurzeit offline. Es wird auf die erneute Herstellung einer Internetverbindung gewartet.

Windows wird möglicherweise nicht gestartet und es wird die Fehlermeldung "NTLDR fehlt" angezeigt, wenn Windows nicht auf dem letzten Stand ist und sich zu viele Dateien im Stammordner befinden

Der Support für Windows XP wurde eingestellt

Microsoft stellte am 8. April 2014 den Support für Windows XP ein. Diese Änderung wirkt sich auf Ihre Softwareupdates und Sicherheitsoptionen aus. Erfahren Sie, was das für Sie bedeutet und wie Sie Ihren Schutz aufrechterhalten können.

Problembeschreibung
Wenn zu viele Dateien in den Stammordner eines Startvolumes kopiert wurden, das das NTFS-Dateisystem verwendet, wird möglicherweise beim nächsten Neustart des Computers folgende Fehlermeldung angezeigt:
NTLDR fehlt
Drücken Sie STRG+ALT+ENTF, um den Computer neu zu starten.
Wenn Sie die Dateien aus dem Stammordner entfernen, wird der MFT-Zuordnungsindex (MFT = Master File Table) nicht auf seine ursprüngliche Größe reduziert.

Hinweis Das in diesem Artikel beschriebene Problem liegt nicht bei Ihnen vor, wenn Sie Windows XP mit Service Pack 2 (SP2) oder Microsoft Windows 2000 mit Service Pack 4 (SP4) verwenden. Im Abschnitt "Weitere Informationen" finden Sie Hinweise zu ähnlichen Problemen.
Ursache
Dieses Problem kann auftreten, wenn der MFT-Stammordner schwer fragmentiert ist. Wenn der MFT-Stammordner viele Dateien enthält, wird die MFT möglicherweise so stark fragmentiert, dass ein zusätzlicher Zuordnungsindex erstellt wird. Da Dateien im Zuordnungsindex alphabetisch zugeordnet werden, wird die NTLDR-Datei unter Umständen in den zweiten Zuordnungsindex verschoben. Ist dies der Fall, wird die im Abschnitt "Problembeschreibung" genannte Fehlermeldung angezeigt.

Normalerweise werden Dateien nicht in den Stammordner geschrieben. Dies kann jedoch geschehen, wenn ein Programm regelmäßig temporäre Dateien im Stammordner erstellt und entfernt oder wenn viele Dateien versehentlich in den Stammordner kopiert werden.
Lösung
Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
  1. Wenden Sie sich an Microsoft Support Services, um das Dienstprogramm "Bcupdate2.exe" zu beziehen. Informationen dazu, wie Sie Kontakt mit Microsoft Support Services aufnehmen, finden Sie auf der folgenden Website von Microsoft:
  2. Erstellen Sie eine Startdiskette, um den Computer zu starten. Weitere Informationen dazu, wie Sie eine Startdiskette für einen Microsoft Windows XP-Computer erstellen, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    305595 Erstellen einer Startdiskette für eine NTFS- oder FAT-Partition mit Windows XP
  3. Führen Sie den folgenden Befehl an einer Eingabeaufforderung aus, um das Dienstprogramm "Bcupdate2.exe" aus dem Softwareupdate zu extrahieren:

    Expand Laufwerkbuchstabe:\bcupdate2.ex_ Laufwerkbuchstabe:\bcupdate2.exe
  4. Führen Sie den folgenden Befehl an einer Eingabeaufforderung aus, um den Startcode des NTFS-Startsektors zu aktualisieren:

    Bcupdate2.exe C: /F

    Hinweis Weitere unterstützte Befehlszeilenparameter:
    /q - Stiller Modus (muss /y enthalten)
    /y - Nicht bestätigen
    /f - Aktualisierung des verwendeten Volumes erzwingen
    /t - Nur auf alten Startcode prüfen
  5. Drücken Sie die Taste J, wenn Sie aufgefordert werden, die Aktualisierung des Volumes zu bestätigen. Nachdem Sie das Dienstprogramm erfolgreich ausgeführt haben, wird die folgende Meldung angezeigt:
    The boot code was updated successfully. (Der Startcode wurde erfolgreich aktualisiert.)
Status
Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.
Dieses Problem wurde erstmals in Windows XP Service Pack 2 behoben.
Dieses Problem wurde erstmals in Windows 2000 Service Pack 4 behoben. Weitere Informationen dazu, wie Sie die neuesten Service Packs erhalten, finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
322389 Wie Sie das neueste Service Pack für Windows XP erhalten
260910 Wie Sie das neueste Service Pack für Windows 2000 erhalten
Hinweis Wenn Sie das Windows XP Service Pack oder Windows 2000 Service Pack installieren, werden dadurch Probleme mit einem vorhandenen Volume nicht behoben. Führen Sie das Dienstprogramm aus, um den Startcode separat zu aktualisieren. Das Service Pack schreibt nur den richtigen Startcode für neue Volumes.
Weitere Informationen
Weitere Informationen zu einem verwandten Thema finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
318728 Problembehandlung bei der Fehlermeldung "NTLDR fehlt" in Windows 2000
886215 Sie erhalten die Fehlermeldung "NTLDR fehlt Neustart mit beliebiger Taste", wenn Sie einen Windows 98-basierten Computer auf Windows 2000 Professional aktualisieren
816793 Problembehandlung bei der Fehlermeldung "NTLDR fehlt" in Windows 2003
842009 Fehler "NTLDR fehlt" beim Versuch, die automatische Systemwiederherstellung in Windows Server 2003 ausführen
883275 Sie können Ihren Computer nicht starten, nachdem Sie die Berechtigungen in Windows Server 2003, Windows XP oder Windows 2000 geändert haben
315261 Der Computer startet nach dem Ändern der aktiven Partition in der Datenträgerverwaltung nicht
812492 Fehlermeldung beim Starten des Computers, wenn kein Systemdatenträger eingelegt wurde
228004 Ändern der aktiven Partition kann das System startunfähig machen
bcupdate
Hinweis Dies ist ein Artikel, der im Schnellverfahren direkt von der Microsoft-Supportorganisation erstellt wurde. Die hierin enthaltenen Informationen werden als Reaktion auf neue Probleme wie besehen bereitgestellt. Da dieser Artikel im Schnellverfahren erstellt wurde, kann er Tippfehler enthalten und zu einem späteren Zeitpunkt ohne vorherige Ankündigung überarbeitet werden. Weitere zu berücksichtigende Informationen finden Sie in den Nutzungsbedingungen.
Eigenschaften

Artikelnummer: 320397 – Letzte Überarbeitung: 01/31/2014 21:34:00 – Revision: 1.0

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • kbresolve kbwinxpsp2fix kbwin2ksp4fix kbbug kbfix KB320397
Feedback