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Eine Verbindung für DirectPlay Player kann nicht aufgebaut werden und keine Fehlermeldung kann auftreten.

Der Support für Windows XP wurde eingestellt

Microsoft stellte am 8. April 2014 den Support für Windows XP ein. Diese Änderung wirkt sich auf Ihre Softwareupdates und Sicherheitsoptionen aus. Erfahren Sie, was das für Sie bedeutet und wie Sie Ihren Schutz aufrechterhalten können.

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Den englischen Originalartikel können Sie über folgenden Link abrufen: 321463
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Problembeschreibung
Wenn ein Peer (im Peer-to-Peer-Modus) Anrufe IDirectPlay8Peer::Connect oder wenn ein Client (im Client-Server-Modus) IDirectPlay8Client::Connect zum Verbinden mit einer Sitzung DirectPlay8 aufruft, wird die Sitzung wird nicht eingerichtet, und Sie erhalten keine Fehlermeldung.
Ursache
Ein Peer ist die Verbindung der Player Host für die Peer-to-Peer-Sitzung vorgenommen. Für einen Client erfolgt die Verbindung an den Server Player für die Client-Server-Sitzung. Der Verbindungsprozess umfasst das Herstellen einer Verknüpfung zwischen dem Peer (Client) und Host (Server), gefolgt von ein Handshake mehrere Stufe über die Verknüpfung zu den beitretenden Player Eintrag in die Sitzung zu überprüfen. Wenn die Verbindung mit dem Host oder Server Player verloren, geht während der Prozess verbinden weiterhin durchgeführt wird, sollte der Connect-Vorgang nicht erfolgreich. Dadurch sollte das folgende Verhalten:
  • Wenn IDirectPlay8Peer::Connect oder IDirectPlay8Client::Connect synchron aufgerufen wird, sollte es einen Fehler zurück.
  • Wenn IDirectPlay8Peer::Connect oder IDirectPlay8Client::Connect asynchron aufgerufen wird, sollten Sie eine Benachrichtigung DPN_MSGID_CONNECT_COMPLETE Meldungshandler des Programms mit einem Fehler buchen.
  • DPN_MSGID_CREATE_PLAYER-Benachrichtigungen, die generiert werden, bevor die Verbindung unterbrochen wird, sollte mit übereinstimmenden DPN_MSGID_DESTROY_PLAYER Benachrichtigungen nicht entfernt.
In einigen Fällen, Microsoft DirectX 8.1 und Windows XP-Client (Sie können DirectX 8.1 nicht auf einen Windows XP-Client installieren) verwenden DirectPlay 8.0-Versionen dieses Verhalten nicht. Stattdessen der Player eine Verbindung zu den Host (oder Server) wird automatisch gelöscht, und das folgende Verhalten:
  • Wenn IDirectPlay8Peer::Connect oder IDirectPlay8Client::Connect synchron aufgerufen wird, wird erfolgreich (DPN_OK).
  • Wenn IDirectPlay8Peer::Connect oder IDirectPlay8Client::Connect asynchron aufgerufen wird, sendet es eine Benachrichtigung erfolgreichen Abschluss (DPN_MSGID_CONNECT_COMPLETE) des Programms Meldungshandler (DPN_OK).
  • Meldungshandler des Programms werden keine Nachrichten DPN_MSGID_DESTROY_PLAYER gebucht.
Lösung
Installieren Sie das neueste Service Pack für Windows XP, um dieses Problem zu beheben. Weitere Informationen finden Sie die folgende KB-Artikelnummer:
322389Wie Sie das neueste Service Pack für Windows XP erhalten

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website: Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Dateiinformationen

Die englische Version dieses Updates müsste die folgenden Dateiattribute oder höher:
   Date         Time   Version      Size     File name   ---------------------------------------------------   18-Apr-2002  17:05  5.1.2600.43  156,672  Dpnet.dll				

Status
Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt. Dieses Problem wurde erstmals in Windows XP Service Pack 1.

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 321463 – Letzte Überarbeitung: 01/12/2015 20:10:46 – Revision: 1.5

Microsoft Windows XP Home Edition, Microsoft Windows XP Professional

  • kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbmm kbwinxpsp1fix KB321463 KbMtde
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