Beim Öffnen einer Datei, die zuletzt in einer früheren Version von Excel gespeichert wurde, möglicherweise externe Verknüpfungen aktualisiert

Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.

Den englischen Originalartikel können Sie über folgenden Link abrufen: 327006
Problembeschreibung
Wenn Sie eine Arbeitsmappe, die externen Hyperlinks in Microsoft Excel 2000 oder höher enthält öffnen, werden Sie aufgefordert, die Verknüpfungen aktualisieren. Wenn Sie auf Nein klicken, können die folgenden Symptome auftreten:
  • Die Verknüpfungen möglicherweise trotzdem aktualisiert werden.
  • Zellen, die externe Hyperlinks enthalten, die keine return gefunden werden # Bezug! , #Value! , oder # Name! Fehler. Aufgrund des Link wird ein Fehler, zurück Funktionen, die zum Berechnen dieses Werts versuchen außerdem andere Fehler.
Ursache
Dieses Problem tritt auf, wenn die Arbeitsmappe, die Sie öffnen zuletzt in einer Version von Microsoft Excel, die älter als die Version ist, die Sie derzeit verwenden gespeichert wurde, die Datei zu öffnen. Dieses Problem tritt beispielsweise auf, wenn Sie eine Arbeitsmappe in Excel 2000 öffnen, die in Microsoft Excel 97 zuletzt gespeichert wurde. Dieses Problem tritt auf, weil beginnend mit Excel 2000, Excel erzwingt eine vollständige Neuberechnung alle Arbeitsmappen, die, die geöffnet werden, zuvor in einer früheren Version von Excel unabhängig vom Status Link Update gespeichert wurden. Excel veranlasst Aktualisierungen für alle externen Verweise, um die Arbeitsmappe vollständig neu zu berechnen, selbst wenn Sie nicht aktualisieren, wenn Sie dazu aufgefordert werden. Dieser Prozess findet statt, da Excel die Arbeitsmappe Berechnung Kette auf die aktuelle Version aktualisiert werden. Wenn die externe Verknüpfung Quellen nicht verfügbar sind, wird Excel nicht korrekt berechnet und gibt Bezug zurück! Fehler. Dies gilt auch für DDE-Verknüpfungen, die während der Neuberechnung nicht verfügbar sind.
Abhilfe
Verwenden Sie um dieses Problem zu umgehen, eine der folgenden Methoden.

Sicherstellen Sie, dass externe Verknüpfung Quellen verfügbar, sind bevor Sie die Datei öffnen

Wenn Sie öffnen Sie die Datei und Fehler in externe Verknüpfung Formeln haben, aber Sie haben nicht die Datei noch gespeichert, gehen Sie folgendermaßen vor:
  1. Schließen Sie die Arbeitsmappe ohne zu speichern, die Arbeitsmappe unverändert zu lassen.
  2. Bestätigen Sie für jede andere externe Verknüpfungsquelle in der Datei, die Sie öffnen möchten, dass die Quelldatei unter dem Pfad verfügbar ist, die in die Verknüpfungsformel angegeben ist. Wenn alle Quellen Verknüpfung nicht mehr verfügbar sind, müssen Sie die Verknüpfung Formel, die mit einer alternativen Datenquelle zeigen oder Entfernen der Verknüpfung Formel dauerhaft, der die Verknüpfung aufheben ändern. Gehen Sie in den nächsten Abschnitt um zu bearbeiten oder Entfernen von Verknüpfungen.
  3. Nachdem Sie bestätigt haben, dass alle Link-Quellen an Ihren definierten Speicherorten verfügbar sind, öffnen Sie die verknüpfte Datei in Excel, und lassen Sie Excel externe Hyperlinks auf die Datei aktualisiert, wenn Sie dazu aufgefordert wird.
  4. Wenn Sie die verknüpfte Datei öffnen und bestätigt, dass alle externen Hyperlinks erfolgreich aktualisiert wurden und neu, dass die Arbeitsmappe erfolgreich in der aktuellen Excel-Version berechnet wurde, speichern Sie die Datei. Die Datei sollte jetzt öffnen und Aktualisieren von Verknüpfungen in der aktuellen Version von Excel wie erwartet.

Aktualisieren oder Entfernen von Verknüpfungen

Wenn Sie die Datei bereits mit Fehlern in den externen Hyperlink Formeln gespeichert oder verknüpften Quelldateien nicht mehr verfügbar sind, müssen Sie suchen Sie die ursprüngliche verknüpfte Datenquelle oder alternative verknüpfte Quellen und anschließend die Verknüpfungen zu diesen Datenquellen wiederherstellen. Gehen Sie folgendermaßen vor um die externe Verknüpfung Quellen zu prüfen und zu wiederherstellen oder entfernen alle fehlerhaften Hyperlinks,
  1. Legen Sie die Berechnung Umgebung auf manuell fest, um vorübergehend zu verhindern die Neuberechnung der zuletzt in einer früheren Version von Excel gespeichert, sodass können aktualisieren oder entfernen externe Hyperlinks Dateien. Gehen Sie folgendermaßen vor um vorübergehend den Berechnungsmodus auf manuell festzulegen,
    1. Schließen Sie alle Arbeitsmappen, die geöffnet sind.
    2. Erstellen Sie eine neue Arbeitsmappe.
    3. Klicken Sie im Menü Extras auf Optionen .
    4. Klicken Sie auf die Registerkarte berechnen , und klicken Sie auf manuell .
    5. Deaktivieren Sie vor dem Speichern neu berechnen Kontrollkästchen, und klicken Sie dann auf OK .
    6. Öffnen Sie die gespeicherte Arbeitsmappe.
  2. Klicken Sie im Menü Bearbeiten auf Verknüpfungen .
  3. Klicken Sie auf Status überprüfen , um den Status für alle Verknüpfungen in der Liste zu aktualisieren. Warten Sie auf den Status von alle Verknüpfungen aktualisiert werden.
  4. Überprüfen Sie den Status in der Spalte Status , klicken Sie auf den Link, und führen Sie einen der folgenden Aktionen:
    • OK. Kein Aktion ist erforderlich. Die Verknüpfung funktioniert und ist aktuell.
    • Unbekannter . Klicken Sie auf überprüfen Status um den Status für alle Verknüpfungen in der Liste zu aktualisieren.
    • nicht anwendbar . Die Verknüpfung verwendet OLE oder DDE (Dynamic Data Exchange). Microsoft Excel kann nicht den Status dieser Arten von Verknüpfungen überprüfen.
    • Fehler: Quelle nicht gefunden . Klicken Sie auf Quelle ändern , und wählen die entsprechende Arbeitsmappe für die Verknüpfung.
    • Fehler: Arbeitsblatt nicht gefunden . Klicken Sie auf Quelle ändern , und wählen das entsprechende Arbeitsblatt in die entsprechende Datei. Die Quelle kann verschoben umbenannt oder wurde haben.
    • Warnung: Werte nicht aktualisiert . Klicken Sie auf Werte zu aktualisieren . Die Verknüpfung wurde nicht aktualisiert, wenn die Arbeitsmappe geöffnet wurde.
    • Warnung: Quelle nicht neu berechnet . Klicken Sie auf Öffnen , und anschließend F9 drücken, um die Arbeitsmappe zu berechnen. Die Arbeitsmappe möglicherweise auf manuelle Berechnung festgelegt werden. Auf automatische Berechnung festlegen möchten, klicken Sie im Menü Extras auf Optionen und klicken dann auf automatisch auf die Berechnung Registerkarte.
    • Fehler: nicht definiert oder nicht rechteckigen Namen . Einige Namen können nicht aufgelöst werden, bis Sie die Quellarbeitsmappe geöffnet. Klicken Sie auf Öffnen , wechseln Sie wieder in die Zielarbeitsmappe, und klicken Sie dann auf Status überprüfen . Wenn das Problem dadurch nicht behoben wird, stellen Sie sicher, dass der Name nicht falsch geschrieben oder fehlt. Wechseln Sie zu der Quellarbeitsmappe, zeigen Sie auf Name , im Menü Einfügen , klicken Sie auf definieren und suchen Sie nach dem Namen.
    • Warnung: offene Quelle, die Werte zu aktualisieren . Klicken Sie auf Öffnen. Die Verknüpfung kann nicht aktualisiert werden, bis Sie die Quelle geöffnet.
    • Quelle ist geöffnet . Die Quelle ist geöffnet. Kein Aktion ist erforderlich, sofern Sie Arbeitsblattfehler erhalten.
    • Werte aktualisiert von Dateinamen . Kein Aktion ist erforderlich. Die Werte wurden aktualisiert.
    • Fehler: Status nicht festzustellen . Excel kann den Status der Verknüpfung nicht bestimmen. Die Quelle enthält möglicherweise keine Arbeitsblätter oder in einem nicht unterstützten Dateiformat gespeichert werden kann. Klicken Sie auf Update Werte .
  5. Nach Beheben der alle Verweise auf Verknüpfung auf automatische Rücksetzen Sie Berechnung , so, dass Excel vollständig neu die Arbeitsmappe in die neue Version berechnet kann. Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie im Menü Extras auf Optionen .
    2. Klicken Sie auf die Registerkarte berechnen , und klicken Sie auf automatisch .
    3. Klicken Sie auf OK .
    Excel muss die Datei zu diesem Zeitpunkt berechnen. Wenn die Berechnung erfolgreich ist, speichern Sie die Datei. Die Datei sollte jetzt öffnen und Aktualisieren von Verknüpfungen in der aktuellen Version von Excel wie erwartet.
Informationen dazu, wie die Berechnung Umgebung bestimmt wird finden Sie im folgenden Artikel der Microsoft Knowledge Base:
214395Beschreibung des wie Excel für den aktuellen Modus des Berechnung bestimmt

Endgültig entfernen Sie die Verknüpfungsformel und mit dem Wert ersetzen

Wenn Sie nicht über die Formeln, die auf externe Hyperlinks verweisen benötigen, kopieren Sie diese Formeln und fügen Sie dann die Werte nur in den Zielzellen.

Hinweis: Wenn Sie eine Formel durch dessen berechneten Wert ersetzen, entfernt Excel die Formel unwiderruflich.

Die Formeln kopieren und Einfügen der Werte, gehen Sie folgendermaßen vor:
  1. Öffnen Sie die Arbeitsmappe in der Version von Excel, in dem es zuletzt gespeichert wurde. Wenn Sie aufgefordert werden die Verknüpfungen aktualisieren, klicken Sie auf Nein . Da die Datei in dieser Version zuletzt gespeichert wurde, Verknüpfungen sind nicht gezwungen, aktualisieren und Berechnung kann auftreten, mit dem letzten bekannten Wert der Verknüpfung.
  2. Klicken Sie mit der rechten Maustaste auf die Zelle oder Zellbereich, der die Formel enthält, die auf eine externe Verknüpfung verweist der; klicken Sie dann auf Kopieren .
  3. Klicken Sie mit der rechten Maustaste auf dieselbe Zelle, und klicken Sie dann auf Einfügen spezielle .
  4. Wählen Sie unter Einfügen im Dialogfeld Inhalte einfügen klicken Sie auf Werte , und klicken Sie dann auf OK .
Nachdem Sie auf diese Weise die unerwünschte Links entfernen, speichern Sie die Datei. Sie können die Datei dann in der neuen Excel-Version öffnen, ohne diese Verknüpfungen aktualisieren, da Sie nicht mehr vorhanden sind.
Status
Es handelt sich hierbei um ein beabsichtigtes Verhalten.
PRB XL2002 XL2000 Update Verknüpfungen XL

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 327006 – Letzte Überarbeitung: 02/24/2009 18:44:18 – Revision: 7.0

Microsoft Office Excel 2003, Microsoft Excel 2002 Standard Edition, Microsoft Excel 2000 Standard Edition, Microsoft Office Excel 2007

  • kbmt kbopenfile kbxlslink kberrmsg kbprb KB327006 KbMtde
Feedback