Die Summe aller n-ten Zellen addieren

Dieser Artikel wurde zuvor veröffentlicht unter D29814
Disclaimer zu nicht mehr gepflegten KB-Inhalten
Dieser Artikel wurde für Produkte verfasst, für die Microsoft keinen Support mehr anbietet. Der Artikel wird deshalb in der vorliegenden Form bereitgestellt und nicht mehr weiter aktualisiert.
Problembeschreibung
Ich arbeite mit Microsoft(R) EXCEL Version 5.0 (nachfolgend EXCEL genannt). Ich möchte von einem Bereich eine Summe bilden, die beispielsweise jede dritte Zelle addiert. Gibt es in EXCEL eine Formel, mit der ich die jeweils n-te Zelle summieren kann?
Lösung
Es gibt in EXCEL zwar keine entsprechende fertige Formel, Sie können aber eine Formel aufbauen, die in einem Bereich immer eine n-te Zelle addiert.

Folgende Formel bildet beispielsweise die Summe über jede dritte Zelle im Bereich A1:A10:

=SUMME(WENN(REST(ZEILE(A1:A10);3)=0;A1:A10))

Da es sich um eine Matrixformel handelt, muß die Eingabe der Formel mit der Tastenkombination [STRG]+[UMSCHALT]+[EINGABE] abgeschlossen werden. EXCEL setzt nach dieser Tastenkombination automatisch geschweifte Klammern um die Formel und gibt den Wert zurück.

Erklärung:
Um die jeweils dritte Zelle in einem Bereich finden zu können, teilen Sie am besten die Zeilennummer durch das Inkrement. Wenn kein Rest bleibt, handelt es sich um eine "dritte Zelle". Um das zu ermitteln, wird die Funktion REST eingesetzt. Die zu dividierende Zahl, also die Zeilennummer, wird mit der Funktion ZEILE ermittelt.

Die Formel könnte so gelesen werden: Teile die Zeilennummer im Bereich A1 bis A10 durch das Inkrement 3 und summiere den entsprechenden Wert, wenn kein Rest verbleibt. Das Abschließen als Matrixformel sorgt dafür, daß das für jede Zelle geprüft werden kann. Die Matrix beinhaltet folgenden Wert:

{FALSCH;FALSCH;WAHR;FALSCH;FALSCH;WAHR; ... }

Immer wenn ein Wert WAHR erscheint, wird der Wert der entsprechenden Zelle in die Summe mit aufgenommen.

Weitere Informationen zu den einzelnen Funktionen der Formel finden Sie in der Online-Hilfe. Eine weitere Erleichterung bietet der Einsatz des Funktionsassistenten, den Sie mit dem Befehl FUNKTION aus dem Menü EINFÜGEN öffnen können. Er bietet Ihnen die Möglichkeit, die Formel Schritt für Schritt zu verschachteln.

Summe addieren Zeile Rest Matrix Inkrement
Eigenschaften

Artikelnummer: 504330 – Letzte Überarbeitung: 08/27/2002 00:00:00 – Revision: 1.0

Microsoft Excel für Windows

  • addieren inkrement matrix rest summe zeile KB504330
Feedback