Authentifizierung kann zeitweise fehlschlagen

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Problembeschreibung
Wenn Sie eine dreistufigen Anwendung Webumgebung, die Kerberos-Authentifizierung verwendet konfigurieren, finden Sie möglicherweise zeitweise diesen Client schlägt die Authentifizierung fehl. Im folgenden Szenario möglicherweise z. B. Ticket-genehmigendes Ticket (TGT) ablaufen, bevor der Client auf dem Zielcomputer authentifiziert wird, auf dem Microsoft SQL Server ausgeführt wird:
  1. Die Clientverbindung zum einen Microsoft Internet Information Services (IIS)-Webserver.
  2. Der Client leitet das TGT an den IIS-Server.
  3. Der IIS-Server ein Computer mit SQL Server mithilfe des Tickets, die vom Client weitergeleitet wurde eine Verbindung herstellt (Kerberos-Delegierung).
Die entsprechenden Eintrag -Funktion gibt einen SEC_E_NO_CREDENTIALS-Fehlercode zurück, in der SQL-Anwendung auf dem Server. Darüber hinaus erhält der Client die folgenden Fehlermeldung:
Der SSPI-Kontext kann nicht generiert werden
Ursache
Dieses Problem kann auftreten, wenn die AcquireCredentialsHandle -Funktion gibt eine falsche Ablaufzeit für das TGT. zurück Der PtsExpiry Parameter der Funktion AcquireCredentialsHandle spiegelt nicht die richtige Lebensdauer der weitergeleiteten TGT. wider.
Lösung

Hotfix-Informationen

Microsoft Windows 2000

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, senden Sie eine Anfrage an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website: Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Dieser Hotfix erfordert Windows 2000 Service Pack 4 (SP4).
Neustartanforderung
Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses hat, die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools „ Datum und Uhrzeit in der Systemsteuerung.
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Adsldp.dll5.0.2195.6748124,68819-Jun-200305: 28X 86
Adsldpc.dll5.0.2195.6748132,36819-Jun-200305: 28X 86
Adsmsext.dll5.0.2195.674863,76019-Jun-200305: 28X 86
"Advapi32.dll"5.0.2195.6743381,20019-Jun-200305: 28X 86
Browser.dll5.0.2195.675369,39206-Jun-200304: 53X 86
Dnsapi.dll5.0.2195.6680134,92819-Jun-200305: 28X 86
Dnsrslvr.dll: 00 5.0.2195.666392,43219-Jun-200305: 28X 86
EventLog.dll5.0.2195.675347.37619-Jun-200305: 28X 86
Kdcsvc.dll5.0.2195.6747148,24019-Jun-200305: 28X 86
Kerberos.dll5.0.2195.6758205,07218-Jun-200302: 43X 86
Ksecdd.sys5.0.2195.669571,88826-Mär-200306: 37X 86
Lsasrv.dll5.0.2195.6749509,71228-May-200305: 39X 86
"Lsass.exe"5.0.2195.674933,55228-May-200305: 39X 86
Msv1_0.dll5.0.2195.6680117,52004-Apr-200309: 12X 86
Netapi32.dll: 00 5.0.2195.6601311,56819-Jun-200305: 28X 86
Netlogon.dll5.0.2195.6695371,98419-Jun-200305: 28X 86
NTDSA.dll5.0.2195.66971,040,14419-Jun-200305: 28X 86
Samsrv.dll5.0.2195.6742392,46419-Jun-200305: 28X 86
SceCli.dll5.0.2195.6737131,34419-Jun-200305: 28X 86
Scesrv.dll5.0.2195.6737306,44819-Jun-200305: 28X 86
Sp3res.dll5.0.2195.67564,576,76817-Jun-200302: 54X 86
W32Time.dll: 00 5.0.2195.660151,47219-Jun-200305: 28X 86
W32tm.exe: 00 5.0.2195.660157,10415-Aug-200222: 32X 86
Wldap32.dll5.0.2195.6741126,22419-Jun-200305: 28X 86
Hinweis: Dieser Hotfix sollte auf dem IIS-Server und dem Client angewendet werden.

Microsoft Windows XP

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website: Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Dieser Hotfix erfordert Windows XP Service Pack 1 (SP1).
Neustartanforderung
Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools „ Datum und Uhrzeit in der Systemsteuerung. Microsoft Windows XP Service Pack 1 (SP1), 32-Bit-Versionen
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Kerberos.dll5.1.2600.1228273,92030-May-200305: 38X 86
Microsoft Windows XP Service Pack 1 (SP1), Itanium-basierte Versionen
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Kerberos.dll5.1.2600.1228929,79230-May-200305: 39IA-64
Wkerberos.dll5.1.2600.1228273,92030-May-200305: 11X 86
Status
Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.
Weitere Informationen
Weitere Informationen zur Benennung von Hotfix-Paketen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
816915Neues Schema für die Dateibenennung in Microsoft Windows-Softwareaktualisierungspaketen

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 818173 – Letzte Überarbeitung: 01/10/2015 14:00:05 – Revision: 5.4

Microsoft Windows 2000 Server SP4, Microsoft Windows 2000 Advanced Server SP4, Microsoft Windows XP Service Pack 1

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