Druckserver wird träge oder hat zu viele named Pipe-Verbindungen von Windows XP-basierten Computern

Der Support für Windows XP wurde eingestellt

Microsoft stellte am 8. April 2014 den Support für Windows XP ein. Diese Änderung wirkt sich auf Ihre Softwareupdates und Sicherheitsoptionen aus. Erfahren Sie, was das für Sie bedeutet und wie Sie Ihren Schutz aufrechterhalten können.

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Den englischen Originalartikel können Sie über folgenden Link abrufen: 835318
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Problembeschreibung
Beim von Ihrem Windows XP-Computer aus drucken, möglicherweise eine oder mehrere der folgenden Symptome auftreten:
  • Der Druckserver empfängt viele Druckaufträge in kurzer Zeit.
  • Der lokale Computer wird träge und nicht mehr reagiert, nachdem mehrere Dokumente gedruckt.
  • Die Anwendung Spoolsv.exe verwendet viele Systemressourcen.
  • Windows öffnet zu viele named Pipe-Verbindungen mit dem Druckserver. Einzelne Windows XP-basierten Computern möglicherweise mehrere Hundert Verbindungen.
Ursache
Diese Probleme möglicherweise auftreten, wenn die Windows- Win32spl.dll-CacheOpenPrinter -Funktion an die Funktion RemoteOpenPrinter asynchron aufruft. Diese asynchronen Aufrufe führen die Funktion CacheOpenPrinter , um mehrere Aufrufe der Funktion RemoteOpenPrinter für eine einzelne drucken Auftrag vornehmen, bevor die Funktion RemoteOpenPrinter bestätigt, dass eine Verbindung hergestellt wird. Jedem Aufruf generiert eine neue Verbindung mit dem Druckserver.
Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Microsoft Windows XP, um dieses Problem zu beheben. Weitere Informationen finden Sie die folgende KB-Artikelnummer:
322389Wie Sie das neueste Service Pack für Windows XP erhalten

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website: Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.Die englische Version dieses Updates besitzt die Dateiattribute (oder höher), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time () angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools „ Datum und Uhrzeit in der Systemsteuerung.

Windows XP

   Date         Time   Version            Size    File name   --------------------------------------------------------------   26-Jan-2004  02:32  5.1.2600.1335      92,672  Win32spl.dll        26-Jan-2004  02:32  5.1.2600.1335     131,072  Winspool.drv

Windows XP 64-Bit Edition

   Date         Time   Version            Size    File name       Platform   -----------------------------------------------------------------------   26-Jan-2004  02:26  5.1.2600.1335     285,184  Win32spl.dll     IA-64   26-Jan-2004  02:26  5.1.2600.1335     433,664  Winspool.drv     IA-64   26-Jan-2004  02:32  5.1.2600.1335      92,672  Wwin32spl.dll    x86   26-Jan-2004  02:32  5.1.2600.1335     131,072  Wwinspool.drv    x86
Status
Microsoft hat bestätigt, dass dies ein Problem in den Microsoft-Produkten ist, die im Abschnitt "Gilt für" dieses Artikels aufgeführt sind.Dieses Problem wurde erstmals im Microsoft Windows XP Service Pack 2.
Weitere Informationen
Weitere Informationen finden Sie die folgende KB-Artikelnummer:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 835318 – Letzte Überarbeitung: 01/12/2015 23:10:12 – Revision: 2.5

Microsoft Windows XP 64-Bit Edition Version 2003, Microsoft Windows XP Professional, Microsoft Windows XP Home Edition, Microsoft Windows XP 64-Bit Edition Version 2002

  • kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB835318 KbMtde
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