Fehler beim Versuch, den Abschlussprozess zum Jahresende im Hauptbuch in Microsoft Dynamics GP durchzuführen: Konto mit einbehaltenen Einnahmen nicht gefunden

Dieser Artikel bietet Lösungen für einen Fehler, der auftritt, wenn Sie den Abschlussprozess zum Jahresende im Hauptbuch in Microsoft Dynamics GP durchführen.

Gilt für: Microsoft Dynamics GP
Ursprüngliche KB-Nummer: 850741

Symptome

Wenn Sie versuchen, den Abschlussprozess zum Jahresende im Hauptbuch in Microsoft Dynamics GP durchzuführen, erhalten Sie die folgende Fehlermeldung:

Konto mit einbehaltenen Einnahmen nicht gefunden.

Das Einbehaltungskonto wurde nicht gefunden.

Ursache

Dieses Problem tritt auf, wenn Sie im Fenster Hauptbucheinrichtung das Kontrollkästchen Bei Segmenten des Divisionskontos schließen aktivieren.

Darüber hinaus kann die Fehlermeldung aufgrund einer der folgenden Ursachen auftreten:

Ursache 1

Es wird nur ein Konto mit einbehaltenen Einnahmen eingerichtet. Das Kontrollkästchen An Abteilungskontosegmenten schließen ist jedoch im Fenster Hauptbucheinrichtung aktiviert. Siehe Auflösung 1.

Ursache 2

Gewinnrückbehaltungskonten werden ohne ein gemeinsames Segment eingerichtet, das geschlossen werden muss. Siehe Auflösung 2.

Ursache 3

Das Kontrollkästchen An Abteilungskontosegmenten schließen ist aktiviert. Das Konto "Gewinnrückbehaltungen" ist jedoch nicht für jede Segmentabteilung eingerichtet. Siehe Auflösung 3.

Ursache 4

Die Konten mit den einbehaltenen Einnahmen enthalten Leerzeichen. Siehe Auflösung 4.

Ursache 5

Die Tabelle GL00105 Kontoindex weist einen beschädigten Datensatz auf. Siehe Auflösung 5.

Ursache 6

Wenn Sie das Schließen für Re-Abteilungskonten verwenden, wird nach Einheitenkonten gesucht. Siehe Auflösung 6.

Lösung

Bevor Sie eine dieser Lösungen ausführen, stellen Sie sicher, dass sich alle anderen Benutzer von Microsoft Dynamics GP oder Microsoft Business Solutions – Great Plains abmelden. Stellen Sie außerdem sicher, dass Sie eine wiederherstellbare Sicherung der Unternehmensdatenbank erstellen.

Lösung 1

Um dieses Problem zu beheben, deaktivieren Sie im Fenster Hauptbucheinrichtung das Kontrollkästchen Bei Segmenten von Divisionen schließen. Gehen Sie dazu wie folgt vor:

  1. Öffnen Sie das Fenster Hauptbucheinrichtung, klicken Sie im Menü Microsoft Dynamics GP auf Extras, zeigen Sie auf Setup, zeigen Sie auf Finanzen, und klicken Sie dann auf Hauptbuch.
  2. Deaktivieren Sie im Fenster Hauptbucheinrichtung das Kontrollkästchen Bei Divisionskontosegmenten schließen .
  3. Klicken Sie auf OK, um die Änderungen zu speichern.

Lösung 2

Um dieses Problem zu beheben, schließen Sie nur ein Segment der verschiedenen Kontonummern für "Einbehaltungen" an. Sie können nicht mehr als ein Segment der Kontonummern schließen.

Beispiel

In diesem Beispiel gibt es die folgenden Kontonummern für beibehaltene Einnahmen:

  • A-000-3030-00
  • B-100-3030-00
  • C-200-3030-00

In diesem Beispiel können Sie nicht mit dem zweiten Segment der Kontonummern schließen. Die zweiten Segmente sind 000, 100 und 200. Nachdem Sie sich für das Segment entschieden haben, durch das Sie schließen möchten, müssen die restlichen Segmente identisch sein. Daher haben Sie in diesem Beispiel die folgenden Optionen:

  • Wenn Sie das zweite Segment schließen möchten, müssen Sie das erste Segment (den Buchstaben) so ändern, dass es für alle Konten identisch ist. Wenn Sie z. B. das zweite Segment und die einbehaltenen Segmente verwenden möchten, ändern Sie die ersten Segmente wie folgt:
    • A-000-3030-00
    • A-100-3030-00
    • A-200-3030-00
  • Wenn Sie das erste Segment schließen möchten, müssen Sie das zweite Segment so ändern, dass es für alle Konten gleich ist. Sie können das zweite Segment mit einer der folgenden Optionen ändern:
    • A-000-3030-00, B-000-3030-00, C-000-3030-00
    • A-100-3030-00, B-100-3030-00, C-100-3030-00
    • A-200-3030-00, B-200-3030-00, C-200-3030-00

Lösung 3

Vergewissern Sie sich, dass keine Segmentabteilung über ein Konto für "Gewinnaufbehaltungen" verfügt, das für sie erstellt wurde. Gehen Sie dazu wie folgt vor:

  1. Öffnen Sie das Fenster Kontosegmenteinrichtung, klicken Sie im Menü Microsoft Dynamics GP auf Extras, zeigen Sie auf Setup, zeigen Sie auf Finanzwesen, und klicken Sie dann auf Segment.

  2. Klicken Sie auf die Nachschlageschaltfläche neben dem Feld Segment , und notieren Sie sich das Kontosegment, das im Fenster Hauptbucheinrichtung zugewiesen ist.

  3. Verwenden Sie die Nachschlageschaltfläche neben dem Feld Zahl .

  4. Notieren Sie sich die Segmentnummern, die Sie mithilfe der Schaltfläche für die Segmentsuche anzeigen können.

  5. Öffnen Sie das Fenster Kontowartung. Klicken Sie dazu auf Karten, zeigen Sie auf Finanzdaten, und klicken Sie dann auf Konto.

  6. Stellen Sie sicher, dass für alle in Schritt 4 aufgeführten Segmente entsprechende Konten mit einbehaltenen Einnahmen eingerichtet sind.

    Beispiel:

    Die folgenden Bedingungen sind erfüllt:

    • Sie verfügen über die Kontonummer 000-3030-00.
    • Das erste Segment der Kontonummer wird als Segment des Divisionskontos eingerichtet.
    • Sie haben festgestellt, dass für das erste Segment die folgenden Zahlen eingerichtet sind: 000, 100, 200, 300 und 400.

    In diesem Beispiel müssen Sie überprüfen, ob auch die folgenden Kontonummern für gewinnbehaltene Einnahmen eingerichtet sind:

    • 100-3030-00
    • 200-3030-00
    • 300-3030-00
    • 400-3030-00
  7. Wenn nicht alle Segmente eingerichtet sind, richten Sie sie jetzt im Fenster Kontowartung ein. Klicken Sie dazu auf Karten, zeigen Sie auf Finanzdaten, und klicken Sie dann auf Konto.

Lösung 4

Um dieses Problem zu beheben, ermitteln Sie, ob die Kontonummern für "Einbehaltene Einnahmen" Leerzeichen enthalten. Gehen Sie dazu wie folgt vor:

  1. Öffnen Sie das Fenster Kontowartung. Klicken Sie dazu auf Karten, zeigen Sie auf Finanzen , und klicken Sie dann auf Konto.

  2. Wählen Sie eines der Konten mit einbehaltenen Einnahmen aus, und überprüfen Sie dann die Kontonummer, um sicherzustellen, dass darin keine Leerzeichen vorhanden sind.

    Beispiel:

    • Sie verfügen über die Kontonummer 000-3030-00.
    • Das erste Segment der Kontonummer wird als Segment des Divisionskontos eingerichtet.
    • Sie haben festgestellt, dass für das erste Segment die folgenden Zahlen eingerichtet sind: 000, 100, 200, 300 und 400.

    In diesem Beispiel müssen Sie überprüfen, ob auch die folgenden Kontonummern für gewinnbehaltene Einnahmen eingerichtet sind:

    • 100-3030-10
    • 200-3030-20
    • 300-3030-30
    • 400-3030-40

    Möglicherweise haben Sie jedoch versehentlich die Segmentlänge des ersten Segments auf vier Zeichen erhöht, und Microsoft Dynamics GP erkennt die Ursprünglich erstellten Konten mit den beibehaltenen Einnahmen nicht. Wenn Sie das erste Segment erhöhen, würden die Kontonummern wie folgt aussehen:

    • 100X-3030-10
    • 200X-3030-20
    • 300X-3030-30
    • 400X-3030-40

    Hinweis

    In diesen Zahlen stellt X einen Leerraum dar.

    Wenn in den Kontonummern Leerzeichen vorhanden sind, fahren Sie mit den folgenden Schritten fort.

  3. Öffnen Sie das Fenster Abstimmen. Klicken Sie hierzu im Menü Microsoft Dynamics GP auf Extras, zeigen Sie auf Hilfsprogramme, zeigen Sie auf System, und klicken Sie dann auf Abstimmen.

    Hinweis

    Der Befehl "Abgleichen" setzt das Kontosegmentformat auf die ursprünglichen Segmentlängen zurück. Die Abstimmung funktioniert nur, wenn keine Konten mit einer tatsächlichen Länge des ersten Segments von vier Zeichen(ohne Leerzeichen) vorhanden sind. Das heißt, keine Konten mit einem ersten Segment wie 1000 wie im Beispiel 1000-1100-00. Wenn dies der Fall ist, rückgängig machen die Segmentlänge bis zu drei Zeichen.

  4. Wählen Sie Kontoformat einrichten aus, und klicken Sie dann auf Einfügen.

  5. Klicken Sie auf Abgleichen, und geben Sie dann das Fehlerprotokoll auf dem Bildschirm aus.

    Hinweis

    Die Tabelle Kontoindexmaster (GL00105) enthält wahrscheinlich weiterhin die Konten, die die Kontolänge von vier Zeichen verwenden. Daher müssen Sie die Tabelle mithilfe der SQL-Wartung neu erstellen.

  6. Öffnen Sie das Fenster SQL-Wartung. Zeigen Sie hierzu im Menü Microsoft Dynamics GP auf Wartung, und klicken Sie dann auf SQL.

  7. Wählen Sie die Unternehmensdatenbank und dann Microsoft Dynamics GP unter Produkt aus.

  8. Wählen Sie unter Finanzreihe die Tabelle Kontoindexmaster aus.

  9. Aktivieren Sie alle Kontrollkästchen, und klicken Sie dann auf Verarbeiten.

    Hinweis

    Nachdem die GL00105 Tabelle neu erstellt wurde, müssen Sie die Daten mithilfe von Links überprüfen wiederherstellen.

  10. Öffnen Sie das Fenster Links überprüfen. Zeigen Sie hierzu im Menü Microsoft Dynamics GP auf Wartung, und klicken Sie dann auf Links überprüfen.

  11. Wählen Sie Finanzwesen als Serie aus, und fügen Sie dann die logischen Tabellen des Kontomasters ein.

  12. Klicken Sie auf OK , um den Prozess zu starten.

    Hinweis

    Die Informationen in der Tabelle Kontomaster (GL00100) sollten jetzt die GL00105 Tabelle auffüllen.

Lösung 5

  1. Öffnen Sie SQL Server Management Studio.

  2. Führen Sie in einem Abfragefenster dieses Skript für die Unternehmensdatenbank aus:

    Delete GL00105
    
  3. Öffnen Sie Microsoft Dynamics GP. Zeigen Sie im Menü Microsoft Dynamics GP auf Wartung, und klicken Sie dann auf Links überprüfen.

  4. Wählen Sie Finanzreihe aus.

  5. Klicken Sie in der Liste Logische Tabellen auf Kontomaster. Klicken Sie auf Einfügen.

  6. Klicken Sie dann auf OK , um Überprüfungslinks auszuführen. Drucken Sie das Fehlerprotokoll auf dem Bildschirm.

  7. Testen Sie es erneut.

Lösung 6

Möglicherweise müssen Sie zusätzliche Abteilungs-RE-Konten mit leeren Segmenten einrichten, um "Einheitenkonten" zu berücksichtigen, damit sie erfolgreich geschlossen werden können. (Zeigen Sie die Struktur Ihrer Einheitenkonten im Vergleich dazu an, wie Ihre Divisional RE-Konten aussehen sollten und in welchem Segment Sie schließen.) Hierfür wurde ein Qualitätsproblem protokolliert, da das System während des RE-Prozesses keine Einheitenkonten untersuchen sollte.