Der Terminaldienste-Desktop ist leer, wenn Sie zu einem Windows 2000-basierten Remotecomputer anmelden

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Den englischen Originalartikel können Sie über folgenden Link abrufen: 887961
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Problembeschreibung
Sie Terminaldienste verwenden, um an einem Computer anmelden, auf dem Microsoft Windows 2000 mit Service Pack 4 (SP4) ausgeführt wird, und die Terminaldienste-Sitzung startet ein Programm. Ein Programm, das in der Sitzung ausgeführt und Sie die Verbindung trennt. Nachdem Sie erneut auf dem gleichen Computer anmelden, ist der Terminaldienste-Sitzung Desktop leer. Keine Symbole oder einer Taskleiste auf dem Terminaldienste-Sitzung-Desktop angezeigt.
Ursache
Dieses Problem, da ein Problem bei der Installation der 830869 Hotfix auf dem Remotecomputer eingeführt wurde. Dieses Problem tritt auf, wenn die Terminaldienste-Sitzung heruntergefahren wird und die ExitWindowsEx -Funktion aufgerufen. Wenn diese Funktion aufgerufen wird, wird das EWX_FORCE-Flag nicht erzwungen. Dieses Flag erzwingt Sitzung Prozesse beenden.
Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, senden Sie eine Anfrage an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website: Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix installieren, müssen Sie Microsoft Windows 2000 Service Pack 3 auf Ihrem Computer installiert haben.

Neustartanforderung

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt den Hotfix 830869.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time () angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools „ Datum und Uhrzeit in der Systemsteuerung.
   Date         Time   Version              Size  File name   -----------------------------------------------------------   24-Mar-2004  02:17  5.0.2195.6876     388,368  Advapi32.dll   24-Mar-2004  02:17  5.0.2195.6866      69,904  Browser.dll   24-Mar-2004  02:17  5.0.2195.6824     134,928  Dnsapi.dll   24-Mar-2004  02:17  5.0.2195.6876      92,432  Dnsrslvr.dll   24-Mar-2004  02:17  5.0.2195.6883      47,888  Eventlog.dll   24-Mar-2004  02:17  5.0.2195.6890     143,632  Kdcsvc.dll   11-Mar-2004  02:37  5.0.2195.6903     210,192  Kerberos.dll   21-Sep-2003  00:32  5.0.2195.6824      71,888  Ksecdd.sys   11-Mar-2004  02:37  5.0.2195.6902     520,976  Lsasrv.dll   25-Feb-2004  23:59  5.0.2195.6902      33,552  Lsass.exe   11-Mar-2004  02:37  5.0.2195.6897     123,152  Msv1_0.dll   10-Jun-2004  16:58  5.0.2195.6949     309,008  Netapi32.dll   24-Mar-2004  02:17  5.0.2195.6891     371,472  Netlogon.dll   24-Mar-2004  02:17  5.0.2195.6896   1,028,880  Ntdsa.dll   19-Jun-2003  20:05  5.0.2195.6702      66,320  Ntprint.dll   11-Mar-2004  21:29  5.0.2195.6906     954,640  Ole32.dll   19-Jun-2003  20:05  5.0.2195.6702     381,712  Printui.dll   11-Mar-2004  21:29  5.0.2195.6904     449,808  Rpcrt4.dll   11-Mar-2004  21:29  5.0.2195.6906     211,728  Rpcss.dll   24-Mar-2004  02:17  5.0.2195.6897     388,368  Samsrv.dll   24-Mar-2004  02:17  5.0.2195.6893     111,376  Scecli.dll   24-Mar-2004  02:17  5.0.2195.6903     253,200  Scesrv.dll   30-Oct-2004  07:07  5.0.2195.6994   6,140,416  Sp3res.dll   24-Mar-2004  02:17  5.0.2195.6824      50,960  W32time.dll   21-Sep-2003  00:32  5.0.2195.6824      57,104  W32tm.exe   17-Nov-2004  17:11  5.0.2195.7000      57,104  Wlnotify.dll
Abhilfe
Um dieses Problem zu umgehen, gehen Sie folgendermaßen vor in Terminaldienste-Client-Sitzung mit der Option Kennwortschutz Bildschirmschoner Bildschirm zu deaktivieren.

Hinweis: Wir empfehlen, dass keinen Bildschirmschoner mit dem Terminaldienste-Sitzung aufgrund der erhöhten Netzwerkbandbreite Verwendung, die erforderlich ist.
  1. Klicken Sie auf Start , klicken Sie auf Systemsteuerung und doppelklicken Sie dann auf das Element Anzeige in der Systemsteuerung.
  2. Klicken Sie auf die Registerkarte Bildschirmschoner , deaktivieren Sie den Kennwortschutz und klicken Sie dann auf OK .
Wenn Sie Sitzungen im Leerlauf trennen möchten, Festlegen des Leerlaufsitzungslimits in den Terminaldiensten. Gehen Sie hierzu für alle Sitzungen auf dem Computer mit Terminaldiensten eingeschaltet folgendermaßen vor.
  1. Klicken Sie auf Start , zeigen Sie auf Programme , zeigen Sie auf Verwaltung und klicken Sie dann auf Terminaldienstekonfiguration .
  2. Doppelklicken Sie unter Verbindungen auf RDP-Tcp , und klicken Sie dann auf die Registerkarte Sitzungen .
  3. Klicken Sie auf Benutzereinstellungen außer Kraft setzen .
  4. Klicken Sie im Leerlaufsitzungslimit des Leerlaufsitzungslimits, die Sie möchten.
  5. Klicken Sie auf der zweiten Benutzereinstellungen überschreiben das Kontrollkästchen, und klicken Sie dann auf die Option Sitzung trennen .
  6. Klicken Sie auf OK .
  7. Beenden Sie Terminaldienstekonfiguration.
Status
Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.
Weitere Informationen
Weitere Informationen zu 830869 Hotfix finden Sie die folgende KB-Artikelnummer:
830869Der Benutzer ist zwangsweise abgemeldet, wenn ein Programm die ExitWindowsEx-Funktion aufruft, auch wenn der Computer gesperrt ist
Weitere Informationen über die neue Datei Namensschema für Microsoft Windows-Softwareupdatepakete finden Sie die folgende KB-Artikelnummer:
816915Neues Schema für die Dateibenennung in Microsoft Windows-Softwareaktualisierungspaketen
Weitere Informationen zur Terminologie, die in diesem Artikel verwendet wird, finden Sie die folgende KB-Artikelnummer:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 887961 – Letzte Überarbeitung: 01/16/2015 01:37:10 – Revision: 1.5

Microsoft Windows 2000 Server SP4, Microsoft Windows 2000 Advanced Server SP4, Microsoft Windows 2000 Professional SP4

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