Der Befehl RSH akzeptiert keine Eingabe, die aus einer Datei in Windows XP Professional mit Service Pack 2 und Windows Server 2003 mit Service Pack 1 geleitet

Der Support für Windows Server 2003 ist am 14. Juli 2015 abgelaufen.

Microsoft beendete den Support für Windows Server 2003 am 14. Juli 2015. Diese Änderung wirkt sich auf Ihre Softwareupdates und Sicherheitsoptionen aus. Erfahren Sie, was das für Sie bedeutet und wie Sie Ihren Schutz aufrechterhalten können.

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Problembeschreibung
Wenn Sie den Befehl RSH auf einem Computer, auf dem Microsoft Windows XP Professional mit Service Pack 2 (SP2) ausgeführt wird verwenden, akzeptiert der Befehl RSH keine Eingabe, die aus einer Datei geleitet.

Beispielsweise tritt dieses Verhalten, wenn Sie den folgenden Befehl aus einer Textdatei statt über die Tastatur input gelesen:
Rsh User_Name CommandHostName -l <.txt Input_File_Name
Hinweis: Command gibt den Befehl, den Sie auf remote Host ausführen möchten.

Darüber hinaus erhalten Sie eine Fehlermeldung, die der folgenden ähnelt:
Terminals lesen: das Handle ist ungültig.
Ursache
Dieses Problem, da der Befehl RSH Eingabe nur von der Tastatur in Windows XP SP2 akzeptiert.
Lösung

Windows Server 2003

Windows Server 2003 Service Pack-Informationen

Installieren Sie das neueste Servicepack für Windows Server 2003, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100So erhalten Sie das neueste Servicepack für Windows Server 2003

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website: Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Dieser Hotfix hat keine Voraussetzungen.

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools „ Datum und Uhrzeit in der Systemsteuerung.
Windows Server 2003 x 86-basierte Versionen
Date         Time   Version         Size    File name -------------------------------------------------------------- 21-Sep-2005  01:09  5.2.3790.2532  13,824   Rexec.exe 21-Sep-2005  01:09  5.2.3790.2532  14,848   Rsh.exe
Windows Server 2003, Itanium-basierte Versionen
Date         Time   Version         Size    File name -------------------------------------------------------------- 20-Sep-2005  11:54  5.2.3790.2532  26,624   Rexec.exe IA-64 20-Sep-2005  11:54  5.2.3790.2532  28,672   Rsh.exe IA-64 20-Sep-2005  11:54  5.2.3790.2532  13,824   Wrexec.exe x86 20-Sep-2005  11:54  5.2.3790.2532  14,848   Wrsh.exe x86
Windows Server 2003 x 64-basierte Versionen
Date         Time   Version          Size   File name -------------------------------------------------------------- 20-Sep-2005  11:54  5.2.3790.2532   18,432  Rsh.exe 20-Sep-2005  11:54  5.2.3790.2532   13,824  Wrexec.exe 20-Sep-2005  11:54  5.2.3790.2532   14,848  Wrsh.exe

Windows XP

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website: Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Dieser Hotfix hat keine Voraussetzungen.

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools „ Datum und Uhrzeit in der Systemsteuerung.
Windows XP SP2
Date        Time   Version       Size    File name----------------------------------------------------30-Mar-2005 01:01 5.1.2600.2643  13,824  Rexec.exe30-Mar-2005 01:01 5.1.2600.2643  14,848  Rsh.exe25-Feb-2005 03:53 6.1.22.4      371,936  Updspapi.dll
Status
Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals im Microsoft Windows Server 2003 Service Pack 2.
Weitere Informationen
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Warnung: Dieser Artikel wurde automatisch übersetzt

Eigenschaften

Artikelnummer: 896336 – Letzte Überarbeitung: 01/16/2015 09:03:26 – Revision: 3.7

  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • kbnosurvey kbarchive kbmt kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbfix kbbug KB896336 KbMtde
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