How to add the document number and the document due date from invoices to the Computer Checks Posting Journal report in Microsoft Dynamics GP

SUMMARY
This article describes how to add the document number and the document due date from invoices to the Computer Checks Posting Journal report.
INTRODUCTION
This article contains step-by-step instructions about how to add the document number and the due date of the invoices that are being paid on the Computer Check Edit List. This report is named the Computer Checks Posting Journal report in Report Writer.

Notes
  • You can also apply these steps to add the document number and the document due date to the MC Computer Checks Posting Journal report.
  • After you follow these steps, the general ledger distributions no longer appear in the Computer Checks Posting Journal report.
MORE INFORMATION
To add the document number and the document due date to the Computer Checks Posting Journal report, follow these steps.

Step 1: Start Report Writer

  • In Microsoft Dynamics GP 10.0, point to Tools on the Microsoft Dynamics GP menu, point to Customize, and then click Report Writer. In the Product list, click Microsoft Dynamics GP.
  • In Microsoft Dynamics GP 9.0 and in Microsoft Business Solutions - Great Plains 8.0, click Tools, point to Customize, and then click Report Writer. In the Product list, click Great Plains.

Step 2: Add a table relationship

  1. On the toolbar, click the Reports button.
  2. In the Report Writer window, click the Computer Check Posting Journal report in the Original Reports list, and then click Insert.
  3. In the Modified Reports list, click the Computer Check Posting Journal report, and then click Open.
  4. In the Report Definition window, click the Tables button.
  5. In the Report Table Relationships window, highlight the Payables Journal Distributions Temporary File*, and then click Remove.
  6. Click OK when you see the following message:
    Are you sure you want to remove this table and its related tables? Remove all corresponding tables.
  7. In the Report Table Relationships window, highlight PM Payment WORK*, and then click New.
  8. In the Related Tables window, highlight PM Payment Apply To Work File*, and then click OK to close the window.
  9. In the Report Table Relationships window, click Close.

Step 3: Create the report restriction

  1. In the Report Definition window, click the Restrictions button.
  2. In the Report Restrictions window, highlight the Dummy4 restriction, and then click Delete.
  3. Click Yes when you see the following message:
    Do you want to delete this restriction?
  4. In the Report Restrictions window, click New.
  5. In the Report Restriction Definition window, type a name in the Restriction Name field. For example, type 912953.
  6. Select PM Payment Apply To Work File for the Report Table.
  7. Select Apply To Voucher Number for the Table Fields.
  8. Click Add Field.
  9. In the Operators box, select the equal sign (=).
  10. Again, in the Fields box, click Add Field. This will create the following restriction expression:
    PM_Payment_Apply_WORK.Apply to Voucher Number=PM_Payment_Apply_WORK.Apply to Voucher Number
  11. Click OK to close the Report Restriction Definition window.
  12. Close the Report Restrictions window.

Step 4: Add the Invoice Number and Document Due Date fields to the report layout

  1. In the Report Definition window, click the Layout button. The Report Layout window opens.
  2. Delete the following fields from the body (B) of the report:
    • Field9
    • Field2
    • Field3
    • Field4
    • Field5
  3. In the Toolbox window, drag the following fields from the PM Payment Apply To Work file table to the body (B) of the report:
    • Apply To Voucher Number
    • Document Number
    • Document Due Date
    • Amount Paid
    Note You will have to rearrange or remove some existing fields in the body (B) to make room for the new field.
  4. Close the layout, and click Save when you are prompted to save the changes to the report layout.

Step 5: Save the changes to the report, and then exit Report Writer

  1. On the File menu, click Microsoft Dynamics GP.
  2. Click Save when you are prompted to save the changes to the report layout.
  3. Click Save when you are prompted to save the changes to the modified report.
  4. Exit Report Writer.

Step 6: Assign security permissions to the modified report

To assign security permissions to the modified report, use one of the following methods.

Method 1: Use security in Microsoft Dynamics GP 10.0

  1. Point to Tools on the Microsoft Dynamics GP menu, point to Setup, point to System, and then click Alternate/Modified Forms and Reports.
  2. In the ID box, type the Alternate/Modified Forms and Reports ID associated with the user ID that will print this modified report.
  3. In the Product list, click Microsoft Dynamics GP.
  4. In the Type list, click Reports.
  5. Expand the Purchasing folder.
  6. Expand the folder for the report that you modified.
  7. Click Microsoft Dynamics GP (Modified).
  8. Click Save.
  9. On the Microsoft Dynamics GP menu, point to Tools, point to Setup, point to System, and then click User Security.
  10. In the User list, click a user ID.
  11. In the Company list, click a company.
  12. In the Alternate/Modified Forms and Reports ID list, click the ID that you typed in step 2.

Method 2: Use the Advanced Security tool in a version earlier than Microsoft Dynamics GP 10.0

  1. On the Tools menu, point to Setup, point to System, and then click Advanced Security.
  2. If you are prompted, type the system password in the Please Enter Password box, and then click OK.
  3. In the Advanced Security window, click View, and then click By Alternate, Modified and Custom.
  4. Use the appropriate step:
    • In Microsoft Dynamics GP 9.0, expand Microsoft Dynamics GP.
    • In Microsoft Business Solutions - Great Plains 8.0, expand Great Plains.
  5. Expand Reports, expand Sales, and then expand the report that you modified.
  6. Use the appropriate step:
    • In Microsoft Dynamics GP 9.0, click Microsoft Dynamics GP (Modified).
    • In Microsoft Business Solutions - Great Plains 8.0, click Great Plains (Modified).
  7. Click Apply, and then click OK.

    Note By default, when you start the Advanced Security tool, the current user and the current company are selected. Any changes that you make are for the current user and the current company. However, you can select additional users and companies in the Company area and in the User area of the Advanced Security window.

Method 3: Use the Standard Security tool in a version earlier than Microsoft Dynamics GP 10.0

  1. On the Tools menu, point to Setup, point to System, and then click Security.
  2. If you are prompted, type the system password in the Please Enter Password box, and then click OK.
  3. In the User ID list, click the user ID for the user who you want to have access to the report.
  4. In the Type list, click Modified Reports.
  5. In the Series list, click Purchasing.
  6. In the Access List box, double-click the report that you modified, and then click OK.

    Note An asterisk (*) appears next to the report name.
TK 7140
Eigenschaften

Artikelnummer: 912953 – Letzte Überarbeitung: 07/26/2011 07:07:00 – Revision: 3.0

  • Microsoft Dynamics GP 2010
  • Payables Management
  • Report Writer
  • kbmbsmigrate kbhowto KB912953
Feedback