"Ihre Anmeldung wurde aus der Benutzeraktivitätsdatei entfernt, und Sie können sich nicht im Buchhaltungssystem befinden" Fehlermeldung beim Starten von Microsoft Dynamics GP

Dieser Artikel bietet eine Lösung für einen Fehler, der beim Starten von Microsoft Dynamics GP auftritt.

Gilt für: Microsoft Dynamics GP
Ursprüngliche KB-Nummer: 916679

Symptome

Wenn Sie Microsoft Dynamics GP starten, erhalten Sie die folgende Fehlermeldung:

Ihre Anmeldung wurde aus der Benutzeraktivitätsdatei entfernt, und Sie können sich nicht im Buchhaltungssystem befinden.

Ursache

Dieses Problem tritt auf, wenn ein automatisches Clientupdate veröffentlicht wird. Außerdem ist der Pfad der Microsoft Windows Installer-Datei (MSP-Datei) falsch, oder die MSP-Datei fehlt.

Lösung

Verwenden Sie eine der folgenden Methoden, um das Problem zu beheben.

Methode 1

Wenn das Clientupdate bereits auf allen Clients installiert ist, löschen Sie das veröffentlichte Clientupdate. Gehen Sie dazu wie folgt vor:

  1. Melden Sie sich mit einem Systemadministratorbenutzerkonto (sa) bei Microsoft Dynamics GP an.
  2. Verwenden Sie den entsprechenden Schritt:
    • Zeigen Sie in Microsoft Dynamics GP im Menü Microsoft Dynamics GP auf Tools, zeigen Sie auf Setup, zeigen Sie auf System, und wählen Sie dann Client Updates aus.
    • Zeigen Sie in Microsoft Dynamics GP 9.0 im Menü Extras auf Setup, zeigen Sie auf System, und wählen Sie dann Client Updates aus.
  3. Wählen Sie im Fenster Automatisierte Client-Updates verwalten das Symbol neben dem Feld Updatename aus.
  4. Wählen Sie im fenster Updates das Update aus, das Sie installiert haben, und wählen Sie dann Auswählen aus.
  5. Wählen Sie im Fenster Automatisierte Client-Updates verwaltendie Option Löschen aus.

Methode 2

Wenn Sie das Clientupdate beibehalten möchten, überprüfen Sie, ob die MSP-Datei vorhanden ist und der Pfad der MSP-Datei korrekt ist. Gehen Sie dazu wie folgt vor:

  1. Melden Sie sich mit einem sa-Benutzerkonto bei Microsoft Dynamics GP an.
  2. Zeigen Sie im Menü Extras auf Setup, zeigen Sie auf System, und wählen Sie dann Client Updates aus.
  3. Wählen Sie im Fenster Automatisierte Client-Updates verwalten das Symbol neben dem Feld Updatename aus.
  4. Überprüfen Sie im fenster Updates, ob der Pfad der MSP-Datei korrekt ist. Korrigieren Sie den Pfad, wenn er falsch ist.
  5. Vergewissern Sie sich, dass sich die MSP-Datei im Verzeichnis am Ende des Pfads befindet.

Methode 3

Wenn sich kein Benutzer beim System anmelden kann, entfernen Sie das automatische Clientupdate aus der Tabelle für automatische Clientupdates in der DYNAMICS-Datenbank. Gehen Sie dazu wie folgt vor:

  1. Vergewissern Sie sich, dass Sie über eine Sicherung der DYNAMICS-Datenbank verfügen.

  2. Öffnen Sie SQL Query Analyzer oder SQL Server Management Studio.

  3. Führen Sie die folgende SQL-Anweisung aus, um alle automatischen Clientupdates anzuzeigen.

    select * from DYNAMICS..SYUPDATE
    
  4. Entfernen Sie das automatische Clientupdate ohne gültigen UNCPath.Remove the automatic client update that doesn't have a valid UNCPath. Führen Sie dazu das folgende Skript aus.

    delete DYNAMICS..SYUPDATE where UPDATENAME = 'XXXX'
    

    Hinweis

    Ersetzen Sie "XXXX" durch den richtigen Updatenamen.

  5. Melden Sie sich bei Microsoft Dynamics GP an.

Status

Microsoft hat bestätigt, dass es sich um ein Problem in den Microsoft-Produkten handelt, die im Abschnitt Gilt für aufgeführt sind. Dieses Problem soll nicht behoben werden.