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Nach der Aktualisierung auf Windows Vista kann ein Programm nicht deinstalliert werden

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
927395 You cannot uninstall a program after you upgrade to Windows Vista
Zusammenfassung
Dieser Artikel beschreibt Methoden, die Sie anwenden können, wenn Sie Probleme mit der Deinstallation eines Programms auf Windows Vista haben, nachdem Sie den Computer von einer früheren Windows-Version aktualisiert haben. Diese Probleme können auftreten, wenn das Programm oder sein Installationsprogramm nicht mit Windows Vista kompatibel ist. Dieser Artikel enthält schrittweise Anleitungen zum Deinstallieren des Programms.
Problembeschreibung
Nachdem Sie ein Upgrade von einer früheren Windows-Version auf Windows Vista durchgeführt haben, können Sie ein Programm nicht deinstallieren. Dieses Problem tritt unabhängig davon auf, ob Sie das Systemsteuerungsprogramm Programme und Funktionen oder das Installationsprogramm des Programms verwenden.
Ursache
Dieses Problem kann auftreten, wenn das Programm oder sein Installationsprogramm nicht mit Windows Vista kompatibel ist.
Lösung
Wenden Sie die folgenden Methoden in der angegebenen Reihenfolge an, um dieses Problem zu beheben.

Methode 1: Deinstallieren Sie das Programm über das Systemsteuerungsprogramm Programme und Funktionen

Gehen Sie folgendermaßen vor, wenn Sie noch nicht versucht haben, das Programm mithilfe des Systemsteuerungsprogramms Programme und Funktionen zu deinstallieren:
  1. Klicken Sie auf StartSchaltfläche Start, geben Sie appwiz.cpl in das Feld Suche starten ein, und klicken Sie in der Liste Programme auf appwiz.cpl.

    Benutzerzugriffssteuerung Wenn Sie aufgefordert werden, ein Administratorkennwort oder eine Bestätigung einzugeben, geben Sie Ihr Kennwort ein, oder klicken Sie auf Fortsetzen.
  2. Klicken Sie mit der rechten Maustaste auf das Programm, und klicken Sie auf Deinstallieren.
  3. Befolgen Sie die angezeigten Anweisungen, um das Programm zu deinstallieren.

Methode 2: Deinstallieren Sie das Programm mithilfe seiner Original-Installationsprogrammdatei

Wenn das Programm unter Programme und Funktionen nicht erscheint, lässt es sich möglicherweise mithilfe seines Installationsprogramms deinstallieren. Wenden Sie hierzu eine der folgenden Methoden an.

Starten des Installationsprogramms über das Menü Start

Gehen Sie folgendermaßen vor, um das Installationsprogramm über das Menü Start zu starten:
  1. Klicken Sie auf StartSchaltfläche Start, klicken Sie auf Alle Programme, und suchen Sie den Programmordner.
  2. Doppelklicken Sie auf das Installationsprogramm in diesem Ordner.

    Benutzerzugriffssteuerung Wenn Sie aufgefordert werden, ein Administratorkennwort oder eine Bestätigung einzugeben, geben Sie Ihr Kennwort ein, oder klicken Sie auf Zulassen.
  3. Befolgen Sie die angezeigten Anweisungen, um das Programm zu deinstallieren.

Starten des Installationsprogramms aus dem Installationsordner des Programms

Gehen Sie folgendermaßen vor, um das Installationsprogramm aus dem Installationsordner des Programms zu starten:
  1. Klicken Sie auf StartSchaltfläche Start, und geben Sie den Namen des Programms in das Feld Suche starten ein.
  2. Klicken Sie in der Liste Programme mit der rechten Maustaste auf das Programm, und klicken Sie auf Dateipfad öffnen.
  3. Suchen Sie das Installationsprogramm, und doppelklicken Sie darauf.

    Benutzerzugriffssteuerung Wenn Sie aufgefordert werden, ein Administratorkennwort oder eine Bestätigung einzugeben, geben Sie Ihr Kennwort ein, oder klicken Sie auf Zulassen.
  4. Befolgen Sie die angezeigten Anweisungen, um das Programm zu deinstallieren.

Starten des Installationsprogramms vom Installationsmedium des Programms

Wenn das Installationsprogramm sich nicht unter dem Menü Start oder im Installationsordner befindet, finden Sie es eventuell auf dem Installationsmedium des Programms. Dies kann zum Beispiel eine CD oder eine DVD sein.

Wenn beim Ausführen des Installationsprogramms eine Fehlermeldung angezeigt wird, oder wenn sich das Programm mit dem Installationsprogramm nicht deinstallieren lässt, wenden Sie eine der folgenden Methoden an.

Verwenden des Programmkompatibilitätsassistenten, um das Installationsprogramm des Programms neu zu installieren

Wenn das Installationsprogramm nicht korrekt funktioniert, wird der Programmkompatibilitätsassistent möglicherweise automatisch gestartet. Gehen Sie folgendermaßen vor, um den Programmkompatibilitätsassistenten zu verwenden:
  1. Klicken Sie auf Erneut mit den empfohlenen Einstellungen installieren.

    Benutzerzugriffssteuerung Wenn Sie aufgefordert werden, ein Administratorkennwort oder eine Bestätigung einzugeben, geben Sie Ihr Kennwort ein, oder klicken Sie auf Zulassen.
  2. Befolgen Sie die angezeigten Anweisungen, um das Programm zu deinstallieren.

Konfigurieren des Original-Installationsprogramms zur Verwendung des Kompatibilitätsmodus

Gehen Sie folgendermaßen vor, um das Original-Installationsprogramms darauf zu konfigurieren, den Kompatibilitätsmodus zu verwenden:
  1. Klicken Sie mit der rechten Maustaste auf das Installationsprogramm des Programms, und klicken Sie auf Eigenschaften.
  2. Klicken Sie auf die Registerkarte Kompatibilität.
  3. Aktivieren Sie das Kontrollkästchen Programm im Kompatibilitätsmodus ausführen für.
  4. Klicken Sie in der Liste auf Windows XP (Service Pack 2), und klicken Sie auf OK.
  5. Doppelklicken Sie auf das Installationsprogramm.

    Benutzerzugriffssteuerung Wenn Sie aufgefordert werden, ein Administratorkennwort oder eine Bestätigung einzugeben, geben Sie Ihr Kennwort ein, oder klicken Sie auf Zulassen.
  6. Befolgen Sie die angezeigten Anweisungen, um das Programm zu deinstallieren.

Methode 3: Deinstallieren Sie das Programm mithilfe seines MSI-Pakets

Gehen Sie folgendermaßen vor, um das Programm mithilfe seines MSI-Pakets zu deinstallieren:
  1. Klicken Sie auf StartSchaltfläche Start, geben Sie %windir%\Installer in das Feld Suche starten ein, und drücken Sie die [EINGABETASTE].

    Der Ordner "Installer" wird geöffnet.
  2. Klicken Sie im Menü Ansicht auf Details.
  3. Klicken Sie mit der rechten Maustaste auf die Spalte Name, und klicken Sie anschließend auf Mehr.
  4. Aktivieren Sie das Kontrollkästchen Subjekt (Subject), geben Sie 340 in das Feld Breite der ausgewählten Spalte (in Pixel) ein, und klicken Sie auf OK.

    Hinweis: Es kann mehrere Minuten dauern, bis neben allen MSI-Dateien die Subjekte erscheinen.
  5. Doppelklicken Sie auf die MSI-Datei des Programms.
  6. Befolgen Sie die angezeigten Anweisungen, um das Programm zu deinstallieren.

Methode 4: Verwenden Sie das MSI-Paket des Programms mit aktivierter Installer-Protokollierung

Gehen Sie folgendermaßen vor, um ein Protokoll des Deinstallationsvorgangs für das Programm zu erstellen:
  1. Klicken Sie auf StartSchaltfläche Start, geben Sie cmd in das Feld Suche starten ein, klicken Sie in der Liste Programme mit der rechten Maustaste auf cmd.exe, und klicken Sie auf Als Administrator ausführen.

    Benutzerzugriffssteuerung Wenn Sie aufgefordert werden, ein Administratorkennwort oder eine Bestätigung einzugeben, geben Sie Ihr Kennwort ein, oder klicken Sie auf Fortsetzen.
  2. Geben Sie an der Eingabeaufforderung msiexec /x <Paketname> /lv* "%userprofile%\desktop\msi.log" ein, und drücken Sie die [EINGABETASTE]. Dabei ist <Paketname> der Pfad und Dateiname der MSI-Datei für das Programm, das Sie deinstallieren möchten.

    Weitere Informationen zu der Eingabeaufforderung mit erhöhten Benutzerrechten in Windows Vista finden Sie auf der folgenden Microsoft-Website:
  3. Befolgen Sie die angezeigten Anweisungen, um das Programm zu deinstallieren.
  4. Öffnen Sie auf Ihrem Desktop die Datei ".msi.log". Sie können diese Protokolldatei auf Probleme untersuchen, die während des Deinstallationsvorgangs des Programms aufgetreten sind.

    Hinweis: Wenn während des Deinstallationsvorgangs ein Fehler aufgetreten ist, erstellen Sie eine Kopie der Protokolldatei, bevor Sie die Deinstallation abschließen oder abbrechen. Sie können dann in der Protokolldatei den Punkt überprüfen, an dem der Fehler aufgetreten ist.
Weitere Informationen zum Aktivieren der Protokollierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
314852 Aktivieren der Windows Installer-Protokollierung in Windows XP

Methode 5: Besuchen Sie die Website des Programmherstellers

Besuchen Sie die Website des Programmherstellers. Der Hersteller stellt möglicherweise ein Deinstallationsprogramm, ein aktualisiertes MSI-Paket oder eine Anleitung zum manuellen Entfernen des Programms zur Verfügung.
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Eigenschaften

Artikelnummer: 927395 – Letzte Überarbeitung: 03/15/2007 20:05:47 – Revision: 1.2

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