Sie sind zurzeit offline. Es wird auf die erneute Herstellung einer Internetverbindung gewartet.

Ihr Browser wird nicht unterstützt.

Sie müssen Ihren Browser aktualisieren, um die Website zu verwenden.

Aktualisieren Sie auf die neueste Version von Internet Explorer.

Fehlermeldung beim Speichern oder einer Entität oder eines Attributs in Microsoft Dynamics CRM 3.0 aktualisieren: "Fehler ist aufgetreten. Weitere Informationen erhalten Sie vom Systemadministrator"

Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.

Den englischen Originalartikel können Sie über folgenden Link abrufen: 934690
Problembeschreibung
Wenn Sie speichern oder einer Entität oder eines Attributs in Microsoft Dynamics CRM 3.0 aktualisieren, erhalten Sie folgende Fehlermeldung:
Ein Fehler ist aufgetreten. Wenden Sie sich an den Systemadministrator, um weitere Informationen zu erhalten.
Plattform-Ablaufverfolgung aktiviert ist, wird darüber hinaus Informationen, die die folgende Informationen ähnelt in der Ablaufverfolgungs-Protokolldatei protokolliert:
[2006-06-26 11:32:59.8] Prozess: w3wp |Thread: 3672 |Category: Anwendung |User: 00000000-0000-0000-0000-000000000000 |Level: Fehler | ErrorInformation.LogError
>MSCRM Anwendung-Problembericht:
Fehler: Methode nicht gefunden: stornieren
Microsoft.Crm.Metadata.AttributeInfo.set_Searchable(Boolean).
Fehlermeldung: Methode nicht gefunden: stornieren
Microsoft.Crm.Metadata.AttributeInfo.set_Searchable(Boolean).
Quelldatei: Nicht verfügbar
Zeilennummer: Nicht verfügbar
Anforderungs-URL: http://localhost:5555/AppWebServices/SystemCustomization.asmx Stapel
Trace-Info: an
Microsoft.Crm.Application.WebServices.SystemCustomization.AttributeCreate.GetAttributeInfo (ParameterBag ParamBag, AttributeMetadata AttributeMD, DynamicMetadataCache MdChache)
>unter Microsoft.Crm.Application.WebServices.SystemCustomization.EntityCreate.Execute (User Benutzer, ParameterBag ParamBag)
Dieses Problem kann auftreten, nachdem Sie ein Microsoft CRM-Hotfix oder Update-Rollup 1 für Microsoft Dynamics CRM 3.0 installiert haben.
Ursache
Dieses Problem tritt auf, wenn eine oder mehrere der folgenden Bedingungen erfüllt sind:
  • Zusätzliche Schritte wurden nicht abgeschlossen werden, nachdem Sie ein Microsoft CRM-Hotfix oder Update-Rollup 1 für Microsoft Dynamics CRM 3.0 installiert.
  • Die Microsoft CRM-Systemanpasser Standardrolle wurde entfernt oder bearbeitet.
Lösung
Gehen Sie folgendermaßen vor, um dieses Problem zu beheben.

Löschen Sie die Microsoft.crm.MetadataService.dll-Datei aus dem globalen Assemblycache (GAC)

  1. Klicken Sie auf dem Microsoft CRM-Server auf Start , zeigen Sie auf Programme , zeigen Sie auf Verwaltung und klicken Sie dann auf Microsoft .NET Framework 1.1 Configuration .
  2. Klicken Sie im Navigationsbereich auf Assemblycache .
  3. Klicken Sie auf Ansicht Liste der Assemblys im Assemblycache .
  4. Klicken Sie mit der rechten Maustaste auf die Microsoft.crm.MetadataService Assembly, und klicken Sie dann auf Löschen .
  5. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie iisreset ein, und klicken Sie dann auf OK .

Bearbeiten der Datei Web.config um den Text zu entfernen, der die Microsoft.crm.MetadataService.dll-Datei dem GAC hinzufügt

Hinweis: In Microsoft Dynamics CRM 3.0 müssen Sie nicht die Datei Microsoft.crm.MetadataService.dll im GAC hinzufügen. Einige Fremdanbieter-Anwendungen jedoch laden diese Datei in den GAC. Dies kann das Problem verursachen, das im Abschnitt "Problembeschreibung" erwähnt wird. Wenn Sie diese Schritte befolgen, sind Anpassungen weiterhin funktionsfähig, auch wenn Sie nicht die Microsoft.crm.MetadataService.dll-Datei dem GAC hinzufügen.
  1. Auf dem Microsoft CRM-Server sichern Sie die Datei Web.config . Speichern der Sicherungskopie der Datei in einen anderen Ordner.

    Hinweis: Die Datei Web.config befindet sich im Hauptordner für Microsoft CRM.
  2. Klicken Sie mit der rechten Maustaste auf die Datei Web.config , klicken Sie auf Öffnen mit und klicken Sie dann auf Editor .
  3. Löschen Sie den folgenden Text.
    <add assembly="Microsoft.Crm.MetadataService, Version=3.0.5300.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
  4. Klicken Sie im Menü Datei auf Speichern .
  5. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie iisreset ein, und klicken Sie dann auf OK .

Die Standardrolle Systemanpasser erstellen

Wenn eine benutzerdefinierte Entität erstellt ist Microsoft CRM automatisch den Systemanpasser Rolle Zugriff auf die neue Entität gewährt. Wenn Sie löschen oder bearbeiten die Rolle Systemanpasser, erhalten Sie die Fehlermeldung, das im Abschnitt "Problembeschreibung" genannt wird.

Dieses Problem sofort beheben möchten, wenden Sie sich an Microsoft Support Services. Eine vollständige Liste mit Telefonnummern der Microsoft Product Support Services und Informationen über Supportkosten der folgenden Microsoft-Website:
Weitere Informationen
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
922815Das Updaterollup 1 für Microsoft Dynamics CRM 3.0 ist verfügbar
Auswahlliste crm30 crm3.0 Crm importieren

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 934690 – Letzte Überarbeitung: 08/15/2007 19:43:48 – Revision: 3.2

  • Microsoft CRM 3.0
  • kbmt kbmbscrm40no kbmbscustomization kberrmsg kbtshoot kbmbsmigrate kbprb KB934690 KbMtde
Feedback