Fehlermeldung, wenn Sie versuchen, in der Microsoft CRM Client für Outlook offline zu gehen: "Fehler beim Verschieben von Daten für Entität"

Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.

938065
Dieser Artikel wurde archiviert. Er wird im vorliegenden Zustand bereitgestellt und nicht mehr aktualisiert.
Problembeschreibung
Beim Ausführen von Microsoft Dynamics CRM-Laptopclient für Microsoft Office Outlook-Kompatibilitätsupdate oder die Microsoft CRM Client für Outlook Offline Access wird die folgenden Fehlermeldung, wenn Sie versuchen, offline zu gehen:
Fehler beim Verschieben von Daten für Entität "entity_name" während der Aktion saInsert, CountRows = 1. Wenden Sie sich für Unterstützung an Ihren Systemadministrator, und versuchen Sie erneut, offline zu gehen.
Außerdem, erhalten Sie die folgenden Fehlermeldung in der Plattform-Ablaufverfolgung:
Fehler beim Einfügen für Entität 'Vorfall', BatchRows = 0 mit Ausnahme von System.Data.SqlClient.SqlException: Das Massenladen ist fehlgeschlagen.
Die Spalte ist in der Datendatei für Zeile 1, Spalte 18 zu lang.
Überprüfen Sie ob das Feldabschlusszeichen und das Zeilenabschlusszeichen richtig angegeben sind.
Der OLE DB-Provider "BULK" für den Verbindungsserver "(null)" meldete einen Fehler. Der Anbieter keine Informationen über den Fehler bereitgestellt.
Eine Zeile konnte nicht von OLE DB-Provider "BULK" für den Verbindungsserver "(null)" abgerufen werden.
am System.Data.SqlClient.SqlConnection.OnError (SqlException-Ausnahme, Boolean BreakConnection)
am System.Data.SqlClient.SqlInternalConnection.OnError (SqlException-Ausnahme, Boolean BreakConnection)
am System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning (TdsParserStateObject StateObj)
am System.Data.SqlClient.TdsParser.Run (RunBehavior RunBehavior, CmdHandler SqlCommand, SqlDataReader Datenstrom, BulkCopySimpleResultSet BulkCopyHandler, TdsParserStateObject StateObj)
am System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds (MethodName String, Boolean Async)
am System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery (DbAsyncResult Ergebnis, MethodName String, Boolean SendToPipe)
am System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
am Microsoft.Crm.Application.Outlook.OfflineSync.Utility.ExecuteSql in d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\Utility.cs:line 55 (String StrCommand, CrmDbConnection DbConnection)
am Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.PopulateTempTable (TempTableName String, String FileName, CrmDbConnection DbConnection, Int32 Count, String Formatdatei) in d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\BCPTransferDataProvider.cs:line 389
am Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsertTable (EntityMetadata Entität, String FileName, Count Int32, Boolean Erweiterung, String Attribute) in d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\BCPTransferDataProvider.cs:line 672
am Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsert in d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\BCPTransferDataProvider.cs:line 637 (EntityMetadata Entität, FileName String, Int32 Count)
am Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.ExecuteInsert (EntityName String, Int32 Count) in d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\BCPTransferDataProvider.cs:line 333
am Microsoft.Crm.Application.Outlook.OfflineSync.SyncData.DoBatchStep (ITransferDataProvider TransferDataProvider, String-EntityName, SyncAction Aktion, BatchRows Int32) in d:\crm\v3rtm\src\Application\Outlook\Components\OfflineSync\Sync.cs:line 1087
Ursache
Dieses Problem tritt auf, wenn folgenden Bedingungen erfüllt sind:
  • Im Hauptformular einer Entität haben Sie ein benutzerdefiniertes Attributfeld, das den NTEXT -Typ verwendet hinzugefügt.
  • Das Feld benutzerdefiniertes Attribut eines verbundenen Datensatzes enthält mehr als 4.000 Zeichen.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben:
  • Wenn Microsoft SQL Server Express 2005 Service Pack 1 auf dem Computer installiert ist, auf dem Microsoft CRM 3.0-Laptopclient für Outlook ausgeführt wird, installieren Sie Hotfix 937545.

    Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    937545Update: Fehlermeldung, wenn Sie die BULK INSERT-Anweisung, verwenden um eine Datendatei in eine Tabelle in SQL Server 2005 mit SP1 zu importieren: "der OLE DB-Provider"BULK"für den Verbindungsserver"(Null)"meldete einen Fehler"
  • Wenn Microsoft SQL Server Express 2005 Service Pack 2 auf dem Computer installiert ist, auf dem Microsoft CRM 3.0-Laptopclient für Outlook ausgeführt wird, installieren Sie Hotfix 941450.
    941450Kumulatives Updatepaket 4 für SQL Server 2005 Service Pack 2

Weitere Informationen

Schritte zum Reproduzieren des Problems

  1. Erstellen Sie auf eine Entität ein benutzerdefiniertes Attribut, das den NTEXT -Typ verwendet und 5000 Zeichen enthalten kann. Erstellen Sie z. B. ein "New_LongField"-Feld auf der Entität Account.
  2. Fügen Sie das benutzerdefinierte Attribut-Feld mit dem Hauptformular.
  3. Veröffentlichen Sie die Änderungen.
  4. Füllen Sie für einen Datensatz dieses Feld benutzerdefiniertes Attribut, um mehr als 4000 Zeichen enthalten.
  5. Versuchen Sie im Microsoft CRM-Laptopclient für Outlook-Kompatibilitätsupdate oder in der Microsoft CRM offline Client für Outlook, offline zu gehen.
Informationsquellen
Weitere Informationen Wenn Sie die Microsoft Dynamics 3.0 CRM-Laptopclient für Outlook verwenden, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
918108 Fehlermeldung, wenn Sie versuchen, die Onlineverbindung eines Laptopclients zu beenden, auf dem Microsoft Dynamics CRM 3.0 ausgeführt wird: "Fehler beim Verschieben von Daten für Entität"
NC

Warnung: Dieser Artikel wurde automatisch übersetzt

Eigenschaften

Artikelnummer: 938065 – Letzte Überarbeitung: 01/16/2015 02:04:50 – Revision: 4.0

  • Microsoft Dynamics CRM 4.0
  • Microsoft CRM 3.0
  • Microsoft CRM client for Microsoft Office Outlook
  • Microsoft Dynamics Live CRM Professional Edition
  • Microsoft Dynamics Live CRM Enterprise Edition
  • kbnosurvey kbarchive kbmt kbmbscrmonlineoutlook kbfreshness2008 kbmbscrmonline kbmbscrm40 kbmbscustomization kberrmsg kbexpertisebeginner kbtshoot kbmbsmigrate kbprb kbexpertiseinter KB938065 KbMtde
Feedback