Einem Computer mit Windows Server 2003 reagiert (hängt) während des Startvorgangs Wenn viele IPv6-Adressen zugewiesen sind

Der Support für Windows Server 2003 ist am 14. Juli 2015 abgelaufen.

Microsoft beendete den Support für Windows Server 2003 am 14. Juli 2015. Diese Änderung wirkt sich auf Ihre Softwareupdates und Sicherheitsoptionen aus. Erfahren Sie, was das für Sie bedeutet und wie Sie Ihren Schutz aufrechterhalten können.

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Den englischen Originalartikel können Sie über folgenden Link abrufen: 970659
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Problembeschreibung
Einem Computer mit Windows Server 2003 reagiert nicht mehr (hängt) während des Startvorgangs und zeigt dann einen schwarzen Bildschirm. Dieses Problem tritt auf, wenn Sie das IPv6-Protokoll auf dem Computer installiert haben und Sie viele IPv6-Adressen, die installierten Schnittstellen zugewiesen haben. Dieses Problem ist sehr wahrscheinlich auftreten, wenn mehr als 50 IPv6-Adressen der Schnittstellen zugewiesen sind.
Ursache
Dieses Problem tritt wegen eines Deadlock-Szenario.

Initialisierung von IP-Adressen, IPv6-Stapel viele Arbeitsaufgaben erstellt, und dies erfordert das System zum Lesen der Registrierung. Jedoch bei der Sitzung Management Subsystem (SMSS) gestartet wird, wird eine exklusive Sperre in der Registrierung. Anschließend versucht die SMSS Arbeitsaufgaben generieren, die von Arbeitsthreads behandelt werden soll. Jedoch davon gegangen Sie aus, dass die Worker-Thread-Warteschlange voll ist und, dass keine Arbeitsthreads frei sind. In diesem Szenario werden alle Arbeitsthreads blockiert, da Sie warten, für die Registrierung Sperre freigegeben werden. Daher tritt ein Deadlock.
Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft-Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website: Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix installieren, müssen Sie Windows Server 2003 Service Pack 2 auf dem Computer installiert sein. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100So erhalten Sie das neueste Servicepack für Windows Server 2003

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time aufgeführt (UTC). Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Server 2003 mit Service Pack 2, x 86-basierte Versionen
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Tcpip6.sys5.2.3790.4510235,39208-Mai 200916: 41Nicht zutreffend
Windows Server 2003 mit Service Pack 2, x 64-basierte Versionen
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Tcpip6.sys5.2.3790.4510377,34408-Mai 200920: 52X 64
Windows Server 2003 mit Service Pack 2, Itanium-basierte Versionen
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Tcpip6.sys5.2.3790.4510766,84808-Mai 200920: 27Nicht zutreffend
Status
Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.
Weitere Informationen
Einige bekannte Probleme können nach der Installation dieses Hotfixes auftreten. Finden Sie im folgenden Knowledge Base-Artikel zu Ihrem spezielle Problem überprüfen und Hotfix 956770 entsprechend:
956770Update: Sie können Probleme haben wenn Sie eine Vielzahl von IP-Adressen auf dem Netzwerkadapter eines Computers unter Windows Server 2003 hinzufügen
Informationsquellen
Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates
System hängt während des Startvorgangs

Warnung: Dieser Artikel wurde automatisch übersetzt.

Eigenschaften

Artikelnummer: 970659 – Letzte Überarbeitung: 01/15/2015 19:52:41 – Revision: 1.1

Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Web Edition, Microsoft Windows Server 2003, Datacenter Edition (32-bit x86), Microsoft Windows Server 2003, Standard x64 Edition, Microsoft Windows Server 2003, Enterprise x64 Edition, Microsoft Windows Server 2003, Datacenter x64 Edition, Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems, Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems

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