Nicht-ASCII-Zeichen in einen Anzeigenamen einer weitergeleiteten Nachricht werden als Zeichen in einer Exchange Server 2007-Umgebung (?) angezeigt.

Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.

Den englischen Originalartikel können Sie über folgenden Link abrufen: 977355
Problembeschreibung
Stellen Sie sich das folgende Szenario vor:
  • Sie haben einen Computer, auf dem Microsoft Exchange Server 2007 ausgeführt wird.
  • Ein Benutzer einen Kontakt erstellt, und der Anzeigename des Kontakts in ostasiatische Zeichen, z. B. Chinesisch und Japanisch Zeichen ist.
  • Eine Auto-Forward-Regel wird zum Weiterleiten einer Nachricht an den Kontakt erstellt.
  • Eine eingehende Nachricht enthält nur ASCII-Zeichen.
Wenn die eingehende Nachricht automatisch weitergeleitet wurde, um den Kontakt in diesem Szenario ist, werden die ASCII-Zeichen in einen Anzeigenamen als Fragezeichen (?) Zeichen angezeigt.
Ursache
Dieses Problem tritt auf, da der Transport-Dienst verarbeitet die serverseitigen Regeln in Exchange Server 2007. Transport-Dienst wird die Adresse des Kontakts aufgelöst und dann codiert den Anzeigenamen des Kontakts. Wenn ein Zeichensatz in der MIME-Nachricht vorhanden ist, wird der Zeichensatz für die Codierung der Anzeigename verwendet. In diesem Szenario wird Exchange Server 2007 nicht erkannt, dass nicht-ASCII-Zeichen beteiligt sind. Aus diesem Grund US-ASCII-Zeichen werden verwendet, für die Codierung und nicht-ASCII-Zeichen im Anzeigenamen als angezeigt werden "?" Zeichen.
Lösung
Um dieses Problem zu beheben, installieren Sie das folgende Update-Rollup:
972076Hinweise zum Updaterollup 2 für Microsoft Exchange Server 2007 Servicepack 2
Status
Microsoft hat bestätigt, dass dies ein Problem in der Microsoft-Produkten handelt, die im Abschnitt "Beziehen sich auf" aufgeführt sind.

Eigenschaften

Artikelnummer: 977355 – Letzte Überarbeitung: 01/22/2010 22:29:19 – Revision: 1.1

Microsoft Exchange Server 2007 Service Pack 2

  • kbmt kbsurveynew kbexpertiseinter kbfix kbqfe kbhotfixrollup KB977355 KbMtde
Feedback