Silverlight für Mac wird nicht erkannt, oder Sie werden ständig zur Installation aufgefordert.

Hinweis

Silverlight wurde eingestellt und wurde offiziell nicht mehr unterstützt. Weitere Informationen finden Sie unter Ende des Supports für Silverlight.

Problembeschreibung

Wenn Sie versuchen, auf eine Website zuzugreifen, für die Silverlight den Inhalt anzeigen muss, erhalten Sie eine Fehlermeldung, die besagt, dass Sie Silverlight installieren müssen.

Ursache

Dieses Verhalten kann aus verschiedenen Gründen auftreten:

  • Ihr System verfügt über eine frühere Version des Plug-Ins und erfüllt nicht die Anforderungen für das Plug-In, das von der Website verwendet wird.

  • Das Plug-In ist nicht installiert.

  • Der Browser ist auf "Run using Rosetta" (Ausführen mit Rosetta) festgelegt, wodurch der Computer fälschlicherweise als PowerPC-basierter Mac identifiziert wird.

Lösung

Bevor Sie entscheiden, wie das Problem behoben werden soll, sollten Sie die aktuelle Umgebung bewerten, in der die Software ausgeführt wird. Gehen Sie dazu wie folgt vor:

  1. Wählen Sie im Apple-MenüÜber diesen Mac aus.

  2. Beachten Sie die Informationen zu Prozessortyp, Geschwindigkeit, RAM und Betriebssystem, da einige Websites bestimmte Anforderungen zum Anzeigen ihrer Inhalte haben.

  3. Schließen Sie das Fenster.

  4. Schließen Sie alle geöffneten Browserfenster.

  5. Doppelklicken Sie auf das Festplattensymbol auf dem Desktop.

  6. Doppelklicken Sie auf den Ordner Bibliothek .

  7. Öffnen Sie den Ordner Internet-Plug-Ins .

  8. Gibt es eine Datei mit dem Namen Silverlight.plugin? Wenn diese Datei vorhanden ist, wird das Plug-In installiert. Um die Version zu bestimmen, klicken Sie auf , um die Datei auszuwählen. Wählen Sie dann im Menü Datei die Option Informationen abrufen aus. Notieren Sie sich die angezeigte Versionsnummer.

    • Wenn die angezeigte Versionsnummer 1.0.xxx ist und Ihr Prozessortyp ein PowerPC ist, haben Sie die richtige Version des Plug-Ins installiert.

    • Wenn Sie über einen Intel-Prozessor verfügen, werden alle Versionen von Silverlight unterstützt. Es wird jedoch empfohlen, die neueste Version auszuführen, damit Sie auf Websites zugreifen können, die die neuesten Features verwenden und die neuesten Produktverbesserungen nutzen können.

Jetzt können wir die einzelnen Ursachen und Lösungen angehen.

Ihr System verfügt über eine frühere Version des Plug-Ins und erfüllt nicht die Anforderungen der Website.

Die häufigste Ursache für dieses Problem ist, dass die Website Silverlight 3 als Inhalt verwendet. Wenn ein Standort Version 3 erfordert, erkennt er, ob Ihr System die Anforderung erfüllt. Wenn das System dies nicht tut, werden Sie zum Upgrade aufgefordert. Sie werden zur Silverlight-Website weitergeleitet. Wenn Sie einen PowerPC verwenden, erkennt die Website dies und dass nur Version 1 installiert werden kann. (Diese Situation müsste vom Supportteam der Website behoben werden, da die Entscheidung, welche Version von Silverlight verwendet werden soll, von den Websitedesignern getroffen wird.)

Das Plug-In ist nicht installiert.

Wenn Silverlight noch nicht installiert wurde, führen Sie die folgenden Schritte aus, um das Plug-In zu installieren:

  1. Starten Sie einen Webbrowser, und besuchen Sie dann die folgende Website:

    http://silverlight.net/getstarted/

  2. Suchen Sie unten rechts im Fenster nach dem Bereich "Silverlight installieren".

    • Wenn Sie einen Intel-Prozessor ausführen, klicken Sie neben "Silverlight 3" auf Mac-Runtime .

    • Wählen Sie andernfalls Runtime für Mac PowerPC neben "Silverlight 1.0" aus.

  3. Nach Abschluss des Downloads sollte die Installation automatisch gestartet werden. Folgen Sie den Anweisungen im Installations-Assistenten.

  4. Nach Abschluss der Installation sollten Sie aufgefordert werden, Ihren Browser zu beenden. Schließen Sie alle Browserfenster, und starten Sie dann den Browser neu. Der Browser sollte das neue Plug-In erkennen.

Der Browser ist auf "Ausführen mit Rosetta" festgelegt, wodurch der Computer fälschlicherweise als PowerPC-basierter Mac identifiziert wird.

Wenn der Browser so eingestellt ist, dass er in der Rosetta-Engine ausgeführt wird, wird der Computer fälschlicherweise als PowerPC-basierter Mac identifiziert, oder die Website erkennt nicht, dass das entsprechende Plug-In installiert ist.

Wenn das entsprechende Plug-In wie im vorherigen Abschnitt beschrieben installiert ist, führen Sie die folgenden Schritte aus:

  1. Doppelklicken Sie auf das Festplattensymbol auf dem Desktop.

  2. Wählen Sie den Ordner Anwendungen aus.

  3. Suchen Sie das Symbol für den Browser, den Sie verwenden. Halten Sie die CTRL-TASTE gedrückt, während Sie auf dieses Symbol klicken.

  4. Wählen Sie Informationen abrufen aus.

  5. Suchen Sie die Option Run using Rosetta (Mit Rosetta ausführen ), und stellen Sie sicher, dass dieses Kontrollkästchen nicht aktiviert ist. Wenn die Option aktiviert ist, deaktivieren Sie das Kontrollkästchen. Schließen Sie das Fenster.

  6. Wählen Sie im Apple-Menü Neu starten aus.

  7. Versuchen Sie nach dem Neustart des Computers erneut, auf die Website zuzugreifen, die die Fehlermeldung generiert hat.

Hinweis

Wenn die entsprechende Version des Plug-Ins nicht installiert ist, stellen Sie sicher, dass das Kontrollkästchen Mit Rosetta ausführen nicht aktiviert ist, und führen Sie dann die Schritte im vorherigen Abschnitt aus, um das Plug-In zu installieren.