Erstellen eines Datenbankmodells (auch als Entitätsbeziehungsdiagramm bezeichnet) in Visio

Erstellen eines Datenbankmodells (auch als Entitätsbeziehungsdiagramm bezeichnet) in Visio

Mit der Vorlage "Datenbankmodelldiagramm" in Visio können Sie ein neues Modell erstellen oder aus einer vorhandenen Datenbank mittels Reverse Engineering ein Modell erstellen.

Symbol "Datenbank", Pfeil, Visio-Diagramm zur Darstellung der Datenbank

In diesem Artikel wird beschrieben, wie Sie ein Datenbankmodell erstellen und welche Aufgaben Sie mit dem fertig erstellten Modell ausführen.

Hinweis: Das Datenbankmodelldiagramm ist nur in bestimmten Versionen von Visio verfügbar. Weitere Informationen finden Sie unter Sie können die Datenbankmodellierungsfeatures nicht finden?

1. Starten eines Datenbankmodelldiagramms

Wenn Sie keine Datenbank haben, die Sie als Ausgangspunkt verwenden möchten, können Sie mit einem leeren Datenbankmodell beginnen, dem Sie Ihre eigenen Tabellen und Beziehungen hinzufügen.

  1. Wählen Sie Datei > Neu aus.

  2. Geben Sie Datenbankmodell in das Suchfeld ein, und drücken Sie die EINGABETASTE.

  3. Doppelklicken Sie in den Suchergebnissen auf Datenbankmodelldiagramm.

    Datenbankmodelldiagramm-Vorlage.
  4. Wählen Sie entweder Metrische Einheiten oder US-Einheiten und dann Erstellen aus.

    Der Assistent für Reverse Engineering wird normalerweise automatisch geöffnet.

  5. Wählen Sie Abbrechen aus, um den Assistenten zu schließen.

  6. Wählen Sie auf der Registerkarte Datenbank in der Gruppe Verwalten die Option Anzeigeoptionen aus.

  7. Wählen Sie im Dialogfeld Datenbank-Dokumentoptionen den gewünschten Symbolsatz sowie weitere Optionen für Tabellen und Beziehungen aus. Wählen Sie dann OK aus. Klicken Sie im Dialogfeld auf die Schaltfläche "Hilfe", um weitere Informationen zu den verschiedenen Optionen zu erhalten.

Wenn Sie eine Datenbank haben, die Sie modellieren möchten, um sie besser verstehen zu können oder die Sie als Ausgangspunkt für ein neues Modell verwenden möchten, verwenden Sie den Assistenten für Reverse Engineering, um das Schema (die Struktur) der Datenbank zu extrahieren und ein neues Modell zu erstellen.

Erforderliche Schritte vor dem Starten des Assistenten:

  • Wenn Sie Reverse Engineering für eine Excel-Arbeitsmappe durchführen möchten, öffnen Sie zuerst die Arbeitsmappe, und benennen Sie die Gruppe (oder den Bereich) der Zellen, die die Spaltenüberschriften enthalten. Wenn Sie mehrere Arbeitsblätter verwenden möchten, benennen Sie einfach die Gruppe von Spaltenzellen in jedem Arbeitsblatt. Im Assistenten für Reverse Engineering werden diese Bereiche wie Tabellen behandelt. Weitere Informationen zum Benennen von Zellbereichen finden Sie unter Definieren und Verwenden von Namen in Formeln.

  • Legen Sie vor dem Ausführen des Assistenten für Reverse Engineering den Standardtreiber auf die Zieldatenbank fest, für die das Reverse Engineering durchgeführt werden soll, um optimale Ergebnisse zu erzielen. Durch diesen Schritt wird sichergestellt, dass der Assistent die systemeigenen Datentypen richtig zuordnet und der gesamte vom Assistenten extrahierte Code im Codefenster ordnungsgemäß angezeigt wird.

Starten des Assistenten:

  1. Wählen Sie Datei > Neu aus.

  2. Geben Sie Datenbankmodell in das Suchfeld ein, und drücken Sie die EINGABETASTE.

  3. Doppelklicken Sie in den Suchergebnissen auf Datenbankmodelldiagramm. Wählen Sie Erstellen aus.

    Der Assistent für Reverse Engineering sollte automatisch geöffnet werden.

    Wenn der Assistent nicht geöffnet wird: Wählen Sie auf der Registerkarte Datenbank im Menüband der Symbolleiste in der Gruppe Modell die Option Reverse Engineering aus.

  4. Führen Sie im ersten Bildschirm des Assistenten für Reverse Engineering die folgenden Aktionen aus:

    1. Wählen Sie den Datenbanktreiber für Ihr Datenbank-Managementsystem (DBMS) aus. Wenn Sie den Visio-Datenbanktreiber noch keiner bestimmten ODBC-Datenquelle zugeordnet haben, klicken Sie auf Einrichten.

      Hinweis: Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen, wählen Sie "ODBC-Treiber Universal" aus.

    2. Wählen Sie die Datenquelle der Datenbank aus, die Sie aktualisieren möchten. Wenn Sie noch keine Datenquelle für die vorhandene Datenbank erstellt haben, klicken Sie auf Neu, um dies jetzt zu erledigen.

      Wenn Sie eine neue Quelle erstellen, wird ihr Name zur Liste Datenquellen hinzugefügt.

    3. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf Weiter.

  5. Folgen Sie den Anweisungen in allen treiberspezifischen Dialogfeldern.

    Geben Sie beispielsweise im Dialogfeld Datenquelle verbinden den Benutzernamen und das Kennwort ein, und klicken Sie auf OK.

    Hinweis: Wenn Sie den Standardtreiber "ODBC-Treiber Universal" verwenden, wird möglicherweise eine Fehlermeldung angezeigt, die darauf hinweist, dass die Informationen, für die ein Reverse Engineering durchgeführt wurde, unvollständig sein können. In den meisten Fällen ist das kein Problem. Klicken Sie einfach auf OK, und setzen Sie die Ausführung des Assistenten fort.

  6. Aktivieren Sie die Kontrollkästchen für den Typ von Informationen, die Sie extrahieren möchten, und klicken Sie auf Weiter.

    Hinweis: Einige Elemente sind möglicherweise nicht verfügbar (werden abgeblendet angezeigt), weil nicht alle Datenbank-Managementsysteme alle Arten von Elementen unterstützen, die der Assistent extrahieren kann.

  7. Aktivieren Sie die Kontrollkästchen für die Tabellen (und Ansichten, falls vorhanden), die Sie extrahieren möchten, oder klicken Sie auf Alles auswählen, um alle Tabellen (und Ansichten) zu extrahieren. Klicken Sie dann auf Weiter.

    Hinweis: Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen und in dieser Liste keine Elemente angezeigt werden, müssen Sie wahrscheinlich den Zellbereich benennen, der die Spaltenüberschriften in Ihrem Arbeitsblatt enthält. Weitere Informationen finden Sie unter Definieren und Verwenden von Namen in Formeln.

  8. Wenn Sie das Kontrollkästchen Gespeicherte Prozeduren aktiviert haben, wählen Sie die zu extrahierenden Prozeduren aus, oder klicken Sie auf Alles auswählen, um alle Prozeduren zu extrahieren. Klicken Sie dann auf Weiter.

  9. Wählen Sie aus, ob die Elemente, für die ein Reverse Engineering durchgeführt wurde, automatisch zur aktuellen Seite hinzugefügt werden sollen.

    Hinweis: Sie können im Assistenten auswählen, dass die Zeichnung automatisch erstellt wird und die Elemente, für die ein Reverse Engineering durchgeführt wurde, zusätzlich im Fenster "Tabellen und Ansichten" aufgelistet werden. Wenn die Zeichnung nicht automatisch erstellt werden soll, können Sie die Elemente aus dem Fenster "Tabellen und Ansichten" auf Ihr Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

  10. Überprüfen Sie die ausgewählten Optionen, um sicherzustellen, dass die gewünschten Informationen extrahiert werden. Klicken Sie dann auf Fertig stellen.

    Der Assistent extrahiert die ausgewählten Informationen und zeigt im Ausgabefenster Hinweise zum Extrahierungsprozess an.

Wenn Sie über ein VisioModeler- oder PLATINUM ERwin-Modell verfügen, können Sie es möglicherweise importieren, um ein Visio-Datenbankmodelldiagramm zu erstellen. Diese Möglichkeit ist auf Wörterbuchmodelldateien (IMD-Dateien) von VisioModeler 2.0 oder höher sowie ERX-Dateien von PLATINUM ERwin 2.6, 3.0 und 3.52 beschränkt.

  1. Wählen Sie Datei > Neu aus.

  2. Geben Sie Datenbankmodell in das Suchfeld ein, und drücken Sie die EINGABETASTE.

  3. Doppelklicken Sie in den Suchergebnissen auf Datenbankmodelldiagramm. Wählen Sie Erstellen aus.

    Der Assistent für Reverse Engineering wird automatisch geöffnet. Wählen Sie Abbrechen aus, um den Assistenten zu schließen.

  4. Wählen Sie auf der Registerkarte Datenbank in der Gruppe Modell die Option Importieren und dann den gewünschten Modelltyp aus.

  5. Geben Sie den Pfad und Dateinamen für das Modell ein, das Sie importieren möchten, oder wählen Sie die Schaltfläche Durchsuchen aus, um die Modelldatei zu suchen. Wählen Sie dann Öffnen aus.

  6. Wählen Sie im Dialogfeld Importieren die Option OK aus.

    Visio importiert die Datei und zeigt deren Status im Ausgabefenster an. Die importierten Tabellen werden im Fenster "Tabellen und Ansichten" angezeigt.

  7. Wählen Sie im Fenster "Tabellen und Ansichten" die Tabellen aus, die Sie modellieren möchten, und ziehen Sie sie auf das Zeichenblatt.

In diesem Artikel wird beschrieben, wie Sie ein Datenbankmodell erstellen und welche Aufgaben Sie mit dem fertig erstellten Modell ausführen können. Wählen Sie für einen Schnellstart Datei > Neu > Software und Datenbank und dann Datenbankmodelldiagramm aus.

Hinweis: Das Datenbankmodelldiagramm ist nur in bestimmten Versionen von Visio verfügbar. Weitere Informationen finden Sie unter Sie können die Datenbankmodellierungsfeatures nicht finden?

1. Starten eines Datenbankmodelldiagramms

Wenn Sie keine Datenbank haben, die Sie als Ausgangspunkt verwenden möchten, können Sie mit einem leeren Datenbankmodell beginnen, dem Sie Ihre eigenen Tabellen und Beziehungen hinzufügen.

  1. Wählen Sie Datei > Neu aus.

  2. Wählen Sie unter Vorlagenkategorien die Option Software und Datenbank und dann Datenbankmodelldiagramm aus.

    Datenbankmodelldiagramm-Vorlage.

  3. Wählen Sie auf der rechten Seite entweder Metrische Einheiten oder US-Einheiten und dann Erstellen aus.

  4. Wählen Sie auf der Registerkarte Datenbank des Menübands in der Gruppe Verwalten die Option Anzeigeoptionen aus.

  5. Wählen Sie im Dialogfeld Datenbank-Dokumentoptionen den gewünschten Symbolsatz sowie weitere Optionen für Tabellen und Beziehungen aus. Klicken Sie dann auf OK.

Wenn Sie eine Datenbank haben, die Sie modellieren möchten, um sie besser verstehen zu können oder die Sie als Ausgangspunkt für ein neues Modell verwenden möchten, können Sie mithilfe des Assistenten für Reverse Engineering das Schema (die Struktur) der Datenbank extrahieren und ein neues Modell erstellen.

Erforderliche Schritte vor dem Starten des Assistenten:

  • Wenn Sie Reverse Engineering für eine Excel-Arbeitsmappe durchführen möchten, öffnen Sie zuerst die Arbeitsmappe, und benennen Sie die Gruppe (oder den Bereich) der Zellen, die die Spaltenüberschriften enthalten. Wenn Sie mehrere Arbeitsblätter verwenden möchten, benennen Sie einfach die Gruppe von Spaltenzellen in jedem Arbeitsblatt. Im Assistenten werden diese Bereiche wie Tabellen behandelt. Weitere Informationen zum Benennen von Zellbereichen finden Sie unter Definieren und Verwenden von Namen in Formeln.

  • Legen Sie vor dem Ausführen des Assistenten für Reverse Engineering den Standardtreiber auf die Zieldatenbank fest, für die das Reverse Engineering durchgeführt werden soll, um optimale Ergebnisse zu erzielen. Durch diesen Schritt wird sichergestellt, dass der Assistent die systemeigenen Datentypen richtig zuordnet und der gesamte vom Assistenten extrahierte Code im Codefenster ordnungsgemäß angezeigt wird.

Starten des Assistenten:

  1. Wählen Sie Datei > Neu aus.

  2. Wählen Sie unter Vorlagenkategorien die Option Software und Datenbank und dann Datenbankmodelldiagramm aus.

  3. Wählen Sie auf der rechten Seite entweder Metrische Einheiten oder US-Einheiten und dann Erstellen aus.

  4. Wählen Sie auf der Registerkarte Datenbank des Menübands in der Gruppe Modell die Option Reverse Engineering aus.

  5. Führen Sie im ersten Bildschirm des Assistenten für Reverse Engineering die folgenden Aktionen aus:

    1. Wählen Sie den Microsoft Office Visio-Datenbanktreiber für Ihr Datenbank-Managementsystem (DBMS) aus. Wenn Sie den Visio-Datenbanktreiber noch keiner bestimmten ODBC-Datenquelle zugeordnet haben, klicken Sie auf Einrichten.

      Hinweis: Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen, wählen Sie "ODBC-Treiber Universal" aus.

    2. Wählen Sie die Datenquelle der Datenbank aus, die Sie aktualisieren möchten. Wenn Sie noch keine Datenquelle für die vorhandene Datenbank erstellt haben, klicken Sie auf Neu, um dies jetzt zu erledigen.

      Wenn Sie eine neue Quelle erstellen, wird ihr Name zur Liste Datenquellen hinzugefügt.

    3. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf Weiter.

  6. Folgen Sie den Anweisungen in allen treiberspezifischen Dialogfeldern.

    Geben Sie beispielsweise im Dialogfeld Datenquelle verbinden einen Benutzernamen und das Kennwort ein, und klicken Sie auf OK. Wenn Ihre Datenquelle nicht kennwortgeschützt ist, klicken Sie einfach auf OK.

    Hinweis: Wenn Sie den Standardtreiber "ODBC-Treiber Universal" verwenden, wird möglicherweise eine Fehlermeldung angezeigt, die darauf hinweist, dass die Informationen, für die ein Reverse Engineering durchgeführt wurde, unvollständig sein können. In den meisten Fällen ist das kein Problem. Klicken Sie einfach auf OK, und setzen Sie die Ausführung des Assistenten fort.

  7. Aktivieren Sie die Kontrollkästchen für den Typ von Informationen, die Sie extrahieren möchten, und klicken Sie auf Weiter.

    Hinweis: Einige Elemente sind möglicherweise nicht verfügbar (werden abgeblendet angezeigt), weil nicht alle Datenbank-Managementsysteme alle Arten von Elementen unterstützen, die der Assistent extrahieren kann.

  8. Aktivieren Sie die Kontrollkästchen für die Tabellen (und Ansichten, falls vorhanden), die Sie extrahieren möchten, oder klicken Sie auf Alles auswählen, um alle Tabellen (und Ansichten) zu extrahieren. Klicken Sie dann auf Weiter.

    Hinweis: Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen und in dieser Liste keine Elemente angezeigt werden, müssen Sie wahrscheinlich den Zellbereich benennen, der die Spaltenüberschriften in Ihrem Arbeitsblatt enthält. Weitere Informationen finden Sie unter Definieren und Verwenden von Namen in Formeln.

  9. Wenn Sie in Schritt 5 das Kontrollkästchen Gespeicherte Prozeduren aktiviert haben, wählen Sie die zu extrahierenden Prozeduren aus, oder klicken Sie auf Alles auswählen, um alle Prozeduren zu extrahieren, und klicken Sie dann auf Weiter.

  10. Wählen Sie aus, ob die Elemente, für die ein Reverse Engineering durchgeführt wurde, automatisch zur aktuellen Seite hinzugefügt werden sollen.

    Hinweis: Sie können im Assistenten auswählen, dass die Zeichnung automatisch erstellt wird und die Elemente, für die ein Reverse Engineering durchgeführt wurde, zusätzlich im Fenster "Tabellen und Ansichten" aufgelistet werden. Wenn die Zeichnung nicht automatisch erstellt werden soll, können Sie die Elemente aus dem Fenster "Tabellen und Ansichten" auf Ihr Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

  11. Überprüfen Sie die ausgewählten Optionen, um sicherzustellen, dass die gewünschten Informationen extrahiert werden. Klicken Sie dann auf Fertig stellen.

    Der Assistent extrahiert die ausgewählten Informationen und zeigt im Ausgabefenster Hinweise zum Extrahierungsprozess an.

Wenn Sie über ein VisioModeler- oder PLATINUM ERwin-Modell verfügen, können Sie es möglicherweise importieren, um ein Visio-Datenbankmodelldiagramm zu erstellen. Diese Möglichkeit ist auf Wörterbuchmodelldateien (IMD-Dateien) von VisioModeler 2.0 oder höher sowie ERX-Dateien von PLATINUM ERwin 2.6, 3.0 und 3.52 beschränkt.

  1. Wählen Sie Datei > Neu aus.

  2. Wählen Sie unter Vorlagenkategorien die Option Software und Datenbank und dann Datenbankmodelldiagramm aus.

  3. Wählen Sie auf der rechten Seite entweder Metrische Einheiten oder US-Einheiten und dann Erstellen aus.

  4. Wählen Sie auf der Registerkarte Datenbank des Menübands in der Gruppe Modell die Option Importieren und dann den Dateityp aus, aus dem Sie importieren möchten.

  5. Geben Sie den Pfad und Dateinamen für das Modell ein, das Sie importieren möchten, oder klicken Sie auf die Schaltfläche Durchsuchen, um die Modelldatei zu suchen. Klicken Sie dann auf Öffnen.

  6. Klicken Sie im Dialogfeld Importieren auf OK.

    Visio importiert die Datei und zeigt deren Status im Ausgabefenster an. Die importierten Tabellen werden im Fenster "Tabellen und Ansichten" angezeigt.

  7. Wählen Sie im Fenster "Tabellen und Ansichten" die Tabellen aus, die Sie modellieren möchten, und ziehen Sie sie auf das Zeichenblatt.

In diesem Artikel wird beschrieben, wie Sie ein Datenbankmodell erstellen und welche Aufgaben Sie mit dem fertig erstellten Modell ausführen können. Wählen Sie für einen Schnellstart Datei > Neu > Software und Datenbank und dann Datenbankmodelldiagramm aus.

Hinweis: Das Datenbankmodelldiagramm ist nur in bestimmten Versionen von Visio verfügbar. Weitere Informationen finden Sie unter Sie können die Datenbankmodellierungsfeatures nicht finden?

1. Starten eines Datenbankmodelldiagramms

Wenn Sie keine Datenbank haben, die Sie als Ausgangspunkt verwenden möchten, können Sie mit einem leeren Datenbankmodell beginnen, dem Sie Ihre eigenen Tabellen und Beziehungen hinzufügen.

  1. Wählen Sie Datei > Neu > Software und Datenbank und dann eine der beiden Datenbankmodelldiagramm-Optionen aus.

  2. Zeigen Sie im Menü Datenbank auf Optionen, und wählen Sie Dokument aus.

  3. Wählen Sie im Dialogfeld Datenbank-Dokumentoptionen den gewünschten Symbolsatz sowie weitere Optionen für Tabellen und Beziehungen aus. Klicken Sie dann auf OK.

Wenn Sie eine Datenbank haben, die Sie modellieren möchten, um sie besser verstehen zu können oder die Sie als Ausgangspunkt für ein neues Modell verwenden möchten, können Sie mithilfe des Assistenten für Reverse Engineering das Schema (die Struktur) der Datenbank extrahieren und ein neues Modell erstellen.

Erforderliche Schritte vor dem Starten des Assistenten:

  • Wenn Sie Reverse Engineering für eine Excel-Arbeitsmappe durchführen möchten, öffnen Sie zuerst die Arbeitsmappe, und benennen Sie die Gruppe (oder den Bereich) der Zellen, die die Spaltenüberschriften enthalten. Wenn Sie mehrere Arbeitsblätter verwenden möchten, benennen Sie einfach die Gruppe von Spaltenzellen in jedem Arbeitsblatt. Im Assistenten werden diese Bereiche wie Tabellen behandelt. Weitere Informationen zum Benennen von Zellbereichen finden Sie unter Definieren und Verwenden von Namen in Formeln.

  • Legen Sie vor dem Ausführen des Assistenten für Reverse Engineering den Standardtreiber auf die Zieldatenbank fest, für die das Reverse Engineering durchgeführt werden soll, um optimale Ergebnisse zu erzielen. Durch diesen Schritt wird sichergestellt, dass der Assistent die systemeigenen Datentypen richtig zuordnet und der gesamte vom Assistenten extrahierte Code im Codefenster ordnungsgemäß angezeigt wird.

Starten des Assistenten:

  1. Zeigen Sie im Menü Datei auf Neu, dann auf Software und Datenbank, und wählen Sie anschließend eine der beiden Datenbankmodelldiagramm-Optionen aus.

  2. Klicken Sie im Menü Datenbank auf Reverse Engineering, um den Assistenten zu öffnen.

  3. Führen Sie im ersten Bildschirm des Assistenten für Reverse Engineering die folgenden Aktionen aus:

    1. Wählen Sie den Visio-Datenbanktreiber für Ihr Datenbank-Managementsystem (DBMS) aus. Wenn Sie den Visio-Datenbanktreiber noch keiner bestimmten ODBC-Datenquelle zugeordnet haben, klicken Sie auf Einrichten.

      Hinweis: Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen, wählen Sie "ODBC-Treiber Universal" aus.

    2. Wählen Sie die Datenquelle der Datenbank aus, die Sie aktualisieren möchten. Wenn Sie noch keine Datenquelle für die vorhandene Datenbank erstellt haben, klicken Sie auf Neu, um dies jetzt zu erledigen.

      Wenn Sie eine neue Quelle erstellen, wird ihr Name zur Liste Datenquellen hinzugefügt.

    3. Wenn die Einstellungen Ihren Vorstellungen entsprechen, klicken Sie auf Weiter.

  4. Folgen Sie den Anweisungen in allen treiberspezifischen Dialogfeldern.

    Geben Sie beispielsweise im Dialogfeld Datenquelle verbinden einen Benutzernamen und das Kennwort ein, und klicken Sie auf OK. Wenn Ihre Datenquelle nicht kennwortgeschützt ist, klicken Sie einfach auf OK.

    Hinweis: Wenn Sie den Standardtreiber "ODBC-Treiber Universal" verwenden, wird möglicherweise eine Fehlermeldung angezeigt, die darauf hinweist, dass die Informationen, für die ein Reverse Engineering durchgeführt wurde, unvollständig sein können. In den meisten Fällen ist das kein Problem. Klicken Sie einfach auf OK, und setzen Sie die Ausführung des Assistenten fort.

  5. Aktivieren Sie die Kontrollkästchen für den Typ von Informationen, die Sie extrahieren möchten, und klicken Sie auf Weiter.

    Hinweis: Einige Elemente sind möglicherweise nicht verfügbar (werden abgeblendet angezeigt), weil nicht alle Datenbank-Managementsysteme alle Arten von Elementen unterstützen, die der Assistent extrahieren kann.

  6. Aktivieren Sie die Kontrollkästchen für die Tabellen (und Ansichten, falls vorhanden), die Sie extrahieren möchten, oder klicken Sie auf Alles auswählen, um alle Tabellen (und Ansichten) zu extrahieren. Klicken Sie dann auf Weiter.

    Hinweis: Wenn Sie ein Reverse Engineering für ein Excel-Arbeitsblatt durchführen und in dieser Liste keine Elemente angezeigt werden, müssen Sie wahrscheinlich den Zellbereich benennen, der die Spaltenüberschriften in Ihrem Arbeitsblatt enthält. Weitere Informationen finden Sie unter Definieren und Verwenden von Namen in Formeln.

  7. Wenn Sie in Schritt 5 das Kontrollkästchen Gespeicherte Prozeduren aktiviert haben, wählen Sie die zu extrahierenden Prozeduren aus, oder klicken Sie auf Alles auswählen, um alle Prozeduren zu extrahieren, und klicken Sie dann auf Weiter.

  8. Wählen Sie aus, ob die Elemente, für die ein Reverse Engineering durchgeführt wurde, automatisch zur aktuellen Seite hinzugefügt werden sollen.

    Hinweis: Sie können im Assistenten auswählen, dass die Zeichnung automatisch erstellt wird und die Elemente, für die ein Reverse Engineering durchgeführt wurde, zusätzlich im Fenster "Tabellen und Ansichten" aufgelistet werden. Wenn die Zeichnung nicht automatisch erstellt werden soll, können Sie die Elemente aus dem Fenster "Tabellen und Ansichten" auf Ihr Zeichenblatt ziehen, um das Datenbankmodell manuell zusammenzustellen.

  9. Überprüfen Sie die ausgewählten Optionen, um sicherzustellen, dass die gewünschten Informationen extrahiert werden. Klicken Sie dann auf Fertig stellen.

    Der Assistent extrahiert die ausgewählten Informationen und zeigt im Ausgabefenster Hinweise zum Extrahierungsprozess an.

Wenn Sie über ein VisioModeler- oder PLATINUM ERwin-Modell verfügen, können Sie es möglicherweise importieren, um ein Visio-Datenbankmodelldiagramm zu erstellen. Diese Möglichkeit ist auf Wörterbuchmodelldateien (IMD-Dateien) von VisioModeler 2.0 oder höher sowie ERX-Dateien von PLATINUM ERwin 2.6, 3.0 und 3.52 beschränkt.

  1. Zeigen Sie im Menü Datei auf Neu, dann auf Software und Datenbank, und klicken Sie auf Datenbankmodelldiagramm.

  2. Zeigen Sie im Menü Datenbank auf Importieren, und klicken Sie auf <Modelltyp> importieren.

  3. Geben Sie den Pfad und Dateinamen für das Modell ein, das Sie importieren möchten, oder klicken Sie auf die Schaltfläche Durchsuchen, um die Modelldatei zu suchen. Klicken Sie dann auf Öffnen.

  4. Wählen Sie im Dialogfeld Importieren die Option OK aus.

    Visio importiert die Datei und zeigt deren Status im Ausgabefenster an. Die importierten Tabellen werden im Fenster "Tabellen und Ansichten" angezeigt.

  5. Wählen Sie im Fenster "Tabellen und Ansichten" die Tabellen aus, die Sie modellieren möchten, und ziehen Sie sie auf das Zeichenblatt.

2. Verfeinern der Diagrammstruktur

Nachdem Sie ein Datenbankmodelldiagramm erstellt haben, beginnt die Arbeit der Diagrammverfeinerung. Sie können die drei Hauptkomponenten eines Modells hinzufügen und anpassen:

  • Entitäten (oder Tabellen),

  • Spalten (welche die Fakten zu einer Tabelle beschreiben) und

  • Beziehungen (die Zuordnungen zwischen Tabellen). Beziehungen können 1:1-, 1:n- oder m:n-Beziehungen sein.

Wählen Sie unten eine Überschrift aus, um Anweisungen zum Hinzufügen des Features zum Modell zu öffnen.

Die Vorlage "Datenbankmodelldiagramm" enthält zwei Schablonen. Wenn Sie die Struktur des Diagramms verfeinern, arbeiten Sie mit der Schablone, die für Sie am geeignetsten ist:

  • Verwenden Sie die Schablone "Entitätsbeziehung" zum Modellieren von Datenbanken, die auf SQL92 oder früheren Standards basieren.

  • Verwenden Sie die Schablone "Objektrelational", die zusätzliche Shapes zum Arbeiten mit Typen enthält, um Datenbanken zu modellieren, die auf SQL99 und späteren Standards basieren.

Verwenden Sie das Shape Entität, um eine Tabelle in Ihrem Diagramm zu erstellen:

  1. Ziehen Sie entweder aus der Schablone Entitätsbeziehung oder Objektrelational ein Shape Entität auf die Zeichnung.

  2. Doppelklicken Sie auf das Shape, um das Fenster Datenbankeigenschaften zu öffnen.

  3. Klicken Sie unter Kategorien auf Definition, und geben Sie einen Namen für die Tabelle ein.

  4. Klicken Sie unter Kategorien auf Spalten, geben Sie einen Namen ein, und wählen Sie einen Datentyp aus.

  5. Aktivieren Sie das Kontrollkästchen Erforderlich für Spalten, die keine Nullwerte enthalten können.

  6. Aktivieren Sie das Kontrollkästchen PS (Primärschlüssel) für Spalten, die jede Zeile in der Datenbanktabelle eindeutig identifizieren.

  7. Klicken Sie unter Kategorien auf Indizes, Trigger, Prüfen oder Erweitert, um diese optionalen Elemente zu erstellen.

Über das Fenster Datenbankeigenschaften können Sie Eigenschaften für Spalten hinzufügen oder ändern, darunter Datentypen und Primärschlüssel:

  1. Doppelklicken Sie in Ihrem Diagramm auf die Tabelle.

  2. Klicken Sie im Fenster Datenbankeigenschaften unter Kategorien auf Spalten.

  3. Klicken Sie in der ersten leeren Zelle vom Typ Physischer Name, und geben Sie einen Namen ein.

  4. Um den Datentyp für eine Spalte zu ändern, klicken Sie auf das Feld Datentyp der Spalte, und wählen Sie den gewünschten Datentyp aus der Liste aus, oder geben Sie ihn in die Liste ein. So können Sie beispielsweise Dezimal(8,2) oder Zeichen(30) eingeben.

  5. Um Nullwerte zu verhindern, aktivieren Sie das Kontrollkästchen Erforderlich.

  6. Um anzugeben, dass die Spalte ein Primärschlüssel ist, aktivieren Sie das Kontrollkästchen PS.

  7. Wenn Sie weitere Spalteneigenschafen zusätzlich zu denen anzeigen möchten, die beim Klicken auf die Kategorie Spalten angezeigt werden, wählen Sie die Spalte aus, und klicken Sie auf Bearbeiten.

In Beziehungen werden Primär- und Fremdschlüssel verwendet, damit Datenbanken eine Zeile in einer Tabelle mit einer Zeile in einer verknüpften Tabelle vergleichen können. Sie können diese Beziehungen in Ihrem Diagramm anzeigen. Darüber hinaus können Sie deren Kardinalität (z. B. "1:n") festlegen und sie mithilfe der Notation "Crow's Feet", "Relational" oder "IDEF1X" anzeigen. Sie können in der Vorlage "Datenbankmodelldiagramm" mit keiner dieser Notationen m:n-Beziehungen anzeigen.

So erstellen Sie eine Beziehung zwischen Tabellen:

  1. Vergewissern Sie sich, dass beide Tabellen im Diagramm sichtbar sind. Wenn Sie für das Modell ein Reverse Engineering aus einer vorhandenen Datenbank durchgeführt haben, müssen Sie möglicherweise eine oder beide aus dem Fenster "Tabellen und Ansichten" auf das Zeichenblatt ziehen.

  2. Doppelklicken Sie auf die Tabelle, die Sie für die Seite des primären Schlüssels der Beziehung verwenden möchten.

  3. Klicken Sie im Fenster Datenbankeigenschaften unter Kategorien auf Spalten.

  4. Klicken Sie im Raster auf die Spalte, die Sie für die eindeutige Identifizierung jeder Zeile in der Tabelle verwenden möchten, und aktivieren Sie das Kontrollkästchen PS, um sie als Primärschlüssel festzulegen.

  5. Ziehen Sie aus der Schablone Objektrelational oder Entitätsbeziehung ein Beziehung-Shape, und legen Sie es auf einem leeren Bereich auf dem Zeichenblatt ab.

  6. Verbinden Sie das obere Ende der Tabelle mit der übergeordneten Tabelle.

  7. Verbinden Sie das andere Ende mit der untergeordneten Tabelle.

    Wenn die zweite Tabelle nicht bereits eine Spalte mit demselben Namen als Primärschlüssel enthält, fügt es der Modellierer zur zweiten Tabelle als Fremdschlüssel hinzu.

    Hinweis: Wenn Beziehungslinien verschwinden, klicken Sie auf der Registerkarte Datenbank in der Gruppe Verwalten auf Anzeigeoptionen. Aktivieren Sie auf der Registerkarte Beziehungen unter Anzeigen das Kontrollkästchen Beziehungen.

So legen Sie die Kardinalität der Beziehung fest:

  1. Doppelklicken Sie auf die Beziehung.

  2. Klicken Sie im Fenster Datenbankeigenschaften unter Kategorien auf Verschiedenes.

  3. Wählen Sie unter Kardinalität die Kardinalität aus, die zur Beziehung am besten passt. Die optimale Wahl bei 1:n-Beziehungen ist entweder Null oder mehr oder Eins oder mehr. Die optimale Wahl bei 1:1-Beziehungen ist entweder Null oder Eins oder Genau Eins.

3. Hinzufügen von Features zum Suchen und Aktualisieren von Daten

Wenn Sie weitere Verfeinerungen am Diagramm vornehmen (z. B. Indizes, Prüfklauseln und Trigger erstellen) möchten, wählen Sie unten eine Überschrift aus, um Anweisungen zum Hinzufügen zu öffnen, indem Sie eine der folgenden Aktionen ausführen:

Indizes verbessern die Leistung (Geschwindigkeit) Ihrer Datenbank, wenn Sie eine Abfrage ausführen.

  1. Öffnen Sie das Datenbankmodelldiagramm.

  2. Doppelklicken Sie auf die Tabelle, der Sie einen Index hinzufügen möchten, und klicken Sie im Fenster Datenbankeigenschaften in der Liste Kategorien auf Indizes.

  3. Klicken Sie auf Neu.

  4. Geben Sie im Dialogfeld Index erstellen einen Namen für den Index ein, und klicken Sie auf OK.

  5. Wählen Sie in der Liste Indextyp eine Option zum Erstellen eines eindeutigen oder nicht eindeutigen Indexes aus.

  6. Wählen Sie in der Liste Verfügbare Spalten den Namen jeder Spalte aus, in die dieser Index einbezogen werden soll. Klicken Sie dann auf Hinzufügen >.

  7. Aktivieren Sie in der Liste Indizierte Spalten das Kontrollkästchen Auf, um einen Index mit aufsteigender Sortierreihenfolge zu erstellen, oder deaktivieren Sie das Kontrollkästchen, um einen Index mit absteigender Sortierreihenfolge zu erstellen.

    Das Datenbankmodelldiagramm wird aktualisiert.

Sie können sich eine Ansicht als eine gespeicherte Abfrage vorstellen. Ansichten sind besonders hilfreich, wenn Sie auf dieselben Informationen aus mehreren Tabellen wiederholt zugreifen müssen oder wenn Sie die Daten für Benutzer verfügbar machen und gleichzeitig verhindern möchten, dass sie an den eigentlichen Tabellen Änderungen vornehmen.

Ziehen Sie aus der Schablone Entitätsbeziehung oder Objektrelational ein Shape Ansicht auf das Zeichenblatt.

Je nach Ihrem Datenbank-Managementsystem (DBMS) können Sie erweiterte Eigenschaften für Tabellen oder Ansichten festlegen, um ihren Speicherort zu bestimmen.

Doppelklicken Sie auf die Tabelle oder Ansicht, deren erweiterte Eigenschaften Sie festlegen möchten, und klicken Sie im Fenster Datenbankeigenschaften in der Liste Kategorien auf Erweitert.

Mithilfe von Prüfklauseln können Sie sicherstellen, dass die in eine Spalte eingegebenen Daten innerhalb eines bestimmten Wertebereichs liegen. So können Sie beispielsweise eine Prüfklausel erstellen, bei der die in die Spalte "Alter" eingegebenen Daten über "65" liegen müssen.

  1. Doppelklicken Sie auf die Tabelle, um das Fenster Datenbankeigenschaften zu öffnen.

  2. Klicken Sie unter Kategorien auf Spalten und dann auf die Spalte, in der Sie eine Prüfklausel hinzufügen möchten.

  3. Klicken Sie auf Bearbeiten.

  4. Geben Sie auf der Registerkarte Prüfen des Dialogfelds Spalteneigenschaften die gewünschten Einschränkungen ein. Weitere Informationen zu Ihren Wahlmöglichkeiten finden Sie unter Dialogfeld "Spalten- und Feldeigenschaften (Registerkarte "Prüfen").

    Die Prüfklausel wird zum Codefenster unter Lokaler Code hinzugefügt.

Mithilfe von gespeicherten Prozeduren und benutzerdefinierten Funktionen können Sie Codepakete erstellen, die Sie wiederverwenden können, um dieselben Aktionen wiederholt auszuführen. Der Hauptunterschied zwischen den beiden besteht darin, dass eine benutzerdefinierte Funktion einen Wert zurückgibt, während die gespeicherte Prozedur Code ausführt, ohne einen Wert zurückzugeben.

  1. Aktivieren Sie auf der Registerkarte Datenbank in der Gruppe Einblenden/Ausblenden das Kontrollkästchen Code, um das Codefenster zu öffnen.

  2. Klicken Sie auf Globaler Code und dann auf Neu.

  3. Klicken Sie auf der Registerkarte Eigenschaften des Code-Editors auf die Art von Code, den Sie erstellen möchten, und geben Sie einen Namen für den Code ein.

  4. Geben Sie auf der Registerkarte Rumpf den Code ein, und klicken Sie auf OK.

Trigger bewirken, dass der darin angegebene SQL-Code ausgeführt wird, wenn ein bestimmtes Ereignis in der Datenbank eintritt.

  1. Doppelklicken Sie auf die Tabelle, um das Fenster Datenbankeigenschaften zu öffnen.

  2. Klicken Sie unter Kategorien auf Trigger und dann auf Hinzufügen.

  3. Geben Sie auf der Registerkarte Eigenschaften einen Namen für den Trigger ein.

  4. Geben Sie auf der Registerkarte Rumpf den Code ein, und klicken Sie auf OK.

    Der Trigger wird im Codefenster unter Lokaler Code hinzugefügt.

Sie können die Datenbankmodellierungsfeatures nicht finden?

Bei einigen Editionen von Visio fehlen einige oder alle Datenbankmodellierungsfeatures:

  • In Visio Standard ist die Vorlage "Datenbankmodelldiagramm" nicht enthalten.

  • Die Editionen Visio Professional und Premium unterstützen die Reverse Engineering-Features für die Vorlage "Datenbankmodelldiagramm" (also das Verwenden einer vorhandenen Datenbank zum Erstellen eines Modells in Visio). Das Forward Engineering (also das Verwenden eines Visio-Datenbankmodells zum Generieren von SQL-Code) wird jedoch nicht unterstützt.

  • Visio für Enterprise Architects umfasst die gesamte Sammlung von Datenbankmodellierungsfeatures, einschließlich Reverse Engineering und Forward Engineering. Visio für Enterprise Architects ist im MSDN Premium-Abonnement enthalten, das für Visual Studio Professional und für rollenbasierte Editionen von Visual Studio Team System verfügbar ist.

Wenn Sie herausfinden möchten, über welche Visio-Version Sie verfügen, klicken Sie im Menü Hilfe auf Info. Der Name der Version wird im Dialogfeld in der obersten Textzeile angezeigt.

Wenn Sie Visio Plan 2 verwenden und erfahren möchten, wie Sie eine bestehende Datenbank zum Erstellen eines Datenbankmodells verwenden können, lesen Sie Durchführen von Reverse-Engineering für eine vorhandene Datenbank.

Siehe auch

Definieren einer Beziehung in einem Datenbankmodelldiagramm

Erstellen oder Bearbeiten von Ansichten in Datenbankmodelldiagrammen

Hinzufügen von Tabellen und Spalten zu Datenbankmodelldiagrammen

Festlegen und Bearbeiten von Datentypen in Datenbankmodelldiagrammen

Anzeigen der Crow's Foot-Notation in einem Datenbankmodelldiagramm

Erstellen oder Bearbeiten eines Indexes in einem Datenbankmodelldiagramm

Beibehalten der referenziellen Integrität in Datenbankmodelldiagrammen

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×