Mit Microsoft anmelden
Melden Sie sich an, oder erstellen Sie ein Konto.
Hallo,
Wählen Sie ein anderes Konto aus.
Sie haben mehrere Konten.
Wählen Sie das Konto aus, mit dem Sie sich anmelden möchten.

Ein UML-Sequenzdiagramm zeigt, wie eine Gruppe von Objekten im Laufe der Zeit in einem Prozess interagiert. Es zeigt die Meldungen, die zwischen Teilnehmern und Objekten im System übergeben werden, sowie die Reihenfolge, in der sie auftreten.

Beispiel für ein UML-Sequenzdiagramm mit einem ATM-System

Verwenden Sie zum Erstellen eines Sequenzdiagramms eine UML-Sequenzvorlage oder ein Startdiagramm, die die UML-Sequenzschablone enthält. Ziehen Sie Shapes aus der Schablone auf den Zeichenbereich, um das Diagramm zu erstellen.

Starten eines Sequenzdiagramms

  1. Starten Sie Visio. Oder, wenn Sie bereits eine Datei geöffnet haben, klicken Sie auf Datei > Neu.

  2. Geben Sie im Suchfeld umL-Sequenz ein.

  3. Wählen Sie das UML-Sequenzdiagramm aus.

  4. Wählen Sie im Dialogfeld die leere Vorlage oder eines der drei Startdiagramme aus. (Wenn Sie sie auswählen, wird auf der rechten Seite eine Beschreibung der einzelnen Angezeigt.) Wählen Sie dann entweder Metrische Einheiten oder US-Einheiten aus.

  5. Wählen Sie Erstellen aus.

  6. Das Diagramm wird geöffnet. Daraufhin sollte neben dem Diagramm das Fenster Shapes angezeigt werden. Wenn sie nicht angezeigt wird, wechseln Sie zu Ansicht >Aufgabenbereiche, und stellen Sie sicher, dass Shapes ausgewählt ist. Wenn sie immer noch nicht angezeigt wird, klicken Sie links auf die Schaltfläche Fenster "Shapes erweitern".

  7. Stellen Sie auf der Registerkarte Ansicht sicher, dass das Kontrollkästchen neben Verbindungspunkte aktiviert ist. Mit dieser Option werden Verbindungspunkte angezeigt, wenn Sie mit dem Verbinden von Shapes beginnen.

  8. Ziehen Sie jetzt die Shapes, die Sie in Ihr Diagramm einbeziehen möchten, aus dem Fenster Shapes auf das Zeichenblatt. Wenn Sie die Textbezeichnungen umbenennen möchten, doppelklicken Sie auf die Bezeichnungen.

Lebenslinien für Objekte und Objekte

Verwenden Sie für jeden Teilnehmer eine Akteur-Lebenslinie-Form und für jede Systemkomponente in Ihrem Prozess eine Objekt-Lebenslinie-Form.

UML-Sequenzlebenslinie

Tipp: Während Sie die Lebenslinien an Ihre Position ziehen, werden grüne Ausrichtungslinien auf dem Bildschirm angezeigt, damit Sie die Lebenslinien im Verhältnis zu den anderen Lebenslinienformen ausrichten und abstandieren können.

  • Doppelklicken Sie in das Überschriftenfeld für jede Lebenslinie, um einen Namen oder Titel ein eingeben.

  • Zum Längen oder Kürzen einer Zeitachse klicken Sie auf die Lebenslinie, und ziehen Sie dann den gelben Kontrollpunkt am unteren Rand der Lebenslinie.

Nachrichten

Verwenden Sie Nachrichten-Shapes, um Informationen zu darstellen, die zwischen den Lebenslinien gesendet werden.

UML-Sequenznachrichten

Tipp:  Visio hilft Ihnen, die Nachrichtenendpunkte an jede Lebenslinie zu kleben. Am Endpunkt wird ein grüner Kreis angezeigt, wenn er an einen Verbindungspunkt geklebt wird. Die Verbindungspunkte verschwinden, wenn Sie mit dem Ziehen fertig sind.

  • Fügen Sie den Anfangsendpunkt an die Lebenslinie an, die die Nachricht sendet, und ziehen Sie dann den Endpunkt auf dem Kopf zur Lebenslinie, die die Nachricht empfängt.

  • Doppelklicken Sie auf das Nachrichten-Shape, um ein Textfeld zu erstellen, und geben Sie einen Namen für die Nachricht ein.

  • Verwenden Sie ein Nachrichten-Shape (eine einfarbige Linie), um eine Anforderung oder die Übertragung von Informationen zu darstellen.

  • Verwenden Sie das Shape "Nachricht zurückgeben" (eine gestrichelte Linie), um eine Antwort auf eine frühere Nachricht zu darstellen.

  • Verwenden Sie eine Selbstnachricht, um einen rekursiven Aufruf eines Vorgangs oder eine Methode, die eine andere Methode aufruft, die demselben Objekt gehört, zu repräsentieren.

  • Verwenden Sie das Asynchrone Nachrichten-Shape, um zu zeigen, wann eine Aktion möglicherweise nicht sofort auftritt.

  • So ändern Sie die Form einer Verbindernachricht:

    1. Klicken Sie mit der rechten Maustaste auf den Verbinder.

    2. Wählen Sie unten im Popupmenü eine der drei Optionen aus (Rechtwinklig, Gerade,Gekrümmt).

    3. Klicken Sie auf den Verbinder, und ziehen Sie ihn, um dessen Form zu ändern.

Fragmente

Wenn eine oder mehrere Interaktionen eine Schleife bilden oder eine Bedingung erfüllt sein muss, um die Interaktion zu beenden, schließen Sie diese Interaktionen in ein Fragment-Shape ein:

  • Verwenden Sie das Fragment "Schleifen" für eine einfache wiederholte Interaktion.

  • Verwenden Sie das Fragment Optional für Schritte, die nur ausgeführt werden, wenn eine bestimmte Bedingung erfüllt ist.

  • Verwenden Sie die Alternative Fragmentform für einen wenn-dann-oder wenn-dann-anderen Prozess oder eine andere Interaktion. Das Fragment umfasst zwei Abschnitte, in denen Sie die alternative Interaktion anzeigen können. Um eine weitere Bedingung hinzuzufügen, ziehen Sie einen Interaktionsopernden auf das Shape. 

    UML-Sequenzbedingung

  • Ziehen Sie das Fragment-Shape auf die Interaktionen, mit der es sich bezieht. Verwenden Sie die Ziehpunkte des Fragment-Shapes, um sicherzustellen, dass alle zugehörigen Interaktionen eingeschlossen sind.

  • Doppelklicken Sie in die Titelecke der Fragmentform, um einen Titel oder eine kurze Beschreibung des Prozesses zwischen dem Fragment hinzuzufügen. Klicken Sie unter der Titelecke auf die Eingabeaufforderung [Parameter], wenn Sie die Bedingungen eingeben möchten, die diesen Vorgang beenden würden.

Aktivierung

Platzieren Sie ein Aktivierungsleisten-Shape in einer Lebenslinie, um zu zeigen, wann und wie lange das Objekt oder der Teilnehmer im Prozess aktiv ist. Normalerweise werden Pfeile zu und von einem Aktivierungsfeld angezeigt, um den Informationsfluss zu veranschaulichen.

Ziehen Sie die Endpunkte der Aktivierungsleiste nach oben oder unten, um die von Ihnen angezeigte Länge zu erhalten.

UML-Sequenzaktivierung

Verunglutung

Eine Abentutung gibt an, wann ein Objekt oder Akteur an einem System teilnimmt. Am Ende der Lebenslinie wird ein großes X angezeigt. So zeigen Sie die Verunglutung eines Objekts in einem Diagramm an

  • Klicken Sie mit der rechten Maustaste auf das Objekt, und wählen Sie "Angewendete Objekte anzeigen" aus.

Verwenden Sie zum Erstellen eines Sequenzdiagramms eine UML-Sequenzvorlage oder ein Startdiagramm, die die UML-Sequenzschablone enthält. Ziehen Sie Shapes aus der Schablone auf den Zeichenbereich, um das Diagramm zu erstellen.

Hinweis: Zum Erstellen und Bearbeiten von UML-Diagrammen auf Visio für das Web-Diagrammen ist eine Visio Plan 1- oder Visio Plan 2-Lizenzerforderlich, die separat im Microsoft 365. Weitere Informationen erhalten Sie von Ihrem Microsoft 365 Administrator. Wenn Ihr Administrator den Self-Service-Einkauf aktiviert hat, können Sie eine Lizenz für Visio erwerben. Weitere Informationen finden Sie unter Häufig gestellte Fragen zu Self-Service-Käufen.

Starten eines Sequenzdiagramms

  1. Öffnen Visio für das Web

  2. Wählen Sie in der oberen rechten Ecke der Seite Weitere Vorlagen aus.

  3. Scrollen Sie im Katalog nach unten zur Zeile UML-Sequenz.

    Das erste Element in der Zeile stellt eine leere Vorlage sowie die Begleitschablone dar. Die anderen Elemente in der Zeile sind Beispieldiagramme, in die bereits einige Shapes gezeichnet wurden, um Ihnen einen schnellen Einstieg zu helfen.

  4. Klicken Sie auf ein Element, um eine größere Vorschau anzuzeigen.

  5. Wenn Sie das zu verwendende Diagramm finden, klicken Sie auf dessen Schaltfläche Erstellen.

    Das neue Diagramm mit der zugehörigen Schablone wird in Ihrem Browser geöffnet.

Lebenslinien für Objekte und Objekte

Verwenden Sie für jeden Teilnehmer eine Akteur-Lebenslinie-Form und für jede Systemkomponente in Ihrem Prozess eine Objekt-Lebenslinie-Form.

UML-Sequenzlebenslinie

Tipp: Während Sie die Lebenslinien an Ihre Position ziehen, werden grüne Ausrichtungslinien auf dem Bildschirm angezeigt, damit Sie die Lebenslinien im Verhältnis zu den anderen Lebenslinienformen ausrichten und abstandieren können.

  • Doppelklicken Sie in das Überschriftenfeld für jede Lebenslinie, um einen Namen oder Titel ein eingeben.

  • Zum Längen oder Kürzen einer Zeitachse klicken Sie auf die Lebenslinie, und ziehen Sie dann den gelben Kontrollpunkt am unteren Rand der Lebenslinie.

Nachrichten

Verwenden Sie Nachrichten-Shapes, um Informationen zu darstellen, die zwischen den Lebenslinien gesendet werden.

UML-Sequenznachrichten

Tipp:  Visio hilft Ihnen, die Nachrichtenendpunkte an jede Lebenslinie zu kleben. Am Endpunkt wird ein grüner Kreis angezeigt, wenn er an einen Verbindungspunkt geklebt wird. Die Verbindungspunkte verschwinden, wenn Sie mit dem Ziehen fertig sind.

  • Fügen Sie den Anfangsendpunkt an die Lebenslinie an, die die Nachricht sendet, und ziehen Sie dann den Endpunkt auf dem Kopf zur Lebenslinie, die die Nachricht empfängt.

  • Doppelklicken Sie auf das Nachrichten-Shape, um ein Textfeld zu erstellen, und geben Sie einen Namen für die Nachricht ein.

  • Verwenden Sie ein Nachrichten-Shape (eine einfarbige Linie), um eine Anforderung oder die Übertragung von Informationen zu darstellen.

  • Verwenden Sie das Shape "Nachricht zurückgeben" (eine gestrichelte Linie), um eine Antwort auf eine frühere Nachricht zu darstellen.

  • Verwenden Sie eine Selbstnachricht, um einen rekursiven Aufruf eines Vorgangs oder eine Methode, die eine andere Methode aufruft, die demselben Objekt gehört, zu repräsentieren.

  • Verwenden Sie das Asynchrone Nachrichten-Shape, um zu zeigen, wann eine Aktion möglicherweise nicht sofort auftritt.

  • So ändern Sie die Form einer Verbindernachricht:

    1. Klicken Sie mit der rechten Maustaste auf den Verbinder.

    2. Wählen Sie unten im Popupmenü eine der drei Optionen aus (Rechtwinklig, Gerade,Gekrümmt).

    3. Klicken Sie auf den Verbinder, und ziehen Sie ihn, um dessen Form zu ändern.

Fragmente

Wenn eine oder mehrere Interaktionen eine Schleife bilden oder eine Bedingung erfüllt sein muss, um die Interaktion zu beenden, schließen Sie diese Interaktionen in ein Fragment-Shape ein:

  • Verwenden Sie das Fragment "Schleifen" für eine einfache wiederholte Interaktion.

  • Verwenden Sie das Fragment Optional für Schritte, die nur ausgeführt werden, wenn eine bestimmte Bedingung erfüllt ist.

  • Verwenden Sie die Alternative Fragmentform für einen wenn-dann-oder wenn-dann-anderen Prozess oder eine andere Interaktion. Das Fragment umfasst zwei Abschnitte, in denen Sie die alternative Interaktion anzeigen können. Um eine weitere Bedingung hinzuzufügen, ziehen Sie einen Interaktionsopernden auf das Shape. 

    UML-Sequenzbedingung

  • Ziehen Sie das Fragment-Shape auf die Interaktionen, mit der es sich bezieht. Verwenden Sie die Ziehpunkte des Fragment-Shapes, um sicherzustellen, dass alle zugehörigen Interaktionen eingeschlossen sind.

  • Doppelklicken Sie in die Titelecke der Fragmentform, um einen Titel oder eine kurze Beschreibung des Prozesses zwischen dem Fragment hinzuzufügen. Klicken Sie unter der Titelecke auf die Eingabeaufforderung [Parameter], wenn Sie die Bedingungen eingeben möchten, die diesen Vorgang beenden würden.

Aktivierung

Platzieren Sie ein Aktivierungsleisten-Shape in einer Lebenslinie, um zu zeigen, wann und wie lange das Objekt oder der Teilnehmer im Prozess aktiv ist. Normalerweise werden Pfeile zu und von einem Aktivierungsfeld angezeigt, um den Informationsfluss zu veranschaulichen.

Ziehen Sie die Endpunkte der Aktivierungsleiste nach oben oder unten, um die von Ihnen angezeigte Länge zu erhalten.

UML-Sequenzaktivierung

Verunglutung

Eine Abentutung gibt an, wann ein Objekt oder Akteur an einem System teilnimmt. Am Ende der Lebenslinie wird ein großes X angezeigt. So zeigen Sie die Verunglutung eines Objekts in einem Diagramm an

  • Klicken Sie mit der rechten Maustaste auf das Objekt, und wählen Sie "Angewendete Objekte anzeigen" aus.

Verwenden Sie zum Erstellen eines Sequenzdiagramms die VORLAGE UML-Modell, die einen Satz von UML-Sequenz-Shapes enthält. Ziehen Sie Shapes aus der Schablone auf den Zeichenbereich, um das Diagramm zu erstellen.

Starten eines Sequenzdiagramms

  1. Klicken Sie unterVorlagenkategorien auf Software und Datenbank, und klicken Sie dann auf UML-Modelldiagramm.

  2. Klicken Sie im Modell-Explorer Strukturansicht mit der rechten Maustaste auf das Paket, in das Sie die Statisches Strukturdiagramm, zeigen Sie auf Neu ,und klicken Sie auf Sequenzdiagramm.

    Ein leeres Seitenblatt wird angezeigt, und die Schablone UML-Sequenz wird zur obersten Schablone. Der Strukturansicht wird ein Symbol hinzugefügt, das das Diagramm darstellt.

    Hinweis: Wenn die Strukturansicht nicht angezeigt wird, zeigen Sie im Menü UML auf Ansicht, und klicken Sie dann auf Modell-Explorer.

Lesen Sie weiter, um weitere Anleitungen zum Arbeiten mit Sequenzdiagrammen zu erhalten.

Lebenslinien für Objekte und Objekte

Verwenden Sie eine Objektlebenslinienform für jeden Teilnehmer und jede Systemkomponente in Ihrem Prozess.

Eine Objektlebenslinie stellt das Vorhandensein eines Objekts zu einem bestimmten Zeitpunkt dar. Wenn das Objekt während des vom Diagramm dargestellten Zeitraums erstellt oder zerstört wird, stoppt oder beginnt die Lebenslinie an dem entsprechenden Punkt. Die Verunglutung eines Objekts wird mit einem großen X gekennzeichnet.

Verwenden Sie eine Lebenslinie- Lifeline shape icon , um die Bedingung für eine Objektlebenslinie zu zeigen.

Nachrichten

  1. Ziehen Sie ein Nachrichten-Shape auf das Zeichenblatt.

    Das nachrichten-Shape, das Sie auswählen, hängt von der Art der Nachricht ab, die Sie senden möchten (normal, asynchron, Prozeduraufruf oder Rückgabe).

  2. Kleben Sie den Nachrichtenendpunkt ohne Pfeilspitze an einen Verbindungspunkt Verbindungspunkt (blaues X) lebenslinie des Objekts, das die Nachricht sendet.

  3. Kleben Sie den Nachrichtenendpunkt mit der Pfeilspitze an einen Verbindungspunkt in der Lebenslinie des Objekts, das die Nachricht empfängt.

  4. Doppelklicken Sie auf die Nachricht, und geben Sie dann den Nachrichtennamen, das Stereotyp, den Sequenzausdruck und die Flussart ein, oder wählen Sie diese aus.

  5. Wählen Sie für einen flachen Nachrichten- oder Prozeduraufruf den Vorgang aus, den die Nachricht generieren soll. Wenn der Vorgang nicht vorhanden ist, klicken Sie auf Neu, um ihn zu erstellen.

    Wählen Sie für eine asynchrone Nachricht das Signal aus, das von der Nachricht generiert werden soll. Wenn für die Klassifizierung kein Empfang für das Signal vorhanden ist, auf dem die Objektlebenslinie basiert, auf der die Nachricht empfangen wird, klicken Sie auf Neu, um den Empfang zu erstellen.

Tipp: Um eine Nachricht von einem Objekt an sich selbst anzugeben, kleben Sie die beiden Endpunkte an einem bogenförmigen Nachrichten-Shape an zwei Verbindungspunkte auf derselben Objektlebenslinie.

Einschränkungen

Wenn eine oder mehrere Interaktionen eine Bedingung erfüllen müssen, um die Interaktion zu beenden, schließen Sie diese Interaktionen in eines der Einschränkungs-Shapes ein:

  • Ein Einschränkungsregel Constraint shape icon ist eine Spezifikation für Bedingungen und Vorschläge, die beibehalten werden müssen, damit das System gültig ist. Einschränkungen werden als Text in geschweiften Klammern ({ }) ausgedrückt und können in einer vordefinierten Sprache, z. B. OCL (Object Constraint Language), oder in natürlicher Sprache geschrieben sein.

    Ziehen Sie den Steuerpunkt Bild eines Steuerpunkts: gelber Diamant Mitte des Constraint-Shapes, und kleben Sie ihn an einen Verbindungspunkt auf einem anderen Element an.

  • Ein Einschränkungselement mit zwei Two Element Constraint shape icon gilt für zwei Elemente, z. B. zwei Klassen oder zwei Zuordnungen. Die Einschränkung wird als gestrichelter Pfeil von einem Element zum anderen mit der Einschränkungszeichenfolgenbeschriftung in geschweiften Klammern ({ }) angezeigt.

  • Ein Or Constraint OR Constraint shape icon gibt an, dass jede Instanz einer Klasse nur an einer Zuordnung gleichzeitig teilnehmen kann. Die Einschränkung wird als gestrichelte Linie angezeigt, die zwei oder mehr Zuordnungen miteinander verbindet, für die eine gemeinsame Klasse verwendet werden muss. Die Zeile wird durch die Einschränkungszeichenfolge ODER in geschweiften Klammern ({ }) beschriftet.

Aktivierung

Platzieren Sie ein Aktivierungsleisten-Shape in einer Lebenslinie, um zu zeigen, wann und wie lange das Objekt oder der Teilnehmer im Prozess aktiv ist. Normalerweise werden Pfeile zu und von einem Aktivierungsfeld angezeigt, um den Informationsfluss zu veranschaulichen.

Ziehen Sie die Endpunkte der Aktivierungsleiste nach oben oder unten, um die von Ihnen angezeigte Länge zu erhalten.

UML-Sequenzaktivierung

Verunglutung

Eine Abentutung gibt an, wann ein Objekt oder Akteur an einem System teilnimmt. Am Ende der Lebenslinie wird ein großes X angezeigt. So zeigen Sie die Verunglutung eines Objekts in einem Diagramm an

  • Klicken Sie mit der rechten Maustaste auf das Objekt, wählen Sie Shape-Anzeigeoptionenaus, und aktivieren Sie im Dialogfeld das Feld Markierung für die Kennzeichnung.

Siehe auch

UML-Diagramme in Visio

Erstellen eines UML-Komponentendiagramms

Erstellen eines UML-Kommunikationsdiagramms

Erstellen eines UML-Verteilungsdiagramms

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×